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Introduction 
ROCPLANE is a quick, interactive and simple to use 
analysis tool for evaluating the possibility of planar 
sliding failure in rock slopes. A planar wedge can be 
defined by: 

• a sliding plane 

• the slope face 

• the upper ground surface 

• an optional tension crack 

as shown in the following figure. 

 

Figure 1-1: A wedge model in ROCPLANE. 

The main assumptions in a planar wedge analysis such as 
ROCPLANE, are as follows: 

1. The ROCPLANE analysis is a 2-dimensional analysis, 
where it is assumed that the strike of the face slope, 
upper slope, failure plane and the tension crack, are 
parallel, or nearly parallel – within approximately 
plus or minus 20 degrees, in order for the analysis to 
be applicable (Ref. 1). 
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2. The failure plane must daylight into the slope face (ie. 
the dip of the failure plane must be smaller than the 
dip of the slope face).  

3. The analysis is performed on a unit width of slope, in 
the out-of-plane direction, as shown below. 

 

Figure 1-2: Slice of unit thickness used in analysis. 

4. All forces in the analysis (wedge weight, water forces, 
external and support forces) are assumed to act 
through the centroid of the wedge. Moments are not 
considered. 

5. The assumed failure mode is therefore translational 
slip – rotational slip and toppling are not taken into 
account. 

6. Release surfaces are present, parallel to the cross-
section of the analysis, which provide negligible 
resistance to sliding at the lateral boundaries of the 
failure. This is shown in Figure 1-3. Alternatively, 
failure can occur on a failure plane passing through 
the convex “nose” of a slope (Ref. 1). 
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Figure 1-3: Release surfaces required to allow planar sliding to 
occur.  

True planar failure in rock slopes is a relatively rare 
situation, because the specific geometrical conditions 
required to produce such a failure are not often 
encountered in real slopes. However, analysis of planar 
failure with ROCPLANE can be very useful for 
understanding slope behaviour, even when the geometry 
is not strictly 2-dimensional.  

Parametric analysis can be very easily carried out. The 
user can easily modify the model geometry, shear 
strength, water pressure and external or support forces, 
and evaluate which slope parameters have the greatest 
effect on stability, and the support forces required to 
stabilize a slope. 
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Wedge Geometry 

In ROCPLANE, the planes defining a wedge can be 
specified at any angles which result in a kinematically 
feasible wedge (ie. a wedge which can slide out of a slope). 
Almost any 3 or 4 sided wedge can be defined by the slope 
planes, failure surface and tension crack, as shown in the 
following figures. 

Figure 1-4 illustrates a simple wedge model with no 
tension crack. 

 

 

Figure 1-4: Typical wedge geometry for ROCPLANE analysis ( A = 
Sliding Plane or Failure Plane, B = Slope Face, C = Upper Face). 

A tension crack is optional in a ROCPLANE model, and 
can be included as shown in Figure 1-5. 
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Figure 1-5: Wedge with vertical tension crack (D) daylighting in 
upper slope face (C) 

Note:  

• A tension crack in a ROCPLANE model does NOT 
have to be vertical.  

• The upper ground surface does NOT have to be 
horizontal.  

The tension crack and upper ground surface can be 
defined at any angles which are compatible with the slope 
plane and failure plane, and form a valid wedge. 

Also note that the upper ground surface does not have to 
be present in a ROCPLANE wedge model. This is the case 
when a tension crack is present which daylights in the 
slope face, or at the crest of the slope.  

For example, Figure 1-6 illustrates a wedge with a non-
vertical tension crack which daylights in the slope face. 
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Figure 1-6: Wedge with non-vertical tension crack (D), daylighting 
in slope face (B) 

Due to the flexibility in defining the slope angles, tension 
crack angle, and distance of tension crack from crest (can 
be zero), a great many different wedge shapes can be 
analyzed in ROCPLANE. 

For example, Figures 1-7 and 1-8 illustrate other wedge 
configurations which may be analyzed with ROCPLANE. 

Overhanging slopes can be analyzed, by defining the 
angle of the slope face to be greater than 90 degrees. This 
is shown in Figure 1-8.  

Many other wedge shapes are possible, by varying the 
wedge geometry parameters. 
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Figure 1-7: Wedge with non-vertical tension crack (D) parallel to 
slope face (B) 

 

Figure 1-8: Wedge with overhanging slope face (B), non-horizontal 
upper slope (C), and non-vertical tension crack (D)  

 



8 ROCPLANE User’s Guide 

 

 

 

Water Pressure 

Various Water Pressure Distribution Models can be 
assumed on the wedge failure plane and tension crack. 
These include: 

• Peak Pressure at Mid Height 

• Peak Pressure at Toe 

• Peak Pressure at Tension Crack Base 

• Custom Pressure 

These are illustrated in the following figures. 

 

Figure 1-9: Peak water pressure at mid height of slope. 

The worst case scenario occurs when the peak water 
pressure is at the toe of the slope, as shown in Figure 
1-10. This can occur if drainage at the toe of a slope 
becomes blocked, for example by frozen water at the base 
of the slope. This will result in the maximum water 
pressure being applied to the wedge failure plane. 
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Figure 1-10: Peak water pressure at toe of slope. 

 

 

Figure 1-11: Peak water pressure at base of tension crack. 
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If the wedge model includes a tension crack, then another 
frequently used model for water pressure, is one in which 
the maximum water pressure occurs at the base of the 
tension crack, as shown in Figure 1-11. Note: with this 
model, the water pressure on the failure plane can be set 
to zero (so that pressure is only applied on the tension 
crack). 

If average water pressures on the failure plane and 
tension crack are known (eg. from piezometer 
measurements), then the user can specify the actual 
(average) water pressure on the failure plane and tension 
crack, as shown in Figure 1-12. 

 

Figure 1-12: User-defined water pressure on failure plane and 
tension crack. 

Finally, the height of water in the slope can be specified 
using the Percent-Filled option. This applies to the Peak 
Pressure Mid Height, Peak Pressure Toe and Peak 
Pressure TC Base options (specify the height of water in 
the tension crack).  
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Shear Strength  

A critical assumption in planar slope stability analysis 
involves the shear strength of the sliding surface. There 
are several models in rock engineering that establish the 
relationship between the shear strength of a sliding 
surface and the effective normal stress acting on the 
plane. ROCPLANE offers the following widely used shear 
strength models. 

Mohr-Coulomb 

In this model the relationship between the shear 
strength, τ, of the failure plane and the normal stress, 

, acting on the plane is represented by the Mohr-
Coulomb equation: 

 

where  is the friction angle of the failure plane and c 
is the cohesion. 

Barton-Bandis 

The Barton-Bandis strength model establishes the shear 
strength of a failure plane as: 

 

where  is the basic friction angle of the failure surface, 
JRC is the joint roughness coefficient, and JCS is the 
joint wall compressive strength. 
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Hoek-Brown 

The Hoek-Brown criterion establishes strength 
according to the formula: 

 

where  is the major principal stress,  is the minor 

principal stress,  is the uniaxial compressive strength 
of the intact rock, and m and s are material constants for 
the rock mass.  

Generalized Hoek-Brown 

The Generalized Hoek-Brown criterion establishes 
strength according to the formula: 

 

where  is the major principal stress,  is the minor 

principal stress,  is the uniaxial compressive strength 

of the intact rock,  is a material constant for the rock 
mass, and s and a are constants dependent on the 
characteristics of the rock mass.  

For the Hoek-Brown and Generalized Hoek-Brown 
criteria, a relationship between shear strength and 
normal stress can be derived from the Hoek-Brown 
equations. 



 Introduction   

 

13

Power Curve 

The Power Curve model for shear-strength, , of a plane 
is given by the relationship: 

 

a, b and c are parameters, typically obtained from a 
least-squares regression fit to data obtained from small-

scale shear tests.  is the normal stress acting on the 
failure plane (Ref. 6). 

Waviness Angle 
Waviness is a parameter that can be included in 
calculations of the shear strength of the failure plane, for 
any of the above strength models. It accounts for the 
waviness (undulations) of the failure plane surface, 
observed over distances on the order of 1 m to 10 m.  

Waviness is specified as the average dip of the failure 
plane, minus the minimum dip of the failure plane. A 
waviness angle greater than zero, will always increase the 
effective shear strength of the failure plane (Ref. 6). 
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RocPlane Analysis 

In ROCPLANE, stability can be assessed using either: 

• DETERMINISTIC (safety factor), or  

• PROBABILISTIC (probability of failure) 

analysis methods. For a DETERMINISTIC analysis 
ROCPLANE computes the factor of safety for a wedge of 
known input parameters. For a PROBABILISTIC 
analysis, statistical data can be entered to account for 
uncertainty in input parameters (orientation, strength, 
water and external forces). This results in a safety factor 
distribution, from which a probability of failure is 
calculated. 

In addition to Deterministic and Probabilistic analyses, a 
Sensitivity analysis can also be performed. This allows the 
user to study the effect of individual variables on the 
safety factor of the wedge, by automatically varying one 
variable at a time, while keeping other variables constant. 

Other ROCPLANE modeling and analysis features 
include: 

• Support modeling, using active or passive bolt 
support. Bolt orientation can be optimized for 
maximum factor of safety, or the bolt capacity for a 
required factor of safety can be calculated. 

• External and seismic forces. 
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RocPlane Documentation 

The documentation for the ROCPLANE program is 
organized as follows: 

Tutorials 
Tutorials are found in the ROCPLANE User’s Guide, the 
manual you are now reading.  

For information on any ROCPLANE options which are not 
covered in this manual, consult the ROCPLANE Help 
system. 

Reference  
Detailed reference information on all of the options in the 
ROCPLANE program is found in the ROCPLANE Help 
system. To access the Help system: 

Select: Help → Help Topics 

from the ROCPLANE menu. 

Theory 
The equations used in the ROCPLANE analysis are 
documented in the ROCPLANE Theory manual. This is 
available as a PDF file, see below for details. 

Further information about planar sliding analysis, can be 
found in References 1 – 6 listed at the end of this chapter. 
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Verification 
Verification examples are documented in the ROCPLANE 
Verification Manual, which is available as a PDF file. See 
below for details. The files used for verification can be 
found in the EXAMPLES folder in your ROCPLANE 
installation folder.  

PDF Files 
The ROCPLANE Tutorial, Theory and Verification 
documents are all available as PDF (portable document 
format) files. After you install ROCPLANE, you will find 
them in the Manuals folder in your ROCPLANE 
installation folder. The PDF documents can also be 
downloaded from our website www.rocscience.com.  

PDF files are viewed with Adobe Acrobat reader. The PDF 
documents can be printed, if you wish to have paper 
copies of the ROCPLANE Theory or Verification 
documentation. 
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Quick Start Tutorial 

 

This “quick start” tutorial will familiarize the user with 
some of the basic features of ROCPLANE.  

If you have not already done so, run ROCPLANE by 
double-clicking on the ROCPLANE icon in your 
installation folder. Or from the Start menu, select 
Programs → Rocscience → RocPlane → RocPlane. 

If the ROCPLANE application window is not already 
maximized, maximize it now, so that the full screen is 
available for viewing the model. 

To begin creating a new model: 

Select: File → New 

A wedge model will immediately appear on your screen, 
as shown in the above figure. Whenever a new file is 
opened, the default input data will form a valid wedge. 
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The first thing you will notice is the four-view, split screen 
format of the display, which shows: 

• TOP 
• FRONT 
• SIDE and 
• PERSPECTIVE  

views of the model. The Top, Front and Side views are 
orthogonal with respect to each other (ie. viewing angles 
differ by 90 degrees). 

Before we proceed, it is very important to note the 
following: 

• Although ROCPLANE displays the model in a 3 
dimensional format, the ROCPLANE analysis is 
strictly a 2-dimensional analysis. The 3D display is for 
the purpose of improved visualization of the problem 
geometry.  

• All input data assumes that the problem is uniform in 
the direction perpendicular to the wedge cross-section. 
The analysis is performed on a “slice” through the 
cross-section, of unit width.  

• All analysis results (eg. wedge weight, wedge volume, 
normal force, resisting force, driving force etc), are 
therefore stated in terms of force per unit length, 
volume per unit length, etc. 
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Project Settings 

Project Settings allows the user to enter a Project Title, 
and select a Unit System and Analysis Type. 

Select: Analysis → Project Settings 

 

Enter “ROCPLANE Quick Start Tutorial” as the Project 
Title. Leave Units = Metric and Analysis Type = 
Deterministic. Select OK. 

• The Project Title appears in the Info Viewer listing, 
and also on printouts of the wedge view. 

• Units determines the length and force units used in 
the analysis. 

• Deterministic analysis means that all input data is 
assumed to be exactly known, and a single safety 
factor is calculated. Probabilistic analysis allows for 
uncertainty in input data. This results in a range of 
safety factors, from which a probability of failure is 
calculated. This is covered in the next tutorial. 
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Input Data 

Now let’s see what input data was used to create this 
model. 

Select: Analysis → Input Data 

 

Figure 2-1: Input Data dialog (Deterministic). 

The Geometry input data which you see in this dialog is 
the default input data, which forms a valid default wedge, 
each time a new file is started.  

Examine the input data in this dialog. Do not change any 
values just yet, we will be coming back to this shortly.  

Before you close the dialog, notice the Safety Factor, 
Wedge Weight etc information displayed in the lower 
right corner. The Safety Factor (FS = …) is also displayed 
in the ROCPLANE toolbar, at the top of the screen.  
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Notice that the wedge weight, normal force etc, are all 
expressed as “tonnes per metre”. Since the analysis is 
performed on a slice of unit width, the “per metre” refers 
to the direction perpendicular to the wedge cross-section, 
as mentioned earlier. 

Select Cancel to close the dialog. 

3D Wedge View 

The mouse buttons can be used to interactively 
manipulate the view as follows: 

• The Perspective view of the model allows the model to 
be rotated for viewing at any angle with the LEFT 
mouse button. 

• The wedge can be moved out of the slope with the 
RIGHT mouse button (or the mouse wheel) in any of 
the four views. 

Rotating the Model 
1. Press and HOLD the LEFT mouse button anywhere in 

the Perspective view. Notice that the cursor changes 
to a “circular arrow” symbol to indicate that you may 
rotate the model. 

2. Now keep the LEFT mouse button pressed, and move 
the cursor around. The model is rotated according to 
the direction of movement of the cursor. 
 

 

 

3. To exit the rotation mode, release the LEFT mouse 
button. Notice that the cursor reverts to the normal 
arrow cursor. 

4. Repeat the above steps to rotate the model for viewing 
at any angle. 

 



24 ROCPLANE User’s Guide 

 

 

 

Moving the Wedge Out of the Slope 
1. Press and HOLD the RIGHT mouse button anywhere 

in ANY of the four views. Notice that the cursor 
changes to an “up-down arrow” symbol.  

2. Now, keep the RIGHT mouse button pressed, and 
move the cursor UP or DOWN. The wedge will slide 
UP or DOWN out of the slope. Note: 

• If your model does NOT have a Tension Crack, 
then the wedge will slide UP or DOWN along the 
Failure Plane. 

• If your model DOES have a Tension Crack, then 
the wedge will slide DOWN along the Failure 
Plane, and UP along the Tension Crack Plane. 

3. To exit this mode, release the RIGHT mouse button. 
Notice that the cursor reverts to the normal arrow 
cursor. 

TIP – if you have a mouse with a mouse wheel, rotating 
the mouse wheel will also move the wedge out of the 
slope. You may find this even more convenient than using 
the right mouse button. 

Resetting the Wedge 

To reset the wedge in its normal position, click and 
RELEASE the RIGHT mouse button in any of the four 
views. The wedge will snap back to its normal position. 
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Resizing the Views 
You can change the relative size of the Top / Front / Side / 
Perspective views in a number of ways: 

1. Double-clicking in any view will maximize that view. 
Double-clicking again in the maximized view, will 
restore the four view display. 

 
Figure 2-2: Maximized Perspective view. 

2. Alternatively, hover the cursor over the vertical or 
horizontal dividers between the views, or over the 
intersection point of the four views. The cursor will 
change to a “parallel line” or “four arrow” symbol. 
Press and HOLD the LEFT mouse button, and drag to 
re-size the views.  

3. Maximizing views can also be accomplished with the 
View → Layout options. To reset the four views to 
equal size, select View→ Layout → All Views. 

Double-clicking in any view 
will maximize that view. 

Double-clicking again in the 
maximized view, will restore 

the four view display. 
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Zooming 
Zooming (from 50% to 800%) is available in the View → 
Zoom menu, to increase or decrease the displayed size of 
the model in all four views, simultaneously. 

Individual views can be zoomed in or out using the Page 
Up / Page Down keys, the + or – numeric keypad keys, the 
F4 / F5 function keys, or the Zoom options in the toolbar. 
The F2 function key is a shortcut to Zoom All. You must 
first click in the view with any mouse button, to make it 
the active view, before you can zoom the view. 

Display Options 
You may change colours and other viewing options in the 
Display Options dialog. 

Select: View → Display Options 

 

Select new slope, wedge and background colours. Select 
Apply in order to view changes. You can minimize the 
dialog, by selecting the � arrow in the upper right corner 
of the dialog. To maximize the dialog, select the � arrow.  
Select the Defaults button to restore the original program 
defaults, and select Close to exit the dialog. 
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2D Wedge View 

A 2D view of the wedge model is available, by selecting 
the 2D View option. 

Select: Analysis → 2D View 

This will generate a new view which only displays the 2D 
wedge model. Remember that the ROCPLANE analysis is 
a 2D analysis, and that the 3D display is for visualization 
purposes only. 

 

Figure 2-3: 2D wedge view. 

The 2D view can display model lengths and angles, as 
well as tables of analysis results and input data. Let’s see 
what display options are available with the 2D view. 

Select: View → Display Options 

(Note: Display Options is also available in the right-click 
menu on the 2D View). 
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Experiment with the 2D display options to see the effects 
on the display. You must select Apply in order to view the 
changes. You can select the Defaults button to restore the 
original program default display options. Select Close 
when you are done. 

 

Zooming 
The wedge model in the 2D view can be zoomed in a 
variety of ways: 

• rotate the mouse wheel to zoom in or out 
• select the zoom options in the toolbar 
• use the F2, F4 or F5 function keys 

Panning 
The wedge model in the 2D view can be panned left, right, 
up or down, using the arrow keys on the keyboard, or by 
clicking and holding the mouse wheel or middle button of 
your mouse, and dragging. 
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Changing the Input Data & Re-calculating the Safety Factor 

Close the 2D view by selecting the X in the upper right 
corner of the view. Alternatively, you can return to the 3D 
view at any time, by selecting the 3D View toolbar button. 

Now let’s experiment with changing the Input Data and 
re-calculating a new Safety Factor. 

This is simply a matter of: 

1. Entering the desired Input Data. 

2. Selecting the Apply button. 

For a Deterministic analysis, the Safety Factor is 
immediately calculated and displayed in the lower right 
corner of the dialog. 

Select: Analysis → Input Data 

Let’s first increase the slope angle. 

1. Enter a slope angle of 55 degrees.  

2. Select Apply, and a new Safety Factor (1.515) is 
calculated, as you can see at the bottom right of the 
Input Data dialog, and in the toolbar. 

3. Minimize the Input Data dialog now, so that you can 
better view the new wedge (select the � arrow in the 
upper right corner of the dialog).  

More About the Input Data Dialog 
Before we proceed, we will discuss some properties of the 
Input Data dialog. As you may have noticed, the Input 
Data dialog in ROCPLANE works a little differently than 
a regular dialog. 



30 ROCPLANE User’s Guide 

 

 

 

1. It is known as a “roll-up” dialog, since it can be 
“rolled-up” (minimized) or “rolled-down” again, by 
selecting the � or � arrow in the upper right corner 
of the dialog. 

 

Alternatively, double-clicking the LEFT mouse button 
on the title bar of the dialog, will also minimize / 
maximize the dialog. 

2. It can be left up on the screen while performing other 
tasks. When not needed, it can be “rolled-up” and 
dragged out of the way (for example, the top of the 
screen) with the LEFT mouse button. 

3. If multiple files are open, the Input Data dialog will 
always display the data in the active file.  

4. The Apply button can be used to compute results 
based on the current Input Data, without closing the 
dialog.  

5. The F3 function key can be used as a shortcut to 
display the Input Data dialog. 

You may find these properties of the Input Data dialog 
useful, for example, when performing parametric 
analysis, or when working with multiple files.  

Now maximize the Input Data dialog, by selecting the � 
arrow, or double clicking on the title bar of the dialog. 

Strength 
Change the shear strength of the failure plane. Select the 
Strength tab of the Input Data dialog. Enter a Cohesion = 
5. Select Apply. The Safety Factor drops to 1.258. Several 
different shear strength models are available in 
ROCPLANE, as discussed in the Introduction. 
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Water Pressure 
By default, Water Pressure is NOT applied to a 
ROCPLANE model, and the analysis is therefore 
applicable to a DRY slope. 

To include Water Pressure in the analysis: 

1. Select the Forces tab in the Input Data dialog. 

2. Select the Water Pressure checkbox.  

3. Various Water Pressure Distribution Models are 
available, by selecting from the list. This includes: 

• Peak Pressure Mid Height 
• Peak Pressure at Toe 
• Peak Pressure at Tension Crack Base 
• Custom Pressure 

 

See the Introduction for illustration of these distributions. 
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4. For this example, we will use the default method 
(Peak Pressure at Mid-Height). 

5. You may also define a Percent Filled, to define the 
water level in the slope. Let’s use the default 100% 
filled for now. 

6. Select Apply. The Safety Factor decreases to 0.623. 
This wedge would therefore be very unstable for these 
water pressure and shear strength conditions. 

7. Change the Percent Filled to 50. Select Apply. The 
Safety Factor increases to 1.099. 

Minimize the Input Data dialog (select the �arrow). 

Use the right mouse button (click and drag) or the mouse 
wheel, to slide the wedge all the way out of the slope. 
Notice that the water level in the slope is indicated by 
blue shading. Since we entered a percent filled = 50 %, 
notice that the lower half of the failure plane is shaded 
blue. 

Also notice, if you rotate the model in the Perspective 
view (click and drag the LEFT mouse button), a blue 
arrow, representing the Water Pressure force is displayed 
normal to the failure plane, on the underside of the 
wedge. 

Click the right mouse button in any view, to reset the 
wedge in the slope. 

Maximize the Input Data dialog. 
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Seismic Force 
Now we will include Seismic Force in the analysis. 

1. Select the Seismic Force checkbox. 

2. Enter a Seismic Coefficient of 0.2. Select Apply, and 
the Safety Factor drops to 0.746. 

 

Notice that an arrow representing the Seismic Force is 
now displayed on the model. 

The Seismic Force applied to the wedge is F = 0.2 * g * m, 
where g = acceleration due to gravity and m = mass of the 
wedge (per unit width of the slope cross-section).  

Remove the Seismic Force by clearing the Seismic 
checkbox, and selecting Apply. 
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Tension Crack 
Let’s now add a tension crack to the model. 

1. Select the Geometry tab in the Input Data dialog. 

2. Select the Tension Crack checkbox. Select Apply. 

 

The Safety Factor is now 0.98. Notice that the wedge now 
appears quite different. We used the “Minimum FS 
Location” option for the Tension Crack. This means that 
ROCPLANE will automatically determine the location of 
the Tension Crack which produces the minimum safety 
factor. 

 

Figure 2-4: Tension crack at crest of slope. 
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In this case, the minimum safety factor results when the 
Tension Crack is placed exactly at the crest of the slope, 
therefore the Upper Slope Face of the wedge is no longer 
present. The wedge is formed only by the slope, failure 
plane and tension crack. 

NOTE – the Minimum FS Location option does NOT 
necessarily mean that the Tension Crack is placed at the 
crest of the slope. It is placed at the location which 
produces the minimum safety factor, which happens to be 
the crest of the slope in this example. 

Now let’s use the Specify Location option, which allows 
the user to specify the location of the tension crack, as 
measured horizontally from the crest of the slope. 

1. Select the Specify Location option for the Tension 
Crack, and enter the Distance From Crest = 20. 

2. Select Apply. The new safety factor = 1.04. The 
Tension Crack is now located 20 meters behind the 
crest of the slope, as shown in the figure below. 

 

Figure 2-5: Tension crack 20 meters from crest of slope. 
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Info Viewer 

Let’s take a look at the Info Viewer option. 

Select: Analysis → Info Viewer 

A convenient summary of model and analysis data is 
displayed in its own view. Scroll down to view all of the 
information. The Info Viewer text can be copied to the 
clipboard, saved to a file, or printed, using options 
available in the File menu, the Edit menu or the right-
click menu. 

 

Figure 2-6: Info Viewer listing. 
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Exporting Images 

In ROCPLANE, various options are available for 
exporting image files. 

Export Image File 

The Export Image File option in the File menu, allows the 
user to save the current view directly to one of the 
following image file formats: 

• JPEG (*.jpg) 
• Windows Bitmap (*.bmp) 

Copy to Clipboard 

The current view can also be copied to the Windows 
clipboard using the Copy option in the toolbar, the Edit 
menu or the right-click menu. This will place a bitmap 
image on the clipboard which can be pasted directly into 
word or image processing applications. 

TIP- to capture the entire application window to the 
clipboard, use the Alt-PrintScreen keyboard combination. 
This is useful if you have multiple tiled views on the 
screen, or to capture all four views of the 3D wedge view. 

Black and White Images (Grayscale) 

The Grayscale option, available in the toolbar, the View 
menu or the right-click menu, will automatically convert 
all views of the current document to Grayscale, suitable 
for black and white image requirements. This can be 
useful when sending images to a black and white printer, 
or for capturing black and white image files.  

That concludes this “quick start” tutorial. To exit the 
program: 

Select: File → Exit 
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Sensitivity Analysis 

 

Sensitivity Analysis in ROCPLANE allows the user to 
determine the “sensitivity” of the safety factor, to 
variation in the input data variables. This is done by 
varying one variable at a time, while keeping all other 
variables constant, and plotting a graph of safety factor 
versus the variable.  

For the following example, let’s start with a new, default 
file. 

Select: File → New 

Any or all input data variables can be specified in a 
Sensitivity Analysis, and results can be generated and 
viewed in a few mouse clicks.  

Select: Analysis → Sensitivity 
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Select the first checkbox. We will use the default data for 
now, so just select OK, and the following graph will be 
generated.  

 

Figure 3-1: Slope Angle vs. Factor of Safety. 

This graph shows the relationship between the Slope 
Angle and the Safety Factor, within the range of values 
we have specified. All other variables are held constant. 
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NOTE: a Sensitivity graph is generated by subdividing 
each variable range (defined by the Min and Max values 
in the Sensitivity dialog), into 50 intervals, and 
calculating the safety factor at each value of the variable 
between the Min and Max values. (If you right-click on 
the graph, and select the Markers option, you will see the 
actual points used to generate the curve. Right-click on 
the graph again, and turn the Markers option OFF). 

You can modify the data in an existing Sensitivity plot, by 
right-clicking the mouse in the plot, and selecting Update 
Sensitivity Data. Do this now, and select the data as 
shown in the dialog below. Select OK, and the graph will 
now display several curves, as shown in Figure 3-2. 

 

NOTE:  

• In the Sensitivity dialog, the From and To values can 
be user defined.  

• The Mean value of each variable, is determined from 
the Input Data dialog, and CANNOT be changed in 
the Sensitivity dialog. 
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Figure 3-2: Multiple curves on a Sensitivity plot. 

When more than one input data variable is plotted on a 
Sensitivity plot, the horizontal axis will be in terms of 
Percent Change, rather than the actual variables. The 
Percent Change is the relative difference between the 
Minimum value of a variable ( 0 percent) and the 
Maximum value of a variable (100 percent). 

Note that all curves in Figure 3-2 intersect at Percent 
Change = 50 %, because by default, the range of each 
variable is symmetrical about the mean value. Since we 
did not change any of the default Min or Max values, all 
curves intersect at a point, equivalent to the mean wedge 
data in the Input Data dialog. 

As one final exercise, we will use the Sensitivity Analysis 
option, to verify the Minimum FS Location option for a 
Tension Crack. As mentioned in the Quick Start Tutorial, 
the Minimum FS Location option automatically 
determines the location of the Tension Crack which 
produces the Minimum Factor of Safety. 



 Sensitivity Analysis 43  

 

1. Open the Input Data dialog, and select the Tension 
Crack option. 

2. The Minimum FS Location option will be in effect by 
default. Select Apply. Note that the Distance from 
Crest = 19.7 meters (this is displayed in the dialog, in 
the greyed out edit box). 

3. Now select the Specify Location option. Select OK. 

4. Select Sensitivity Analysis, and plot the Distance from 
Crest. Also, enter Min and Max values of 0 and 47, as 
shown below.  

 

5. Select OK, and you should see the following graph. 

 

Figure 3-3: Tension Crack Distance From Crest versus Safety 
Factor. 
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If you examine this graph, you can see that the Minimum 
Safety Factor occurs when the Tension Crack is around 20 
meters from the crest. This corresponds to the value 
determined from the Minimum FS Location option for a 
Tension Crack (19.7 meters). 

Finally, note that the Maximum value which we entered 
in the Sensitivity dialog, for the Distance From Crest, of 
47 meters, was based on the maximum Bench Width. If 
you go back to the Input Data dialog, you can see this 
value in the greyed out edit box, underneath the Bench 
Width Analysis option. The maximum Bench Width is 
determined from the Slope Height and the wedge 
geometry, and also represents the maximum distance at 
which a Tension Crack can be located from the crest. 

As additional exercises: 

• Notice that a Chart Properties option is available in 
the right-click menu on all graph views. This allows 
the user to customize chart axes and colours. 

• The Sampler option available in the right-click menu, 
allows the user to obtain exact values of points on the 
sensitivity curves (see the Probabilistic Analysis 
tutorial for a discussion of the Sampler). 

• Chart data can be exported and graphed in Excel, 
with a single mouse click. The Chart in Excel option is 
available in the toolbar, the View menu or the right-
click menu. 

That concludes this tutorial, to exit the program: 

Select: File → Exit 

 

 



 Probabilistic Tutorial 45  

 

Probabilistic Analysis 

 

This tutorial will familiarize the user with the 
Probabilistic analysis features of ROCPLANE.  

If you have not already done so, run ROCPLANE by 
double-clicking on the ROCPLANE icon in your 
installation folder. Or from the Start menu, select 
Programs → Rocscience → RocPlane → RocPlane. 

If the ROCPLANE application window is not already 
maximized, maximize it now, so that the full screen is 
available for viewing the model. 

To begin creating a new model: 

Select: File → New 

A default wedge model will immediately appear on your 
screen. Whenever a new file is opened, the default input 
data will form a valid wedge. 
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Project Settings 

Project Settings allows the user to enter a Project Title, 
and select a Unit System and Analysis Type. Let’s switch 
the Analysis Type to Probabilistic. 

Select: Analysis → Project Settings 

 

Enter “ROCPLANE Probabilistic Tutorial” as the Project 
Title. Leave Units = Metric and change the Analysis Type 
to Probabilistic. Select OK. 

Note: 

• Analysis Type can also be changed at any time, using 
the drop-down list box in the ROCPLANE toolbar. 
This is a convenient shortcut. 

• The Project Title appears in the Info Viewer listing, 
and also on printouts of the wedge view. 

• Units determines the length and force units used in 
the analysis. 

Analysis Type can be 
selected from the drop-down 

list box in the toolbar. 
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Probabilistic Input Data 

Now let’s look at the input data. 

Select: Analysis → Input Data 

You should see the Probabilistic Input Data dialog shown 
below. 

 

Defining Random Variables 
To define a random variable in ROCPLANE: 

1. First select a Statistical Distribution for the variable. 
(In most cases a Normal distribution will be 
adequate.) 

2. Enter Standard Deviation, Minimum and Maximum 
values. NOTE that the Minimum / Maximum values 
are specified as RELATIVE distances from the mean, 
rather than absolute values.  

Minimum / Maximum values 
are specified as RELATIVE 

distances from the mean 
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3. Any variable for which the Statistical Distribution = 
“None” will be assumed to be “exactly” known, and 
will not be involved in the statistical sampling. 

See the ROCPLANE Help system for information about 
the properties of the statistical distributions available in 
ROCPLANE. 

For this example, we will define Normal Statistical 
Distributions for the following variables: 

• Failure Plane Angle 
• Failure Plane Cohesion  
• Failure Plane Friction Angle 

Failure Plane Angle 
Select the Failure Plane tab in the Input Data dialog, and 
enter the following data for the Angle: mean = 28, 
Distribution = Normal, Std. Dev. = 2, Rel. Min. = 5, Rel. 
Max. = 5 
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Failure Plane Strength 
Select the Strength tab and enter the following data for 
the Failure Plane Cohesion and Friction Angle: 

• Cohesion (Mean) = 10 

• Friction Angle (Mean) = 35 

For both Cohesion and Friction Angle: 

• Distribution = Normal 

• Standard Deviation = 2 

• Relative Min = Relative Max = 5 
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Water Pressure 
Select the Water tab. Select the Water Pressure Exists 
checkbox. We will use all of the default settings: 

• Peak Pressure – Mid Height 

• Percent Filled = 100% 

• Distribution = None. 
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Probabilistic Analysis 

To carry out the ROCPLANE Probabilistic Analysis, select 
Apply or OK in the Input Data dialog. 

Note: 

• Apply will run the analysis without closing the dialog. 
• OK will run the analysis and close the dialog. 

The analysis will be run using the parameters you have 
just entered. Calculation should only take a few seconds. 
The progress of the calculation is indicated in the status 
bar. 

Probability of Failure 
The primary result of interest from a Probabilistic 
Analysis is the Probability of Failure. This is displayed in 
the toolbar at the top of the screen. 

 

For this example, if you entered the Input Data correctly, 
you should obtain a Probability of Failure of 14.5%. (ie. 
PF = 0.145 means 14.5% Probability of Failure). 

Later in this tutorial, we will discuss Random versus 
Pseudo-Random sampling. By default, Pseudo-Random 
sampling is in effect, which means that you will always 
obtain the same results each time you run a Probabilistic 
Analysis with the same input data. If Pseudo-Random 
sampling is turned OFF, then different results will be 
generated each time the analysis is run. 
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Wedge Display 
The wedge initially displayed after a Probabilistic 
Analysis, is based on the mean input values, and is 
referred to as the Mean Wedge. It will appear exactly the 
same as one based on Deterministic Input Data with the 
same orientation as the mean Probabilistic Input Data. 

Other wedges generated by the Probabilistic Analysis can 
be displayed, as described in the Viewing Other Wedges 
section. 

Histograms 
To plot histograms of results after a Probabilistic 
Analysis: 

Select: Statistics → Plot Histogram 

 

Select OK to plot a histogram of Safety Factor. 

The histogram represents the distribution of Safety 
Factor, for all valid wedges generated by the Monte Carlo 
sampling of the Input Data. The red bars at the left of the 
distribution represent wedges with Safety Factor less 
than 1.0.  
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Figure 4-1: Safety Factor histogram. 

Mean Safety Factor 

Notice the mean, standard deviation, min and max values 
displayed below the histogram.  

It should be noted that the mean Safety Factor from a 
Probabilistic Analysis (ie. the average of all of the Safety 
Factors generated by the Probabilistic Analysis) is not 
always the same as the Safety Factor of the Mean Wedge 
(ie. the Safety Factor of the wedge corresponding to the 
mean Input Data values).  

Verify this by switching to the Wedge View. In the title 
bar of the wedge view, the safety factor of the Mean 
Wedge is displayed. Compare this value to the Mean 
safety factor listed at the bottom of the Histogram. These 
values will in general not be equal. There are various 
reasons for this:  

1. Monte Carlo sampling does not sample your input 
data distributions “exactly” (eg. see Figure 4-3). 

TIP – you can apply a 3D 
effect to histograms with the 
3D Histogram option in the 

right-click menu. 

For a Monte Carlo analysis, 
the mean Safety Factor is not 
necessarily the same as the 
Safety Factor of the Mean 

Wedge. 
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2. Number of samples is small. 

3. If invalid wedges are generated by the probabilistic 
analysis (eg. invalid geometries), this can also lead to 
differences between the deterministic safety factor 
and the probabilistic mean safety factor. 

NOTE: if you use Latin Hypercube sampling, and a large 
number of samples eg. (10000), the deterministic and 
probabilistic mean safety factors should be very nearly 
equal. This is left as an optional exercise to explore, after 
completing this tutorial. 

Switch back to the Histogram view. (TIP – if you select 
the Window → Tabs option, tabs will appear at the bottom 
of the application window, allowing you to easily switch 
between different views, as shown in Figure 4-2) 
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Viewing Other Wedges 

Now tile the Histogram and Wedge views, so that both are 
visible. 

Select: Window → Tile Vertically 

 

Figure 4-2: Safety Factor histogram and wedge view. 

A useful property of Histograms (and also Scatter Plots) is 
the following: 

• If you double-click the LEFT mouse button anywhere 
on the plot, the nearest corresponding wedge will be 
displayed in the Wedge view. 

For example: 

1. Double-click at any point along the histogram.  

2. Notice that a different wedge is now displayed.  
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3. The Safety Factor of this wedge is displayed in the 
title bar of the Wedge view, and the title bar will 
indicate that you are viewing a “Picked Wedge” rather 
than the “Mean Wedge”.  

4. Double-click at various points along the histogram, 
and notice the different wedges and safety factors 
displayed in the wedge view. For example, double-
click in the “red” Safety Factor region, to view wedges 
with a Safety Factor < 1. 

This feature allows the user to view any wedge generated 
by the Probabilistic Analysis, corresponding to any point 
along a histogram distribution.  

In addition to the Wedge View, all other applicable views 
(for example, the Info Viewer) are also updated to display 
data for the currently “Picked Wedge”. 

Note: 

• this feature can be used on histograms of any 
statistical data generated by ROCPLANE, and not 
just the Safety Factor histogram 

• this feature also works on Scatter plots. 

Resetting the Mean Wedge 

To reset all views so that the Mean Wedge data is 
displayed: 

Select: View → Reset Wedge 

This will display the Mean Wedge in the Wedge View, and 
all other applicable views will also be updated to display 
the Mean Wedge data. 
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Histograms of Other Data 

In addition to Safety Factor, you may also plot histograms 
of: 

• Wedge Weight, Wedge Volume  

• Normal, Driving and Resisting Forces 

• Failure Plane Length, Upper Face Length 

• Any random input variable (ie. any Input Data 
variable which was assigned a Statistical 
Distribution) 

For example: 

Select: Statistics → Plot Histogram 

In the dialog, set the Data Type = Wedge Weight, and 
select OK. 

A histogram of the Wedge Weight distribution will be 
generated. 

Note that all of the features described above for the Safety 
Factor histogram, apply to any other Data Type. For 
example, if you double-click on the Wedge Weight 
histogram, the nearest corresponding wedge will be 
displayed in the Wedge View. 

Let’s generate one more histogram.  

Select: Statistics → Plot Histogram 

This time we will plot one of our Input Data random 
variables. Set the Data Type = Failure Plane Angle. Select 
the Plot Input Distribution checkbox. Select OK. 
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The histogram shows how the Failure Plane Angle Input 
Data variable was sampled by the Monte Carlo analysis. 
The curve superimposed over the histogram is the Normal 
distribution you defined when you entered the mean, 
standard deviation, min and max values for Failure Plane 
Angle in the Input Data dialog. 

Show Failed Wedges 

Let’s demonstrate one more feature of Histogram plots, 
the Show Failed Wedges option. Right-click on the 
Histogram and select Show Failed Wedges.  

The distribution of failed wedges (ie. wedges with Safety 
Factor < 1) is now highlighted on the Histogram. This 
option allows the user to see the relationship between 
wedge failure, and the distribution of any input or output 
variable.  

 

Figure 4-3: Failure Plane Angle – Monte Carlo sampling of normal 
distribution. Failed Wedge distribution is displayed.  

The Show Failed Wedges 
option allows the user to see 

the relationship between 
wedge failure and the 

distribution of any input or 
output variable. 
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As we would expect, the failed wedges correspond to 
larger Failure Plane Angles, as can be seen in Figure 4-3. 

Cumulative Distributions (S-curves) 
In addition to the histograms, cumulative distributions (S-
curves) of the statistical results can also be plotted. 

Select: Statistics → Plot Cumulative 

 

Select OK. 

The cumulative Safety Factor distribution will be 
generated, as shown in Figure 4-4. (Maximize the view if 
necessary). 

Notice the vertical dotted line visible on the plot. This is 
the Sampler, and allows you to obtain the coordinates of 
any point on the cumulative distribution curve. 

• To use the sampler, just SINGLE click the LEFT 
mouse button anywhere on the plot, and the sampler 
will jump to that location, and display the results. 

• Alternatively, press and HOLD the LEFT mouse 
button on the plot, and you will see the double-arrow 
icon. Move the mouse left or right, and the sampler 
will continuously display the values of points along 
the curve. 
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Figure 4-4: Cumulative safety factor distribution. 

The display of the Sampler can be turned on or off in the 
right-click menu or the View menu. 

A point on a cumulative probability curve, gives the 
probability that the plotted variable will be less than or 
equal to the value of the variable at that point.  

For a cumulative Safety Factor distribution, the 
cumulative probability at Safety Factor = 1, is equal to the 
Probability of Failure. As the Sampler indicates in Figure 
4-4, the cumulative probability at Safety Factor = 1, is 
equal to 0.145, which is the Probability of Failure for this 
example. 
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Scatter Plots 
Scatter Plots allow the user to examine the relationships 
between analysis variables. To generate a Scatter Plot: 

Select: Statistics → Plot Scatter 

 

In the Scatter Plot dialog, select the variables you would 
like to plot on the X and Y axes, for example, Safety Factor 
vs. Wedge Weight. Select the Show Regression Line option 
to display the best fit straight line through the data. Select 
OK to generate the plot.  

As can be seen in Figure 4-5, there appears to be very 
little correlation between Safety Factor and Wedge 
Weight. However, Safety Factor does generally increase 
with increasing Wedge Weight. 

The Correlation Coefficient, listed at the bottom of the 
plot indicates the degree of correlation between the two 
variables plotted. The Correlation Coefficient can vary 
between -1 and 1 where numbers close to zero indicate a 
poor correlation, and numbers close to 1 or –1 indicate a 
good correlation. Note that a negative correlation 
coefficient simply means that the slope of the best fit 
linear regression line is negative.  
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Figure 4-5: Scatter plot of Safety Factor vs. Wedge Weight. 

Alpha and beta, also listed at the bottom of the plot, 
represent the y-intercept and slope, respectively, of the 
best fit linear regression line to the scatter plot data. 

Note: 

• As demonstrated earlier with Histograms, you may 
double-click the mouse on a Scatter Plot, to display 
the data for the nearest wedge on the plot. This is left 
as an optional exercise for the user to demonstrate. 

• The Show Failed Wedges option, described previously 
for Histograms, also works on Scatter Plots. For 
example, right-click and select Show Failed Wedges. 
All wedges with Safety Factor < 1 are now highlighted 
in RED on the Scatter Plot. 

• For the special case of Cohesion vs. Friction angle, a 
user-defined correlation coefficient can be specified in 
the Input Data dialog. See the Additional Exercises at 
the end of this tutorial for details. 
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Random vs. Pseudo-Random Sampling 
By default in ROCPLANE, Pseudo-Random Sampling is 
in effect for a Probabilistic analysis. Pseudo-Random 
Sampling allows the user to obtain reproducible results 
from a Probabilistic Analysis. Tile the views and we will 
demonstrate this. 

Select: Window → Tile Vertically 

Your screen should look similar to the figure below, if you 
have followed the tutorial this far. 

 

Figure 4-6: Tiled views of probabilistic analysis results. 

The Probabilistic Analysis can be re-run at any time, by 
selecting the Compute button in the toolbar.  

Select: Analysis → Compute 

Notice that even though the analysis is re-run, all graphs, 
and the probability of failure, remain unchanged. Select 
Compute again to verify this. 
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Pseudo-Random Sampling means that the SAME "seed" 
number is always used to generate random numbers for 
the sampling of the input data distributions. This results 
in identical sampling of the input data distributions, each 
time the analysis is run (with the same input 
parameters). The Probability of Failure, mean Safety 
Factor, and all other analysis output, will be reproducible. 
This can be useful for demonstration purposes, the 
discussion of example problems, etc. 

The Pseudo-Random Sampling option can be turned off in 
the Input Data dialog, under the Sampling tab.  

Select: Analysis → Input Data 

In the Input Data dialog, select the Sampling tab, and 
clear the Pseudo-Random Sampling checkbox. Select OK. 

Now re-select the Compute button, several times. Notice 
that after each Compute: 

• all graphs are updated and display new results,  

• the probability of failure will in general, be different 
each time the analysis is run (for this example, you 
should find that the Probability of Failure will vary 
between about 14 and 18 %) 

This demonstrates the difference between Random and 
Pseudo-Random sampling, and also graphically 
demonstrates the ROCPLANE Monte Carlo analysis.  

Note that the Wedge view does not change when you re-
compute, since by default the Mean Wedge is displayed, 
(ie. the wedge based on the mean Input Data), which is 
not affected by re-running the analysis. 
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Info Viewer 
Let’s examine the Info Viewer listing for a Probabilistic 
Analysis. 

Select: Analysis → Info Viewer 

A convenient summary of model and analysis parameters 
is displayed in its own view. Scroll down to view all of the 
information. 

As with the plot views, if you re-compute the analysis, the 
Info Viewer listing is automatically updated to reflect the 
latest results. 

Current Wedge Data 

Notice the Current Wedge Data listing in the Info Viewer. 
By default, the Mean Wedge data is displayed after a 
Probabilistic analysis. 

As we pointed out earlier, if you double-click on a 
Histogram or Scatter plot, the nearest wedge will be 
displayed in the Wedge View. The Current Wedge Data in 
the Info Viewer will also be updated, to reflect the data for 
the “picked” wedge. Let’s demonstrate this. 

1. Close (or minimize) all views you may have on the 
screen, EXCEPT the Info Viewer and the Safety 
Factor Histogram. 

2. Select the Tile Vertically toolbar button. 

3. If necessary, scroll down in the Info Viewer view, so 
that the Current Wedge Data is visible. 

4. Double-click at different points on the Safety Factor 
histogram, and notice that the Current Wedge Data is 
updated to show the data for the “picked” wedge. 
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5. Note: the Mean Wedge Data information is still 
displayed, above the Picked Wedge data, as can be 
seen in the following figure. 

 

Figure 4-7: Wedge Data for Picked Wedge and Mean Wedge. 

6. To reset the Current Wedge Data to the Mean Wedge 
data: 

Select: View → Reset Wedge 
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Additional Exercises 

Sampling Method 
So far we have used Monte Carlo sampling throughout 
this tutorial. As an additional exercise, set the Sampling 
Method to Latin Hypercube, and re-run the analysis. 

Select: Analysis → Input Data 

In the Input Data dialog, select the Sampling tab, and set 
the Sampling Method to Latin Hypercube. Select the Apply 
button. 

Examine the Probability of Failure, and the Safety Factor 
Histogram. The results should be very similar to the 
Monte Carlo analysis.  

The difference is in the sampling of the Input Data 
random variables. For example, generate a Histogram of  
Failure Plane Angle.  

Select: Statistics → Plot Histogram 

Set the Data Type = Failure Plane Angle. Select the Plot 
Input Distribution checkbox. Select OK. 

Compare the histogram with Figure 4-3. The Latin 
Hypercube sampling method results in a much smoother 
sampling of the Input Data distribution, compared to the 
Monte Carlo method. 
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Correlation Coefficient for Cohesion and 
Friction Angle 
In this tutorial, Cohesion and Friction Angle were treated 
as completely independent variables.  

In fact, it is known that Cohesion and Friction Angle are 
related in a general way, such that materials with low 
friction angles tend to have high cohesion, and materials 
with low cohesion tend to have high friction angles. 

In the Input Data dialog, the user may define the degree 
of correlation between Cohesion and Friction Angle, for 
the Failure Plane. This only applies if: 

1. BOTH Cohesion and Friction Angle are defined as 
random variables (ie. assigned a statistical 
distribution) 

2. Normal or Uniform distributions are defined (will not 
work for other distribution types). 

As a suggested exercise, try the following: 

1. Define Normal distributions for the Cohesion and 
Friction Angle. 

2. Select the “Correlation coefficient between cohesion 
and friction angle” checkbox. 

 

3. Enter a correlation coefficient. (Initially, use the 
default value of –0.5.) 

4. Re-run the analysis. 

5. Create a Scatter Plot of Cohesion vs. Friction Angle. 
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6. Note the correlation coefficient listed at the bottom of 
the Scatter Plot. It should be approximately equal to 
the value entered in the Input Data dialog (ie –0.5 in 
this case). Note the appearance of the plot. 

7. Now repeat steps 3 to 6, using correlation coefficients 
of -0.6 to -1.0, in 0.1 increments. Observe the effect on 
the Scatter Plot. Notice that when the correlation 
coefficient is equal to –1, the Scatter Plot results in a 
straight line. 

NOTE that the default correlation coefficient of –0.5 is a 
good typical value to use, if more precise data is not 
available. 

Exporting Data to Excel 
After generating any graph in ROCPLANE, you can easily 
export the data to Microsoft Excel with a single mouse 
click, as follows: 

1. Select the Chart in Excel button from the toolbar. 
(Alternatively, you can right-click on a graph and 
select Chart in Excel from the popup menu.) 

2. If you have Microsoft Excel on your computer, this 
will automatically start up the Excel program, export 
the graph data to Excel, and generate a graph in 
Excel. 

Finally, we will note the Export Dataset option in the 
Statistics menu. This option allows the user to export raw 
data from a Probabilistic Analysis, to the clipboard, a file, 
or to Excel, for post-processing. Any or all data generated 
by the probabilistic analysis, can be simultaneously 
exported. 
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Support Tutorial 
Bolts may be added to a ROCPLANE model to evaluate 
the effect of support on wedge stability. Bolt orientation 
can be optimized, or the bolt capacity for a required factor 
of safety, can be calculated.  

In this tutorial, we will add a bolt to a wedge model, and 
discuss how bolts (and external loads) are implemented in 
the ROCPLANE analysis. 

Let’s start with a new (Deterministic) file for the purposes 
of the following demonstration. 

Select: File → New 

Adding Bolts 

Bolts are added individually to a wedge model, with the 
Add Bolt option in the toolbar or the Support menu.  

Select: Support → Add Bolt 

1. Move the cursor into the Top or Front orthogonal 
views.  

2. Notice that the cursor changes to an “arrow / rockbolt” 
icon.  

3. As you move the cursor over the wedge, notice that 
the “rockbolt” and “arrow” now line up – this indicates 
that you may add the bolt to the wedge. 

4. Click the LEFT mouse button at a point on the wedge 
where you want the bolt installed.  
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5. The bolt will be added to the model, and a new safety 
factor will automatically be computed, using the 
default properties shown in the Bolt Properties dialog 
which you will see in the middle of the screen. 

 

Figure 5-1: Adding a bolt. 

6. NOTE: 

• The bolt is initially installed NORMAL to the face 
of the wedge on which you clicked (ie. normal to 
the Upper or Face slope). However you can modify 
the orientation using the Bolt Properties dialog. 

• The bolt is automatically “snapped” to the center 
of the 3D wedge model, regardless of the lateral 
location at which you clicked the mouse. 
Remember that the ROCPLANE analysis is 2D, 
and that the 3D view is for display purposes only. 
The lateral location of a bolt on the slope, has no 
effect on the analysis, so all bolts are displayed at 
the “center” of the 3D wedge view. 
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Bolt Capacity 
As you can see in the Bolt Properties dialog, the bolt 
Capacity is entered as a force per distance (tonnes per 
meter). The capacity therefore takes account of the 
spacing of the bolts in the out-of-plane direction.  

• For example, if the capacity of an individual bolt was 
50 tonnes, and the out-of-plane bolt spacing was 2 
meters, the Capacity which you would enter in the 
Bolt Properties dialog, would be 50 / 2 = 25 tonnes / 
meter. 

• Each bolt in ROCPLANE, therefore actually 
represents a ROW of equally spaced bolts. 

Since the default wedge model in ROCPLANE is a very 
large wedge (60 meter high slope), and the default Bolt 
Capacity in the Bolt Properties dialog is 20 tonnes / meter, 
the effect of the single bolt which we added, on the safety 
factor, is very small (safety factor changed from 1.637 to 
1.649 after adding the bolt). 

Let’s increase the bolt capacity to 200 tonnes / meter, so 
that we can see a greater change in the safety factor. 

In the Bolt Properties dialog, enter a Capacity = 200, and 
select the Apply button. Notice that the Safety Factor now 
increases to 1.758. 

Optimize Orientation 
The Optimize button in the Bolt Properties dialog, allows 
the bolt orientation to be optimized, for maximum Safety 
Factor. 

Select the Optimize button. Notice that the bolt Angle is 
now equal to –15 degrees, and the Safety Factor = 1.848. 
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Now select OK in the Bolt Properties dialog, and the bolt 
will be added to the model. 

Before we proceed further, we will explain how bolts are 
actually implemented in the ROCPLANE analysis. 

How Bolts are Implemented in ROCPLANE 

Bolts are implemented in the ROCPLANE stability 
analysis as follows: 

Capacity and Orientation 
1. Bolts affect the Safety Factor through their Capacity 

and Orientation. 

2. Bolt capacities and orientations are added vectorially, 
and are included in the Safety Factor calculation as a 
single, equivalent force passing through the centroid 
of the wedge. Either the ACTIVE or PASSIVE bolt 
model will apply (see below). 
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3. Multiple bolts with the same orientation can therefore 
be simulated by a single bolt having the same total 
capacity. 

Length and Location 
1. Bolt Length affects the Safety Factor in ROCPLANE 

as follows: 

• As long as a bolt passes through the wedge, (ie. 
Anchored Length > 0) the full capacity of the bolt 
will be applied in the analysis.  

• If the Anchored Length of a bolt = 0 (ie. it does not 
pass through the wedge), then the bolt will have 
NO effect on the model (ie. its effective capacity 
will be zero). 

2. The Location of bolts has NO effect on Safety Factor, 
since all forces in the wedge stability analysis are 
assumed to pass through the centroid of the wedge. 
(ie. bolt forces are NOT applied at the actual location 
of the bolts). Bolt Location in ROCPLANE is only for 
visualization purposes (eg. seeing the anchored 
length), but has no effect on the analysis. 

Bolts vs. External Force 
1. A bolt is exactly equivalent to an External Force with 

the same magnitude and orientation, if the bolt model 
is ACTIVE (see below).  

(As a suggested exercise, the user can verify that a 
bolt using the ACTIVE bolt model, and an equivalent 
External Force, result in the same Safety Factor, for a 
given wedge.) 

2. Bolts and External Forces are NOT equivalent, if the 
bolt model is PASSIVE (see below). 



76 ROCPLANE User’s Guide 

 

 

 

Multiple Bolts 
Any number of bolts can be added to a model. 

However, remember that bolts in ROCPLANE simply 
behave as force vectors passing through the centroid of 
the wedge. The applied force is equal to the bolt capacity. 

Therefore, in terms of the effect on the Safety Factor, 
multiple bolts can be simulated by: 

• a fewer number of bolts, or even a single bolt, with 
equivalent capacity and direction, 

• or an equivalent External Force. 

Installation of multiple bolts can be used for visualizing 
the bolt installation, and the necessary bolt lengths and 
spacing. Or for back-calculating the Safety Factor of an 
existing wedge support system. 

Active and Passive Bolt Models 
In general terms, the Factor of Safety is defined as the 
ratio of the forces resisting motion, to the driving forces. 
Driving forces include the mass of the wedge accelerated 
through gravity, seismic forces, and water pressure. 
Resisting forces arise from the cohesion and frictional 
strength of the wedge sliding planes. 

Active Support is included in the ROCPLANE analysis as 
in Eqn. 4.1. 

S

N

Tforcedriving
TforceresistingF
−

+= φtan
 Eqn.4.1 
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where NT  is the normal component and ST  is the shear 
component of the force applied to the failure plane by the 
support.  

Active Support is assumed to act in such a manner as to 
DECREASE the DRIVING FORCE in the Factor of Safety 
calculation. Tensioned cables or rockbolts, which exert a 
force on the wedge before any movement has taken place, 
could be considered as Active support. 

Passive Support is included in the ROCPLANE analysis 
as in Eqn. 4.2. 

forcedriving
TTforceresistingF SN ++= φtan

 Eqn.4.2 

By this definition (Ref. 13), Passive Support is assumed to 
INCREASE the RESISTING FORCE provided by shear 
restraint, in the Factor of Safety equation.  

Untensioned dowels or grouted cablebolts, which only 
develop a resisting force after some movement of the 
wedge has taken place, could be considered as Passive 
support. 

Since the exact sequence of loading and movement in a 
rock slope is never known in advance, the choice of Active 
or Passive bolt models is somewhat arbitrary. The user 
may decide which of the two models is more appropriate 
for the wedge and support system being analyzed. In 
general, Passive support will always give a lower Factor of 
Safety than Active support.  

 

Tensioned cables or rockbolts 
could be considered as 

ACTIVE support. 

Untensioned dowels or 
grouted cablebolts could be 

considered PASSIVE support. 
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Support Capacity for a Required Factor of Safety 

The Factor of Safety option in the Bolt Properties dialog, 
can be used to determine the bolt capacity required to 
achieve a given Factor of Safety.  

We will now demonstrate this, using the single bolt we 
have already added to the model. 

To edit the properties of a bolt: 

Select: Support → Edit Bolt 

1. Use the mouse to select the bolt. NOTE: Bolts can be 
selected in the Top, Front or Side views (bolts cannot 
be selected in the Perspective view). 

2. The Bolt Properties dialog will appear, and will show 
the properties of the selected bolt (Capacity = 200, 
Angle = –15). 

3. Select the Factor of Safety option, and enter a Factor 
of Safety = 2. 

4. Select the Apply button. ROCPLANE determines the 
bolt CAPACITY required to achieve the Factor of 
Safety which you have entered. 
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5. Notice that the bolt capacity is now 321 tonnes / 
meter. This is the capacity required to achieve a 
Factor of Safety = 2 (using the Active Bolt Model). 

6. Select the Passive Bolt Model, and select Apply. 

7. Using the Passive Bolt Model, a bolt Capacity of 577 
tonnes / meter is required to achieve Factor of Safety 
= 2. As expected, using the Passive Bolt Model, the 
required bolt Capacity is much higher, compared to 
the Active Bolt Model. 

8. Select OK to close the dialog. 

Now it is important to note the following: 

• Since we have only installed a single bolt in this 
example, the calculated capacity in fact represents the 
TOTAL support capacity (per meter width of slope), 
necessary to achieve the specified Factor of Safety. 

This suggests that a procedure for support design in 
ROCPLANE could be as demonstrated in this tutorial (ie): 

1. Install a single bolt, with a nominal capacity. 

2. Use the Optimize button to optimize the bolt 
orientation (or enter a bolt orientation, if known). 

3. Use the Factor of Safety option to determine the total 
Capacity necessary to achieve a required Factor of 
Safety. 

4. You may then use this value for further design 
purposes (eg. calculate the required number of bolts of 
a specified capacity, and use this number to determine 
appropriate bolt spacing). This assumes that all bolts 
are installed at the same orientation. 
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5. If multiple bolts are installed (eg. at different 
orientations), then remember that the Bolt Properties 
dialog only applies to the currently selected bolt. Keep 
this in mind when using the Optimize or Factor of 
Safety options. That is, the Optimize option only 
optimizes the orientation of the currently selected 
bolt, and the Factor of Safety option only affects the 
capacity of the currently selected bolt. 

The user is encouraged to experiment with support in 
ROCPLANE. The simplicity of the model, and the ease 
with which parametric analysis can be carried out, make 
it easy to determine the effect of bolt orientation and 
capacity on the Factor of Safety.  

Viewing Bolts 

We will now mention some display options which can be 
useful for viewing bolts. 

Select: View → Display Options 

The “ends” of the slope which are drawn on the model, can 
be turned off in the Display Options dialog.  

Clear the Draw Slope Ends checkbox, and select Apply.  

This makes bolts easier to view, particularly in the Side 
view. The bolt colour can also be customized in the 
Display Options dialog. Note that the “Selection” colour 
refers to the colour of “selected” bolts while you are using 
the Delete Bolts or Edit Bolts options.  

Customize the Bolt Colour. Select Apply and Close. 

It is useful to note that after adding bolts, if you move the 
wedge out of the slope, the bolts stay “in” the slope, and 
are completely visible. This allows you to examine the bolt 
installation in more detail. 
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To move the wedge out of the slope, you can click and drag 
the right mouse button (as described in the Quick Start 
Tutorial), or simply rotate the mouse wheel. After moving 
the wedge out of the slope, you may then want to rotate 
the model in the Perspective view, to view the model from 
any angle. 

Listing of Bolt Properties 

A listing of all bolts and their properties can be found: 

• in the 2D wedge view 

• in the Info Viewer listing. 

The 2D View and the Info Viewer options, are available in 
the Analysis menu, and in the toolbar. 

 

Bolts in a Probabilistic Analysis 

The above discussion of bolts in ROCPLANE assumes a 
Deterministic Analysis of a single wedge. 

If the Analysis Type is PROBABILISTIC:  

• the Probabilistic Analysis will be run EACH time a 
bolt is added or edited (ie. when OK is selected in the 
Bolt Properties dialog). 

• Selecting Apply in the Bolt Properties dialog will 
calculate a new Safety Factor for the MEAN wedge, 
but will NOT run the Probabilistic Analysis. 

• If you are deleting bolts, the Safety Factor for the 
MEAN wedge will be re-calculated as each bolt is 
deleted, but the Probabilistic Analysis will only be run 
when you exit the Delete Bolts option. 
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NOTE: 

Bolts should be used with some caution in a Probabilistic 
Analysis. 

Since the bolts are added while viewing the mean wedge, 
the orientations of bolts added on the mean wedge may no 
longer be optimal in terms of support, to other wedges 
generated by the Probabilistic Analysis. 
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