Manual de uso del software Isatis

El software Isatis funciona bajo el sistema operativo UNIX o LINUX y también (con ayuda
del emulador Exceed) bajo Windows. Para tener informacion adicional sobre el uso de este

software, se puede recurrir a la ayuda on-line que aparece al presionar la tecla F'I o
Help.
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Creacion de un proyecto nuevo

El punto de partida consiste en crear un estudio: File > Data File Manager
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La creacion de un proyecto se realiza gracias al sub-menu Study > Create. Se
especifica el nombre del nuevo proyecto en la zona de texto, luego se puede
cerrar el Data File Manager (Study > Close).

Create Study

i Data File Manager

i Data File Manager

Es conveniente fijar ahora los parametros del nuevo estudio (en especial, la
escala de color utilizada por defecto y las unidades para medir las distancias).

File > Color Scales

Se copia la escala de color “Rainbow Reverse” (en lectura sola) a una escala
nueva llamada “arcoiris”.
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Preferences > Study Environment.

En la pestafia “Units”, se coloca el kildmetro como unidad por defecto.

i Study Environment




En la pestafia “Graphics”, se elige la escala de colores “arcoiris” como escala por defecto.

il Study Environment




Importacion de los datos

Ahora, se puede importar la base de datos que se desea estudiar: File > Import > ASCII. El
archivo con datos (jura.dat) ya contiene el encabezado (header) requerido por Isatis (el
encabezado describe el contenido del archivo: nombre de las variables, unidades en las
cuales se miden, etc.). Se puede considerar tres tipos de bases de datos:

= estructura free: corresponde a datos esparcidos en el espacio (caso que nos interesa)

= estructura grid: corresponde a datos ubicados en una malla regular

= estructura /ine: corresponde a datos ubicados a lo largo de sondajes.
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Hay que especificar el lugar donde colocar los datos en el estudio. Al presionar en New
Points File aparece el File and Variable Selector, el cual es comin a numerosos ments de
Isatis. El lado izquierdo muestra lo que existe en el estudio actual (todavia nada, aparte del
nombre del estudio), el lado derecho contiene las variables disponibles (todavia ninguna).
Se crea nuevas carpetas, archivos y variables gracias a la parte inferior de la ventana.

La estructura de un estudio considera la siguiente jerarquia:
Estudio > Carpetas (Directories) > Archivos (Files) > Variables

Primero, se presiona el boton New Directory y se entra el nombre de una nueva carpeta (por
ejemplo, “Datos”). De vuelta en el File and Variable Selector, se presiona el botén New
File y se da un nombre, por ejemplo, “Muestras de suelo”. El programa ahora esta listo para
importar la base de datos. La parte derecha indica la lista de variables disponibles; en este
caso, no hay ninguna variable (“None”) hasta que se presione el botén OK para validar esta
ventana y el boton /mport.



% File and Variable Selector File and Variable Selector




De ser exitosa la importacién de los datos, el buzén de mensajes indica los pardmetros del
archivo y el nimero de datos.

il Isatis v6.0.5 (WinNT) [Study: Contaminacion de suelo] (2 ]E|X)
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Se puede borrar el mensaje (Clear) y esconder la ventana de mensajes (Hide).

Estudio exploratorio de los datos

El principal menu de estudio exploratorio corresponde a Statistics > Exploratory Data
Analysis. Se entra la base de datos a analizar al presionar el boton Data File.
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Se accede al File and Variable Selector. Se elige un archivo con datos, al desplazarse en el
lado izquierdo de la ventana (aqui, el tnico archivo disponible es “Datos > Muestras de
suelo”). Luego, se selecciona las variables que se desea analizar: presionar Data Variable#1
en la parte inferior y escoger las variables deseadas en el lado derecho de la ventana (en
este caso, Co y Ni, que representan las concentraciones de cobalto y niquel). Finalmente, se
sale del File and Variable Selector (botén OK).
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[zre]
[F]
-

- HHHHHHHHHEEEE

ﬂ
N
ﬂ
N

z| 2] =] [=]
z| ] [=] [=]

N
K|

E
H

El menu de estudio exploratorio aparece ahora por completo. Su contenido es:

e lista de las variables disponibles, entre las cuales se debe seleccionar aquella(s) que
se desea analizar (Co, Ni o ambas variables);

® un botdn Statistics para calcular estadisticas bésicas de las variables;

® un botén que permite personalizar los pardmetros de cédlculo antes de dibujar un
grafico (se aconseja activar esta opcion para no usar los pardmetros por defecto);

® 8 iconos que representan respectivamente: mapa de ubicacion, nube de correlacion,
histograma, curvas tonelaje-ley, grafico cuantil contra cuantil, nube de correlacion
diferida, variograma experimental y mapa variografico;

® un botén Run cuyo uso no es util a esta altura;

e un botén Close para cerrar la ventana del estudio exploratorio.



Se obtiene un mapa de ubicacién de los datos al presionar el primer icono. Por defecto, el
mapa se representa como una proyeccion en el plano horizontal, con las muestras sefialadas
por una cruz verde cuyo tamafo es proporcional al valor del dato (asi, datos con valores
altos aparecen con cruces grandes).
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Todos los gréificos en Isatis poseen cuatro mends:
* Management: entrega opciones como guardar el gréfico en Isatis o copiarlo
» Zoom: permite acercar o alejar el punto de vista
= Options: permite desplegar una regla (Ruler) para ver las coordenadas de un punto

»  Applications: este submenu contiene las opciones propias al tipo de gréfico que se
estd considerando. Por ejemplo, cambiar el estilo de la representacion de un mapa
(pintar los datos con colores) o modificar el nimero de clases de un histograma, etc.
En cambio, los tres primeros submenus (Management, Zoom, Options) son comunes
a todos los gréficos y no contienen aplicaciones especificas.

Se calcula algunas estadisticas elementales (botdn Statistics); los resultados indican un
valor maximo de 1084 ppm para la concentracién de cobalto, el cual se considera como un
valor aberrante que deberd ser eliminado de la base de datos.
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Para ello, podemos seleccionar este dato aberrante en el mismo mapa (corresponde a la cruz
de mayor tamafio). El botén derecho del mouse trae varias opciones:

No Action: desactiva la seleccion

Highlight y Highlight Append: pone en relieve los datos seleccionados

Un-Highlight all information: desactiva la opcién anterior

Mask: oculta los datos seleccionados y no los considera en los calculos

Unmask: todos los datos se vuelven activos

Display Data Information: proporciona informacién sobre los datos seleccionados en el
buzén de mensaje

e View Graphic Parameters: permite cambiar los parametros de la representacion grafica.

En este caso, la opcion adecuada es Mask. El dato aberrante aparece ahora con color rojo.
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Page 1: Base Map (Co) ' | Page 1: Base Map (Co)

Para descartar el dato aberrante en todas las manipulaciones futuras, se tiene que guardar
esta seleccion: Application > Save in selection. Esta vez, se usa el File and variable
selector para crear una nueva variable, a la cual se le da el nombre de “sin outlier”.

Page 1: Base Map (Co) File and Variable Selector
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Un resumen aparece en el buzén de mensaje, indicando que los datos seleccionados son
360, mientras que inicialmente habia 361 datos.

=l Isatis Messages

Lo que se hizo fue crear una variable binaria (que vale O para el dato aberrante y 1 para los
otros datos) y que se puede usar como “filtro”, es decir, se puede pedir al programa analizar
solamente los datos donde la variable de seleccion vale 1. Para ello, es preciso volver a
presionar el botén Data File al principio del ment de estudio exploratorio.

La variable creada (“sin outlier”’) aparece en ambos lados del File and variable selector. En
el lado derecho, se considera como variable binaria (0-1), mientras que en el lado izquierdo
se considera como filtro. Esta dltima aplicacién es la que buscamos, de modo que conviene
entrar en la seleccion (lado izquierdo) y validar (OK).
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Se puede calcular de nuevo las estadisticas. Se observa que ya no hay datos aberrantes para
las concentraciones de cobalto (valores entre 1.55 y 20.60 ppm).
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il Exploratory Data Analysis

[Ei Isatis Messages

En el mapa, el mend Application > Graphic Specific Parameters permite personalizar el
modo de representacion de los datos. En este caso, se desea dibujar los datos con un cédigo
de color (Color Code Variable), escogiendo la concentracion de cobalto (“Co”) para definir
la escala del co6digo de color.

File and Variable Selector
Graphical Parameters

Finalmente, se puede arreglar la escala de color al presionar Edit al lado de la opcién Color
Scale, eligiendo por ejemplo una escala de color entre O y 18 ppm.
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Color Scale Definition

Graphical Parameters

Contiguous Bounds

Abhora, el mapa aparece con el cddigo de color solicitado (azul para valores bajos, verde y
amarillo para valores intermedios y rojo para valores altos).
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Base Map (Co)

Antes de continuar con los otros iconos del estudio exploratorio, procederemos a verificar
que no existen datos duplicados y a desagrupar los datos.

* Busqueda de datos duplicados: Tools > Look for duplicates.
Se define una nueva variable de seleccion (por ejemplo, “sin outlier ni duplicado”) y se
considera como duplicados a datos distantes de menos de 1 metro. Se encuentra un par
de datos duplicados, siendo descartado el segundo dato de este par.

i Isatis v6.0.5 (WinNT) [Study: Contaminacion de suelo]
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il Look for Duplicates
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» Desagrupamiento de datos: Tools > Declustering.
El desagrupamiento se realiza por el método de las celdas. En input, se entran los datos
de concentracion de cobalto (con seleccidn para filtrar datos aberrantes y duplicados) y
se elige un tamafio de celda de 250m * 250m, correspondiente a la malla de muestreo
subyacente.

File and Variable Selector

il Declustering

Volvemos ahora al menu Statistics > Exploratory Data Analysis. Procedemos a entrar los
datos contenidos en la seleccion final (sin outlier ni duplicado) y a calcular un histograma
de las concentraciones de cobalto (tercer icono). Se cambia los pardmetros de calculo por
defecto, eligiendo dibujar el histograma entre los valores 0 y 20 ppm, con 20 clases.

i Exploratory Data Analysis

Page 2: Histogram (Co) |;H§Hz|
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Se puede comparar este histograma con el histograma obtenido al utilizar los ponderadores
de desagrupamiento (Compute using the weight variable > ponderadores)

i Exploratory Data Analysis :: Page 2: Histogram (Co)

Frequencies

En el histograma, se puede seleccionar una parte de los datos con ayuda del mouse. En el
siguiente ejemplo, se selecciona los datos mayores que 15 ppm, que se ponen en relieve
gracias a la opcién Highlight (botén derecho del mouse). Todas las ventanas del estudio
exploratorio (mapa, histograma...) estdn vinculadas, de modo que los datos seleccionados
aparecen también en el grifico del mapa (datos sefialados en azul).

Page 2: Histogram (Co)

Frequencies

Se regresa al estado anterior con la opcion Un-Highlight all information.
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Entre las otras herramientas del estudio exploratorio, cabe destacar

* La nube de correlacién entre dos variables (por ejemplo, las concentraciones de cobalto
y de niquel). En Application > Graphic Specific Parameters, existen opciones para
dibujar las curvas de regresion (regresion lineal y media condicional) sobre la nube de
puntos.

il Exploratory Data Analysis

Page 4: Scatter Diagram (Co, Ni)

» Los gréificos cuantil contra cuantil (QQ-plots). Permiten comparar dos distribuciones
empiricas (por ejemplo, las distribuciones de concentracion de cobalto y niquel) o una
distribucién empirica contra una distribucién tedrica (por ejemplo, la distribucién de
concentraciéon de cobalto contra una distribucién Gaussiana).
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il Exploratory Data Analysis

il Exploratory Data Analysis
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Quantile Calculation Parameters

Page 10: Q-Q Plot (Co)

Page 8: Q-Q Plot (Co)

H-Scatter Plot Calculation Parameters

)
i
i
L
+ fa
S

it

2.5 50 7.5 100 125 15.0 17.5
Gauss (n=9. 439, 5=3.563)

) CEX

La nube de correlacién diferida, que busca comparar pares de datos con cierta distancia

de separacion. Se puede destacar a los puntos de la nube mds alejados de la diagonal,
que corresponden a los pares de datos con valores muy disimiles.

19



Analisis variografico de datos

El cdlculo de variogramas experimentales y mapas variograficos todavia se realiza con el
menu Statistics > Exploratory Data Analysis.

» EIl mapa variogréfico corresponde al dltimo icono y sirve para detectar anisotropias. Se

elige los siguientes pardmetros de cédlculo:

@)

O O O O O

Nuamero de direcciones: 18 (1 direccion cada 10° de dngulo). En Isatis, el mapa
se dibuja en forma radial, lo que facilita la interpretacion de las direcciones.
Nudmero de pasos: 10

Paso (distancia): 250 m

Tolerancia en la distancia: 1 paso (250 m)

Tolerancia en la direccién: 1 sector (10°)

Nudmero minimo de pares de datos: 1

il Exploratory Data Analysis CEX Variogram Map Calculation Parameters [X|

Se aprecia una anisotropia de tipo zonal, con direccién principal de continuidad
N60°E (franja que se destaca en el mapa variografico).
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El variograma experimental corresponde al pendltimo icono. Para empezar, se puede

calcular un variograma omnidireccional (sin importar la direccién) y despliegar la nube
variogréfica. Se verifica que los valores més altos de esta nube corresponden a pares de
datos que se originan en un mismo dato, a saber, el dato de maxima concentracién de
cobalto (20.6 ppm).

#l Exploratory Data Analysis \ZHEHZ|

Variogram Calculation Parameters

Page 6: Base Map (Co)

variogran : Co

Acorde al mapa variogréfico, se espera una anisotropia con direcciones principales
N60°E y N30°W. Por consiguiente, se vuelve a calcular el variograma experimental,
esta vez en forma direccional (sin despliegar la nube variografica), con los siguientes
parametros:

O

O 0O O O O O

Ancho de banda = 1000 m

Numero de direcciones: 2

Nimero de pasos: 10

Paso (distancia): 350 m

Tolerancia en la distancia: 0.5 paso (175 m)
Tolerancia angular: 20°

Nudmero minimo de pares de datos: 1
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Yariogram Calculation Parameters

Se guarda este variograma experimental en los pardmetros del estudio: Application >
Save in parameter file. Se escribe el nombre del variograma en la zona de texto, luego
se presiona Add para agregar este nombre a la lista, OK para validar y finalmente Save
para guardar.

Page 7: Variogram (Co) = DX Save in Parameter File

variogram : o
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Para ajustar un modelo de variograma, es preciso ir a otro menu: Statistics > Variogram
Fitting. Primero, se selecciona el variograma experimental (‘“Concentracion de cobalto”),
luego se define el nombre del modelo de variograma en (NEW) Variogram model. Para
mayor facilidad, se puede dar al modelo el mismo nombre que el variograma experimental.
El programa hace automdticamente la distincién entre un variograma experimental y un
variograma modelado. El nombre del modelo se entra en la zona de texto, luego se presiona
Add para agregar el nombre a la lista de modelos y OK para validar.

B Variogran Fiting HEE

Experimental Vani | Concentracion de cobalto Print. | Apply_|
I ®perimental Variograms. d Search: [\Datos\Muestras de suelo\

Reset
I {(NEW) Variogram Model... None ... |

T ——

— Graphic
1 Fitting Window

Graphic Bounds... | Automatic

1 Global Window

— Htting Parameters
i Automatic Sill Fitting
_i Show Advanced Parameters

Run (Save) Close

= T

Hew File Name: Iclmcentracinn de cobaltd

[

El mend de ajuste trae las siguientes opciones:

e Print: escribe las caracteristicas del variograma experimental en el buzén de mensaje

e [dit: edita y modifica la definicién del modelo

e [Fitting window: dibuja el variograma direccidon por direccion y (en caso multivariable)
variable por variable

® Global window: dibuja el variograma en todas las direcciones y para todas las variables
simultdneamente

® Automatic sill fitting: permite que el programa ajuste las mesetas de los modelos
anidados en forma automatica

e Show advanced parameters: reglas usadas para el ajuste automadtico de mesetas

® Run (save): guarda el modelo ajustado

e (lose: cierra la ventana

Activemos las opciones (Fitting Window, Global Window y Automatic Sill Fitting), luego
editemos el modelo (Edit). Se entra en la ventana que define el modelo variografico (por
defecto, se trata de un modelo esférico isétropo). Las primeras opciones (hasta Rotation for
anisotropy) son de uso especializado y no se detallardn aqui.

Para definir la Rotation for anisotropy, las opciones son: None (ninguna rotacién, o sea, los

ejes principales de anisotropia son los ejes de coordenada), Global (todos los modelos
anidados tendrdn las mismas direcciones de anisotropia) y Local (cada modelo anidado
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podrd tener sus direcciones propias de anisotropia). En nuestro caso, elegimos la opcién
Global. Por defecto, el dngulo es idéntico al dngulo utilizado para calcular el variograma

experimental (30° con respecto al eje de abscisa, dando de esta forma la direccién principal
N60°E).

En la lista de Basic structures, se presiona Add para agregar un modelo de base, Delete para
suprimir uno, Delete all para suprimir todo. Cada modelo de base puede ser elegido dentro
de una lista que se encuentra en Function Type. Su alcance (Scale factor o Range) se define
a continuacion; puede ser el mismo a lo largo de todas las direcciones del espacio, o bien
cambiar segin la direccién; en este dltimo caso, es preciso activar la opcién Anisotropy
(per structure) y especificar los alcances en las direcciones principales de anisotropia. En
cambio, las mesetas no aparecen, dado que hemos activado la opcién de ajuste automatico.

Se cambia el modelo esférico en un modelo pepitico (Nugger). Luego, se agrega 3 modelos
esféricos, de alcances respectivos (0.85km;0.85km), (3km;1.8km) y (eo;1.8km) (para este
dltimo modelo, se deja el valor del primer alcance en blanco para indicar que es infinito).
Al presionar el boton 7est, el programa calcula automdticamente las mesetas que realizan el
mejor ajuste del variograma experimental.

Ml Variogram Fitting > Model Definition @
I i G de cobalto Print Load Model... | Default Model | Reset Model |
. Drift Part Basic Drift Functions... | Mo Drift
I (NEW) Variogram Motlel... | concentracion de cobalto Edit...

Covariance Part
— Graphic

 Fitting Window

Special Options: Convolution... | None
Graphic Bounds... | Automatic
Incrementation... | None

— Fitting Rotation for Anisotropy: None 4 Global ~ Local (Per Structure)

Global Anisotropy Definition... | Angle-30.00

Basic Struciures:

M Global Window

I Automatic Sill Fitting
I Show Advanced Parameters

1 - Nugget effect Add
Run (Save) Close 2 - Spherical - Range = 850.00n
3 - spherical - Range - 1800.00n Delete
7l
Delets All |
(=) )
Creyacloristics of the Selected Basic Struciure:
Function Type: Spherical Model =
M Anisotropy (per Structure)
Anisotropic Scale Factors (Ranges) along U, ¥ and W (Defined in the Rotated System)
a7 m ¥ a/fis0 m Al e
s e
Test Print 0K Cancel
EE@] i Global Window =13
Management Zoom Options  Application Help Management Zoom Options Application Help
i A

w150

ariogran : Co
n
ariogran : Go

Distance (kn)

n

Distance (km)

=

Ready.

Zoom: x1.00

Rearly.

Zoom: x1.00
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Podemos desactivar la opcidn de ajuste automadtico, en cuyo caso las mesetas aparecen en la

ventana de definicion del variograma. De este modo, se puede afinar el ajuste obtenido con
el ajuste automatico.

Model Definition

EEX|

4l 3| alffz00 4
a

Otra manera de ajustar el variograma experimental es usar la ventana Fitting Window. Con
el boton derecho del mouse, se selecciona el mend Entering the interactive fitting mode.
Cada uno de los modelos anidados estd representado por un cuadrado, del cual se puede

modificar el alcance (moviendo de derecha a izquierda) y/o la meseta (moviendo de arriba a
abajo).

Fitting Window Fitting Window CEX]|

Variogran : Go

Fitting Window

1 2 3
Distance (kn)

25



Esta opcién de ajuste actda en una direccién del espacio a la vez, de modo que es preciso
ver también lo que sucede en la otra direccidn: Application > variable & direction selection
(escoger la direccion 2 y validar). Por ejemplo si se cambia la meseta de un modelo anidado
en una direccidn, el cambio también afecta la otra direccidn.

Variable and Direction Selection for the Fitting Wind... |z Fitting Window

Variogram : Co

Distance (km)

Se guarda el modelo definido al ejecutar el botén Run (Save) de la ventana de ajuste de
variograma, luego se puede cerrar dicha ventana (Close).

#l Variogram Fitting

Validacion cruzada

Validaremos el modelo de variograma encontrado y definiremos una vecindad de kriging
mediante validacion cruzada: Statistics > Cross Validation.
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Los datos (Data File) corresponden a las concentraciones de cobalto, excluyendo los datos
aberrantes y duplicados. El botén Target variable permite seleccionar la variable a analizar
en caso de tener un modelo multivariable y el Threshold corresponde al umbral a partir del
cual una estimacion se considera “mala”. Por defecto, este umbral es 2.5, es decir, que una
estimacion es mala cuando el valor absoluto del error de estimacidn es mayor que 2.5 veces
la desviacion estdndar de estimacion.

Se pide realizar tests graficos (Graphic representations). En cambio, no se desea modificar
el modelo variogréifico segin los resultados obtenidos (en caso de activar la opcioén Rescale
the structure sills..., se modificaria la meseta del modelo de tal forma que los resultados de
validacién cruzada den menos de un 5% de datos mal estimados). Se selecciona el modelo
de variograma con la opcién Model. Se puede escoger realizar un kriging simple (de media
conocida) con el botén Special model options; por defecto, se realiza un kriging ordinario.

Falta especificar una vecindad de kriging (Neighborhood). Se define el nombre de la nueva
vecindad en la zona de texto, luego se agrega este nombre a la lista (4dd) y se valida (OK).
Por defecto, la vecindad es tnica, o sea, contiene la totalidad de los datos. Se modifica esta
eleccién con el botén Edit. Aqui, se puede definir una vecindad mévil (Moving), que estd
constituida por una elipse. Se decide dividirla en cuadrantes, con un dato como minimo (en
la vecindad entera) y 6 datos como maximo en cada cuadrante. Se oriente la elipse segiin
las direcciones principales de anisotropia (dngulo de 30° en Rotation), con radios de 1500m
en la direccion N60°E y 1000m en la direccion N30°W. Se dejan nulas las distancias de
proximidad.

Ml Cross-validation E@E\ > Neighborhood @
Humber of Variables:  ¥| Al Apply
" Search: [[\Datos\Miestras de suelo\ —

o=

Target Variable... | Co
Threshold an Standardized Score for Outiiers:  ¥| /2.5

M Graphic Representations

1 Rescale the Structure Sills According to the Cross-Validation Scores

I Motel...| concentracion de cobalto Edit. = 7 =
w‘ No special model option New File Name: | Vecindad de krigind I'_Mn
| Neighborhood... Mone Edit... 0K cancel

Special Kriging Options... | All Variables ighored

% Neighborhood Definition 3
Run Test Close
Load... Default Reset
Bl Cross-validation =)l | weighborhood Type  mowng |

Number of varkbies: | Y| AJT
.| s s Rt S Sh e e LTy

Bl e Rotation... | Angle=30.00

Search Elipsoid: Maximum Distances in the System after Rotation:

U v| a[7s00 m v ¥ |00 m W v|al[fese. 18838 m

1 Use Anisotropic Distances (Accorting to the Search Elipsoid)

Sectors ] Aavancen | Sorting |

Dimensions of the Proximity Rectangle (for Punctual Estimation Only):

Target Variable... | Co X v| a0 m Y v]ao m  z ¥|alE m

Threshold on Standardized Score for Outiers: | ¥| Al[2.5 Minimum Number of Samples: | Al

1 Anguier Sectors: A |

- Rescale the Structure Sills Accorting to the Cross-Validation Scores Optimum Number of Sampies per Sector:  v| /[T
I Model...| concentracion de cobalto Edit...

Special Model Options. . Mo special model option Tost Print. oK Cancel
| Heighborhood...| Vecindad de kriging Edit...

M Graphic Representations Humber

Run Test Close
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De vuelta en la ventana principal, se tiene tres opciones: cerrar la ventana (Close), ejecutar
la validacién cruzada (Run) o realizar una prueba (7est). Al escoger esta dltima opcidn, se
obtiene un mapa de los datos. Al pinchar un dato con el mouse, se efectia la validacién de
este dato, indicdndose los datos vecinos seleccionados y sus ponderadores de kriging. En el
menu Application, existen opciones adicionales, como imprimir la informacién relativa a la
estimacion (Print complete information), la cual aparece en el buzén de mensajes. En
particular, uno se puede fijar en la pendiente de la regresion entre el valor real y el valor
estimado (Slope of the regression Z | Z'), 1a cual debe acercarse a 1 para que la nube de
puntos (real/estimado) sea lo mds cercana posible a la linea diagonal.

;

Management Zoom Options lication
Number of Variables:  v| /1 oy Z o Appl

Selection for Display...
Data File...| Datos / Muestras de suelo [Selection = sin outlier ni duplicado]

Selection of Target...
[R] Target Yariable #1 = Co Print Weights & Resuits
[R] Extermal Drift #1 = None = -
[R] External Drift #2 = None sk Print Complete Information |
m f*t:in;:ﬂl ﬂr;ﬁ P = !:ﬂ?_e R ommin 10 b asiEnated
ac an for Target Yariable 31 = Nane BEesie v )

[R] Variance of Measurement error = None

[R] Selection of Test Data = None

[V] Cross Validation Estination = None

[V] Cross Validation Standardized Error = None

Target Variable... | Co
Threshold on Standardized Score for Outiers:  ¥| 4[[2.5

W Graphic Representations

1 Rescale the Structure Sills According to the Cross-Validation Scores
I Model...| concentracion de cobalto Edit...
Special Model Options... | No special model option
Heighbothood...| Vecindad de kriging
Special Kriging Options... | All Variables ignored 2

T ()

Run Test

General results of the calculation

Results for : Punctual

- For variable V1
Nunber of Neighbors
Mean Distance to the target
Total sun of the weights

Sun of positive weights
Lagrange parameters #1
Estinated value

Estination variance
Estination standard deviation
Variance of 2* (Estimated 2)
Covariance between Z and 2Z*
Coxrelation between 2 and 2*
slope of the regression Z | 2* = 1.007606
signal to Noise ratio (final) = 2,224dd41

CLLNINLO RN AN

T (k)

Target Variable: Co
Display Weights of: Co
Option: Punctual

Value: 9.6275 (True: 9.16)
Stl. Dev.: 2.41747 (St error: 0.276116)

Sum of Weights (%): 100.00 (+ 114.93,- 14.93)

Ready.

Save...

La prueba se puede repetir con varios datos; también se puede probar distintas vecindades
de kriging o distintos modelos variogréficos.

Luego, se cierra la ventana Test (Management > Delete Window) y se ejecuta la validacion
cruzada (Run). Esto desemboca en dos tipos de resultados. Por una parte, las estadisticas
basicas (media y varianza) sobre los errores de estimacion y los errores estandarizados, las
cuales aparecen en el buzén de mensajes. Por otra parte, los tests graficos que habian sido
solicitados:

* un mapa de ubicacién de los datos
* la nube de correlacion entre los valores reales y los valores estimados
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» el histograma de los errores estandarizados cometidos

* la nube de correlacion entre los errores estandarizados y los valores estimados

En rojo, se sefialan aquellos datos que han sido “mal” estimados (error estandarizado mayor
que 2.5 o menor que —2.5).

Statistics based on 359 test data

Mean Variance
Error 0.01692 4,48050
5td. Error 0.00170 0.90350

Statistics based on 352 robust data

Mean Variance
Error -0.00909 3.53385
Std. Error -0.00852 0.70454

A data is robust when its Standardized Error lies between -2.500000 and 2.500000

Successfully processed = 359
CPU time elapsed (sec) = 0.36
=l

Clear Save...l
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Definicion de un modelo de bloques

Antes de realizar la estimacién por kriging, se requiere definir una grilla que cubre la zona
muestreada y cuya malla representa las unidades de remediacién ambiental (20m de lado en
cada eje). Se crea la grilla deseada en File > Create Grid File.

Se entra en el File and variable selector al presionar New Grid File. Luego, se define una
nueva carpeta (Modelos) y un nuevo archivo (Grilla 20x20). Los parametros de la grilla
propuesta son:

= origen: (0.31km ; 0.31km)

=  malla: (0.02km ; 0.02km)

= numero de nodos : (242,275)

Se puede despliegar la grilla junto con los datos disponibles al entrar el archivo con datos
en Display File (Optional) y activar la opcién “Graphic Check”.

| Cre

HManagement Zoom Options #fiplication Help

Ml Create Grid File X
NMew Grid File...| Modelos / Gnlla 20x20 gF

2D Grid File i

Display File (Optional)...| Datos / de suelo [ ion = sin outlier ni

— M Graphic Check

Mode Block 1 Projection  %6% 4F
_I Rescale in the Graphic Page
— Grid P
Calculated from Samples | Reset from File | it
X Y
Format  ...| Decimal{12,3) ...| Decimal(12,3)
otk
unit .| Length(km) oue| Length(km)

origin | 4l 0.3F ﬂAl 0.31
Mesh | al[0.08 ¥ [ 0.0

Hodes 3 1}
number | A 24 ¥ alfzrs
Rotation... Ho rotation
Run Close or
i} 1 2 3 4 5
X (m)
1=
R Zoom: x1.¢

Para refinar la definicién de la zona de estudio (que no corresponde a la grilla rectangular
completa), se puede guardar el mapa de los datos obtenido en Exploratory Data Analysis
como imagen. Luego, en el ment File > Selection > Geographic, se puede cargar la grilla y
superponer la imagen del mapa de los datos (Management > Background). Finalmente se
delinea la zona de estudio utilizando la opcién “Mask from polygon™.
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Page 3: Base Map (Co)

i Geographic Selection X] Geographic Selection

Background

Geographic Selection

T )

X (kw)
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lectio

| Geographic Se - 1=

Management Zoom Options  Application He

Ml Geographic Selection

pata ...| Modelos 7 Grilla 20x20 [Selection = None]

[R] Template Selection = Nene

[R] Proportional Variable = None

IR] Literal Variable = None

IR] Color Yariashle = None

[¥] New Selection Variable = zona de estudio

20 tispiay B
§R] Proporbional Yaxiable = Newe
3 FB] Litoxal arishle » Neme
1 3 ER) Bekor Yarishle - None
5
Display as Points |  ispiay as isws | | Display as Grd |
2] 35927 selected samples / 66550 Reset Selection|
i =

X ()

Estimacion de las concentraciones de cobalto por kriging

La interpolacién por kriging se encuentra en Interpolate > Estimation > (Co-)Kriging.

Las unidades a estimar miden 20mx20m y tienen un soporte mayor que las muestras de
suelo. Por esta razén, se realiza un kriging de bloque, activando la opcidn correspondiente
al inicio de la ventana de kriging. Los datos a utilizar (Input File) son las concentraciones
de cobalto en las muestras de suelo. Se especifica el nombre de las variables de salida en
Output File (a saber, el valor estimado y la desviacién estandar de kriging), el modelo de
variograma (Model) y la vecindad (Neighborhood). No se prueba ninguna opcién especial
(Special model options y Special kriging options).

Sin embargo, por tratarse de una estimacién no puntual, una discretizacién es requerida,
cuyos pardmetros se especifican en la vecindad (Edir). Al final de la ventana que define la
vecindad, aparece una opcién Discretizing (por defecto, 5x5x1). Se decide aumentar esta
discretizacién a 10x10x1. Al presionar el boton Calculate Cvv, el buzén de mensajes indica
los resultados de 11 intentos para calcular la varianza de las concentraciones de cobalto en
las unidades de remediacion (esta varianza se evalda a partir del modelo de variograma,
mediante una integracién numérica). De ser suficiente la discretizacién de los bloques, los
resultados deberian permanecer relativamente estables. En el presente caso, todos los
intentos sefialan una varianza de 12.85.
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il Standard (Co-)Kriging LEX Neishborhood Definition

Se aprueba el parametro de discretizacion de la vecindad (OK) y se ejecuta el kriging de
bloques (Run).

Los resultados del kriging pueden verse en el menu Statistics > Exploratory Data Analysis:
* mapas de los valores estimados y desviaciones estdndar de estimacion
* histograma de los valores estimados
= seleccion de los bloques cuya estimacion sobrepasa un umbral critico (12 ppm).

Las estadisticas basicas indican que de las 35927 unidades de remediacién, 30278 (o sea, el
84.3% del total) tienen valores estimados bajo el umbral critico de 12 ppm. Ahora, debido a
la propiedad de suavizamiento del kriging, esta proporcién puede estar ser engafiosa: el
kriging tiende a acercar los valores estimados a la media de los datos, disminuyendo la
frecuencia de valores extremos (sobre el umbral). Para remediar a esta situacién se preferira
utilizar simulaciones condicionales.
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il Exploratory Data Analysis =3 Page 1: Base Map (Kriging ordinario Co) [ |B|&X]

ase Map (Desviacion kriging
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Simulacion condicional de las concentraciones de cobalto

La simulacion se lleva a cabo en el marco del llamado modelo multi-Gaussiano. Contempla
las siguientes etapas.

1) Transformacion de los datos originales (concentracion de cobalto) a datos Gaussianos:
Statistics > Gaussian Anamorphosis Modeling. En este mend, se debe especificar los
valores extremos admisibles para la concentracién de cobalto (por ejemplo, O ppm y 22
ppm), el grado del polinomio utilizado para modelar la funcién de anamorfosis (100), el
nombre de la funcién de anamorfosis (por ejemplo, “anamorfosis Co”) y la opcién de
transformacién. Respecto a lo dltimo, las dos primeras opciones (Frequency inversion 'y
Empirical inversion) realizan la transformacion de los datos siguiendo la anamorfosis
empirica (funcién escaloneada, que aparece en negra en el grafico de la anamorfosis),
mientras que la tercera opcion (Linear Interpolator Inversion) utiliza la anamorfosis
modelada (linea azul).

il Gaussian Anamorphosis Modeling

Fitting Parameters

092 W N

Anamorphosis

Anamorphosis

A =l =E el 0 3 2 3 4 5

usgian values
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2) Estudio exploratorio y variografico de los datos Gaussianos: Statistics > Exploratory
Data Analysis y Statistics > Variogram Fitting.

®= Primero, se comprueba que el histograma de los datos transformados tiene forma de
campana de Gauss.

BEnlese orvilat e nalvEs Page 7: Histogram (Gaussiana Co) \:Hiﬂz\

= Se verifica que los pares de datos transformados tienen distribuciones bigaussianas,
mediante la visualizacion de nubes de correlacion diferida (que deben tener forma
de elipses) o del cuociente entre la raiz cuadrada del variograma y el madograma
(que debe ser constante e igual a 1.77).

H-Scatter Plot Calculation Parameters

il Exploratory Data Analysis
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Page 6: Variogram (Gaussiana Co)

Variogram Calculation Parameters

= Se calcula y se guarda el variograma experimental de los datos transformados. Para
ello, se usa los mismos pardmetros que para calcular el variograma experimental de
los datos originales.

Sqrt of Variogram / Madogram : Gaussian

0o 0.5 1.0 1.5 2.0

Distance (k)

Variogram Calculation Parameters : Page B: Variogram (Gaussiana Co) 7 X Experimental Variogram

= Se ajusta un modelo de variograma (Statistics > Variogram Fitting). El modelo
propuesto consta de un efecto pepita (Nugger) y tres modelos esféricos anidados,
con alcances (0.5km;0.5km), (2km;1.5km) y (eo;1.5km) a lo largo de las direcciones
N60°E y N30°W, respectivamente. Se guarda el modelo al presionar el botén Run
(Save).
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Il Variogram Fitting |- |B]%] > Model Definition

Global Window

Variogran : Gaussisna Co

Distance (km)

3) Simulacién condicional: Interpolate > Conditional Simulation. Isatis dispone de tres
algoritmos de simulacién de funciones aleatorias multi-Gaussianas:
* Algoritmo de bandas rotantes (7Turning Bands)
= Algoritmo secuencial (Sequential Gaussian)
*  Algoritmo de descomposicion matricial (LU Decomposition)

En el presente caso, se decide usar el primer algoritmo (bandas rotantes). La simulacién
se realizard sobre bloques (option Block), a saber, unidades de remediacién de 20m de
lado. En input file, uno entra los datos Gaussianos de cobalto, mientras que en output
file se define una variable de salida (simulacion Co). Se trata de una variable vectorial
(“macro-variable”), que tiene tantas componentes como realizaciones construidas (en
este caso, seran 50). Luego, se entra la funcién de anamorfosis (anamorfosis Co) que se
usard para transformar las simulaciones desde el espacio Gaussiano al espacio de las
concentraciones de cobalto, el modelo variografico de los datos Gaussianos, el tipo de
kriging utilizado para condicionar las simulaciones (kriging simple de media 0) y la
vecindad de kriging. Finalmente, se debe entrar dos nimeros:

* Un nimero de semilla (Seed), requerido para la generacion de valores aleatorios. Se

aconseja tomar un nimero grande (6 a 8 digitos). En caso de hacer varias corridas
(por ejemplo, 5 corridas de 10 realizaciones), se debe cambiar la semilla en cada
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corrida, a falta de que los nimeros aleatorios generados serian los mismos y, por lo
tanto, las realizaciones también serian las mismas.

= Un ndmero de “bandas rotantes” que es propio del algoritmo de simulacién. La
simulacidén en el espacio 2D se logra mediante simulaciones unidimensionales a lo
largo de lineas distribuidas en forma regular o casi regular en el espacio 2D.
Converge a una simulacién multi-Gaussiana cuando se suma una gran cantidad de
simulaciones unidimensionales (debido al teorema del limite central), para fijar las
ideas, varios cientos o miles. En este caso se decide tomar 1000 bandas.

Gaussian Back Transformation

il Turning Bands Simulation

4) Procesamiento de las simulaciones. En el mend Tools > Simulation Post-Processing, se
puede calcular varias estadisticas (bloque a bloque) sobre las concentraciones simuladas
de cobalto. Por ejemplo:
= Promedio y desviacién estandar de las realizaciones (Statistical Maps)

= Cuantiles (por ejemplo, la mediana) de las realizaciones (Iso-Frequency Maps)

= Probabilidad de sobrepasar un umbral dado (Iso-Cutoff Maps), por ejemplo 12 ppm.
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Statistical Maps

E Modelos / Grilla 2020 [Selection = zona de estudio]

Iso-Cutoff Maps
1571 r—

5117 Fr—
J51 /7 EE—

HModelos ! Grilla 2020 [Selection = zona de estudio]

5) Definicion de dreas segtin el nivel de peligrosidad (File > Selection > Intervals). Por
ejemplo: un drea de remediacion donde la probabilidad de superar el umbral 12 ppm es
mayor que 0.5; un drea segura con las unidades cuya probabilidad de superar 12 ppm
es menor que 0.2; un drea incierta con las unidades cuya probabilidad de superar 12
ppm estd entre 0.2 y 0.5, la cual requerird un muestreo adicional para saber si se debe
remediar o dejar in situ.

il Interval Selection
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6) Visualizacion de los resultados (Statistics > Exploratory Data Analysis), por ejemplo
mapas de la concentracion esperada (media de las realizaciones), de la incertidumbre
asociada (desviacion estandar de las realizaciones), de la probabilidad de encontrar una
concentracion sobre 12 ppm y de las tres dreas previamente definidas.
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Cabe notar la similitud entre el mapa de kriging y el mapa obtenido al promediar las
realizaciones. En cambio, la desviacion estdndar de las realizaciones depende no sélo
de la cantidad y posicién de las muestras, sino que también de las concentraciones de
cobalto medidas en estas muestras, a diferencia de la desviacion estdndar de kriging.
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