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Tutorial: Classification Methods

Overview of This Tutorial

This tutorial provides an introduction to classification procedures using Landsat TM data from Cafion City, Colorado.
Results of both unsupervised and supervised classifications are examined and post classification processing including

clump, sieve, combine classes, and accuracy assessment are discussed.

Files Used in This Tutorial
CD-ROM: Tutorial Data CD #2
Path: envidata\can_tm

File Description

can_tmr.img Cafion City, Colorado TM reflectance image
can_tmr.hdr ENVI header for above

can_km.img K-meansf classification

can_km.hdr ENVI header for above

can_iso.img ISODATA classification

can_iso.hdr ENVI header for above

classes.roi Regions of interest (ROI) for supervised classification
can_pcls.img Parallelepiped classification
can_pcls.hdr ENVI header for above

can_bhin.img Binary encoding result

can_hin.hdr ENVI header for above

can_sam.img SAM classification result
can_sam.hdr ENVI header for above

can_rul.img Rule image for SAM classification
can_rul.hdr ENVI header for above

can_sv.img Sieved image

can_sv.hdr ENVI header for above
can_clmp.img Clump of sieved image

can_clmp.hdr ENVI header for above
can_comb.img Combined classes image
can_comb.hdr ENVI header for above

can_ovr.img Classes overlain on gray scale image
can_ovr.hdr ENVI header for above

can vl.evf Vector layer generated from class #1
can_v2.evf Vector layer generated from class #2

This dataset is Landsat TM data from Cafion City, Colorado.

Examining a Landsat TM Color Image

This portion of the exercise will familiarize you with the spectral characteristics of the Landsat TM data of Cafion City,
Colorado, USA. Color composite images will be used as the first step in locating and identifying unique areas for use as

training sets in classification.

Before attempting to start the program, ensure that ENVI is properly installed as described in the Installation Guide that

shipped with your software.

1. From the ENVI main menu bar, select File 2 Open Image File.

2. Navigate to the envidata\can_tm directory, select the file can_tmr.img from the list, and click Open. The
Available Bands List appears on your screen.

3. Click on the RGB Color radio button in the Available Bands List. Red, Green, and Blue fields appear in the middle

of the dialog.

3
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4. Select Band 4, Band 3, and Band 2 sequentially from the list of bands at the top of the dialog by clicking on
the band names. The band names are automatically entered in the Red, Green, and Blue fields.

5. Click Load RGB to load the image into ENVI.
6. Examine the image in the display group.

Reviewing Image Colors

The color image displayed below can be used as a guide to classification. This image is the equivalent of a false color
infrared photograph. Even in a simple three-band image, it's easy to see that there are areas that have similar spectral
characteristics. Bright red areas on the image represent high infrared reflectance, usually corresponding to healthy
vegetation, either under cultivation, or along rivers. Slightly darker red areas typically represent native vegetation, in this
case in slightly more rugged terrain, primarily corresponding to coniferous trees. Several distinct geologic and
urbanization classes are also readily apparent as is urbanization.

#1 #1 (R:TM Band 4,G:TM Band 3,8:TM Band ... [= |[B](X]

File ©werlay Enhance Tools ‘Window

Using the Cursor Location/Value
Use ENVI's Cursor Location/Value option to preview image values in the displayed spectral bands.

1. From the Display group menu bar, select Tools - Cursor
Location/Value. Alternatively, double-click the left mouse button

# Cursor Location f Yalue |:||E X|
in the Image window to toggle the Cursor Location/Value dialog on File (Options

and off. Disp #1 [276.167) Sem: R143 G130 B:124
2. Move the cursor around the image and examine the data values in Data: A:35 G:27 B:24

the dialog for specific locations. Also note the relation between

image color and data value.

3. From the Cursor Location/Value dialog, select Files > Cancel.

4
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Examining SpeCtraI PIOtS ﬂl_#1 Spectral Profile:can_tmr.img E@_g

Use ENVI's integrated spectral profiling capabilities to examine the

spectral characteristics of the data. Spectral Profile

1. From the Display group menu bar, select Tools = Profiles 2
Z Profile (Spectrum) to begin extracting spectral profiles.

2. Examine the spectra for areas that you previewed above using
color images and the Cursor/Location Value dialog by clicking
the left mouse button in any of the display group windows.
Note the relations between image color and spectral shape.
Pay attention to the location of the image bands in the
spectral profile, marked by the red, green, and blue bars in
the plot.

3. From the Spectral Profile dialog menu bar, select File >
Cancel.

"~ Reflectance

Exploring Unsupervised Classification Methods

Unsupervised classification can be used to cluster pixels in a data set based on statistics only, without any user-defined
training classes. The unsupervised classification techniques available are Isodata and K-Means.

Applying K-Means Classification

K-Means unsupervised classification calculates initial class means evenly distributed in the data space then iteratively
clusters the pixels into the nearest class using a minimum distance technique. Each iteration recalculates class means and
reclassifies pixels with respect to the new means. All pixels are classified to the nearest class unless a standard deviation
or distance threshold is specified, in which case some pixels may be unclassified if they do not meet the selected criteria.
This process continues until the number of pixels in each class changes by less than the selected pixel change threshold

or the maximum number of iterations is reached. 1l 5
. e -Means Parameters
1. From the ENVI main menu, select Classification =

Unsupervised - K-Means or review the pre-calculated
results of classifying the image by opening the can_km. img
file in the can_tm directory

.

MNumber of Claszes 5 -

. . . Ch Threshold % [0-100)|5.00
2. Select the can_tmr.img file and click OK. The K-Means ange Threshold % { )

Parameters dialog appears. ey 1 a
3. Accept the default values, select the Memory radio button,

and click OK. The new band is loaded into the Available .

Bands List. b aximum Stdey From Mean
4. From the Available Bands List, click the Display #1 button M awimurn Distance Ermor

and select New Display.

5. From the Available Bands List, select the K-Means band and
click Load Band.

6. From the Display group menu bar, select Tools - Link -
Link Displays then click OK to link the images.

Output Resultta € File

ak. | I]ueue| Ear‘u:el| Help|

7. Compare the K-MEANS classification result to the color
composite image using the dynamic overlay feature in ENVI (click using the left mouse button in the Image
window).

8. From the Display group menu bar, select Tools 2 Link = Unlink Display to remove the link and turn off the
dynamic overlay feature.

9. |If desired, experiment with different numbers of classes, change thresholds, standard deviations, and maximum
distance error values to determine their effect on the classification.

5
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Applying Isodata Classification

Isodata unsupervised classification calculates class means evenly distributed in the data space then iteratively clusters the
remaining pixels using minimum distance techniques. Each iteration recalculates means and reclassifies pixels with
respect to the new means. This process continues until the number of pixels in each class changes by less than the
selected pixel change threshold or the maximum number of iterations is reached.

1. From the ENVI main menu bar, select Classification 2 Unsupervised - Isodata, or review the pre-
calculated results of classifying the image by opening the can_iso. img file in the can_tm directory.

2. Select the can_tmr.img file and click OK. The ISODATA Parameters dialog appears.

3. Accept the default values, select the Memory radio button, and click OK. The new band is loaded into the
Available Bands List.

#1 ISODATA Parameters E] |

Muriber of Clazses: Min |5 - Ma:-:lT 0o = bl asimum Shdey From Mean |
b asirnum [terations 1 - b asimnum Distance Error

Change Threshold % (0-100)|5.00

Output Resultta © File & Memany

Mikirmumn 3 Pixel in Class |1 -

b aximnum Clazs Stdw 1.000

Mirirmumn Clazs Distance (5000

M amirum & Merge Pais |2 -

| [ueue | Cancel | Help |

4. From the Available Bands List, click the Display #2 button and select New Display.
5. Select the ISODATA band and click Load Band.

6. From the Display group menu bar, select Tools 2 Link = Link Displays and click OK in the dialog to link the
images.

7. Compare the ISODATA classification result to the color composite image using the dynamic overlay feature in
ENVI (click using the left mouse button in the Image window).

8. Toggle the dynamic overlay of the third image by holding the left mouse button down and simultaneously clicking
on the middle mouse button. Compare the ISODATA and K-MEANS classifications.

9. |If desired, experiment with different numbers of classes, change thresholds, standard deviations, maximum
distance error, and class pixel characteristic values to determine their effect on the classification.

10. From the Display group menu bar on the K-Means Image window, select File > Cancel to close the image
display. Close the ISODATA Image window using the same technique.

Exploring Supervised Classification Methods

Supervised classification can be used to cluster pixels in a data set into classes corresponding to user-defined training
classes. This classification type requires that you select training areas for use as the basis for classification. Various
comparison methods are then used to determine if a specific pixel qualifies as a class member. ENVI provides a broad
range of different classification methods, including Parallelepiped, Minimum Distance, Mahalanobis Distance, Maximum
Likelihood, Spectral Angle Mapper, Binary Encoding, and Neural Net. In this tutorial, you will experiment with two
methods for selecting training areas, also known as regions of interest (ROIs).

6
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Selecting Training Sets Using Regions of Interest (ROI)

As described in the tutorial, “An Introduction to ENVI” and summarized here, ENVI lets you define regions of interest
(ROISs) typically used to extract statistics for classification, masking, and other operations. For the purposes of this
exercise, you can either use predefined ROIs, or create your own. In this exercise, you will restore predefined ROIs.

1. From the Display group menu bar, select Tools - Region of Interest - ROI Tool. The ROI Tool dialog
appears.

2. From the ROI Tool dialog menu bar, select File > Restore ROls.
3. Select the classes.roi file and click Open. Click OK to restore the ROIs.

Applying Parallelepiped Classification

Parallelepiped classification uses a simple decision rule to classify multispectral data. The decision boundaries form an n-
dimensional parallelepiped classification in the image data space. The dimensions of the parallelepiped classification are
defined based upon a standard deviation threshold from the mean of each selected class. If a pixel value lies above the
low threshold and below the high threshold for all n bands being classified, it is assigned to that class. If the pixel value
falls in multiple classes, ENVI assigns the pixel to the last class matched. Areas that do not fall within any of the
parallelepiped classifications are designated as unclassified.

1. From the ENVI main menu bar, select Classification - Supervised - Parallelepiped, or review the pre-
calculated results of classifying the image by opening the can_pcls.img file in the can_tm directory.

Select the can_tmr.img file and click OK. The ISODATA Parameters dialog appears.

Click the Select All Items button to select the ROIs.

Select to output the result to Memory using the radio button provided.

Toggle the Output Rule Images to No then click OK. The new band is loaded into the Available Bands List.

o M wn

#l Parallelepiped Parameters

Select Clazzes from Regions:
Output Besultto © File ™ Memary

Murmber of iterms selected: |3

| Clear &ll ltems | Dutput Rule Images ?lﬁﬂ

Set Max stdev from Mean

" Mone ™ SingleValue  Multiple Values

M ax stdev from Mean|3.00

0k, | IJueue| Eance|| Help| Preview|

From the Available Bands List, click the Display #1 button and select New Display.
Select the Parallel band and click Load Band.

From the Display group menu bar, select Tools = Link = Link Displays and click OK in the dialog to link the
images.

9. Use image linking and dynamic overlay to compare this classification to the color composite image and previous
unsupervised classifications.

7
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Applying Maximum Likelihood Classification

Maximum likelihood classification assumes that the statistics for each class in each band are normally distributed and
calculates the probability that a given pixel belongs to a specific class. Unless a probability threshold is selected, all pixels
are classified. Each pixel is assigned to the class that has the highest probability (i.e., the maximum likelihood).

1. Using the steps above as a guide, perform a Maximum Likelihood classification.
2. Try using the default parameters and various probability thresholds.

3. Use image linking and dynamic overlay to compare this classification to the color composite image and previous
unsupervised and supervised classifications.

Applying Minimum Distance Classification

The minimum distance classification uses the mean vectors of each ROl and calculates the Euclidean distance from each

unknown pixel to the mean vector for each class. All pixels are classified to the closest ROI class unless the user specifies
standard deviation or distance thresholds, in which case some pixels may be unclassified if they do not meet the selected
criteria.

1. Using the steps above as a guide, perform a Minimum Distance classification.
2. Try using the default parameters and various standard deviations and maximum distance errors.

3. Use image linking and dynamic overlay to compare this classification to the color composite image and previous
unsupervised and supervised classifications.

Applying Mahalanobis Distance Classification

The Mahalanobis Distance classification is a direction sensitive distance classifier that uses statistics for each class. It is
similar to the Maximum Likelihood classification but assumes all class co-variances are equal and therefore is a faster
method. All pixels are classified to the closest ROI class unless you specify a distance threshold, in which case some pixels
may be unclassified if they do not meet the threshold.

1. Using the steps above as a guide, perform a Mahalanobis Distance classification.
2. Try using the default parameters and various maximum distance errors.

3. Use image linking and dynamic overlay to compare this classification to the color composite image and previous
unsupervised and supervised classifications.

Exploring Spectral Classification Methods

The following methods are described in the ENVI User’s Guide. These were developed specifically for use on
hyperspectral data, but provide an alternative method for classifying multispectral data, often with improved results that
can easily be compared to spectral properties of materials. They typically are used from the Endmember Collection dialog
using image or library spectra, however, they can also be started from the Classification - Supervised menu option.

Collecting Endmember Spectra

The Endmember Collection:Parallel dialog is a standardized means of collecting spectra for supervised classification from
ASCII files, regions of interest, spectral libraries, and statistics files.

1. From the ENVI main menu bar, select Classification @ Endmember Collection.
2. Click the Open drop-down button and select New File.

3. Select the can_tmr.img file and click Open. The can_tmr. img file will appear in the Select Input File section
of the Classification Input File dialog.

4. Select the can_tmr.img file within the Select Input File section of this dialog and click OK. The Endmember
Collection dialog appears with the Parallelepiped classification method selected by default. The available

8
ENVI Tutorial: Classification Methods



&y
S ENVI Tutorial: Classification Methods

classification and mapping methods are listed under the Algorithm menu. You will use this dialog in the

#1 Endmember Collection:P... E@Ej

following exercises.

File Import BRGNS Options  Help

ﬁ v Parallelepiped
Mazk: chong  Minimum Distance
W avelength: Mahalanchis Distance
& bar Maxirmum Likelihood
¢ spectral Angle Mapper
Binary Encoding ”

=

Linear Spectral Lnmixing
Matched Filkering
Mixckure Tuned MF
Spectral Feature Fitking
Mulki Range SFF

| aE R

Applying Binary Encoding Classification

The binary encoding classification technique encodes the data and endmember spectra into Os and 1s based on whether
a band falls below or above the spectrum mean. An exclusive OR function is used to compare each encoded reference
spectrum with the encoded data spectra and a classification image is produced. All pixels are classified to the endmember
with the greatest number of bands that match unless the user specifies a minimum match threshold, in which case some
pixels may be unclassified if they do not meet the criteria.

1.

From the Endmember Collection:Parallel dialog menu bar, select Algorithm - Binary Encoding or review the
pre-calculated results of classifying the image by opening the can_bin. img file in the can_tm directory. These
results were created using a minimum encoding threshold of 75%.

For this exercise, we will use the predefined ROIs in the CLASSES.ROI file. From the Endmember
Collection:Parallel dialog menu bar, select Import - from ROI/EVF from Input File. The Select Regions for

Stats dialog appears. -
PP #1 Endmember Collection Spectra E@E
Click the Select All Items button, and click OK. : ' : :
File Edit ©ptions Plot_Function Help

In the Endmember Collection:Parallel dialog, click Select
All then click Plot to view the endmember spectral plots for
the ROIs collected in the Endmember Collections dialog.

Endmember Collection Spectra

In the Endmember Collections dialog click Apply. The
Binary Encoding Parameters dialog appears.

In the Binary Encoding Parameters dialog, select to output
the result to Memory using the radio button provided.

Toggle the Output Rule Images to No, then click OK to
start the classification. The new band is loaded into the
Available Bands List.

From the Available Bands List, select the Parallel band and click Load Band.

9
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9. Use image linking and dynamic overlay to compare this classification to the color composite image and previous
unsupervised and supervised classifications.

Applying Spectral Angle Mapper Classification

The Spectral Angle Mapper (SAM) is a physically-based spectral classification that uses an n-dimensional angle to match
pixels to reference spectra. The algorithm determines the spectral similarity between two spectra by calculating the angle
between the spectra, treating them as vectors in a space with dimensionality equal to the number of bands. SAM
compares the angle between the endmember spectrum vector and each pixel vector in n-dimensional space. Smaller
angles represent closer matches to the reference spectrum. Pixels further away than the specified maximum angle
threshold in radians are not classified.

1. Using the steps in the last exercise as a guide, perform a Spectral Angle Mapper classification, or review the
pre-calculated results of classifying the image by opening the can_sam. img file in the can_tm directory

2. Use image linking and dynamic overlay to compare this classification to the color composite image and previous
unsupervised and supervised classifications.

Exploring Rule Images

ENVI creates images that show the pixel values used to create the classified image. These optional images allow users to
evaluate classification results and to reclassify if desired based on thresholds. These are gray scale images; one for each
ROI or endmember spectrum used in the classification.

The rule image pixel values represent different things for different types of classifications, for example:
Classification Method | Rule Image Values

Parallelepiped Number of bands satisfying the parallelepiped criteria
Minimum Distance Sum of the distances from the class means

Maximum Likelihood Probability of pixel belonging to class

Mahalanobis Distance Distances from the class means

Binary Encoding Binary match in percent

Spectral Angle Mapper Spectral angle in radians (smaller angles indicate closer
match to the reference spectrum)

1. From the ENVI main menu bar, select File 2 Open Image &l #3 ENVI Color Tables
File. File Options

2. Navigate to the envidata\can_tm directory, select the file
can_rul.img from the list, and click Open. The Available
Bands List appears on your screen.

3. Click on the Gray Scale radio button in the Available Bands List ﬂ

and open each Rule band into its own image window (use the Shetch Baottam
Display > New Display button). 4
4. Use image linking and dynamic overlay to compare the color Stretch Top
composite image to the rule images. Calor Tables:
. B LIMEAR -
5. From the Display group menu bar, select Tools - Color BLUEAWHITE
Mapping = ENVI Color Tables and drag the Stretch Bottom GRM-RED-BLL-AWHT
and Stretch Top sliders to opposite ends of the dialog. Areas RED TEMPERATLRE
with low spectral angles (more similar spectra) appear bright. BLUE/GREEN/RED/YELLOW
STD Gakdbdd-l|
PRISH
RED-FURFLE

10
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Post Classification Processing

Classified images require post-processing to evaluate classification accuracy and to generalize classes for export to image-
maps and vector GIS. Post Classification can be used to classify rule images; to calculate class statistics and confusion
matrices; to apply majority or minority analysis to classification images; to clump, sieve, and combine classes; to overlay
classes on an image; to calculate buffer zone images; to calculate segmentation images; and to output classes to vector
layers. ENVI provides a series of tools to satisfy these requirements.

Extracting Class Statistics

This function allows you to extract statistics from the image used to produce the classification. Separate statistics
consisting of basic statistics, histograms, and average spectra are calculated for each class selected.

1. From the ENVI main menu bar, select Classification = Post Classification = Class Statistics. The
Classification Input File dialog appears.

2. Click the Open drop-down button and select New File.
3. Select the can_pcls.img file from the can_tm directory and click Open. The Statistics Input File appears.

4. Select the can_tmr.img file within the Select Input File section of this dialog and click OK. The Class Selection
dialog appears.

5. Click the Select All Items button then click OK. The Compute Statistics Parameters dialog appears.

6. Click the Histograms, Covariance, and Covariance Image check boxes in the Compute Statistics Parameters
dialog to calculate all the possible statistics.

7. Click OK to compute the statistics. The Class Statistics Results dialog appears.

B Class Statistics Results: can_tmr.img

File ©Options

Stats for Unclassified +

Select Plat v| Clear Plat |

an_tmr.dmg

Select Stat+

Filename: C:%Documents and Settings‘mwelch\My D ~
Dims: Full Scene (256,000 points)

Class Distribution Summary
Unclassified: 184,442 points (72.048%)
Region #1: 10,145 points (3.963%)
Region #2: 8,426 points (3.291%)
Region #3: 52,987 points (20.698%)

Stats for Class: Unclassified

Basic Stats Min Max Mean Stdev

Band 1 4] 100 17.586992 6.177730

< >
11
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Generating a Confusion Matrix

ENVI's confusion matrix function allows comparison of two classified images (the classification and the “truth” image), or
a classified image and ROIls. The truth image can be another classified image, or an image created from actual ground
truth measurements. In this exercise, you will compare the Parallelepiped and SAM classification images using the
Parallelepiped classification image as the ground truth.

1.

From the ENVI main menu bar, select Classification 2 Post Classification 2 Confusion Matrix 2 Using
Ground Truth Image. The Classification Input File dialog appears.

Select the can_pcls.img file and click OK. The Ground Truth #ll Match Classes Parameters E]
Input File appears.

: : Select Select

lick th - lect New File.
Click the Open drop-down button and select New File Ground Truth Class Clazzification Image
Select the can_sam.img file from the can_tm directory and Region #3 [Blue

click Open.

Select the can_sam.img file within the Select Input File
section of this dialog and click OK. The Match Classes
Parameters dialog appears.

Click the Select All 1tems button then click OK. The

Ground Truth Class |F=egic.n #2 [Blue1][247 p

Compute Statistics Parameters dialog appears. Clagzific:ation EIass|Heginn #3
Select Region #1 from both fields and click Add &dd Cambination
Combination. Continue to pair corresponding classes from
the two images in this way then click OK. The Confusion Matched Clazzes
Matrix Parameters dialog appears. Unclazsified <-> Unclassified
. . . Reqgion #1 [Red1] [327 points] <> Region #1
Click the Output Result to Memory radio button then click Region #2 [Green] [137 points] < Fegion #2
OK.

Examine the confusion matrix and confusion images (in the

Available Bands List). Determine sources of error by comparing ok | Cancel
the classified image to the original reflectance image using

dynamic overlays, spectral profiles, and Cursor Location/Value.

Clumping and Sieving
Clump and Sieve provide means for generalizing classification images. Sieve is usually run first to remove the isolated

pixels based on a size (number of pixels) threshold, then clump is run to add spatial coherency to existing classes by
combining adjacent similar classified areas.

1.

From the ENVI main menu bar, select Classification = Post Classification = Sieve Classes. The
Classification Input File dialog appears.

Select the can_sam.img file within the Select Input File section of this dialog and click OK. The Sieve
Parameters dialog appears.

Click the Output Result to Memory radio button then click OK. The image is loaded into the Available Bands
List.

You will now use the output of the sieve operation as the input for clumping. From the ENVI main menu bar,
select Classification - Post Classification - Clump Classes.

Select the previously created image file from memory within the Select Input File section of this dialog and click
OK. The Sieve Parameters dialog appears.

Click the Output Result to Memory radio button then click OK. The image is loaded into the Available Bands
List.

Compare the three images (can_sam.img, Clump, and Sieve) and reiterate if necessary to produce a
generalized classification image.
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8.

Optional: compare the pre-calculated results in the files can_tm\can_sv. img (sieve) and can_clmp. img
(clump of the sieve result) to the classified image can_pcls.img (parallelepiped classification) or calculate your
own images and compare to one of the classifications.

Combining Classes

The Combine Classes function provides an alternative method for classification generalization. Similar classes can be
combined to form one or more generalized classes.

1.

From the ENVI main menu bar, select Classification - Post Classification - Combine Classes or review
the pre-calculated results of classifying the image by opening the can_comb.img file in the can_tm directory. The
Classification Input File dialog appears.

Select the can_sam.img file within the Select Input File section of this dialog and click OK. The Combine
Classes Parameters dialog appears.

Select Region #3 from the Select Input Class field, click Unclassified from the Select Output Class field, click
Add Combination, then click OK. The Combine Classes Output dialog appears.

Click the Output Result to Memory radio button then click OK. The image is loaded into the Available Bands
List.

Using image linking and dynamic overlays, compare the combined class image to the classified images and the
generalized classification image.

Overlaying Classes
Overlay classes allow you to place the key elements of a classified image as a color overlay on a gray scale or RGB image.

You can examine the pre-calculated image can_tm\can_ovr.img or create your own overlay(s) from the
can_tmr. img reflectance image and one of the classified images.

1.

From the ENVI main menu bar, select Classification - Post Classification - Overlay Classes or review the
pre-calculated results of classifying the image by opening the can_comb. img file in the can_tm directory. The
Classification Input File dialog appears.

Using the can_tmr image in the Available Bands List, select Band 3 for each RGB band (Band 3 for the /2 band,
Band 3 for the G band, and Band 3 for the B band) and click OK.

Open the can_tm\can_comb. img, select it as the classification input in the Classification Input File dialog, and
click OK.

Using the SHIFT key on your keyboard, select Region #1 and Region #2 in the Class Overlay to RGB
Parameters dialog.

Click the Output Result to Memory radio button then click OK. The image is loaded into the Available Bands
List.

Load the overlay image into an image window.

Using image linking and dynamic overlays, compare this image to the classified image and the reflectance image.
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Editing Class Colors

When a classification image is displayed, you can change the color associated with a specific class by editing the class

colors.
1.

From the Display group menu bar, select Tools - Color Mapping > Class Color Mapping. The Class Color
Mapping dialog appears.

Click on one of the class names in the Class Color Mapping dialog and change the color by dragging the
appropriate color sliders or entering the desired data values. Changes are applied to the classified image
immediately.

To make the changes permanent, select Options - Save Changes from the menu bar in this the dialog.

@l #1 Class Color Mapping g@f@

File Options

Selected Clazzes:
IInclazzified

Fegion #1 [Fedl
Region §2 [Greenl] [137 paintz]
Region #3 [Blue1] [347 points]

Clazg Mame:

« " mlfeE

Red
Kl I I |
Green
Rl I =g
Blue

Working with Interactive Classification Overlays

In addition to the methods above for working with classified data, ENVI also provides an interactive classification overlay
tool. This tool allows you to interactively toggle classes on and off as overlays on a displayed image, to edit classes, get
class statistics, merge classes, and edit class colors.

1.
2.

N o o A

From the Available Bands List, load Band 4 of can_tmr.img as a gray scale image.

From the Display group menu bar, select Overlay = Classification. The Interactive Class Tool Input File dialog
appears.

Select the can_sam.img file within the Select Input File section of this dialog and click OK. The Interactive
Class Tool appears with each class listed with its corresponding colors.

Click each On check box to change the display of each class as an overlay on the gray scale image.
Explore the various options for assessing the classification using the Interactive Class Tool Options menu.
Interactively change the contents of specific classes using the Interactive Class Tool Edit menu.

From the Display group menu bar, select File - Save Image As - Image File to burn in the classes and
output to a new file.

From the Interactive Class Tool menu bar, select File = Cancel to exit the interactive tool.
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Overlaying Vector Layers

You can load pre-calculated vector layers onto a gray scale reflectance image for comparison to raster classified images,
or convert one of the classification images to vector layers.

1. Load the can_clmp.img into a display group.

2. From the Display group menu bar, select Overlay - Vectors. The Vector Parameters: Cursor Query dialog
appears.

3. From the Vector Parameters: Cursor Query dialog menu bar, select File > Open Vector File.

Using the SHIFT key on your keyboard, select the can_v1.evf and can_v2.evf files from the can_tm directory
and click Open. The vectors derived from the classification polygons will outline the raster classified pixels.

Converting a Classification to a Vector

1. From the ENVI main menu bar, select Classification = Post Classification = Classification to Vector. The
Raster to Vector Input Band dialog appears.

2. Select the can_clmp.img file Clump result within the Select Input File section of this dialog and click OK. The
Raster to Vector Parameters dialog appears.

3. Using the SHIFT key on your keyboard, select Region #1 and Region #2 from the Select Input Class field.

In the Enter Output Filename field, type canrty and click OK to begin the conversion. The layers are loaded
into the Available Vectors List.

Select Region #1 and Region #2s in the Available Vectors List dialog then click Load Selected.
Select a display number from the Load Vector dialog and click OK

From the Vector Parameters dialog menu bar, select Edit - Edit Layer Properties to change the colors and fill
of the vector layers to make them more visible.

8. Using image linking and dynamic overlays, compare the combined class image to the classified images and the
Select

Adding Classification Keys Using Annotation

ENVI provides annotation tools to put classification keys on images and in map layouts. The classification keys are
automatically generated.

1. From the Display group menu bar, select Overlay 2> . . -
Annotation for either one of the classified images, or &l #1 Clump (can_sv.img):can_clmp.... E@@

for the image with the vector overlay. File Cwerlay Enhance Tools ‘Window

2. From the Annotation menu bar, select Object > Map

Key to start annotating the image. You can edit the Unclas=sified
key characteristics by clicking the Edit Map Key Regiﬂn # 1
Items button in the dialog and changing the desired . R ~ - #r'
characteristics. VEZIOI 3~

Region #3

3. Click once with the left mouse button in the Image
window to place the map key in the image window.

4. Click and drag the map key using the left mouse
button in the display to place the key.

5. Click in the display with the right mouse button to
finalize the position of the key. For more information
about image annotation, please see the ENVI User’'s Guide.

Ending the ENVI Session

You can quit your ENVI session by selecting File = Exit from the ENVI main menu.
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