
REFERENCIA RÁPIDA MATHCAD 

 

1.0 INTRODUCCIÓN 

 

El siguiente documento es una referencia rápida para el uso de MathCad, indicándose 

las consideraciones principales que se debe tener en la programación, manejo de 

variables y procedimientos, así como también las ventajas del uso de ésta herramienta 

en cálculos de ingeniería. 

 

 

1.1 VENTAJAS EN EL USO DE MATHCAD 

 

Algunas de las principales ventajas en el uso de MathCad son su fácil manejo de 

ecuaciones y también la presentación estilo “Editor de Texto”. Otras ventajas son: 

 

• Versión digital del trabajo: Los cálculos quedan disponibles en versión digital, 

siendo simplemente adjuntados e impresos con a la memoria de cálculo (útil en 

el almacenamiento digital de éstas). 

• Secuencia Input-Output: Una vez creada una planilla para un determinado 

problema que es iterativo, basta con cambiar las variable iniciales y revisar los 

resultados (en algunas ocasiones, una misma planilla puede hasta ser útil en otro 

proyecto de similares características, todo depende de cuan genérico sea ésta 

programada). 

• Procedimientos acorde al uso: Los cálculos no son cajas negras como los  

realizados por los módulos de diseño de algunos programas de ingeniería ya que 

se realizan de acuerdo al problema que se resuelve(Ej: SAP2000). 

• Tipo de ecuaciones: Fácil uso y evaluación de ecuaciones algebraicas y 

numéricas. Puede, además, realizar cálculo con expresiones  algebraicas. 

• Edición del trabajo: Posibilidad de combinar texto y gráficos en una misma 

hoja. 

• Despliegue de ecuaciones: A diferencia de Excel, las ecuaciones se ven y 

pueden ser impresas. 



• Publicación en web: Se puede guardar el trabajo en versión html y ser 

publicado en una página web. 

• Otros. 

 

2.0 CONSIDERACIONES  

 

En general MathCad es similar a un editor de texto, dónde puede haber texto, gráficos  y 

ecuaciones al mismo tiempo.  Estas últimas pueden ser a partir de valores presentados 

en la misma ecuación o a partir de variables globales definidas al principio de la planilla 

(trabajar con variables). Como todo lenguaje de programación, las variables deben ser 

declaradas al principio, se pueden crear procedimientos, ciclos de loop, etc pero esto es 

para un uso más avanzado, acá solo se verán operaciones básicas. 

 

3.0 ORDEN DEL CÁLCULO (MUY IMPORTANTE) : Es importante tener 

presente que cuando se trabaja con ecuaciones a partir de variables que deben ser 

declaradas y asignadas por el calculista (por ejemplo M:= 1000 tonfm) el orden del 

cálculo realizado por MathCad es siempre de izquierda a derecha y desde arriba hacia 

abajo. Vale decir, si en una ecuación ocupo una variable que he declarado en alguna 

línea bajo dicha ecuación, ésta ecuación aparecerá marcada en rojo indicando error ya 

que la variable debe ser declarada y designada antes de la ecuación. 

 

4.0 EL PROGRAMA 

4.1 BARRAS DE TAREAS Y PALETAS 

Menú Principal 

 

The Math Palette 

 

Cada botón activa una paleta distinta, los cuales se muestran a continuación: 

         

 

Arithmetic Palette  Graph Palette    Vector and Matrix Palette Evaluation Pallete 

       

 

Calculus Palette  Evaluation and Boolean Palette Programming Palette 



   

 

Greek Symbol Palette Symbolic Keyword Palette 

 

4.2 BARRA DE TAREAS 

 

4.3 BARRA DE FORMATO 

 

 

4.4 MANEJO Y OPERACIONES CON MATHCAD 

4.4.1 POSICIONARSE EN UNA LINEA: Pincha con el mouse la zona donde 

quieres ubicarte, o muévete con las flechas arriba y abajo. Para desplazarse 

horizontalmente usa las flechas izquierda y derecha. 

 

4.4.2 INGRESANDO ECUACIONES 

Todo lo que se ingresa en una hoja MathCad queda definido por la región que esto 

ocupa. Si se escribe “1+” se veráa que aparece un cuadro negro subrayado por una línea 

azul justo luego del operador “+”, todo esto queda contenido dentro de  una “región” 

rectangular. La línea azul indica hasta dónde se extiende la siguiente operación a 

ingresar. En este caso, indica que se ingresara algo  después de “+” hasta donde 

terminemos de escribir. 

 
 

 

Si ingresamos, por ejemplo, “x+6”, veremos que la línea azul subraya sólo “6”, pero si  

presionamos la barra de espacio, aparecerán subrayados “x+6”, indicando que cualquier 

operación que realicemos (por ejemplo multiplicar) afectara hasta dónde termina la 

línea azul. 
 

 

si digitas “*20” aparecerá  

 



Una vez terminado de ingresar la ecuación, digitar “:” para que sea evaluada y 

luego dar “Enter”. 

 

4.4.3 ESCRIBIR TEXTO: Los caracteres de texto en MathCad son reconocidos 

luego que damos un espacio a la primera palabra o letra o caracter que digitemos. En el 

momento que se escribe y se presiona  espacio, el tamaño de la fuente cambia 

automáticamente y ya se trabaja la región como un texto. Otra forma es digitar “ ( usar 

teclas shift + 2) para salir del modo “por defecto” y luego escribir el texto. 

 

4.4.4 DEFINIR UNA VARIABLE: Escribir la variable y luego “:” para anotar su 

valor. Inmediatamente aparecerá “:=”. Se puede asignar inmediatamente las unidades de 

ésta, o bien trabajar todo en forma numérica. 

 

b:= 1000cm  ó b:=1000 cm 

 

4.4.5 CALCULO DE UNA EXPRESIÓN: Luego de escribir la expresión que se 

desea calcular, se digita “=” y automáticamente aparece a la derecha el resultado 

numérico o bien el resultado numérico con sus unidades correspondientes. 

 

a:=3   b:=5  a + b = 8 

     5 + 3 = 8 

 

4.4.6 OPERADORES (BÁSICOS): Pueden ser utilizados tanto con valores 

numéricos o  algebraicos.  

 

SUMA    + 

RESTA   - 

DIVISIÓN   /   

MULTIPLICACIÓN * 

POTENCIA   ^(shift + la tecla que esta al lado derecho  de P) 

 

 

 



4.4.7 MATRICES: Ocupar la paleta para arreglo de matrices y vectores. 

 

a) Valores ingresados directamente desde teclado 

Escribir la variable para la matriz seguido de “:”, y luego presionar la 

paleta   luego escribir el tamaño de la matriz en “rows” y “columns” y luego “insert”. 

 

A

4

5

7

5

0

2

1

12

8  

 

b) Valores cargados automáticamente mediante un procedimiento 

 

Sólo como ejemplo: 

 

Kt Kf Kt←

Ki K p( )←

Kf
C1 p, 3⋅ m− C1 p, 3⋅ l−,

Ki3 m− 3 l−, Kf
C1 p, 3⋅ m− C1 p, 3⋅ l−,

+←

Kf
C2 p, 3⋅ m− C1 p, 3⋅ l−,

Ki6 m− 3 l−, Kf
C2 p, 3⋅ m− C1 p, 3⋅ l−,

+←

Kf
C1 p, 3⋅ m− C2 p, 3⋅ l−,

Ki3 m− 6 l−, Kf
C1 p, 3⋅ m− C2 p, 3⋅ l−,

+←

Kf
C2 p, 3⋅ m− C2 p, 3⋅ l−,

Ki6 m− 6 l−, Kf
C2 p, 3⋅ m− C2 p, 3⋅ l−,

+←

m 2 0..∈for

l 2 0..∈for

p 1 9..∈for

Kf

:= Kf=Kt (se define inmediatamente el tamaño de la matriz Kf)

Ki=K(p)  se utiliza una matriz auxiliar y se define 

el tamaño de ésta.

 

 

Acá el símbolo � indica que todo lo que esta contenido en la matriz de la derecha, se 

carga en la matriz de la izquierda. Observar la forma en que se realiza un ciclo “for”. En 

éste tipo de procedimientos, se utiliza la paleta de programación. 

 

 



4.4.8 VECTORES 

 

Utilizando la paleta           ingresar una matriz de 1 columna y cuantas filas sea 

necesario para el vector. Al igual que para las matrices, se puede definir un vector y 

cargarlo mediante un procedimiento. 
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4.4.9 EDITAR FUNCIONES 

La sintaxis para cualquier función es similar a la que se ve en cualquier libro, se digita 

f(x), salvo que para definir la función, y tal como se indico anteriormente, debe venir 

seguida de “:=” (digitar sólo “:”, ya que el símbolo “=” aparece automáticamente)  y 

luego la expresión. 

 

 

 

 

 

 

4.4.10 RESOLVER POLINOMIOS 

Para resolver un polinomio puede utilizarse, entre otros procedimientos, la función 

integrada “polyroots”. Está necesita como entrada un vector de tamaño n+1, donde n 

representa el grado del polinomio, por lo que se tienen n raíces que lo resuelven. En el 

siguiente ejemplo se muestra su uso. Primero se define la ecuación a resolver, sólo 



como referencia y luego se ingresan los términos del polinomio empezando por el 

término constante y finalizando por el término cuadrático. 
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Para más funciones que resuelven polinomios consultar la ayuda de MathCad. 

 

4.4.11 EVALUAR UNA FUNCION EN FORMA CONDICIONADA 

 

En muchos problemas es necesario evaluar una función de acuerdo al intervalo en que 

los parámetros de ésta se encuentran comprendidos, como lo es por ejemplo el diseño en 

Acero. La resistencia a la compresión de un perfil  depende del intervalo en que se 

mueve la esbeltez de éste. Obsérvese el siguiente ejemplo: 

 

λc
Lp

rπ

Fy

E
⋅:= λc 1.678= Zona elástica de la curva

Fcr 0.658
λc

2

Fy⋅




 λc 1.5≤if

0.877Fy⋅

λc
2

otherwise

:=

Fcr 0.841= Tonf

 

Se define la resistencia a la compresión crítica Fcr, de un perfil de acero, a partir de la 

esbeltez crítica λc. Dependiendo de la posición de λc respecto a 1.5 se evalúa la 

resistencia. 

 

 



En éstos comandos se utiliza la paleta de programación. 

 

La línea vertical se añade con “Add Line” luego de escribir “Fcr:=”. Se verá algo así 

desplegado: 

 

Fcr :=

 

 

Si se necesita agregar más condiciones, hacer clic “Add Line”. Luego digitar la 

expresión a evaluar, y asegurarse que ésta esté completamente subrayada (presionando 

la barra de espacio se subrayan las expresiones): 

 

 

 

luego hacer clic en “if” y escribir la condición que se debe cumplir. Para agregar otra 

ecuación y su condición, posicionarse con el mouse o las teclas en la posición siguiente. 

 

 

 

 

 

 

 

 

 

 

 

 



4.4.12 GRÁFICOS 

 

Para trabajar con gráficos en MathCad debe utilizarse la “paleta de gráficos”

 

 

que se encuentra en la barra de herramientas. Existen varios tipos de gráfico posibles, 

desde escalares hasta en 3D. Acá se mostrará el uso de un  gráfico de funciones 

escalares. 

 

i GRAFICO A PARTIR DE UNA FUNCIÓN 

 

Definir la función y agregar después de ésta un gráfico pinchando  aparecerá algo 

así. 

 

f x( ) x
2

:=

 

 

Pinchar en las ordenadas y agregar “x”, luego pinchar en las abscisas y escribir f(x), 

entonces se despliega el gráfico de la función. 

 

f x( ) x
2

:=

10 0 10
0

50

100

f x( )

x  

 



 

ii A PARTIR DE VALORES PUNTUALES 

 

Primero se puede definir una matriz que contenga los valores a graficar, y que serán 

leídos a partir de ésta. Acá se muestra un ejemplo. Nótese el uso del comando ORIGIN, 

el cual fija el “origen” de todos los arreglos (matrices y vectores) en un valor 

determinado. Acá se fijo el origen en 1, es decir, se empieza a contar los subíndices de 

un vector desde 1 hasta el tamaño de éste. Luego se crea una variable “índice” i, como 

una variable que esta comprendida entre un rango de valores (entre 1 y 4 tomando sólo 

valores enteros) para así poder recorrer todo el arreglo (matriz) “b”. Para graficar se 

ingresa en las ordenadas toda la primera columna y en las abscisas toda la segunda 

columna, simplemente ingresando el arreglo bi,1 y bi,2. 

ORIGIN 1≡

b
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2
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
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i 1 4..:=
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0
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bi 2,

bi 1,  

 

 

 

 

 

 



4.4.12 UNIDADES: Las unidades con que se trabajará en el proyecto se “setean” en 

Math � Options � pinchar la pestaña “Unit System” y luego escoger el sistema de 

unidades con que se trabajará. Estas pueden ser insertadas después de un valor 

numérico, utilizando el operador  * y luego usar Insert�Unit Menu o simplemente 

luego de digitar la magnitud de la variable, escribir las unidades. MathCad 

automáticamente revisa y calcula conversión de unidades. El siguiente ejemplo trabaja 

con las unidades kg, m y  seg. Al ingresar una variable con otras unidades, MathCad 

realiza la conversión automáticamente. 

 

M 2 ton⋅:= ton 907.185kg=

M 1.814 10
3

× kg=  

 

 

PRECAUCIÓN: NO NOMBRAR VARIABLES CON NOMBRE DE UNIDADES 

COMO POR EJEMPLO kg:=1000m. 

 

 

4.4.13 INSERTAR IMÁGENES: Simplemente usar el comando copiar y pegar. 

(Copiar desde la ubicación dónde está la imagen con “Edit=>Copy” y en  MathCad 

pegar con “Edit=>paste”) 

 

Cuando se agrega alguna imagen desde un archivo que puede ser modificada más tarde, 

se puede utilizar Insert=> Object click "Create From File" y buscar la localización del 

archivo. Si pinchas "Link to File" la imagen se actualiza automáticamente. 

 

NO USAR INSERT=>PICTURE PORQUE LO QUE SE QUIERE COLOCAR ES 

EN REALIDAD UN OBJETO. 

AJUSTAR LA IMAGEN AL TAMAÑO DESEADO PINCHANDO EN LOS 

BORDES DE ÉSTA CON EL PUNTERO DEL MOUSE. 

 

4.4.14 EXPORTAR A WEB: OJO, UTILIZAR ESTA OPCIÓN SÓLO COMO 

UNA MANERA DE PUBLICACIÓN O PARA IMPRIMIR EN OTRO LUGAR 

DONDE MATHCAD NO SE ENCUENTRE DISPONIBLE. ANTES DE 



UTILIZAR ESTO, ASEGURARSE DE HABER GUARDADO UN RESPALDO 

DEL TARABAJO  BAJO LA EXTENSIÓN “*.mcd” (SIMPLEMENTE USAR 

SAVE). 

File=> “Save as” y seleccionar, bajo la casilla don colocas  el nombre del archivo, la 

extensión HTML. 

 

 

4.4.15 JUSTIFICAR TEXTO Y EVITAR TRASLAPO: 

Para Justificar el texto y evitar traslapo de dos grupos o regiones  de textos 

consecutivos, realizar lo siguiente: 

Format=> Align Regions (Para justificar) 

Format=> Separate Previene el traslapo de regiones. Las regiones son las zonas dónde 

se escribe texto o alguna expresión a ser evaluada. 

Otra opción buena es pinchar con el botón derecho sobre la región que se desea ajustar, 

seleccionar “properties” y seleccionar la plantilla “Text”. Marcar el cuadro "push 

regions down as you type". Así en la medida que escribamos, todo lo que esté bajo la región 

será desplazado. 

 

4.4.16 ESCRIBIR UNA EXPRESIÓN QUE NO QUEREMOS QUE SEA 

EVALUADA 

Cuando se trabaja con expresiones que sólo queremos mostrar o explicar algún 

desarrollo que se hace a partir de ésta, tendremos el problema que MathCad tratará  

calcular dicha expresión. Una vez escrita la expresión, no escribir “=” ni “:”, ya que será 

marcada en rojo al tratar de evaluar la expresión. En vez de esto, ocupar el operador 

booleano “=” de la paleta “Evaluation and boolean”. 

 

 

 



Atte. Mauricio Muñoz A. 


