
Chapter 6 

Developing Servlets Using IBM WebSphere Studio Application Developer

In the previous chapter, we learned the basics of HTTP and servlets. Now it’s time to put these concepts to work. Java servlets are one of the simplest ways to extend the capabilities of a Web server with business specific behavior. To build, deploy, and test servlets, it helps to understand how to use the available tools effectively, in particular, WebSphere Studio Application Developer (WSAD) and other products in the WebSphere Studio product family as described in Chapter 2.

WSAD is a collection of tools integrated together to provide a workbench tailored to the development of Web, J2EE, and Web Services based applications.  In this chapter, you will learn how to develop servlets using WSAD. We’ll start with a brief introduction to WebSphere Studio Workbench and the WebSphere Studio Application Developer integrated set of tools contained in the Workbench. Then we’ll take a use-case approach to explore in detail the steps required to develop a typical servlet based example. In Chapter 8, we’ll examine how to deploy, test, and debug the servlet-based application developed here.
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Figure 7.1 Architectural Roadmap
We will develop a simple example that allows us to view and update employees in a database.  Figure 7.1 shows the architectural roadmap used to implement the example. We’ll cover creating a simple model based on Plain Old Java Objects (POJOs), persisting instances of the model in a database accessed through JDBC, developing static HTML, input forms processing, and handling servlet requests and generating HTML responses. This architecture is certainly not the most sophisticated, and it has many drawbacks that we’ll be discussing. However, it has all the pieces of the layered architecture:

· Presentation: HTML, some of which is created by servlets.

· Controller/Mediator: In this case, the servlet engine in the application server itself supports the controller/mediator layer through servlets.

· Domain Model: There’s only one domain model object, Employee, but its still a domain model.

· Data Mapping: We use the Active Record pattern to map the Employee to its data source.

· Data Source: The actual data is in an EMPLOYEE table in a relational database accessed through JDBC.
Throughout the development steps, we’ll be taking a closer look at the features of WSAD. There are a lot, and we won’t try to cover all of them here. Instead, we’ll highlight those used to build our end-to-end example in the context in which they are used. In Chapter 13, we’ll look at this same example to see how it can be simplified using JavaServer Pages and more sophisticated persistence implementation mechanisms. 

Introduction to the IBM WebSphere Studio Family of Tools

J2EE specifies a number of roles played by participants in the development process. WSAD in turn provides an integrated development environment for developing J2EE applications that organizes the tools in a manner that is appropriate for each role. Tools are available for authoring Web content using HTML, CSS, XML, XSL, XML Schema, Java programs, EJB components and deployment descriptors, Web services, as well as tools for integration with relational databases, application profiling, and debugging. Like any craft, your thorough knowledge and efficient use of available tools will go a long way toward improving the result (your applications), as well as reducing the level of frustration that would otherwise accompany the construction process. The WSAD help system introduces the tool components that make up the platform. For details select Help>Help Contents, and follow the links to Application developer information>Product overview>Application development tools. 

WebSphere Studio Workbench Overview 

Aside from viewing the help, a brief introduction of the WebSphere Studio Workbench (WSWB, or just Workbench) will be helpful in getting you started on the tasks you’ll be performing in the rest of the chapter. The Workbench is IBM’s branded version of the Eclipse tool integration platform. WSWB is functionally equivalent to Eclipse, the basic difference being that IBM provides fee-based defect and problem support of WSWB, while Eclipse is supported via the open source community process (mailing lists, newsgroups, bugzilla, and so on).  WSAD extends WSWB with a set of plug-in extensions that provide the J2EE and Web Services authoring, deployment, and testing tools. If you are already familiar with the Eclipse development environment, you already know a lot about using WSAD. We’ll provide additional details throughout the development of the example where they can be better understood in the context in which they are used. As always, additional detailed information is available from WSAD Help. From the help contents, follow Application developer information> Getting Started>Workbench fundamentals. For more information on the Eclipse tool integration platform, see http://www.eclipse.org.

Install WSAD on Windows platforms using the typical Install Shield tools, or on Linux or other UNIX platforms using the install tools typically used for those platforms. Installation is very straightforward and requires very little input. Once installed, you can startup WSAD using the installed menu item, or by invoking wsappdev.exe in the installation folder. Before starting up WSAD though, we should spend some time thinking about how to organize our work. Eclipse and WSWB use the notion of workspaces to partition the development of related applications. Each workspace has an associated directory that contains meta-data about the configuration of the workspace, information about the projects in the workspace, the state of the workspace when it was last shutdown, user interface layout, etc. For example, you could use different workspaces for managing collections of closely related projects. You could use one workspace for all projects but this could get cumbersome as the number of projects increases. The biggest advantage of multiple workspaces is that they each remember their own Workbench configuration and state. You can also import preferences from another workspace to save reentering. When you first start up WSAD, a dialog displays the default workspace and gives you an opportunity to change it to a location of your choice, and optionally to permanently change the default. 
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Figure 7.2 Selecting a Workspace

You can accept the default, but if you’d like to have multiple workspaces or put the workspace somewhere else on your computer, you can browse to or enter a new workspace path. A workspace is just a folder in your local file system. We recommend using a number of different workspaces for managing collections of related projects. You can do this by creating shortcuts (or links) to <WSAD Installation Folder>\wsappdev.exe in the desktop start menu. After creating the shortcut, edit its properties and add a –data <workspacePath> parameter. Then WSAD will use different workspaces for each shortcut used to start it. 
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Figure 7.3 WebSphere Studio Workbench on workspace-wsbook

A workspace contains any number of projects. Projects contain the development resources that taken together produce an application or some reusable application component. Each project has one or more natures, which define the semantics of the project. The resources in the project, what happens when the resources change, how resources are edited, and what actions are available define a project’s semantics. For example, when a Java source file in a Java project changes, the corresponding Java class file is recreated, and all of the Java files that depend on that file (i.e., import it) are also recompiled. Similarly, when a servlet source changes in a Web project, not only is the file recompiled, but it is also re-deployed to the Test Environment so the changes are visible the next time the servlet is invoked (more on this later). 

Inside a project are resources organized in folders. The Workbench provides a Navigator view for navigating the projects in a workspace, and the resources in the projects. Figure 7.3 shows the Servlet Example project in the navigator view.

The resources displayed in the resource navigator have pop-up menus that offer choices specific to the selected resource(s). Various tools installed into the Workbench contribute these choices. Each resource has a type, generally distinguished by its file extension. For example, .java files are Java resources while .html files are HTML files. Each file can be associated with one or more editors, one of which is the default editor invoked when you double-click on the file. The editors that are configured for the resource types can be seen by right clicking on the file and selecting Open With (the default is first and indicated by a check in front of the menu item), or by examining the workbench preferences. To see the workbench and other tool preferences, select Window>Preferences from the menu bar, and expand Workbench> File Associations. You can use this preferences page to add new resource types and associate them with either Workbench (internal) editors, or external editors that run in the underlying operating system. For example, you might associate *.jar with your favorite ZIP utility so you can simply double-click to examine its contents.
Each editor provides a way of viewing and manipulating the specific resource type. Editors may have other associated views that provide alternative ways of looking at or modifying a resource. For example, most editors also contribute to the Outline view to provide a quick way of navigating the contents of a resource or to provide context sensitive menu items on selected items in the resource. Many views and some editors also contribute to the properties view to show the detailed properties of a selected item in the editor. Figure 7.3 also shows the HTML page editor opened on index.html with the outline view showing the HTML tags in the file.

When you save a resource, the Workbench optionally performs an incremental build of the project, updating any resource that depends on the saved resource. The project nature determines what builders run, and how they react to changes in the project’s resources. The tasks view displays any information, warnings, or errors resulting from a build. Double click on entries in the task view to open the resource editor and navigate to the position in the resource causing the error. 

Not only does the Workbench provide projects as a way of organizing resources, but it also provides perspectives as a way of organizing the Workbench user interface. This, along with specialized project types and wizards, is how the Workbench organizes itself to support roles-appropriate tools. Each plug-in extension to the Workbench can contribute any number of perspectives.  A perspective groups together the most common views, editors, and actions that support a set of tasks associated with a user’s role. The Workbench has a number of predefined perspectives that other tools can enhance with their own views, editors, or actions. Some products, such as WSAD, define new perspectives that group their own editors and views with some of those that come with the base Workbench to support a specific solution. Independent of how a perspective was defined, an Eclipse user is free to modify it or define entirely new ones, since after all, a perspective is just a designer’s idea of how users performing a particular set of tasks might best organize their workbench. You can:

· Position views at the left, right, or bottom of the workbench window by dragging the view title bar

· Resize views by dragging their borders

· Open additional views from the Window>Show View menu item

· Stack views in tabbed panes

· Choose which sets of perspective menu items are available with Window>Customize Perspective…

· Create and save custom perspectives

To see the available perspectives, select menu item Window>Open Perspective. The cascaded menu lists the most common and recently opened perspectives. Select Others… to see them all. It is often useful to switch perspectives as you change roles in developing an application. For example, you might be developing the HTML client resources for a Web application, and then have to edit the Java servlets that generate HTML responses. The Web perspective provides views and navigators for both activities, but if you’re doing a lot of Java development, perhaps for your application’s business model, you might want to switch to the Java perspective. Alternatively, if you’re developing EJBs, you’ll probably want to switch to the J2EE perspective.  Figure 7.3 shows the default, or Resource perspective with a few additional views opened in the bottom pane. You can quickly switch between other perspectives that are also open by pressing the shortcut buttons along the left side of the Workbench window. 

A word of caution: not all perspectives behave the same. Menu items that look the same between perspectives may actually do different things. For example, selecting a file in the navigator and invoking the Rename… popup menu item renames the file in the file system as expected. However, if you select a .java file from the Java perspective and invoke Rename, the Java tools actually perform a refactor operation that updates all the references to the class corresponding to the .java file. Similarly, renaming an HTML file in the Web perspective will update all the links to that file. Therefore, it’s always a good idea to do things in the most resource specific perspective. Each perspective generally names and/or organizes the menu items differently to help avoid confusion.

The Workbench also provides support for working in a team and for versioning and configuration management. Rather than requiring a specific repository, the Workbench supports integration with many different repository management systems. Typical Workbench configurations include support for the Open Source CVS, Rational ClearCase, or Merant PVCS. Depending on your installation, you may have any or all of these. The Workbench also supports development with no repository manager at all, or simple resource sharing through a non-versioning WebDAV enabled repository. The Workbench uses an optimistic resource sharing policy. The resources in your workspace are in your own private space on your local hard drive. Of course, you could share your drive with others, but a workspace usually provides a private scope in which you can do your work independent of other developers who may be working on the same or related resources. When you are ready to integrate your work with others, you can synchronize your workspace with the shared repository. Synchronization detects changes you’ve made compared to the versions in the shared repository and gives you a chance to merge your work with the work of others into your workspace. When you are satisfied that the changes are properly integrated, you can commit your work saving it to the shared repository where it will then be available to other team members for further development and integration. 

Finally, each tool can contribute its own help to the help system. Help is available both through the Help>Help Contents menu item and by pressing F1 to get context sensitive help based on the current cursor location. We’ll be referring to specific sections of the help system throughout the book. Take a minute and get familiar with the available help so that you’ll have a better idea where to look when you need it. Each Workbench configuration will be slightly different depending on what plug-ins have been included, so it’s hard to predict what might be available in any given Workbench instance.  We would refer the interested reader to [Shavor] for more in-depth coverage of the basic features that the WebSphere Studio Workbench offers, such as team development support.

Building an Example Servlet with WSAD

Now that you know what WSAD is capable of, it’s time to get started building the servlet example. We’re going to cover a lot of ground in these next few sections so be prepared to spend some time working on the example. Instead of implementing a simple Hello World servlet, we believe you’ll get a lot more out of an example that is closer to something you might actually build yourself. Hopefully you’ll find this example complete enough to use as the basis for some of your own work. Here’s what the finished example looks like when run:
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Figure 7.4 Servlet Example index.html

Selecting the Browse Employees link invokes the application and provides a simple list-detail display of the employees in the WASBOOK database. Figure 7.5 shows the list with Jane Doe’s details. You can display a particular employee’s details by clicking on the link on their Id. The HTML isn’t that pretty, but we want to keep it as simple as possible in order to focus on the semantics.
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Figure 7.5 The Servlet Example List-Detail pages
In this chapter, we’ll develop enough of the example to create new employees, and display, and update their details.

Now that you’re familiar with the example, let’s see what’s involved to build it using Java servlets. Follow these steps in implementing the servlet example using WSAD:

1. Create a Web project

2. Building a business model with Java Objects
3. Persist the model using JDBC

4. Create and edit HTML for the list-detail user interface

5. Create the servlet for accessing and updating the model

The following sections cover each step in detail. These steps are typical of what you need to do to create any dynamic Web application using servlets. 

Create a Web project

A WSAD Web project nature extends the Java project nature with perspectives, wizards, editors, views, and builders for developing static and dynamic web applications. To create a Web project, start up WSAD on your workspace and open the Web perspective by selecting Window>Open Perspective>Other… from the menu bar. Select Web from the list of available perspectives.
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Figure 7.6 Select Perspective

Next, create a new Web project by selecting File>New>Web Project. This will bring up the Create a Web Project wizard As shown in Figure 7.7.
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Figure 7.7 Create a Web Project Wizard

First, you must enter the Project Name. By default, all projects and project resources are stored in folders under your workspace folder with the project folder name the same as the project name. However, you can choose to create a folder for your project anywhere in the file system with any name you want. If you use an existing folder, the resources in that folder are automatically included in the project. For this example, we’ll leave Use default selected and let the wizard assign the New project location. Next, specify that this project is a J2EE Web Project so you can add dynamic content in the form of servlets to this project. A static web project contains resources accessible through a traditional HTTP Web server that contains no additional business logic (servlets, JSPs, or EJBs).  Therefore, you can deploy static Web applications to a simple HTTP server without a J2EE deployment descriptor. The Web Project features list allows you to select things the wizard will automatically add to your Web project. For our simple servlet example, we don’t need anything special and want to create most of the resources ourselves anyway. So make sure no features are selected and press Next. 
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Figure 7.8 J2EE Settings Page

The next page is for specifying the J2EE settings for a J2EE Web project. These settings configure the Web application server with information required to run our Web project. As we discussed earlier, an Enterprise Application Archive (EAR) collects together J2EE client, Web, and EJB modules for deployment on a J2EE application. An EAR file contains all the information needed to deploy and run the complete application. An Enterprise application project is a project that contains an EAR. In Chapter 20, we will present more information on structuring an Enterprise Application project within WSAD.  In Chapter 8, you’ll see how to deploy EAR projects to the server. You can use an existing EAR project or create a new one. If you select Existing, you can use the Browse… button to select an EAR project from your workspace. Select New to create a new EAR project, enter DefaultEAR as the project name, and select Use default (the same as you did for your Web project). The Context Root is the URL prefix used to access resources in your Web project. Select a context root that easily identifies your Web application, but is not too difficult to type. It’s also a good idea to avoid spaces in the context root, as they have to be escaped in URLs. For example, if you use servletExample as your Context Root, you would use http://localhost:9080/servletExample/index.html to access the project’s home page. Next, select J2EE Level 1.3 to specify that you want to use its associated level of the Java Servlet Specification, namely level 2.3. WebSphere Application Server version 5 and the WebSphere Test Environment that is part of WSAD supports the latest J2EE Level 1.3, and that’s the level we’ll be covering in the book. So, that’s the level you’ll want to use in developing the example. Press Finish to create your Web Application and DefaultEAR Enterprise application project.

Let’s take a quick look at what the wizard created. 
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Figure 7.9 Servlet Example Project

Figure 7.9 shows the DefaultEAR and Servlet Example projects created by the Create a Web Project wizard in the J2EE Navigator View. The project folders follow the structure defined by the J2EE 1.3 specification. The J2EE Navigator View provides a few conveniences over the simple Navigator View for Web projects. The two most important conveniences are quick access to the deployment descriptors and viewing Java resources in packages rather than folders in the file system. In the servlet example, the Web Deployment Descriptor corresponds to the web.xml, ibm-web-ext.xmi, and ibm-web-bnd.xmi files that are in the Web content/WEB-INF folder. These files correspond to the J2EE Web Application Archive (WAR) deployment descriptor, the IBM Web application extensions, and the IBM WebSphere bindings respectively. You can edit these files individually, but it is much easier to double-click Web Deployment Descriptor and edit them as a group using WSAD’s Web deployment descriptor editor. The WSAD Web deployment descriptor editor is more than just a text editor on a number of integrated XML files. It presents a higher-level view of the semantics of a Web deployment descriptor rather than the details of its persistence format. Similarly, the EAR Deployment Descriptor in the DefaultEAR project corresponds to the J2EE deployment descriptor application.xml in the META-INF folder.

If you would like to avoid a lot of typing, you can import the rest of the files for the sample servlet from the CD-ROM. See Appendix A for instructions on loading the workspace containing the examples and the case study.

Building a business model with Java objects

Chapter 5 introduced different presentation patterns including MVC, the central pattern used throughout the book. The initial focus of MVC is the application business model, which is what you will be building in this section. The model for our servlet application is intentionally simple in order to cover the end-to-end details of application development in the smallest space possible. It consists of an employee with properties for name, age, and address information.
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Figure 7.10 Servlet Example Model

To create the model, you first have to create a Java package to contain the model classes. Select the Java Source folder in the Servlet Example project, right-click and select New>Package, enter com.wsbook.servletexample.domain for the package name, and press Finish. Next, create the model class. Select the package you just created, right-click and invoke New>Class. Figure 7.11 shows the dialog used to create a new class called Employee. 
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Figure 7.11 Create the Employee Class

This dialog is self-explanatory, but there are a couple of things that are of interest. First, you can specify an Enclosing type to create an inner class. You can enter a super-class name, or browse existing classes that are visible to your project for selecting the Superclass, and you can specify any additional interfaces the class should implement. Finally, the wizard can generate some commonly required methods for you, including stub implementations for inherited abstract methods. Fill in Employee for the class Name and press Finish. The next section covers the code for the Employee JavaBean, along with its persistence implementation using JDBC.

The Java editor has many nice features, far too many to describe here. Here are a few useful ones that might not be obvious for first-time users. 

· Invoke content assist by pressing Ctrl-Space, use the up and down arrow keys to scroll through the selections, press return to accept a selection. You can use content assist to fill in variable and method names, discover method parameters, add structured blocks of code, or just reduce typing.

· “Quick fix” is available for some errors in the Java source. Click on the light bulb in the left margin, or select the Quick Fix menu item from an item in the tasks view.
· Position the cursor over almost any text to get a hover help description, or click on any identifier and press F3 to go to that definition. This is particularly useful for quickly navigating to other classes.

· Select an undefined class name referenced in a Java source file and press Control-Shift-M to add the required import statement automatically at the beginning of the file. Alternatively, press Control-Shift-O to organize your import statements, removing any that are unnecessary, adding any that are missing, and sorting them in the ordered specified in the Java preferences.
· Add a try/catch block around selected code by selecting Source>Surround with try/catch block. The editor will automatically add catch statements for each exception raised in the selected code.

· Use Source>Generate getter and setter… to generate accessor methods for a field.

· Use Source>Override methods… to generate stub implementations of superclass methods, or unimplemented abstract methods.

· Use Refactor to change your Java source updating all references in the current workspace.

For further details, see Help>Help Contents>Java Development, especially, Tips & Tricks.

Persist the model using JDBC and the Active Record Pattern

Now we’re ready to look at persisting objects in the business domain model. There are a number of patterns and tools for persisting an object model in a relational database. Since persistence is such an important topic and we want the example to be typical of what you might need to do, we’ll cover one of the simple patterns in this section. Later in the book, you’ll see other patterns and how to use local entity EJBs to persist business domain objects and map them to existing relational databases. In this chapter, we’ll use JDBC directly so you can contrast the different approaches. We’ll do this by implementing a simple object-to-persistence store mapping technique based on the Active Record pattern [Fowler]. This pattern puts the responsibility for implementing persistence in the business object itself. Active record is useful when the domain object is simple, does not participate in an inheritance hierarchy, or has few associations with other domain objects. So, it’s a good fit for our example, which only has one domain object. First, we have to actually create the database and populate it with test data. 

Sidebar: Active Record is usually not the best choice

The Active Record pattern is a very convenient way to add persistence to a domain model, especially in a situation where you have a small number of domain objects and limited associations between them. However, in most cases, you will want to separate the persistence code from the domain code by introducing a data mapping layer based on the Broker pattern [GOF] or Data Mapper pattern [Fowler]. These patterns will then store and load domain objects to/from the database. Chapter 16 covers the Data Mapper pattern.

Space does not permit covering all the details for creating a database, creating a schema for the example, setting authentication, and populating the tables with sample data, especially given the variability in popular database management systems. Therefore, we’ll just give a quick overview using IBM DB2 to show what the example needs from a typical database management system. See the documentation for your system for specific details. Listing 7.1 is a DB2 command line processor script file that creates a database for our example. 

Listing 7.1 Create sample database script initializeDatabase.clp

drop database EJPBOOK;
create database EJPBOOK;
connect to EJPBOOK;
grant connect on database to user "GUEST";
create schema acme;
create table acme.employee (
    id        varchar(10) not null primary key,
    name      varchar(60),
    age       integer,
    street    varchar(60),
    city      varchar(60),
    state     varchar(60),
    zip       varchar(30)
);
grant all on table acme.employee to user "GUEST ";
commit work;
connect reset;
terminate;
This script creates a database called EJPBOOK, connects to the database, creates the employee table, and grants privileges necessary for user GUEST to connect to the database and access the employee table. You can execute the script by entering db2cmd db2 –t –f initializeDatabase.clp from an OS command prompt. The –t command argument tells the command processor to use a semi-colon to separate commands, something that is useful for long commands like the create table statement. You can also create an external tool in the Workbench for executing any selected DB2 script. Select Run>Configure…to invoke the External Tools Configuration dialog. Click New… and enter the information as shown in Figure 7.12. The Workbench provides a number of convenience variables for accessing information from the workspace. You specify these variables using the format ${variable-name}. For example, ${resource_name} would evaluate to the name of the selected resource. Press the Browse Variables… button to see what variables are available, and to insert them into the field.
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Figure 7.11 Configuring an External Tool

Execute a DB2 script file by selecting the file and invoke Run>External Tools>db2. Other database systems can use a similar technique and script. 

Now let’s look at the code for the Employee class as given in listing 7.3. Note that Listing 7.3 is incomplete and does not contain comments. Browse the code on the CD for the complete listing.
Listing 7.2 Employee.java

package com.wsbook.servletexample.domain;
import java.sql.Connection;
import java.sql.PreparedStatement;
import java.sql.ResultSet;
import java.sql.SQLException;
import java.util.ArrayList;
import java.util.Collection;
import javax.naming.InitialContext;
import javax.sql.DataSource;
import com.wsbook.servletexample.ApplicationProperties;
import com.wsbook.servletexample.exception.DuplicateKeyException;
import com.wsbook.servletexample.exception.MappingException;
import com.wsbook.servletexample.exception.NoSuchObjectException;
public class Employee {

private String id = "";

private String name = "";

private int age = 0;

private String street = "";

private String city = "";

private String state = "";

private String zip = "";

public Employee() {


super();

}

public Employee(String id) {


this.id = id;

}

public boolean equals(Object anObject) {


if (anObject == null) {



return false;


}


if (!(anObject instanceof Employee)) {



return false;


}


Employee anEmployee = (Employee) anObject;


return anEmployee.getId().equals(getId());

}

public String getId() {


return id;

}

public String getName() {


return name;

}

public int getAge() {


return age;

}

public void setName(String value) {


name = value;

}

public void setAge(int value) {


age = value;

}

static final String authId = ApplicationProperties.getDatasourceSchemaName();

protected static final String _createString =


"INSERT INTO "+authId+".EMPLOYEE "+


"(ID, NAME, AGE, STREET, CITY, STATE, ZIP)"+


"VALUES (?, ?, ?, ?, ?, ?, ?)";

protected static final String _readString =


"SELECT * FROM "+ authId+ ".EMPLOYEE " +


"WHERE ID = ?";

protected static final String _findAllString =


"SELECT * FROM "+authId+".EMPLOYEE ";

protected static final String _updateString =


"UPDATE "+ authId+".EMPLOYEE "+


"SET NAME=?, AGE=?, STREET=?, CITY=?, STATE=?, ZIP=? "+


"WHERE ID = ?";

protected static final String _deleteString =


"DELETE FROM "+authId+".EMPLOYEE  WHERE ID = ?";

public void create() throws SQLException, DuplicateKeyException {


Connection connection = null;


try {



connection = getConnection();



PreparedStatement ps = connection.prepareStatement(_createString);



ps.setString(1, getId());



ps.setString(2, getName());



ps.setInt(3, getAge());



ps.setString(4, getStreet());



ps.setString(5, getCity());



ps.setString(6, getState());



ps.setString(7, getZip());



int rows = ps.executeUpdate();



if (rows != 1) {




throw new DuplicateKeyException("Duplicate employee "+id);



}


} finally {



close(connection);


} 

}

public static Employee findByPrimaryKey(String id) throws SQLException, NoSuchObjectException {


Connection connection = null;


try {



connection = getConnection();



PreparedStatement ps = connection.prepareStatement(_readString);



ps.setString(1, id);



ResultSet rs = ps.executeQuery();



rs.next();





return load(rs);


} finally {



close(connection);


} 

}

public static Collection findAll() throws SQLException {


ArrayList list = new ArrayList();


Employee emp = null;


Connection connection = null;


try {



connection = getConnection();



PreparedStatement ps = connection.prepareStatement(_findAllString);



ResultSet rs = ps.executeQuery();



while (rs.next()) {




emp = load(rs);




list.add(emp);



}



return list;


} finally {



close(connection);


} 

}

private static Employee load(ResultSet rs) throws SQLException {


Employee emp = new Employee();


emp.id = rs.getString(1);


emp.setName(rs.getString(2));


emp.setAge(rs.getInt(3));


emp.setStreet(rs.getString(4));


emp.setCity(rs.getString(5));


emp.setState(rs.getString(6));


emp.setZip(rs.getString(7));


return emp;

}

public void update() throws SQLException, MappingException {


Connection connection = null;


try {



connection = getConnection();



PreparedStatement ps = connection.prepareStatement(_updateString);



// can't update the id



ps.setString(1, getName());



ps.setInt(2, getAge());



ps.setString(3, getStreet());



ps.setString(4, getCity());



ps.setString(5, getState());



ps.setString(6, getZip());



ps.setString(7, getId());



int rows = ps.executeUpdate();



if (rows != 1) {




throw new MappingException("Unable to update employee "+id);



}


} finally {



close(connection);


} 

}

public void delete() throws SQLException, MappingException {


Connection connection = null;


try {



connection = getConnection();



PreparedStatement ps = connection.prepareStatement(_deleteString);



ps.setString(1, getId());



int rows = ps.executeUpdate();



if (rows != 1) {




throw new MappingException("Unable to delete employee "+id);



}


} finally {



close(connection);


} 

}

public static Connection getConnection() throws SQLException {


// get a connection


DataSource ds = getDataSource();


return ds.getConnection(ApplicationProperties.getDatasourceUserId(), 








 ApplicationProperties.getDatasourcePassword());

}

public static DataSource getDataSource() {


DataSource ds = null;


try {



InitialContext context = new InitialContext();



ds = (DataSource) context.lookup(ApplicationProperties.getDatasourceJndiName());


} catch (javax.naming.NamingException ne) {



MappingException e = new MappingException("NamingException: cannot find DataSource in initialContext");



ne.printStackTrace();


}


return ds;

}

protected static void close(Connection conn) {


try {



if (conn != null) conn.close();


} catch (SQLException e) {


}

}
}
The Employee class has accessor methods to get and set its attributes. Only some of the accessors are in the listing, see the example code for the complete implementation, including JavaDoc comments. The id attribute is read-only, so it does not have a set accessor. The Active Record pattern includes SQL statements and methods for typical CRUD (Create, Read, Update, and Delete) operations. Each of these operations is implemented by getting a connection to the database, preparing the corresponding SQL statement, filling in query or update parameters, executing the statement, and processing the results, perhaps raising any necessary exceptions. Notice the use of class ApplicationProperties that has static methods to get the database URL, schema name, and password. ApplicationProperties uses a Java ResourceBundle to get configuration properties from a Java .properties file. Listing 7.3 is an example application.properties file.

Listing 7.3 Sample Application Properties
com.wsbook.servletexample.mapping.datasource.name=java:comp/env/jdbc/EJPBOOK
com.wsbook.servletexample.mapping.datasource.schemaname=jamsden
com.wsbook.servletexample.mapping.datasource.userid=guest
com.wsbook.servletexample.mapping.datasource.password=guest
Create and Edit HTML for the list-detail user interface

Now that the model is complete and able to be persisted in a database, we’re ready to start looking at the user interface. For maximum flexibility, availability, and ease of installation, we’ll host the user interface in a Web browser, and implement it using HTML. Our example is typical of what many Web applications have to do; display a list of model items, let users select from the list, and display and update details of the selected item. HTML is a language for describing user interfaces. HTML doesn’t know anything about the model or how is it used by the application. That’s where servlets come in. By using mediators and domain objects, servlets provide dynamic content for the pages and logic for updating the model using the information returned from an HTML form. Take another look at Figure 7.5, which shows the employees list and the details for employee Jane Doe. The HTML page consists of three frames to hold the banner, the employee list, and the details for the selected employee. The employee list is a table with columns displaying some subset of the employee data to help users in choosing a selection. An HTML form displays the employee details. Another table is used to organize and layout the labels, fields, and buttons on the form.

In this section, we’ll cover the development of the static HTML used to access the employee list and organize its contents. In the next section, we’ll look at the servlets that actually provide and update the dynamic data. WSAD provides a number of excellent tools for developing HTML and XML documents.  These tools are best used from the Web perspective, so if you don’t have that perspective selected, select it now by either clicking the Web perspective button in the shortcut bar on the left side of the Workbench window (its icon looks like a globe) or select Window>Open Perspective>Web. 

Web applications generally have a “welcome” page, often the home page, or first page introducing the application. Its role is to orient the user and provide organized links to the rest of the application. Index.html, index.jsp, welcome.html are typical names for welcome pages. Specifying a URL for a folder without apecifying a file in that folder access the welcome page by default. For example, http://localhost:9080/servletExample/index.html and http://localhost:9080/servletExample/ would access the same page. You can specify the welcome pages in the Web deployment descriptor, but we’ll look at that in the next Chapter 8. Next select the Web Content folder, right click, and select New>HTML/XHTML File. Fill in index.html for the file name, and take the defaults for the rest of the fields. To get descriptions of other fields available from the New HTML/XHTML File wizard, press F1. Press Finish to create the file and open Page Designer on the contents. Notice that the wizard generated initial contents based on the selected generation model and markup language.

Figure 7.3 shows the Web perspective with Page Designer opened on the index.html file. Before getting into the details of using Page Designer, let’s take a quick look at the views that are in the Web perspective. Remember you can add or remove any views you want or reposition the views to suit your taste. The layout in Figure 7.3 is just the default layout for the Web perspective. If you have made changes to the perspective, you can reset the perspective back to the default layout by selecting Window>Reset Perspective. Recall that the Web perspective uses the J2EE Navigator by default instead of the resource Navigator in order to provide easier access to the Web Deployment Descriptor and to display Java source in packages instead of file folders to make it easier to navigate. Use the Server Configuration tab to configure different application servers for deploying and testing your applications. Chapter 8 covers this important topic. The bottom left pane provides many convenient views for navigating and modifying HTML. The Gallery provides a number of page layouts and styles, images, wallpapers, web art, MIDI sounds, and style sheets from which to choose. The Thumbnail view shows small graphic summary views of the files in your project, or in the Gallery. You can select elements from the thumbnail view and add them to your web page. The Library view provides a list of active elements that you can add to your HTML pages including JavaScript and JSP elements. This makes it very easy to add rich content and actions to your page without having to know all the JavaScript details. We’ll be using the JSP elements in Chapter 13. The Outline view shows an outline of the HTML source and provides a quick and easy way to navigate the document. In particular, use the Outline view to navigate to the location of specific HTML elements in the Page Designer design view since the actual elements aren’t directly visible in that view. The Attribute view shows all the Page Designer attributes of the selected item in the design view. Contrast with the Properties view, which shows all the HTML attributes of the selected HTML element and their current values. This is a great way to see what attributes are available on an HTML element. The Properties view isn’t open by default in the Web perspective, but you’ll find it helpful if you like to do a lot of HTML source editing. To add the view, select Window>Show View>Others… and then select Basic>Properties. Then position the view where you want it by dragging its title bar. You may want to arrange the view at the bottom left because you don’t generally look at attributes and properties at the same time. The Links view lets you look at the links to and from a file selected in the J2EE Navigator view. This is a great view for finding and fixing broken links. 

Finally, there’s the Page Designer editor itself. Page Designer is a multi-page editor that provides three presentations of the edited file: Design, Source, and Preview. The design view is a WYSIWYG editor that is best for doing general editing as you can see what the page will look like as you edit. Use the gallery and library views to add layout, static content, and dynamic content to your page. Use the attributes view to edit the details of the selected element. Note that when viewing the attributes of a link, the attributes of the text are shown when the cursor is positioned in the text inside the anchor element. To display and edit the link’s URL reference, make sure the cursor is positioned at either the beginning or the end of the anchor text. The Source pane is for directly editing the HTML source. Use the Properties view as a convenient way to edit the attributes of the selected HTML element. Non-default values of properties are automatically added to the HTML element. Full content assist is available by pressing Control-Space anywhere. Use content assist to see what HTML elements or attributes are valid at the current cursor location or to select a value for an attribute. In addition, allowing the cursor to pause over an element displays hover-help on that element. You can also open the source directly by selecting an HTML file from the navigator and selecting Open With>Source Editor. This might be necessary when editing pages with multiple frames, some of which cannot be displayed, perhaps because they reference servlets instead of HTML pages. The preview view lets you see what your page will actually look like when viewed in a Web browser. This view also shows how existing Windows applications built with ActiveX are integrated into the Workbench. On Windows systems, the HTML viewer used in the preview view is actually the Windows Internet Explorer.

Page Designer has lots more features, enough for its own book. This introduction should be sufficient to get you started and we’ll cover more details throughout the book. As always, additional detail is available from the product’s online help.

Now back to the example. Add some content to your index.html welcome page that introduces users to your Web application and provides initial access to its functionality. Use headings, paragraphs, alignment, style sheets, etc. to make the page look the way you want. We’ll keep the HTML intentionally simple in our example in order to focus on the overall application flow. Add a link to your page to a file called browseEmployees.html, which will contain the frames to layout the employee list and details.

Select the Web Content folder again, and create another HTML file called browseEmployees.html and enter the code shown in Listing 7.4. The page contains three frames: one for the banner at the top, another resizable frame for the employee list, and a third, on the bottom for the employee details. The src attribute of the “banner” frame references banner.html, so create that file and add some interesting looking banner from Gallery>Image->Banner or create your own using File->New>Other…>Web>ImageFile to create an image file and edit it with WebArt Designer. The src attribute for the “list” frame is BrowseEmployees, the URL used to access the servlet that provides the employee list from the database. We’ll develop this servlet in the next section. Notice the information marker next to the line that references the BrowseEmployees servlet. This marker indicates there is a broken link in the file. You can also see the broken link from the Links view when you select browseEmployees.html from the J2EE Navigator view and in an error in the Tasks view. The error will go away when you create the servlet and add it to the Web application deployment descriptor. The “detail” frame doesn’t have any src attribute. A link provides the content generated by the BrowseEmployees servlet, which uses the “detail” frame as its target. This frame will be empty the first time you access the browseEmployees.html file.

Listing 7.4 browseEmployees.html

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Servlet Example</title>
</head>
<frameset rows="50,*, 240">

<frame name="banner" scrolling="no" noresize src="banner.html" 


   marginwidth="0" marginheight="0" frameborder="0"/>

<frame name="list" scrolling="auto" src="BrowseEmployees" 


    marginwidth="50" marginheight="20"frameborder="1"/>

<frame name="detail" marginwidth="0" marginheight="20" 

       frameborder="0"/>

<noframes>

<body>

<p>This page uses frames, but your browser doesn't support them.</p>

</body>

</noframes>
</frameset>
</html>
Create the servlets for accessing and updating the model

Now we’re finally ready to create our first servlet. The browseEmployees.html file had a link in the list frame to BrowseEmployees. This URL references the servlet that accesses the database to get a list of employees and formats the result into an HTML page displayed in the frame. Select package com.wsbook.servletexample in the Java Source folder, right click, and select New>Servlet. Fill in com.wsbook.servletexample for the Java package, and BrowseEmployees for the servlet class name, and press next. 
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Figure 7.14 New Servlet Wizard

Figure 7.14 shows the second page of the new servlet wizard. Use this page to select which servlet methods you wish to implement. These methods correspond to the HTTP methods that can be used to access and update Web content. The employees list is read-only, and requires no parameters, so we’ll just implement doGet() which, you’ll remember, is used to return a page. Also, make sure to select the Add to web.xml option. This adds the servlet to the Web application deployment descriptor so it can be accessed through a specific URL. We’ll look at the details in the next chapter when we prepare to execute the application. Note the Mappings: section. By default, WSAD added URL mapping /BrowseEmployees to the mappings, which in turn adds it to the Web deployment descriptor. This means that this URI can be used by an HTTP client application to cause the Web application server to invoke the doGet() method of the BrowseEmployees servlet. The URL mapping will also fix the broken link we had in our browseEmployees.html file. You can have many mappings to the servlet in order to provide access through different URLs. We only need the default, so press Finish to create the initial servlet code. When you do, you’ll see that the broken link warning is removed from the tasks view.

Next, add the following code to BrowseEmployees.java.

Listing 7.5 BrowseEmployees.java

package com.wsbook.servletexample;
import java.io.IOException;
import java.io.PrintWriter;
import java.sql.SQLException;
import java.util.Iterator;
import javax.servlet.ServletException;
import javax.servlet.http.HttpServlet;
import javax.servlet.http.HttpServletRequest;
import javax.servlet.http.HttpServletResponse;
import com.wsbook.servletexample.domain.Employee;
public class BrowseEmployees extends HttpServlet {

public void doGet(HttpServletRequest req, HttpServletResponse resp)


throws ServletException, IOException {


PrintWriter out = resp.getWriter();


out.println("<HTML>");


out.println("<BODY>");


out.println("<h3 align=\"center\">All Employees</h3>");


out.println(



"<TABLE align=\"center\" BORDER=\"yes\" CELLSPACING=2 CELLPADDING=0 WIDTH=\"70%\">");


out.println("<TR>");


out.println("<TD><center><b>Id</b></center></TD>");


out.println("<TD><center><b>Name</b></center></TD>");


out.println("<TD width=\"40\"><center><b>Age</b></center></TD>");


out.println("</TR>");


try {



Iterator employees = Employee.findAll().iterator();



while (employees.hasNext()) {




Employee employee = (Employee) employees.next();




out.println("<TR>");




out.println(





"<TD><A HREF=\"EmployeeDetails?id="






+ employee.getId()






+ "\" target=\"detail\">"






+ employee.getId()






+ "</A></TD>");




out.println("<TD>" + employee.getName() + "</TD>");




out.println("<TD width=\"40\">" + employee.getAge() + "</TD>");




out.println("</TR>");



}


} catch (SQLException e) {


}


out.println("<TR>");


out.println(



"<TD colspan=\"3\"><A href=\"EmployeeDetails\" target=\"detail\">Create Employee...</A></TD>");


out.println("</TR>");


out.println("</TABLE>");


out.println("</BODY>");


out.println("</HTML>");

}
}
This code is typical of a servlet that provides dynamic content. It first accesses the output PrintWriter from the HttpServletResponse in order to write output back to the Web browser, which displays it in the list frame of the browseEmployees.html page. Most of the rest of the code just outputs the HTML for the output page. It uses a table to display the employee id, name, and department. This is sufficient information to help users identify which employee they would like to update. The code uses the Employee findAll static method to access the database and get an iterator over employees to display each employee in a table row. Notice that the employee id is placed inside an HTML anchor element that specifies a link to EmployeeDetails with an id argument containing the employee id. This link is used to invoke the EmployeeDetails servlet, which displays the employee details in the detail frame of browseEmployees.html. There is also a special row added to the bottom of the table that contains a link to EmployeeDetails with no argument so users can create a new employee.

Create another servlet in the same package called EmployeeDetails that also implements the doGet() method. The code is given is Listing 7.6.

Listing 7.6 EmployeeDetails.java

package com.wsbook.servletexample;
import java.io.IOException;
import java.io.PrintWriter;
import java.sql.SQLException;
import javax.servlet.ServletException;
import javax.servlet.http.HttpServlet;
import javax.servlet.http.HttpServletRequest;
import javax.servlet.http.HttpServletResponse;
import com.wsbook.servletexample.domain.Employee;
import com.wsbook.servletexample.exception.NoSuchObjectException;
public class EmployeeDetails extends HttpServlet {

public void doGet(HttpServletRequest req, HttpServletResponse resp)


throws ServletException, IOException {


String employeeId = req.getParameter("id");


Employee employee = new Employee();


if (employeeId != null) {



try {




employee = Employee.findByPrimaryKey(employeeId);



} catch (NoSuchObjectException e) {




e.printStackTrace();



} catch (SQLException e) {




e.printStackTrace();



}


}


PrintWriter out = resp.getWriter();


out.println(



"<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\">");


out.println("<html>");


out.println("<head>");


out.println("<title>Employee Details</title>");


out.println(



"<meta http-equiv=\"Content-Type\" content=\"text/html; charset=iso-8859-1\">");


out.println("</head>");


out.println("<body bgcolor=\"#FFFFFF\" text=\"#000000\">");


out.println("<h3 align=\"center\">Employee Details</h3>");


out.println("<div align=\"center\">");


String action = "UpdateEmployee";


if (employeeId == null) action = "CreateEmployee";


out.println(



"<form name=\"updateEmployee\" target=\"_top\" method=\"post\" action=\""+action+"\">");


if (employeeId != null)



out.println(




"  <input type=\"hidden\" name=\"id\" value=\""





+ employee.getId()





+ "\"/>");


out.println(



"  <table align=\"center\" border=\"1\" cellpadding=\"0\" cellspacing=\"0\" width=\"70%\">");


if (employeeId == null) {



out.println("    <tr>");



out.println("      <td width=\"60\">");



out.println("        <div align=\"right\">Id:</div>");



out.println("      </td>");



out.println("      <td>");



out.println(




"        <input type=\"text\" name=\"id\" size=\"70\" value=\""





+ employee.getId()





+ "\"/>");



out.println("      </td>");



out.println("    </tr>");


}


out.println("    <tr>");


out.println("      <td width=\"60\">");


out.println("        <div align=\"right\">Name:</div>");


out.println("      </td>");


out.println("      <td>");


out.println(



"        <input type=\"text\" name=\"name\" size=\"70\" value=\""




+ employee.getName()




+ "\"/>");


out.println("      </td>");


out.println("    </tr>");


out.println("    <tr>");


out.println("      <td width=\"60\">");


out.println("        <div align=\"right\">Age:</div>");


out.println("      </td>");


out.println("      <td>");


out.println(



"        <input type=\"text\" name=\"age\" size=\"70\" value=\""




+ employee.getAge()




+ "\"/>");


out.println("      </td>");


out.println("    </tr>");


out.println("    <tr>");


out.println("      <td width=\"60\">");


out.println("        <div align=\"right\">Street:</div>");


out.println("      </td>");


out.println("      <td>");


out.println(



"        <input type=\"text\" name=\"street\" size=\"70\" value=\""




+ employee.getStreet()




+ "\"/>");


out.println("      </td>");


out.println("    </tr>");


out.println("    <tr>");


out.println("      <td colspan=\"2\">");


out.println(



"        <table border=\"0\" cellpadding=\"0\" cellspacing=\"0\">");


out.println("          <tr>");


out.println("            <td width=\"60\">");


out.println("              <div align=\"right\">City:</div>");


out.println("            </td>");


out.println("            <td>");


out.println(



"              <input type=\"text\" name=\"city\" size=\"27\" value=\""




+ employee.getCity()




+ "\">");


out.println("            </td>");


out.println("            <td width=\"30\">");


out.println("              <div align=\"right\">State:</div>");


out.println("            </td>");


out.println("            <td>");


out.println(



"              <input type=\"text\" name=\"state\" size=\"6\" value=\""




+ employee.getState()




+ "\">");


out.println("            </td>");


out.println("            <td width=\"30\">");


out.println("              <div align=\"right\">Zip:</div>");


out.println("            </td>");


out.println("            <td>");


out.println(



"              <input type=\"text\" name=\"zip\" size=\"10\" value=\""




+ employee.getZip()




+ "\">");


out.println("            </td>");


out.println("          </tr>");


out.println("        </table>");


out.println("      </td>");


out.println("    </tr>");


out.println("      <td colspan=\"2\">");


out.println("        <div align=\"center\">");


out.println(



"          <input type=\"submit\" name=\"submit\" value=\"Submit\" align=\"center\">");


if (employeeId != null) {



out.println(



"          <input type=\"submit\" name=\"submit\" value=\"Delete\" align=\"center\">");


}


out.println("        </div>");


out.println("      </td>");


out.println("    </tr>");


out.println("  </table>");


out.println("</form>");


out.println("</div>");


out.println("</body>");


out.println("</html>");

}
}
This code is similar to the previous servlet. It again uses the Employee class to access the database, but this time using the findByPrimaryKey method for a specific employee identified by the id HttpServletRequest parameter. Recall that the BrowseEmployees servlet provided this parameter in the link that invokes the EmployeeDetails servlet. An HTML form contains the employee information using input fields so that users can update the employee data. At the bottom of the form, there are a couple of submit input elements for updating and deleting the employee. The form action is UpdateEmployee, and it uses the post method instead of get. Recall that an HTML form puts all the form input fields into HttpServletRequest parameters. HTTP can communicate parameters using headers or in a request entity body. In both cases, the parameters are in the form “?name=value” and are parsed so getParameter can be used to access the parameter by name. However, most Web application servers limit the size of HTTP headers, limiting the number of parameters that can be passed in an HTTP GET method. Therefore, it is generally best practice to use the POST method for passing data in HTML forms. 

The HTML form generated by the EmployeeDetails servlet passes each of the form input fields as a parameter using the input field name as the parameter name. Next, we’ll create another servlet that will use this information to update the employee in the database. Create a new servlet called UpdateEmployee, but have this servlet implement the doPost() method instead of doGet(). This is because the form’s action tag invoked the UpdateEmployee servlet using the post method. Listing 7.7 contains the code for the UpdateEmployee servlet.

Listing 7.7 UpdateEmployee.java

package com.wsbook.servletexample;
import java.io.IOException;
import java.sql.SQLException;
import javax.servlet.ServletException;
import javax.servlet.http.HttpServlet;
import javax.servlet.http.HttpServletRequest;
import javax.servlet.http.HttpServletResponse;
import com.wsbook.servletexample.domain.Employee;
import com.wsbook.servletexample.exception.MappingException;
import com.wsbook.servletexample.exception.NoSuchObjectException;
public class UpdateEmployee extends HttpServlet {

public void doPost(HttpServletRequest req, HttpServletResponse resp)


throws ServletException, IOException {


// Update the employee and address information and 


String employeeId = req.getParameter("id");


Employee employee = null;


try {



employee = (Employee) Employee.findByPrimaryKey(employeeId);


} catch (NoSuchObjectException e) {



System.out.println("***Error, employee doesn't exist");


} catch (SQLException e) {



e.printStackTrace();


}


// see what button the user pressed


String action = req.getParameter("submit");


if (action.equals("Delete")) {



try {




employee.delete();



} catch (SQLException e) {




e.printStackTrace();



} catch (MappingException e) {



}


} else {



employee.setName(req.getParameter("name"));



try {




employee.setAge(Integer.parseInt(req.getParameter("age")));



} catch (NumberFormatException exc) {




System.out.println("***Error, employee id must be a number");



}



employee.setStreet(req.getParameter("street"));



employee.setCity(req.getParameter("city"));



employee.setState(req.getParameter("state"));



employee.setZip(req.getParameter("zip"));



try {




employee.update();



} catch (MappingException e) {




System.out.println(





"***Error, couldn't save employee or address");



} catch (SQLException e) {




e.printStackTrace();



}


}


// refresh the employee's list so it shows the updates



resp.sendRedirect("browseEmployees.html");

}
}
UpdateEmployee is an example of a controller servlet that handles user input and invokes operations on the business model in order to implement some business use case, in this case, updating the business data. This servlet again uses the Employee class to get a particular employee by id, and then uses parameters from the HttpServletRequest that were provided by the HTML form to update the employee information. Notice that the code does little data validation, and errors are handled by simply raising exceptions, which will result in the servlet displaying a standard error page that you typically wouldn’t present to your users in a real application. Servlets generally catch these errors and send output that is more suitable in a generated error HTML page. However, we’ll ignore this for now in order to keep the code simple. Notice the last line in the UpdateEmployee servlet. This code redirects the request back to the browseEmployees.html page in order to refresh the employee list with the updated employee information.

Some Problems with this Example

Our servlet example was simple, but covered many of the steps required for many Web applications using dynamic data and shared business logic. This simple example might make you wonder what else you need. We’ll soon discover that as we scale up the functionality, complexity, persistence, transaction, and security needs of our applications, this simple pattern won’t be nearly enough. So as a final look at what we’ve learned in this chapter, let’s look at what was tedious or inflexible and in doing so, briefly introduce some the additional features of J2EE and WSAD that we will explore in the coming chapters.

· Editing HTML inside Java source was difficult to develop and error prone. There was no way to use the WSAD HTML editor for WUSIWUG editing, formatting, preview, content assist, attributes, etc. This resulted from the un-integrated mixture of two languages. Later on, we’ll see how Java Server Pages address this issue.

· All the data parameters passed into the servlets used to update the database were passed as strings with no data validation. The Struts framework provides additional facilities and validation that will help you simplify and standardize your forms data processing.

· The EmployeeDetails servlet mixed display and control logic for accessing employees in the same component making control logic more difficult to reuse in other user interfaces. Using Java Server Pages and the Struts framework to separate reusable business logic from reusable user interface modules address this issue.

· Developing the database mapping code using the Active Record pattern was reasonably simple, but somewhat tedious. In addition, it was only one business object with no associations, no inheritance, and no data transformations between the data in the object model and tables in the relational database. This simple solution will not scale up well to more complex models and database schemas. J2EE local Container Managed Entity Beans solve this problem by automatically generating all database assess code and providing a tool for interactively mapping object and relational models for those cases where the defaults are enough.

· Mixing persistence into the model classes couples them to a particular database implementation. We need an approach that provides a common interface for persistence, but allows for variability of both the objects being persisted, and the persistence mechanisms used.

· A lot of database code in the Employee class is generic and unnecessarily repeated in each domain object. Other object-to-relational mapping patterns factor out the common code so you only need to implement the things that are specific to the object. We’ll look at another approach for developing the domain model in Chapter 16.

· Our sample application didn’t use transactions except at the database access level, or security beyond what could be set on individual Web resources and the database itself. J2EE Enterprise JavaBeans address this functionality by supporting a rich, role based security model and method-level access control.

Summary

Web based application development involves a myriad of different file and resource types. If not efficiently managed, the process of moving from development to test, and ultimately a production environment, can result in what might feel like an endless cycle of regressions due to these files being “out of synch”. Having a good, well-integrated, well-understood tool set that knows the relationships between the artifacts of an application and how to manage change will go a long way to improving and shortening the development process and increasing the quality of the resultant applications.

WSAD is more than just another HTML authoring tool; it provides a complete, integrated development environment for J2EE applications and Web services. In this chapter, we covered an overview of WSAD and the WebSphere Studio Workbench that provides the Eclipse based tool integration environment. We then looked at the steps required to create and edit a simple, but complete Web application based on J2EE servlets using. Along the way, we took a more detailed look at just a few of the tool components that make up WSAD. In the next chapter, we’ll look at how to deploy and test this simple application within WSAD. Later chapters will address all of the issues raised in the previous section.
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