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Introduction
Welcome to the Adobe Premiere Pro Best Practices and Workflow Guide for Long 
Form and Episodic Post Production� This deep-dive anthology of expert, step-by-
step advice and illustrated examples was written by a team of industry experts and 
leading Adobe engineers� 

This document covers a broad range of essential topics, starting with how to configure and 
optimize your settings, establish best practices for offline dailies, and help you navigate the 
remaining workflow all the way though turnovers and final deliverables.

This guide is not intended to be an all-encompassing, one-size-fits-all solution, but rather a 
detailed look at the recommendations and vetted procedures that have empowered our award-
winning customers. 

A bit of history... beginning in 2005, Adobe made a commitment to hiring seasoned experts from 
the post production and VFX fields to help their engineers and product design teams evolve 
Premiere Pro’s professional toolset. The goal was to ensure that even the most demanding cutting 
rooms could rely on and trust Adobe applications for editing long form content. 

After years of performance and feature refinements that were proven on commercials and music 
videos by industry vanguards such as Rock Paper Scissors and EXILE, in 2013 Premiere Pro was 
chosen by director David Fincher and his post team for Gone Girl which became the first Hollywood 
film to be edited with Premiere Pro. Followed soon by hits like Tim Miller’s Deadpool and The Coen 
Brothers’ Hail, Caesar!, the journey for Premiere Pro adoption in long form content was well 
underway. 

Continuing with an impressive list of award-winning feature films, hundreds of streaming series and 
documentaries, we are honored to see the platform adopted by so many incredibly talented 
storytellers. 

Our deep learnings from years of working directly with our film and video customers has helped 
vastly improve the capabilities, reliability, and performance of Premiere Pro and was the 
foundation for the guidance in this document. 

In 2020 the key new Productions feature was released, dramatically improving performance and 
collaboration for long form editorial teams. Early iterations were first deployed on Only the Brave, 
Dolemite Is My Name, Mindhunter and Terminator: Dark Fate. Mank was the first film to utilize the 
fully-featured version of Productions, which is now available to all Premiere Pro users.

We hope this guide serves as a useful reference throughout your production and we look forward 
to hearing about your success using Premiere Pro.



4Best Practices & Workflow Guide | Before Getting Started 

Chapter 2

Before Getting 
Started



5Best Practices & Workflow Guide | Before Getting Started 

Chapter Contents

Merged Clips �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  � 6

Sequence Audio �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  � 6

Modifying an Existing Multicam Clip   �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  7

MXF OP-Atom �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  7

AAF Export �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  7

Media Cache Files �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  � 8

Scratch Disks �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  � 9

Auto Save �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  � 9

Transmit �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  � 9

File System Notifications in a Production�  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  � 9

Third Party Plug-ins and Extensions �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  � 9

GPU Drivers   �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  � 9

Nested Sequences in a Production�  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  10

Save All  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  10

Creative Cloud Cleaner Tool�  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  �  10



6Best Practices & Workflow Guide | Before Getting Started 

Introduction
This chapter is a collection of important tips and recommendations to read before 
starting your Film or TV project in Premiere Pro� Many of the items are covered in 
other chapters of this guide, but are presented here because they are the most 
important to be aware of before you get started�

Merged Clips
Never use the Merge Clips function in Premiere Pro to sync audio and video. The merge clips 
feature creates a new clip which does not retain the original audio metadata, which can block 
common audio turnover workflows. 

Instead, use Multi-Camera to sync all footage. Multi-Camera clips 
can be modified after creation, match back to the original source clip, 
and preserve all metadata throughout your audio turnover 
workflow.

See the chapter "Multi-Camera Editing" on page 78 for more 
information.

Sequence Audio
When you drag a clip or Multicam into the Timeline panel to create a new sequence, Premiere Pro 
does its best to guess how to configure the sequence’s audio channel format. However, you often 
don’t want your sequence’s audio channel format to match your clip or Multicam. Instead, always 
manually create your editorial sequence first and choose the appropriate format.

Choose File > New > Sequence� Click the Tracks tab, then select the appropriate audio channel 
format from the Mix drop-down menu. You cannot change the audio channel format of a sequence 
after creating it.

You can save presets of your sequence settings for easy re-use later. When creating a new sequence, 
dial in your settings and then use the Save Preset button to save the preset.

Don't use the Merge Clips 
function to sync audio and 

video.

Save custom Sequence 
Settings presets.
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Modifying an Existing Multicam Clip
Premiere Pro allows for the modifying of an existing Multicam clip, which can be useful to correct 
sync, or if new camera angles need to be added later. When working in a Production, it is best to 
modify Multicam clips before they have been cut into other sequences. If you need to modify a 
Multicam after it has been cut into other sequences, make sure to open the project containing the 
Multicam clip and modify that original instance.

MXF OP-Atom
MXF files in the OP-Atom format use a separate file on disk for each track of a clip. A video clip 
with two audio channels would be three separate MXF files. Using MXF OP-Atom can result in 
increased network load as Premiere Pro has to keep more file handles open against the storage 
system.

While Premiere Pro can import and play back OP-Atom files, the best practice is to use MXF OP1a 
which puts the audio and video together in a single MXF file per clip.

AAF Export
• When exporting an AAF to Avid Pro Tools, use Breakout to Mono (check Enable).

• When exporting an AAF to Avid Media Composer do not use Breakout to Mono. 

 

See the chapter "Turnovers" on page 115 for more information.

Enable or disable Breakout 
to Mono depending on the 

target software.
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Media Cache Files
Media Cache Files and Media Cache Database are recommended to stay either in their default 
location on the system boot drive or on a separate fast SSD directly attached to each workstation. 
You can set the location in Preferences > Media Cache.

Adobe does not recommend and cannot support configurations where Media Cache files are 
placed on shared storage.

Avoid using compressed audio formats like MP3 and AAC. Transcode these files to WAV or AIFF 
before importing to avoid needing to create those cache files.

If you upgrade your project to a newer version of Premiere Pro and experience playback issues or 
instability, try clearing your media cache. Premiere Pro will rebuild the cache the next time you 
open a project.

Deleting the Media Cache
1. Close all Creative Cloud apps if they are open 

(After Effects, Media Encoder, and Premiere Pro share the same cache files)  

2. Launch Premiere Pro  
(do not open any projects)

3. Open Preferences > Media Cache

4. Click Remove Media Cache Files (Delete)

5. You will now see Delete all Media Cache files from the system as an available option

6. Quit Premiere Pro and relaunch

Delete all media cache 
files when opening a 

project in a newer version of 
Premiere Pro.
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Scratch Disks
When working in a shared environment with a team, set the Scratch Disks to a shared location so 
render files are shared across every editorial system. Choose File > Project Settings > Scratch 
Disks or File > Production Settings > Scratch Disks to set your scratch disk locations.

Auto Save
Auto Save saves a copy of the current project to the scratch disk location. If you want to save the 
current project at the same time an auto save copy is created, enable “Auto Save also saves the 
current project” found in Preferences > Auto Save�

The Auto Save timer starts after a project has been modified.

Transmit
Premiere Pro supports full screen playback using the built in GPU or third-party hardware.

Some transmit devices have fixed frame sizes and frame rates they support. Playing a clip in the 
Source Monitor or a Sequence that doesn’t match a supported frame size and frame rate can lead 
to incorrect playback or no playback at all.

File System Notifications in a Production
Premiere Pro’s Production feature uses notifications from the underlying file system in order to 
know when projects or folders in a production have been updated. If your shared storage system 
does not support file system notifications, Premiere Pro will fall back to polling the folder 
periodically. This method is less efficient and can cause increased network usage if many editors 
are all working inside a large production.

For best results, use SMB or ensure that your shared storage supports file system notifications.

Third Party Plug-ins and Extensions
Older versions of third-party plug-ins can cause instability with Premiere Pro. If you are 
experiencing trouble launching the application, try removing the plug-ins that can be found here: 

Plug-in Paths
• Mac: /Library/Application Support/Adobe/Common/Plug-ins/7�0/MediaCore

• Windows: C:\Program Files\Adobe\Common\Plug-ins\7�0\MediaCore

Extension Paths
There are two paths on Windows where extensions can be installed. Check both locations for 
third-party extensions:

• Mac: /Library/Application Support/Adobe/CEP/extensions

• Windows Option 1: C:\Program Files (x86)\Common Files\Adobe\CEP\extensions

• Windows Option 2: C:\Program Files\Common Files\Adobe\CEP\extensions

GPU Drivers
Premiere Pro can automatically detect known issues with GPU drivers. If you see a System 
Compatibility Report after launching Premiere Pro, follow the instructions to resolve the issue.

When choosing an NVIDIA driver, use the Studio version for best performance and stability in 
Premiere Pro.

https://en.wikipedia.org/wiki/Server_Message_Block
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Nested Sequences in a Production
When working in a Production and moving an editing sequence between projects, any nested 
sequences contained in the editing sequence will travel with the editing sequence. This is because 
sequences cannot link across projects like regular clips can.

Save All
When working in a Production, you can end up with many project files open at the same time. 
Using File > Save All rather than the usual File > Save will save any open project that has been 
modified. Many editors prefer to map the Save All command to CMD/CTRL+S so they can quickly 
save all open projects.

Creative Cloud Cleaner Tool
The Creative Cloud Cleaner tool is a utility for experienced users to clean up corrupted installations, 
remove old Adobe software, or fix problem files and resolve permission issues in registry keys. 

How and when to use the Creative Cloud Cleaner tool.

https://helpx.adobe.com/creative-cloud/kb/cc-cleaner-tool-installation-problems.html
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Introduction
Premiere Pro runs on an incredibly wide range of hardware and configurations� 
This chapter provides hardware and settings recommendations geared towards 
film & TV productions� 

Rather than give a single recommended spec, this chapter explains how Premiere 
Pro uses computer components so you can choose the hardware options best 
suited to your workflow and budget�

Hardware

Summary
If you aren’t interested in the details that follow and just want a list to reference, use the following 
when shopping for computer hardware for Premiere Pro:

• CPU: The sweet spot is 8-16 cores, but keep in mind that core speed matters. 8 fast cores (3.5+ 
GHz) are usually preferable to 20 slower cores (2 GHz).

•  RAM: Minimum 64 GB. Don’t be afraid to go higher if you have large, complex project files.

•  GPU: Buy as powerful a GPU as your budget can support. Keep drivers current. For NVIDIA 
GPUs on Windows, use the Studio driver rather than the Game Ready driver.

•  Storage Devices: Install Premiere Pro on a fast NVMe boot drive and have a secondary fast 
SSD (internal or external) for Media Cache files.

•  Networking: Use fast, modern network options like 10 GbE whenever possible. The SMB 
protocol works best for Productions.

A Balanced System
The key to building or choosing a good system for video editing in Premiere Pro is to build a 
powerful system with an eye for balancing the components to avoid severe bottlenecks in any one 
component. If your workflow is specific to certain video formats or workflows, you can use that to 
inform your choices when finding a good workstation. 

Depending on the workflow, Premiere Pro can lean heavily on the GPU, or the CPU, or ideally both 
in unison.

CPU (Central Processing Unit)
Despite the recent advances in using the GPU and other dedicated video hardware, overall 
performance in any video editing system still comes down to a powerful CPU. For best 
performance in Premiere Pro, choose a CPU that has at least 8 cores and a minimum of 3 GHz clock 
speed.

It’s true that more cores are generally better, but only to a point. The more cores a given CPU has, 
the slower each core will run. Since not everything video software needs to do can be split across 
multiple cores, there is still a benefit to having your cores be fast. 

Therefore, there is a sweet spot for video editing, usually in the 8-16 core range. Look for reviews of 
a CPU you are considering to see how it handles video editing tasks.
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RAM (Random Access Memory)
Generally speaking, as long as the RAM in your system is compatible with the CPU and able to run 
at its advertised speeds, you don’t have to worry about the specifications any further. That leaves 
just the question of how much RAM to have.  When using Premiere Pro on a professional 
workstation, start with 64 GB and increase from there as needed.

Premiere Pro’s RAM usage consists of two main areas:

1. Video frames decoded for playback: This is what most people think of when considering 
RAM in Premiere Pro. For example, you might think “I’m working in 6K, so I’ll need more 
RAM”. While this is true, it’s often more important to consider the second use case below.

2. Project data: When you open a project file in Premiere Pro, the data is read off of your drive 
and decoded into objects in memory. Each bit of data in the project uses more RAM. Every 
imported clip, every time an effect is used, every sequence, etc. will all use more RAM.  
Thus, for larger projects it is possible that the project data is using more RAM than the video 
frames decoded for playback mentioned above.  
The .prproj project file saved on your disk is compressed, so it’s not at 1:1 mapping of file size 
to RAM used. For example, a 15 MB project file could require 4 GB of RAM once it is opened 
and ready to use.

GPU (Graphics Processing Unit)
The GPU is a specially designed type of processing chip that focuses on highly parallelizable tasks. 
A good example is applying a color shift to a video frame. Rather than your CPU cores going pixel 
by pixel and changing the color, a GPU can give a few pixels to each of its thousands of small cores 
and finish processing the frame more quickly.

This Help page has up-to-date GPU information:  
https://helpx.adobe.com/x-productkb/multi/gpu-acceleration-and-hardware-encoding.html

The GPU is used in four main areas in Premiere Pro:

1. Hardware Accelerated Decode (playback)

2. GPU Accelerated Renderer

3. Hardware Accelerated Encode (export)

4. Sensei Machine Learning processing

Hardware Accelerated Decode
Premiere Pro can use the dedicated hardware on modern GPUs (or some CPUs) to decode certain 
formats more quickly than if it were done “in software”, meaning as generalized software 
instructions. Think of it like slicing an egg: you could do it by hand, slowly slice by slice (software) 
or you could toss it in a dedicated egg slicer, press down once, and you’re done (hardware).

Generally speaking, Hardware Accelerated Decoding is available for H.264 (AVC) and H.265 
(HEVC) formats. There are some limitations as to what is supported based on things like frame size, 
bit depth, and chroma subsampling based on what your GPU supports.

Make sure Hardware Accelerated Decode is enabled in Preferences > Media.

GPU Accelerated Renderer
When your timeline playhead lands on a frame, the video frame is decoded to an uncompressed 
frame, then any effects are applied. GPU Accelerated Rendering refers to using the GPU to process 
any effects on the decoded frame. This could be a simple scale or position adjustment, a Lumetri 
color shift, or a third-party effect.

https://helpx.adobe.com/x-productkb/multi/gpu-acceleration-and-hardware-encoding.html
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The setting to control GPU accelerated rendering is found in Projects Settings > General. On a Mac 
you should leave it set to Metal. On Windows with an NVIDIA GPU, set it to CUDA. On Windows 
with an AMD GPU, set it to OpenCL. 

Switching to “Software Only” means the GPU will not be used when creating the frames you see on 
screen.

Hardware Accelerated Encode
Just as modern GPUs have dedicated hardware to decode H.264 and H.265 (described above), they 
also have dedicated hardware to export to those formats. When you are exporting to either H.264 
(AVC) or H.265 (HEVC) you can take advantage of hardware accelerated encoding to export much 
faster. 

Like with decoding, your specific GPU will dictate exactly which frame sizes, bit depths, and other 
settings can be used. If you use a setting outside of those, Premiere Pro will fall back to exporting 
using Software Encoding (on the CPU).

Sensei Machine Learning Processing
The types of processing that are involved in running machine learning models and other types of 
AI/ML operations benefit from running on GPU hardware. Premiere Pro will use any available GPU 
or dedicated ML processors when using Sensei features like Auto Reframe, Scene Edit Detection, 
Auto Ducking, and more.

GPU Drivers
Drivers play a key part in being the translator between Premiere Pro and the physical GPU 
hardware. If you are on a Mac, you don’t need to worry about the GPU drivers as they are bundled 
into the operating system. If using a Windows computer, make sure that your drivers are up to date 
from the manufacturer when you set up the system. You should update them periodically, for 
example between jobs. 

If your system is working fine and the drivers are within a year or two, you don’t need to be 
constantly updating them. Sometimes new drivers may introduce issues in GPU performance in 
video editing software.

NVIDIA GeForce GPUs have two types of drivers: Game Ready and Studio. Use the Studio drivers 
for best performance in Premiere Pro.

Storage Devices
There are three roles storage devices can play in your editing system. Higher end workstations will 
have separate physical drives for each role. Lower end systems or laptops can still work well even if 
a single drive is handling all three roles, assuming the drive is a modern, fast SSD.

1. Boot drive: It is recommended to install Premiere Pro on the system boot drive. This drive 
should be fast, ideally using the NVMe protocol. If your system doesn’t or can’t have other 
drives, this drive can fill the following two roles as well.

2. Cache drive: This should be a fast SSD dedicated to Premiere Pro. In Preferences > Media 
Cache, set the Media Cache Files and Media Cache Database to this drive. You should have a 
dedicated cache drive for each workstation using Premiere Pro, and should not put the cache 
on a shared server.

3. Media drive: This drive holds your media and may sacrifice speed for a large capacity. While 
faster drives are always better, the main consideration for this drive should be that it is able to 
offer a read speed fast enough to handle the number of concurrent clips you need to play back 
multiplied by the bitrate of those clips. Shared networked storage is also commonly used as 
the media drive.

On Macs with Apple silicon 
the renderer will always be 

set to Metal.

AI = Artificial Intelligence

ML = Machine Learning
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Networking
Premiere Pro is flexible with the type of networks it can support. As a best practice when building a 
modern networked storage, prefer 10 Gb Ethernet speeds as a minimum. These networks allow for 
many users to be using shared storage at once and can handle the higher bitrates of modern frame 
sizes.

While Premiere Pro can access media using a number of different types of network protocols, SMB 
is the preferred protocol for any type of shared setting. SMB is also recommended when using the 
Productions workflow in a shared environment. 

Productions can work with other proprietary third-party solutions, but check with the third party 
vendor before assuming it works with Productions.

Hardware I/O Monitoring

Audio
If you use a hardware audio monitoring solution, support in Premiere Pro should be essentially 
plug & play. Open Preferences > Audio Hardware, then select your device. If you are only 
monitoring audio (and using video on your computer monitors) you should leave Mercury 
Transmit turned off in the Playback preferences.

Video
Premiere Pro’s system for monitoring video and audio externally is called Mercury Transmit. The 
settings for Mercury Transmit are found in Preferences > Playback. If you are sending audio along 
with the video over Transmit, make sure that your Audio Hardware preferences are not set to also 
use the same audio device. 

You can connect an additional display to your system’s GPU output and select that display in the 
Playback preferences. Premiere Pro will then take over that full display and show whatever is 
playing in your Source or Program Monitor.

Having both Audio 
Hardware preferences and 

Playback preferences set to 
the same audio device can 

cause unexpected issues. 

Audio Hardware prefer-
ences set to not use the 

Transmit hardware. 
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More advanced setups can utilize third-party hardware in the form of PCIe cards or Thunderbolt 
devices. These devices can often handle multichannel audio along with advanced video formats 
including HDR to monitor in professional setups. When using one of these systems, make sure to 
use the latest drivers from the manufacturer.

System Compatibility Report
Premiere Pro automatically performs a system check during launch to identify the capabilities of 
the hardware and detect any issues. If you see no alert, then no issues were found. If an issue is 
found, you will see the System Compatibility Report window explain what the issue is and how to 
address it.

Operating System
Generally speaking, Premiere Pro can be expected to run on the current version of macOS or 
Windows, and the two previous major releases. Consult the requirements listed online for the 
currently supported operating systems: 

https://helpx.adobe.com/premiere-pro/system-requirements.html 

Playback preferences 
are set to use the Transmit 

hardware. 

You can view System 
Compatibility Report at any 

time by choosing it from the 
Help menu.

https://helpx.adobe.com/premiere-pro/system-requirements.html
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Settings & Configuration
Having a good hardware setup is important, but making sure to understand and configure some 
key options in Premiere Pro will ensure a fast and stable editing experience. This section goes over 
important best practices to consider and implement before starting a big project.

Project Settings / Production Settings
When working in a single project file, the settings found in File > Project Settings apply to that 
project and are stored inside the .prproj file. When working in a Production, the settings found in 
File > Production Settings are stored in the .prodset file found in the production folder and apply 
to any project opened by any user working in the production.

General > Renderer
This setting controls which rendering engine Premiere Pro will use. The rendering engine is 
responsible for taking a decoded video frame and applying any effects or modifications. Choosing 
Software Only means the CPU (and no GPU) is used. This method is the slowest and should only be 
used for troubleshooting. 

If on a Mac, set the renderer to use the GPU Accelerated Metal engine. On Windows with an 
NVIDIA GPU, choose CUDA. On Windows with an AMD (or other) GPU, use OpenCL.

Scratch Disks
These scratch disk locations can be set wherever is best for your workflow. There is no need to set 
them to the same fast SSD recommended for the Media Cache. Note that in a Production workflow 
with a team, you need to set the scratch disks to a location that all users have access to.

Ingest Settings
Note that Ingest Settings are intentionally disabled when working in a Production to avoid 
unintended conflicts.

Media Cache Preferences
Where possible, Premiere Pro generates small cache files to speed up the loading and accessing of 
large amounts of media. The Media Cache works best when placed on a fast, dedicated solid-state 
drive (SSD), because then Premiere Pro is able to use the full speed of the drive without competing 
with other open programs or the operating system. 

When working in a shared networking environment (like the Productions workflow), it is 
recommended to keep the Media Cache set local to each system.

In Premiere Pro, open Preferences > Media Cache and use the Browse buttons to set the Media 
Cache Files and Media Cache Database to your desired disk. Note that some very small Media 
Cache Files may still be written to the default location on the boot drive even if you set the 
preference to store Media Cache on an external drive. This is expected behavior.

XMP Preferences
Adobe’s Extensible Metadata Platform (XMP) is a file labeling technology that lets you embed 
metadata into files themselves during the content creation process. Premiere Pro can use XMP to 
track separate media files that may have similar attributes like video files with the same file name 
from the camera. Premiere Pro has three XMP-related preferences found in Preferences > Media.

Write XMP ID to files on import
When enabled, Premiere Pro will write an ID into the XMP metadata for any imported media file. 
This ID can then be used to identify the clip when relinking after the media has been moved. If you 
are working in a Production on shared storage where every editor is using the same set of media, 
turn this setting off on all systems.

https://www.adobe.com/products/xmp.html
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If you are setting up a project or production that will have the same set of media in different 
locations, follow these steps:

1. Open Preferences > Media and check "Write XMP ID to files on import"

2. Import the media (the ID is written into XMP)

3. Share the media files to the other editors 

This way the ID is in the media files before they are shared, and everyone is using the same set.

Write clip markers to XMP
When enabled, marker data is written into the XMP file metadata (in addition to the project file 
data). This can be useful when marking up a clip that will be used in various different projects. You 
can create a new empty project, import the clip, and the markers will already be there.

However, if you are working on shared storage or in a Production workflow it is best to leave this 
preference disabled as your markers will already share between users via the project file data.

Enable clip and XMP metadata linking
Premiere Pro has two different sets of metadata fields. One is Project metadata that includes 
common fields like Description, Tape Name, Scene, Shot, etc. The other is a broader set of XMP 
metadata fields, which contains many of the same fields as the Project metadata. Turning on this 
preference means that data entered into a Project metadata field can also be written into the 
corresponding XMP metadata field (if a match exists).

You can explore this using the Metadata panel. Select a clip, then in the Metadata panel search for 
a shared field, like “Description”. If the “Enable clip and XMP metadata linking” is enabled, you will 
be able to toggle the chain link icon to link the two Description fields so that a change in one 
ripples to the other.

Auto Save Preferences
By default, Premiere Pro’s auto save takes a copy of your project as it is in memory and writes it out 
as a backup file in the location specified in the Project or Production Scratch Disk settings. If you 
would like Auto Save to also save the project for you when it does an Auto Save, enable the setting 

“Auto Save also saves the current project(s)” found in Preferences > Auto Save.

If you need to recover a file from Auto Save, navigate to the scratch disk location for Auto Save and 
locate the project file that matches the name of the project you are looking for. There will be one 
copy of the project with no user name or timestamp in the file name – this will always be the most 
recent Auto Save. 

Older copies of the project will have a timestamp and, if Project Locking is enabled, the user name, 
appended in the format ProjectName-YYYY-MM-DD_HH-MM-SS-UserName�prproj 

XMP metadata linking 
enables toggling of  the 

chain link icon.
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Collaboration Preferences
Project locking is enabled automatically when you work in a Production. You can also turn it on 
even if you are only working in a single project file. Project locking puts a .prlock file next to your 
project with the same name so that other Premiere Pro users won’t be able to modify the file while 
you are editing. Once you close the project, the .prlock file disappears.

You can set a User Name in the Collaboration preferences so that other users can see who is 
working in any project in a Production.

Memory Preferences
The Adobe Video & Audio applications can share system RAM when working on the same media 
or projects, for example when using Dynamic Link between After Effects and Premiere Pro. In 
Preferences > Memory you can set how much system RAM is reserved for other applications. 

A good rule of thumb is to leave roughly 20% of your memory for other applications. Dedicated 
workstations with large amounts of RAM can reserve even less.

Optimize rendering for
You should leave this setting set to “Performance”. If you are working with high-resolution material 
and see a Low Memory Warning alert while working, change the setting to “Memory”.

Playback Preferences
If using a Mercury Transmit device to play back video and audio, you choose that device in 
Preferences > Playback. If you see “Setup…” next to your video device, you can click there to find 
hardware-specific options for use in Premiere Pro.

Use the Offset control if your video and audio are out of sync due to delays in one signal path or the 
other. For example if your audio is coming before your video, add an offset until it aligns. 

If you’d prefer to think in terms of frames, use 1000 divided by your frame rate to find how many 
milliseconds (ms) is equal to one frame.

If you experience lag, failure to play or pause, or other unusual timeline behaviors while using a 
Mercury Transmit device, make sure that the device is selected in Preferences > Playback and is 
not selected in Preferences > Audio Hardware�  
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Chapter 4

Working with 
Dailies
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Dailies is a film industry term used to describe all the footage that was shot on a 
given day� If a shoot lasted 25 days, there would be 25 days’ worth of dailies� The 
term has been around for a long time originating in the film-only days when film 
was shot one day, processed at day’s end, workprinted, then screened so all 
stakeholders could review and discuss the previous day’s shoot� 

While the term dailies is still used today, digital technologies have expanded the definition and 
expectations as to what a dailies deliverable may include. These assets can be found on hard drives 
either locally or in the cloud, managed in folders with the camera originals, production audio, 
proxies, an ALE file, and reports—organized and made available as needed to any of the 
collaborators involved in the production.

Glossary
In this chapter we’ll be using some terms and abbreviations that you may or may not be familiar 
with. Here’s a quick explanation of some of them.

ALE (Avid Log Exchange)
An ALE file is a human readable text file with lots of metadata about each clip. It’s actually a TSV 
(Tab Separated Values) file, which means it can be opened and edited in spreadsheet applications 
like Excel. See example here:

BWF (Broadcast Wave Format)
BWF is a professional audio format based on WAV, with the addition of support for metadata and 
timecode. The file extension is .WAV. 

https://en.wikipedia.org/wiki/Broadcast_Wave_Format

CDL (Color Decision List)
A CDL is a standardized set of four color correction parameters: Offset, Power, Slope and Saturation 
developed by the American Society of Cinematographers. The CDL file format is much simpler than 
the LUT formats, and smaller. 

The CDL format is software-agnostic, which means it’s well suited for multi-software workflows. 
CDL values for each clip can be stored as values in an ALE (Avid Log Exchange) file. 

In Premiere Pro, CDL values will be applied using the ASC CDL effect.  

https://en.wikipedia.org/wiki/ASC_CDL

https://theasc.com/ac_magazine/October2008/PostFocus/page1.html

iXML
iXML is an open XML standard for embedding location sound metadata in Broadcast Wave audio 
files and in video files, including Scene, Take and Notes information. http://www.ixml.info/

Dailies are also sometimes 
referred to as “rushes”.

The ASC CDL effect in 
Premiere Pro is very 

lightweight compared to the 
Lumetri Color effect.

https://en.wikipedia.org/wiki/Broadcast_Wave_Format
https://en.wikipedia.org/wiki/ASC_CDL
https://theasc.com/ac_magazine/October2008/PostFocus/page1.html
http://www.ixml.info/
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Wave Agent by Sound Devices is a good, free tool to edit iXML data. 

https://www.sounddevices.com/product/wave-agent/

LUT (Look-Up Table)
LUTs are used in color grading to transform an input color value into a desired output color value. 
LUTs are commonly used to perform a technical transformation from one color space to another, 
but can also capture a creative color change as well. LUTs are a primary grade; they apply to the 
entire frame. 

 

LUTs come in a variety of formats and complexity. 

https://en.wikipedia.org/wiki/3D_lookup_table

 

Source Clip Effects
In addition to applying effects to track items or clips in a sequence, Premiere Pro can apply effects 
to Source Clips. When you apply an effect to a Source Clip, the effect automatically ripples down to 
all instances of the clip in all sequences.

A clip that has a Source Clip effect applied displays a red line under the FX badge in the sequence. 
In addition, the Effects Control panel displays a new tab called Source that shows the applied 
effects. 

 

Premiere Pro supports 
many different LUT formats.

This clip has an ASC CDL 
effect and a Lumetri Color 

Effect applied as Source 
Clip Effects.

Footage courtesy of 
Michael Burton, Pretty 

Moving Pictures, LLC.

FX Badge with red line.

https://www.sounddevices.com/product/wave-agent/
https://en.wikipedia.org/wiki/3D_lookup_table
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Source Clip Effects are found under the Source tab in both Lumetri Color panel and in the Effect 
Controls panel.

To disable Source Clip Effects, select clips in the Project panel and right click. Choose Disable 
Source Clip Effects.

https://helpx.adobe.com/no/premiere-pro/using/master-clip-effects.html

This clip has an Alexa LUT 
applied as a Source Clip Effect.

Source Clip Effects disabled.

Footage courtesy of Michael 
Burton, Pretty Moving 

Pictures, LLC.

https://helpx.adobe.com/no/premiere-pro/using/master-clip-effects.html
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Dailies Workflow
Before you start a project there are a few things that the whole team needs to agree upon about 
dailies.

How will the dailies be created?
Will your dailies be provided as a service or created locally in the cutting room? 

Typically, dailies are done as a service from either a facility or a freelancer specializing in this type 
of work. One of the biggest changes to dailies ushered in with digital acquisition is the ability to 
provide dailies on set, near the set on location, or even in the cutting room. 

The type of dailies service is up to the production, post supervisor, and budgets allocated. Anyone 
providing dailies is doing so as a service to the requirements of editorial and preferences of the 
editor, assistant editor, post supervisor, etc. Make sure these are understood and agreed upon to 
eliminate any surprises later in post-production. Run a camera test through the entire dailies 
process to identify any unexpected issues.

How will the dailies be delivered? 

Hard Drive
A hard drive is always used as one form of backup on set and can also be used to deliver dailies to 
the cutting room. Hard drives are typically used when the cutting room is within walking or driving 
distance to the shooting location, or when shooting in a location where fast Internet speeds are 
unavailable or cost prohibitive. 

Factors like amount of footage, size of files, etc can make shipping hard drives more cost effective 
than digital Internet transfers. These types of decisions are usually made by the post supervisor. 

Internet Transfer
With the speed of Internet services going up and costs going down, digital transfer is commonplace 

– especially when the cutting room is far from the shooting location. The dailies are done on set, 
then transferred to the cutting room using a variety of accelerated secure services. 

Editorial vs Viewing Dailies
As previously mentioned, the definition of dailies has expanded due to digital formats, the Internet, 
and long-distance based productions and post locations. This document will cover editorial 
dailies which are the assets that will be used by the editing team. 

Other types of dailies deliverables are sometimes referred to as “viewing dailies” because 
stakeholders are not in the editing room and are either on set, in-transit, etc. Those types of 
services usually have a different set of requirements than those used for editorial although some of 
the individual requirements may be the same (such as file naming for example). 

There are several solutions on the market that cater to dailies viewing or review and approval such 
as PIX, CLEAR, and Frame.io. 

Most productions will get 
the dailies delivered as a 

service. If you need to create 
the dailies in editorial, the 

Proxies chapter shows how to 
do it in Premiere Pro.

https://pix.online/
https://www.primefocustechnologies.com/studios
https://frame.io/
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DIT Best Practices
The definition and role of the DIT (Digital Imaging Technician) has evolved over the years. Initially 
the DIT worked with the Director of Photography to ensure image quality and consistency. It has 
come to include what was once referred to as the Data Wrangler and is all now one role. 

When working with both post-production and the Director of Photography, the following is a 
common set of tasks that will be performed:

 ■ Camera image set up, color space, LUT creation, and receiving the camera’s recorded output 
as well as any camera reports.

 ■ Receive the production audio and reports.

 ■ Receive any output from the Script Supervisor if their work is to be included in the dailies 
process. 

 ■ Manage backup and archive of all materials. Minimum requirements are two hard drives 
backup and an LTO (maybe two) stored at different locations. 

Dailies documentation
When working with Editorial, it is best to get their requirements in a written document to ensure 
everyone is on the same page as to what will be delivered. This will include requirements such as:

 ■ Proxy codec to be used in editorial including resolution.

 ■ Deciding how the dailies frame size will relate to the original frame size and how that will 
affect the conform process.

 ■ Pass along a framing chart if available.

 ■ Any frame rate manipulation if needed, such as high-speed recording for slow motion 
playback. Often this will mean receiving a set of dailies in both frame rates.

 ■ Color balanced dailies versus color corrected dailies

 ■ Color balancing is a quick one pass basic color balance including shadows and highlight 
to  be uniform across takes.

 ■ Color correction can be a more involved process with exact color correction, mattes, etc.

 ■ Color workflow—LUTs, ASC CDL, or LUTs + ASC CDL.

 ■ Will this be baked into the dailies and tracked as metadata or are they to be applied in 
editorial?

 ■ Burn-in windows—Premiere Pro can overlay metadata into the clip as needed if not burned in. 
If metadata is to be burned into the camera proxy files, then:

 ■ What metadata? Here are some examples:

 ■ Filename

 ■ Camera Timecode

 ■ Sound timecode (for double system workflows)

 ■ Clip name (such as Scene and Take)

 ■ Decide where each window is to be placed, including size, font, color, backdrop, opacity, 
etc.

 ■ Flash on/off at start and end. If so, how many seconds?

 ■ In double system audio workflows:

 ■ Sync in dailies or sync in editorial?

 ■ If syncing in dailies, all tracks (MIX + ISO) or just MIX?

 ■ Extract BWF/iXML metadata.

 ■ Type of reporting required and in what format.

 ■ Metadata transfer via ALE to editorial.
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When creating dailies, the operator should ensure a consistent method and management of the 
metadata that is available. For original camera files, make sure that the entire original camera 
filename is preserved and passed along as part of the proxy media being created. This includes:

 ■ Use the same filename as the as the source camera files.  
Note: if your camera does not create unique file names, it is important to rename the files 
before creating dailies or starting to work with them. Talk with members of your post 
production team to agree upon a way to rename the files that will be appropriate for the entire 
workflow.  
A common practice is to prefix the name with <shoot date>_<card>. Failing to rename 
identical files means that all software using these files during post production run the risk of 
becoming confused due to multiple clips having the same file names.

 ■ Most professional cameras include a Reel or Tape name as metadata in the clips. Make sure 
this information is also written into the dailies files to ensure a smooth conform.

 ■ Maintain the original source timecode. 
If B cameras are being used that do not have timecode, the files may all start at 00:00:00:00. 
This is OK as long as the filename is unique. Some cameras will reuse file names, so be sure to 
have an agreed upon file naming convention in place with the post-production team before 
the files are transcoded.

 ■ Sync sound as part of dailies.  
As per above, the sync requirements will be defined by editorial on a per production basis. In 
very general terms, faster turnaround productions like television will sync during the dailies 
process while theatrical productions will choose to sync in editorial.  In all cases, the 
production audio metadata must be maintained to ensure anyone downstream can return to 
the original assets if needed. 

Budgets will usually dictate how many services are required by the DIT, combined with system 
capabilities and turnaround time. In some cases, a production may ask for a transcode only service. 
This can mean different things to different people, but at its most basic, the original camera assets 
are converted to a proxy format with no other services provides such as color correction or 
balancing and syncing of audio. 

These scenarios usually assume that the audio recorded in camera is good enough or sync will be 
done by editorial. In these scenarios it is only:

 ■ Preserve original file name in proxy.

 ■ Preserve original timecode in proxy.

 ■ Preserve original frame rate in proxy.

 ■ Define codec type, data rate, and resolution. 

 ■ Single LUT or no LUT applied.

When you see clips with file 
names like AA0922.MXF, with 
no random or unique charac-

ters, there’s a good chance that 
clips from other camera cards 

will have duplicate names.
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Full Dailies with Notes, Color Pass, etc�
As seen in previous sections, the definition of “dailies” can be quite expansive and will be defined 
based on the editorial team’s requirements. The term “Full Dailies” may be mentioned and that too 
will be up to editorial requirements and capabilities of the dailies systems being used. For example, 
the dedicated dailies systems offer various reporting methods, whereas tools like DaVinci Resolve 
do not output reporting but can be used in a transcode process.  In all cases, from all systems, an 
ALE of the relevant metadata can be exported. 

Full Dailies can therefore include color correction, color management, double system audio sync, 
viewing dailies, reporting and delivery of reports to key stakeholders, upload and delivery of both 
viewing and editorial dailies, backup and archive and any other related special requests particular 
to a production. 

Are Dailies Baked with LUT or Nondestructive Grade? 
One such request that will be determined by production is whether any of the color-managed 
processes used in the production pipeline are to be “baked” into the editorial proxies. There are 
pluses and minuses to each method. At a high level:

Baked In
Look of dailies is defined on set and baked in to ensure no changes can occur downstream from 
the initial intent. This ensures the DP’s intent from the get-go. It also eliminates some additional 
processing on the part of the editing system.

Even when the CDL and LUT are baked into the dailies, the metadata describing the CDL and LUT 
should be passed along via ALE so it is kept with the clips and passed along for conform and final 
color grade. 

Nondestructive
In this scenario, the camera originals are transcoded in their original color space, usually a LOG 
format of some kind. When using RAW formats, a color space is chosen to maximize the full 
possibilities of the image but is not color corrected in any way to be pleasing to the eye. A LUT may 
have been defined, or they are using ASC CDL workflows, or a combination of the two. All this is 
metadata only, and not baked into the editorial proxies, but these values are applied and played 
back in Premiere Pro. 

This allows for flexibility in the editorial process to update and change the look and feel of the 
images as needed – instead of sending over new media and relinking, the values can be tweaked 
directly or via an updated ALE that is merged. This also offers the ability to transmit any changes 
done in editorial to others downstream to reflect new intent.
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Using ALE (Avid Log Exchange)
Avid’s ALE format is the de facto metadata standard for feature film and episodic productions, 
providing metadata about each clip. It’s a spreadsheet format with Tab Separated Values (TSV), 
which means it can easily be edited in spreadsheet applications.

Using an ALE file in a dailies workflow makes it much easier to track and modify all the associated 
metadata with each shot. For example, a producer using a spreadsheet app could add comments 
to a set of dailies, and in one quick step, those comments can be added to dozens of clips in 
Premiere Pro. Premiere Pro can also export a new ALE file if necessary to document changes made 
to the metadata within the NLE. 

The structure of an ALE file
The ALE file can include a lot of metadata—even additional custom metadata that is not supported. 
The format is broken into 3 segments: Heading, Column, and Data.

Heading
The header was a result of early systems needs, but for the most part it has been deprecated with 
newer editing systems. 

Name Example Value(s) Description

FIELD_DELIM TABS Type of separator used in the file.

VIDEO_FORMAT NTSC 
PAL 
720 
1080 
Custom

Defines content resolution and used by 
some systems to ensure content 
matches project type. “Custom” 
defined any format 2K or higher.

AUDIO_FORMAT 48kHz Used by some systems to match 
project settings.

FPS 23.976 Overall frame rate of items in the list. 
This can be overridden by values on a 
per clip level in the body of the ALE.

Part of an ALE file, showing 
Heading, Column and Data.
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Column
This section declares the field names of the metadata values to follow in the “Data” section of the 
file. 

ALE can contain a lot of metadata fields, but Premiere Pro will only support a set of defined 
columns. The table on the next page shows all the supported ALE fields and which Premiere Pro 
fields they are mapped to.

Column info emphasized 
with gray.
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ALE Fields Supported in Premiere Pro
This table shows all the supported ALE fields and which Premiere Pro fields they are mapped to.

Column Import Export Example Data
Premiere Pro 

mapping
Description

Alt import name 

recognized

Name Yes Yes 26-1(A) Name Name of clip, usually entered based 

on script notes

Filepath Yes Yes /folder/folder/filename.extension Media File Path Path to file in dailies system

Tape Yes Yes L10264556 Tape Name Name of tape or reel

Start Yes Yes 02:06:04:21 Media Start First frame in SMPTE timecode

End Yes Yes 02:07:10:22 Media End Last frame in SMPTE timecode

Duration Yes Yes 00:01:06:01 Media Duration File duration in SMPTE timecode

Daily Roll Yes Yes A001 Daily Roll Alternative Tape Name

Labroll Yes Yes L10264556 Lab Roll Alternative Tape Name

Camroll Yes Yes A149 Camera Roll Alternative Tape Name

TC 24 No Yes* 02:06:04:21 N/A Ignored on input,  

 * always writes "TEMP TC 24"

Tracks No Yes* VA1A2A3A4 N/A Ignored on input,  

 * always writes "VA1"

Soundroll Yes Yes SR_27 Sound Roll Tape Name but from the sound 

recorder

Sound TC Yes Yes 21:46:38:23 Sound Timecode Alternate SMPTE timecode

Scene Yes Yes 26 Scene Script scene number

Take Yes Yes 1 Shot Script take number

DESCRIPT Yes Yes Car pulls up Description Arbitrary text from script notes

Comments Yes Yes dog Comment Arbitrary text from script notes Comment

Notes Yes Yes helicopter Log Note Arbitrary text from script notes

Circled Yes Yes Y Good Circle take; Premiere will write N if 

not checked

Good Take

ASC_SOP Yes Yes (1.1167 1.1360 1.1553) 

(-0.1140 -0.1745 -0.1226) 

(0.7934 0.6427 0.9789)

ASC_SOP CDL values for Slope, Offset, and 

Power each in RGB

ASC_SAT Yes Yes 1 ASC_SAT CDL value for Saturation

Lut Yes Yes LutName Lut Arbitrary LUT name

Lut1 Yes Yes LutName Lut1 Arbitrary LUT name, usually for 

input transform

Input LUT

Lut2 Yes Yes LutName Lut2 Arbitrary LUT name, usually for 

output transform

Output LUT

ImageFileName Yes Yes A001_C006_0817A6_001.R3D Original Video File Camera Original File

AudioFileName Yes Yes 26-1.WAV Original Audio File Audio Original File

Frame_width Yes No 1920 Video Info Width of video frame (in pixels), 

overriden after media is linked

Frame_height Yes No 1080 Video Info Height of video frame (in pixels), 

overriden after media is linked
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Importing the ALE
Using an ALE requires starting by importing the ALE first. This creates placeholder, offline Source 
clips with all the metadata. 

Linking the media
With all the clips selected, right-click one of them and choose Link Media or click File > Link 
Media. This brings up the Link Media dialog.

Click Locate and navigate to the location of the first file. If you’re not sure which subfolder it’s in, 
you can ask Premiere Pro to find it by clicking the Search button. You typically only need to link 
one file, and the rest will be found automatically.

All the media files are offline, 
so you need to relink the media. 

The first file in the list is the 
one you need to point Premiere 

Pro to. 

The Display Only Exact Name 
Matches checkbox enables a 

clutter free search. 

Turn this off if no matches are 
found and you need to use 

other criteria than the file name 
to locate the media.

Footage courtesy of Michael 
Burton, Pretty Moving Pictures, 

LLC.
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If files have been moved to other folders, or if their file names were changed after the ALE file was 
made, there will be some files that are not found automatically. In those cases, you can use the 
Match File Properties checkboxes at the bottom of the Link Media dialog box to help Premiere Pro 
find the files. 

If you know that you have multiple clips with the same file name in the project, un-check Relink 
Others Automatically.

Depending on your network configuration you may not want to use the Media Browser to locate 
the files. If you want to use Finder (macOS) or Explorer (Windows) to locate the files, uncheck the 
Use Media Browser to Locate Files checkbox. 

Dealing with missing file names
Premiere Pro looks for clip file names in ALE columns with either the name Filepath or the name 
Source File Path. ALE files don’t always have this info in these columns, and Premiere Pro will fail to 
recognize it. If both columns are missing from the ALE, then the file name will not show in the Link 
Media dialogue, and it will be a manual process to link each file. 

For the relinking in Premiere Pro to work, either of these two metadata columns in the ALE file 
must contain just the file name, or point to some kind of original file path, like  
D:\clips\A002C001_160508_R1JC.mov. 

In somecases, the necessary data will be in another column in the ALE file, like Tape Name or UNC. 
You can open the ALE in a text editor or a spreadsheet program, and rename the column header to 
Filepath or Source File Path.

Updating metadata from an ALE file
If the ALE file had missing or corrected metadata, you can ask for an updated ALE, then select all 
the clips in the Project panel, then click Clip > Update Metadata and choose the new ALE to get 
the missing metadata.

This feature makes it possible to have one main source of truth, and correct errors in metadata at 
the same time as adding additional information. There are 3rd-party tools and scripts that can 
merge multiple spreadsheets together into a single document. So, in any cases where there are 
multiple ALE files, it’s possible to merge them together. 

If there’s new metadata in Premiere Pro that needs to be added to the main ALE file, you will need 
to export an ALE file from Premiere Pro, then merge that metadata with the original  file, and use 
Update Metadata to add the merged info into the clips. 

Premiere Pro found the other 
files automatically. 

The file path does not have 
to be a valid path to relink. 

Premiere Pro will just pull the 
name off the end of the file path 

and know to look for that. 

Note that the Update Metadata 
function replaces all the 

metadata in the files. There is 
no merging of information, so 
any metadata you’ve added in 

Premiere Pro will be gone. 
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Display the metadata you need
 You can customize which metadata columns are showing and in what order.

 

You can move the columns around to show them in any order you want. Above, the Scene column 
is being dragged to the left, next to the Frame Rate column.

Note that the settings you’ve done here, like choosing which columns to show and the order of the 
chosen columns in the Project panel, are saved into your Workspace. 

Right-click an existing 
column name and choose 

Metadata Display. 

Un-check the ones you don’t 
want to see and choose the 

ones you do want to see. 

The result of column reorder-
ing. 
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Using Metadata Views
To make sure you can easily restore the metadata view you set up, choose Save as New View 
Preset in the panel menu of the Project panel or bin, and give it a descriptive name. 

This creates a new .pvpreset file in the Project View Presets folder in the user settings folder, which 
means it will be available in all projects—and you can use Sync Settings to make it available on 
other systems. You can also restore and manage the views in the same panel menu.

Save your workspaces with your custom view active, so you don’t lose the metadata view when 
switching workspaces. You can also assign keyboard shortcuts to 10 of your favorite views, which 
lets you switch between views very fast. Choose Manage Saved View Presets in the panel menu in 
the bin and assign the shortcuts.

Now open the Keyboard Shortcuts panel by clicking Edit > Keyboard Shortcuts (Windows), or 
Premiere Pro > Keyboard Shortcuts (macOS) and search for “project view”. Key combinations that 
include numbers work well and are easy to remember. 

Now you can easily restore your favorite views no matter how messy you’ve made your bin.
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Working with Color metadata
As mentioned in the section on DIT Best Practices (page 27), there are 2 different ways of 
handling color in an offline workflow: baking it in or working non-destructively. 

With a baked dailies workflow, the color effects are applied when the dailies are rendered—there are 
no “live” effects inside Premiere Pro applying the color. In this workflow, it’s still important to keep 
track of the metadata so that the colorist knows what the editor and director were seeing and use 
that as a reference for the final color grade. 

Working non-destructively means that the dailies are ungraded, and live effects such as Lumetri (for 
LUTs) or ASC CDL are applied in a particular order to build out the desired “look” for the clips. With 
this workflow comes added flexibility in modifying or adjusting the look of a shot, and using the 
Global FX toggle, the director can instantly see what the original shot looked like (“flat”). This can 
be useful if trying to see if a highlight still has detail, for example, when it looks blown out with the 
overall look applied. 

Baking dailies is the most common workflow today, as it eliminates the need for multiple effects 
applied to each clip during editorial, reducing CPU/GPU load on the systems. However, as GPUs 
and computers continue to grow in power, it’s expected more users will take advantage of what 
the non-destructive workflow can offer.

In either workflow, it’s typical to use a combination of LUTs and CDL values to achieve each scene's 
overall “look”. These are usually stacked in a particular order. For example, with the CDL values 
applied first, then a “Scene LUT” for the particular location, and finally an overall “show LUT” that 
does the adjustment for the editing color space. It’s common to refer to this package of 
transformations as the overall look. 

The order does matter� In cases of a non-destructive workflow, it’s best to run proper tests ahead 
of time to ensure that the overall look in editorial is what the cinematographer intended.

There are two ways to store color metadata for dailies: LUT reference, or CDL values.

LUTs
When working with an ALE file, it may refer to different LUT names, but typically, no LUT files are 
included. A LUT reference in an ALE is just a metadata field, so the Color Metadata is just passed 
through. 

In a Baked Dailies workflow, these names are included for later use by the colorist during conform 
and finishing. Since the color has already been applied, it can be ignored during editorial.  

In a non-destructive workflow, it’s important to locate the LUTs listed in the metadata columns, and 
manually add them to the footage. Depending on the combination of LUTs used, this can be done 
with Source Clip Effects or adjustment layers. Lumetri, applied as a Source Clip Effect, has a menu 
in the Basic portion for a Transform LUT (called Input LUT), and another menu in the Creative 
portion to apply a Scene LUT (called Look). 

For certain cameras, like ARRI or RED, it’s important to test out the LUTs being applied 
automatically, and make sure they are the actual LUTs used by the cinematographer in the correct 
order.
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CDLs
In a nondestructive workflow, having the CDL values listed in 
the ALE file is helpful, as Premiere Pro will automatically apply 
a special, lightweight Source Clip Effect (ASC CDL) to each file 
during ingest. This ASC CDL effect will apply the CDL values 
and modify the color accordingly. 

If the CDL values are not in the ALE file, it’ll be necessary to 
create a preset of the ASC CDL effect and apply this to the 
dailies as part of the color effects to replicate the look. Note 
that the CDL that you apply manually in Premiere Pro values 
won’t automatically fill in the metadata columns—it’ll need to 
be added there as well. 

If you make changes in CDL values, they will be changed when 
you output a new ALE from Premiere Pro. 

In a Baked Dailies workflow, the CDL color correction is already in the file. It may be necessary to 
have the metadata in the files as well, but it’s important to not apply the CDL values twice. 

CDL metadata in the ALE
ALE files can contain color correction info from a CDL or a LUT. CDL metadata is stored in the 
ASC_SOP and ACS_SAT columns. The ASC_SOP column stores Slope, Offset and Power settings for 
each color channel, and the ASC_SAT column stores the Saturation setting.

When one of these columns has data, the clip gets the ASC CDL effect applied as a Source Clip 
Effect.  The CDL effect is very light compared to Lumetri, but if you want to turn it off for all clips 
you can easily do so. Select all clips, right-click on one, and choose Disable Source Clip Effects. 

Note that this does not delete the effect, it’s just turned off. 

If the CDL values come 
in with the ALE file, it’ll 
be necessary to disable 

the Source Clip Effects to 
prevent the values from 

being applied a second time. 

These clips have no LUT 
applied, but there is CDL 

metadata. 

The YouTube playlist “Inside 
Hollywood's Cutting Rooms” 
has a video tutorial on Work-
ing with ALE Workflows in 
Premiere Pro. 

https://www.youtube.com/watch?v=ctcDvGQSuHY
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Chapter 5

Proxy 
Workflows
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Proxy Workflows
In video post-production the term “proxy” refers to a media file that is a copy of a 
source camera file that has been transcoded to be easier to edit with, a smaller file 
size, or both� In the context of Premiere Pro there are two general ways to use 
proxy media files:

1. A traditional offline/online workflow where Premiere Pro never sees the 
source camera files and works with proxies the entire time�

2. Premiere Pro imports the source camera files, creating and managing the 
proxy media�

Read the following two sections and decide which workflow is appropriate for  
your production� 

Traditional Offline/Online Workflow
This method has survived since the very beginning of digital non-linear editing because while 
computer processing speed has increased by orders of magnitude, the size and complexity of 
camera files has matched, if not exceeded, that increase. Picture editors always favor smooth 
playback and timeline performance to craft their art, so most high-end productions will prefer to 
use this tried and true workflow.

The offline/online workflow starts with proxy media (often called dailies) being made before any 
media is imported into Premiere Pro. This can be done on set, by a DIT, or handled by a specialized 
dailies facility. The “offline” media is so-called because it is not the source camera media and is 
only used for the edit process. Later the edit will be conformed against the source media and 
brought “online” for color grading, sound mixing, visual effects, and finishing.

In this workflow Premiere Pro is usually only ever aware of the offline or proxy media. While it is 
possible to relink your project to the source camera files in Premiere Pro, this is typically done in 
dedicated conform or color grading software. If your project is using this workflow, you can stop 
reading here. The rest of this document will detail how to use proxies inside of Premiere Pro.

Proxies Inside Premiere Pro
If your editorial team is starting with the source camera files, using proxies inside Premiere Pro 
enables many of the same benefits of the above offline/online workflow with the added advantage 
of being able to access the source camera files with the click of a button. Premiere Pro imports the 
source camera files, understanding them to be full resolution, then creates and manages its own 
low resolution proxy media.
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It is important to understand that once you have created or attached proxies, each source clip in 
the Project panel will be connected to two files on disk: one for the full resolution and one for the 
proxy. You don’t have to worry about managing the files or changing the scale if you switch 
between using one or the other.

This workflow offers additional flexibility in the creation of proxy media. You can enable proxy 
creation via Ingest Settings so that all media that is imported automatically has proxies created in 
the background using Adobe Media Encoder. 

Alternatively, you could import your media and only create proxies for clips that are difficult to play 
back smoothly on your computer. It’s also possible to attach proxies made by a third party panel or 
MAM system that integrates with Premiere Pro.

Some features of Premiere Pro can affect your ability to use proxies. See "Additional 
Considerations When Using Proxies in Premiere Pro" on page 55.

 

In a standalone single 
project file you can create 

proxy media whenever you 
like. 

If you are working in a 
Production, create your 

proxy media before starting 
to edit with those clips.
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Creating or Attaching Proxies
The primary reason to create and use proxies in Premiere Pro is to improve playback and editing 
performance. Depending on the types of footage and power of your computer, some projects may 
call for creating proxies for all clips while others may only need certain batches of clips to have 
proxies. 

Many modern systems are powerful enough to not need proxies at all. If you’re not sure if you need 
proxies, try editing with some of your source camera footage and see how your computer 
performs. 

The Dropped Frame Indicator can help you determine if you need proxies or not. If your system is 
not able to keep up with playing back your footage or timeline, Premiere Pro will skip or “drop” 
frames to keep the playhead moving in real time. 

Choose Show Dropped Frame Indicator in the wrench menu of the Program Monitor. When the 
indicator is green, no frames have been dropped. If it changes to yellow during playback, some 
frames have been dropped. Hover the pointer over the yellow dot to show how many frames were 
dropped.

If you opt to create your own preset or create proxies outside of Premiere Pro, it is crucial that 
the proxy media audio channelization matches that of the source camera files� Failure to match 
them can lead to workflow-halting issues trying to relink them�

The following three sections describe three methods of creating proxies. Most workflows should 
use the first method.

If the Dropped Frame 
Indicator turns yellow, you 

are dropping frames. 

When you create proxies 
in Premiere Pro using the 

default proxy presets, audio 
channels will automatically 

match the source.
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Creating Proxies Inside Premiere Pro – Simple
Recent versions of Premiere Pro include a simplified proxy creation workflow. Select one or more 
clips, then right-click and choose Proxy > Create Proxies…

Choose Proxy Format
The Format drop-down menu can be set to either QuickTime or H.264.

 • Use QuickTime to create MOV files with presets for ProRes, Cineform, or DNxHR VR.  
These files may be larger than your source media, but are easy for the computer to play and 
edit. Choose one of these presets if you have a good amount of working storage space and are 
mainly concerned about editing performance.  
This is also the best option if you have source camera files with multichannel audio.  

 • Use H�264 to create MP4 files with presets for Low, Medium, and High resolution�  
These files will generally be small but may not play back well on older or underpowered 
computers. Ensure that your system supports hardware accelerated decoding before using 
H.264 proxies.  
The MP4 format only supports Mono, Stereo, and 5.1 audio channelization. If your source 
camera files have a different channelization, use QuickTime. 

Choose Proxy Destination
Every project will have a different preference as to the location where the proxies are created. It 
can be useful to use the second option to keep all your proxy media in one location (like a separate 
drive) to easily facilitate taking just the smaller proxies with you on a portable drive when working 
remotely.

When you click OK to create the proxies, Adobe Media Encoder launches and queues a transcoding 
job for each clip. Once that job is created, your project will mark the source camera clip as having a 
proxy. 

You can continue to work in Premiere Pro and Media Encoder will continue to create the proxies. 
As soon as the proxy file is created in the file path that your project expects, the proxy is 
considered online and Premiere Pro will be able to use it.

Choose QuickTime if your 
source files have multi-

channel audio. The H.264 
option only supports mono, 

stereo and 5.1.
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One job per clip is created 
in Adobe Media Encoder, 

and transcoding starts. 

The Progress panel in 
Premiere Pro shows the 
Proxy creation progress.
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Creating Proxies Inside Premiere Pro – Advanced
Premiere Pro supports a more complex but more powerful method for proxy creation that enables 
control over how the proxies look. Using this method requires some discipline and organization, 
and is only recommended if your needs extend beyond the previous method.

Step 1: Create an Encoding Preset

Use Adobe Media Encoder to create your Encoding Preset. In the Preset Browser click the + button 
and choose “Create Encoding Preset…”  Give the preset a name. It can be helpful to use the term 

“Encoding” to easily identify it later.

a. Choose a Format for your proxies. QuickTime is a common choice that supports a wide array 
of video codecs and audio channelizations.

b.  In the Video tab, start by clicking the Match Source button so the video properties will match 
the source media.

Create an Encoding  
+ Ingest Preset pair for 

each group of clips with a 
different frame rate, frame 
aspect ratio, or audio chan-

nelization.

Start by creating an 
Encoding Preset in Adobe 

Media Encoder. 
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c. Uncheck the box for Width and Height, then change them to your desired proxy size. 
Proxies are commonly made at fractional resolutions like ½ or ¼. Divide your source camera 
width and height by 2 or 4 to calculate your new proxy frame size. 
Example: If you want ¼ resolution proxy files for 4K (4096x2160) media: 
       Width = 4096/4 = 1024 pixels 
        Height = 2160/4 = 540 pixels

d. In the Audio tab make sure the audio channelization matches your source camera files.

e. Click OK to create the Encoding Preset and see it added to the Preset Browser.

Step 2: Create an Ingest Preset
In the Preset Browser of Media Encoder, click the + button and choose “Create Ingest Preset…” Give 
the preset a name. It can be helpful to use the term “Ingest” to easily identify it later.

a.  In the Transfer section, check the box for “Transcode files to Destination”.

b. Set the destination where you want the proxy media to be created. 

⚠ The frame size is specific 
to each preset you make. 
Create a preset for each 

different frame size your 
footage uses.

The Destination setting 
only applies when using 

the Ingest Preset in 
Premiere Pro’s Ingest 

settings.  
If using the Create Proxies 
dialog, the location prefer-

ence in that dialog will 
override the Destination in 

your Ingest Preset.
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c. In the Format drop-down menu, choose the same Format you chose for your Encoding preset.

d.  In the Preset drop-down menu, choose your Encoding Preset from "Step 1: Create an Encoding 
Preset".

e. Click OK to create the Ingest Preset and see it added to the Preset Browser.

f. Right click on your new Ingest Preset in the Preset Browser and choose “Export Presets…”

g.  Save the Ingest Preset file somewhere you can easily find it later.

Step 3: Create Proxies in Premiere Pro Using Your Ingest Preset

a.  Select one or more clips, then right-click and choose Proxy > Create Proxies…

b.  Click “Add Ingest Preset…” and navigate to the Ingest Preset file you saved at the end of "Step 2: 
Create an Ingest Preset".

c. Choose one of the Destination options

d. Click OK

e.  Media Encoder launches and queues up the proxy creation job.

You can also use your Ingest Preset to automatically create proxies when media is imported by 
choosing File > Project Settings > Ingest Settings. Check the box to enable Ingest, then choose 

“Create Proxies” from the drop-down menu and add your Ingest Preset if it isn’t listed in the Preset 
drop-down menu.

Choose the Ingest 
Preset from step 2. 
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Creating Proxies Outside Premiere Pro
While most workflows benefit from creating proxies using Premiere Pro and Media Encoder as 
described above, some advanced users prefer to create proxy media using another application. 
Premiere Pro supports this using the “Attach Proxies” command.

When creating proxies outside Premiere Pro, it is recommended to test your workflow with one or 
two clips from each camera first:

1. Import the test source media files into Premiere Pro

2. Create the test proxy media in the outside application

3. Right click on the test clips in Premiere Pro and choose Proxy > Attach Proxies…

4. Use the Attach button and the browsing interface (similar to Relink) to point to the proxy 
media files

5. If no warning or error dialog appears, confirm in the Project panel List View that the “Proxy” 
column shows the proxy as “Attached”

It is essential when 
using “Attach Proxies” 

that the frame aspect 
ratio, frame rate, audio 

channelization, and field-
ing match the source 

media already imported 
into Premiere Pro.
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Using Proxies in Premiere Pro
When proxies have been created and attached—regardless of which method was used—you can 
switch between proxies and the original media files in three different ways.

Enabling Proxies in Preferences > Media
Open Preferences > Media and check the box called “Enable proxies”. This will tell Premiere Pro to 
use proxy media, if available, in any projects that are opened. If proxy media has not been created 
for a clip, or the proxy media files are missing, Premiere Pro will fall back to using the full 
resolution media.

Enabling Proxies in the Source or Program Monitor
A “Toggle Proxies” button is available in the Source and Program Monitor panels. Click the + 
button in the bottom right of either panel to access the Button Editor. Drag the Toggle Proxies 
button to the panel’s button bar, then click OK. Toggling this button is the equivalent of opening 
the Media Preferences and toggling the checkbox for “Enable Proxies”. When the button is blue 
Premiere Pro will be using proxy media, if available.

Enabling Proxies with a Keyboard Shortcut
The “Toggle Proxies” command is not mapped to a default keyboard shortcut, but can easily be 
assigned to a key in the Keyboard Shortcut Editor.

The Toggle Proxies 
button in the Program 

Monitor is blue here, 
showing that Proxies are 

enabled.
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Proxy Status in the Project Panel
Premiere Pro’s Project panel supports three metadata columns that display information about 
proxy media. To enable them, right click on a column header while in List View and choose 

“Metadata Display…”. Search for “proxy” and enable the fields you want to display. 

Proxy: Displays the current status (Attached or Offline).  
If empty, no proxy has been created or attached

Proxy File Path: The full path to the proxy media file.  
Analogous to File Path field for the full resolution media

Proxy File Name: The file name of the proxy media.  
Analogous to the File Name field for the full resolution media

Search for "Proxy" in 
the Metadata Display 

dialog to show the avail-
able proxy fields.

The Proxy column in the 
Project panel List View 

shows attached proxies.  
Proxy media file name and 

path are also shown here.
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Proxy Info in the Properties Panel
The Properties panel shows information for both the original clip and the attached proxy file. You 
may need to scroll down to see the Proxy information.

Scaling and Transform when Frame Sizes Differ
As the goal of using proxy media is to improve performance, the frame size of the proxy media is 
usually smaller than that of the full resolution media. Imagine a scenario where the full resolution 
media is UHD (3840x2160) while the proxy media was created as HD (1920x1080). 

Premiere Pro will continue to consider the clip as a UHD frame size, even if proxies are toggled on. 
You will not have to adjust any scaling, transform, masking, or effect parameters as you toggle back 
and forth between proxy and full resolution media. The smaller frame of the proxy media is 
automatically stretched to fill the UHD clip size.

The Properties panel 
describes the Proxy 

media below the original 
media.
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Effects and Proxies
Some effects perform best when they have access to the full pixel data and will always use the full 
resolution media if it is available. These effects include:

Warp Stabilizer

Rolling Shutter Repair

Morph Cut

Compound Arithmetic

Rendering Video Previews
When rendering video previews in your timeline, full resolution media is always used if available.

Export with Proxies
Exporting requires using either the full resolution or proxy media. This section describes the 
options when exporting.

Media Export
By default, Premiere Pro will use full resolution media when exporting, even if proxies have been 
enabled in Media Preferences or by using the Toggle Proxies button. This is to avoid 
unintentionally exporting at a lower resolution. 

If your export doesn’t require the full resolution media and you would prefer to export more 
quickly, you can check the “Use Proxies” checkbox in the Export Settings dialog.

Interchange Format Export
Timeline interchange formats like XML, AAF, and EDL will always refer to the full resolution media, 
if available.

These effects use the 
full resolution media if 

available.

The Use Proxies  
checkbox lets you export 

using proxies instead of 
the original media.
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Detach Proxies
To remove proxies you no longer need, you can use the “Detach Proxies” command. Select your 
clips in the Project panel, right click, then choose Proxy > Detach Proxies. The proxy media files 
will remain on disk; this command simply returns the source clip to a proxy-less state.

Working Remotely with Only Proxies
A common technique to facilitate editors working remotely is to organize the project and media 
such that it is easy to take just the proxy media and leave behind the full resolution media. Follow 
these steps:

1. When creating the proxy media, choose a destination separate from the original media. This 
can be a dedicated folder, or for the smoothest relinking use a separate drive or volume on 
your shared storage.

2. Give the editor a copy of the proxy media on an external drive and a copy of the project. 
Match the name of the external drive with the name of the drive or volume containing the 
proxy media. On Windows, make sure the drive is mapped to the same drive letter.

3. On the editor’s remote system open the project. If the proxy drive name matches, Premiere 
Pro should only ask to relink the full resolution media. Choose Cancel in the Relink dialog to 
leave the full resolution offline and continue working with only proxy media. 
 If the drive name and paths of the proxy media do not match, make sure to relink the proxy 
files in the Relink dialog and avoid relinking any of the full resolution files.

4.  The editor can now work with only the proxy media.
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Additional Considerations When Using Proxies in Premiere Pro

Modifying Clips (Audio Channels, Interpret Footage, etc�)
If your workflow relies on modifying the source clips using any of the following commands, do not 
use proxies in Premiere Pro. Doing so will result in unexpected behavior: 

Modify > Audio Channels

Modify > Interpret Footages

Modify > Timecode

Modify > Captions

Merge Clips
Do not use Merge Clips if using proxies inside Premiere Pro� Use the Multicam workflow, even if 
only syncing one video clip to one audio clip.

Source Settings
Some formats like RED have Source Settings that allow you to change parameters from the camera, 
like ISO. You can create proxies from these kinds of formats, but the proxies will always use the 
default settings from the camera metadata. Any changes you make to the Source Settings will not 
be used when creating proxies.

Relinking
Full resolution media and proxy media will both appear in the Link Media dialog, if they are offline. 
Take care when relinking to avoid accidentally pointing your proxy media to the full resolution, or 
vice versa.

Render and Replace
Using the Render and Replace command will create a new source clip in your project. This new 
source clip will not have a proxy attached even if the original source clip did.

Captions
The proxy workflow in Premiere Pro is not designed to work with clips that include embedded 
captions.
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Chapter 6

Working with 
Productions
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Productions
Productions in Premiere Pro provides a new framework for organizing multi-
project workflows and collaboration using shared local storage� Productions 
represents the culmination of our Shared Projects approach to local collaboration�

What is a Production?
A Production is a collection of Premiere Pro project files inside a folder that can be thought of as a 
cohesive unit. While the goal of Productions is to be flexible and not prescribe how editors use 
them, a good starting point is to think about a Production as an evolution of a project file. 

What used to be a single .prproj file is now a Production folder and what used to be a bin inside the  
.prproj file is now a component project inside the Production folder.

Productions and the file system
A Production is a folder on disk that has 
unique behaviors compared to a traditional 
project file. 

Actions performed in the new Production 
panel are reflected in the file system and vice 
versa, forming the backbone of the powerful 
new collaboration possibilities available to 
editors working in a Production.

Left: A standard Premiere 
Pro Project, where all the 

assets, bins and sequences 
live in one large project.

Right: A Premiere Pro 
Production, where multiple 

project files live together.

The File System on the 
disk has the exact same 

structure as the Premiere 
Pro Production.

The .prodset file is the 
settings for the Production. 

⚠  Do not open, move or 
rename this file.
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Comparing Productions and Team Projects
Team Projects is Adobe’s cloud-native collaboration system for Premiere Pro and After Effects. A 
Team Project lives in Creative Cloud and allows teams to collaborate no matter where they are 
located, provided they have an internet connection. 

Alternatively, Productions live on a local or shared storage and do not require an internet 
connection or specific Creative Cloud license to function. A Team Project can be converted to a 
standalone project file and added to a Production.

Benefits of a Production Workflow
While Productions are a natural fit for large, complex projects like those found in film & TV, 
Premiere Pro editors working on projects of any size can benefit from working with Productions.

Break up large projects for speed and organization
In a Production only the clips and sequences that are open are using system memory and 
processing power. By breaking up clips, sequences, and other project items into smaller 
component projects inside a Production any editor can benefit from faster open and save times. 
No more waiting for the entirety of your large project to load before being able to work on the one 
section you need.

Avoid duplicate clips
Before Productions, Premiere Pro required every clip in a sequence to have a corresponding 
Source Clip somewhere in the same project. This meant that when sharing sequences back and 
forth between editors it was common to accumulate duplicate clips. 

In a Production, clips in a sequence can refer back to the Source Clips in the project they originated 
in. Performing edits across projects or moving sequences between projects no longer generates 
duplicate clips.

Easily reuse projects
The project files inside a Production can be treated as reusable components. Instead of importing 
thousands of sound effects into your edit project to audition them, for example, import and 
organize them in a sound effects project that you add to all of your Productions for easy access.

Collaboration
Individual editors can use Productions on their local storage and get all of the above benefits. 
Editorial teams working with Productions on shared storage systems unlock a new workflow 
designed to keep everyone organized and efficient while also preventing conflicts. 

The first editor to open a project in a Production gets a "lock" on it that other editors can see in 
their Production panel. Anyone can open a locked project to play a sequence, export, or copy 
elements out, but no changes can be made unless the editor has the lock.

 

Productions don't need 
an internet connection, 

and work with any Creative 
Cloud license.

https://helpx.adobe.com/team-projects/using/getting-started.html
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The Production Panel Interface 
The Production panel gives you a bird’s eye view of all your projects and shows you who is working 
on what so you and your team can track your progress. 

Here's an overview of the Production Panel and the icons, buttons and other user interface 
elements you will see when working with a Premiere Pro Production.

Green Pen means you can 
edit the project.

Outlined icon means the 
project is closed on your 

system.

Solid icon means the 
project is open on your 

system.

Red lock means someone 
else is editing the project.

Zoom slider adjusts the 
size of the text and icons in 

the panel.

Buttons for New Project, 
New Folder, and Trash.

Search for projects and 
folders in the Production.

Name shows who is  
editing the project.

Scroll bar will reveal more info, and 
show columns like creation date, modifi-

cation date, and project size.
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Project Locking
Projects displayed in the Production panel can be in one of three states:

Open, Read/Write: Projects in this state have a solid icon with a green pen indicating that only you 
are able to edit the project. Other editors may have your project open but they can only view it, not 
make changes. The User Name you entered in Preferences > Collaboration is shown next to this 
project in the Project Locked column. You can move or rename this project in the Production Panel. 

Open, Read Only: Projects in this state have a solid icon and may have a red lock. In either case 
you are not able to modify the project, only view it. If a red lock is present it means another editor 
has the project open Read/Write and their name will appear next to the project. 

Any open Timeline or Project panels from these projects will have a lock icon in the panel tab. You 
cannot move or rename projects in this state. Holding Cmd/Ctrl while double clicking a project will 
open it in Read Only mode. 

Closed: Projects in this state have an outlined icon and may have a red lock. This indicates the 
project is closed on your system and not using any memory or processing power. If a red lock is 
present the name of the editor working in the project appears next to the project. 

You can move or rename closed projects only if they do not have a red lock icon. 

Working in a Read Only project
Although you can't do any editing in a Read Only project, a variety of tasks can still be performed 
without changing the project:

• Load clips and sequences into the Source Monitor

• Set In/Out points and perform edits from the Source Monitor

• Play sequences in the Timeline and Program Monitor

• Export media, XML, AAF, EDL, etc.

• Copy project items into a project that is open Read/Write

Refresh Notifications
While working in a Read Only project, if the user who is editing the project saves new changes 
Premiere Pro will show a notification. The notification is not an error but simply information that 
you are no longer looking at the most current version of the project. When this happens the Project 
panel will show a small yellow alert triangle. ⚠

The Production panel will also italicize the name of the project with changes. 

To see the new changes, use Refresh Project in the panel menu of the Project panel, or File > 
Refresh All Projects. You can assign keyboard shortcuts to both of them of course. The Refresh 
command is also found in the context menu if you right-click on a project in the Production panel.

Lock icon next to sequence 
name indicates no changes 

can be made.

Left: Notification in Project 
panel. Alert triangle means that 

the project has been changed.

Right: Italicized project in 
Production panel.
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Shared Storage Systems
Productions can be saved anywhere you already work with a single project file, however a 
networked shared storage system is required for a team of editors to collaborate in a Production.

Productions in Premiere Pro are flexible and designed to work on a wide range of available storage 
solutions. Because Productions can work on many systems it is not possible for Adobe to validate 
compatibility for specific storage systems. 

Before purchasing or renting a shared storage solution, ask if it has been tested to work with 
Productions in Premiere Pro. In general, here are some best practices for using Productions on 
shared storage: 

• Network Attached Storage (NAS) systems usually offer multiple ways to connect.  
When choosing between options like SMB, AFP, or NFS always prefer connecting with SMB.

• Premiere Pro can handle translating path differences between macOS and Windows. For 
best results on macOS make sure the same volume name is used on all systems. On Windows 
make sure to map the share to a drive letter that is the same on all systems.

• Other types of shared storage systems that use proprietary file systems or client applications 
to connect can work with Productions assuming they provide updates to the file system in a 
way Premiere Pro can understand.  
Check with the storage provider to see if they support Productions.

• Scratch disks (Auto Save, Preview Files, etc) are safe to put on shared storage.  
Productions will set the scratch disks next to the Production folder by default and the location 
can be configured in Production Settings.

• Media Cache Files and Media Cache Database are recommended to stay either in their 
default location on the system boot drive or on a separate fast SSD directly attached to each 
workstation.  
Adobe does not recommend and cannot support configurations where Media Cache files are 
placed on shared storage.

• Like with traditional hard drives, a faster connection will generally yield better performance. 
A 1 Gbps connection speed per workstation is the minimum for working in a Production.  
For greater than HD frame sizes and larger Productions a faster connection like 10 Gbps is 
recommended.  
The more users working simultaneously in a Production, the faster the storage system and 
network need to be.

• While it is safe to store a production in a consumer file syncing service (Dropbox, Google 
Drive, etc), doing so is not recommended to simulate a shared storage system. Collaboration 
with Productions is not designed to work with these services� See the section titled 

“Decentralized Collaboration with Productions” for an example of how to share Productions 
without a shared storage system.

A note on server time
Core parts of collaborating with Productions rely on the timestamps of files as reported by the file 
system. With shared storage systems there is usually a configurable date & time setting.  

Always check that your editing system time matches the storage server’s time� 
 
The easiest way to ensure this is to set the server to communicate with a NTP time server. If this is 
not an option, manually setting the time as close as possible will work. Make a note to check the 
server time every so often to make sure it has not drifted. More than a few minutes drift in either 
direction can lead to unexpected behavior.

The editing system time must 
match the storage server's time.
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Creating a Production
A few settings in Premiere Pro are recommended when working in a Production:

• In Preferences > Media, uncheck the following:

• Write XMP ID to Files on Import

• Write Clip Markers to XMP

• In Preferences > Collaboration

• Make sure Enable Project Locking is checked.

• Enter a User Name that others will see when you open a project.

• Choose Window > Workspaces and uncheck Import Workspaces from Projects. This avoids having 
your workspace change when opening projects used by other editors.

What is XMP?
Adobe’s Extensible Metadata Platform (XMP) is a file labeling technology that lets you embed 
metadata into files themselves during the content creation process. Premiere Pro can use XMP to 
track separate media files that may have similar attributes like video files with the same file name 
from the camera.

Most solo editors are not affected by these settings, but they can negatively impact collaborative 
teams working on a shared storage system. See “Decentralized Collaboration with Productions” for 
an example of a workflow that benefits from turning on these features.

Steps to create a Production 

1. Choose File > New > Production…

2. Give your Production a name. This will also be the name of the folder on disk.

3. Click the blue path text to select a location to save the Production folder. For collaboration, 
make sure to save the Production on your shared storage.

4. Click Create.

5. The Production panel is opened and your first project is created for you.

After creating your Production, choose File > Production Settings to configure the settings for your 
Production. These settings apply to all users who open the Production. See the section on 

“Production Settings” for more information.

Turn XMP ID off when work-
ing from shared media.

If the ID is modified, or 
the clocks are not in sync, 

Premiere Pro may start 
re-generating waveforms etc.

Project Locking settings in 
the Collaboration preferences.

The New Production  
dialog box.

https://www.adobe.com/products/xmp.html
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Opening an Existing Production
Opening a project that is part of a production will also open the production. Editors used to 
opening their project from Finder/Explorer or the Home screen recent list can continue to do so. 

1. From the Home screen or with a standalone project open choose File > Open Production

2. Select a recently used Production from the dropdown menu and click Open, 
or click Browse and navigate to an existing Production folder and choose it.

Opening Productions
Unlike standalone project files, only one Production can be open at a time. Projects that live 
outside a Production can be opened while a Production is open. Premiere Pro’s Home screen will 
show a list of most recently used projects, including projects that are part of a Production. 

Opening a project that is part of a Production (via that list or a double click on disk) will also open 
the Production. 

To import an existing project into your Production, see “Add Project to Production” below.

Building Out a Production
Productions are designed to be flexible to allow for any number of workflows. How you organize 
your projects and folders is completely up to your needs. If you’re not sure where to start, consider 
the example structure in the image in "What is a Production" above. 

What would have been a bin in a single project is now a project inside the Production. 

For collaboration, keeping projects small means you are less likely to have two editors needing to 
both be working in the same project at the same time.

The Open Production  
dialog box.

When an existing production 
is first opened and none of the 

projects are opened, only the 
Production panel will be visible. 

Opening a project will also 
open the rest of the Premiere 

Pro interface.

NOTE: The production folder 
is designed to only contain 

Premiere Pro project files. 

⚠ Do not store media or other 
files in your production folder!
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New project
Click the New Project button or choose New Project from the context menu. Give the project a 
name and click OK. When in a Production, File > New Project will create a new project in the 
Production panel as opposed to a standalone project.

New folder
Click the New Folder button or choose New Folder from the context menu. Give the new folder a 
name and click OK.

Moving and renaming projects and folders
Projects can be moved or renamed if you have them open read/write (green pen icon) or if they 
are closed with no red lock. Folders can be moved or renamed if all of the projects inside are in 
one of these states.

Changing project lock status
A project that is open read/write (green pen icon) can be changed to read only without closing the 
project so that others can then open and modify the project while you keep viewing it. Click the 
green pen button in the Project panel or right-click on the project in the Production panel and 
choose Read-Only Mode.

A project that is open in read only mode (solid icon, no lock or pen) can be changed to read/write 
mode if no other editor has it open in read/write mode. Click the red lock icon in the Project panel 
or right-click on the project in the Production panel and choose Read-Write Mode.

Adding an existing project to a Production
To incorporate existing project files into your Production, use the Add Project To Production 
command. 

Right-click in the Production panel or use the 
Production panel menu to choose Add Project To 
Production and then choose a project on disk. 

Premiere Pro will make a copy of the project 
inside the Production. The process will also 
upgrade the project version if necessary and 
ensure it is not a duplicate. 

While it is possible to add project files to your 
Production via the file system directly, avoid 
doing so unless you are certain the project 
comes from the same version of Premiere Pro 
and is not a duplicate of an existing project in 
your Production.

If you’re not sure, use the Add Project To Production command�

The left icon is the New 
Project button.

Project panel lock icons.

The Add Project To Produc-
tion command upgrades the 

project version if necessary. 
It also ensures the project 

isn't a duplicate.
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Make a Copy of a project
If you need to make an exact copy of an existing project file, right-click on it in the Production 
panel and choose Make a Copy. Doing this from inside the Production panel allows Premiere to 
make sure that the unique ID inside the project file is not duplicated. Avoid making duplicates 
directly in the file system, Finder, or Explorer. 

See "A note on duplicate projects" below.

Using a template project or production
Building out a production that can then be used as a template for future productions is a great way 
to ensure consistency. After you have set up a production to your liking, copy it to a new location, 
making sure the folder name isn’t changed. Open the production and use the Rename Production 
command found in the Production panel menu to give it a new name.

If you have a template project file you like to use instead, make sure that you add it to your new 
productions using the Add Project to Production command found in the Production panel menu.

Using the trash
When a project or folder in the Production panel is no longer needed it can be sent to the trash. 
Select the project(s) or folder(s) and click the trash button. Projects and folders can also be 
dragged to the trash. The trash will not appear in the main Production panel list until a project or 
folder has been sent to the trash.

Emptying the trash
Right-click on the trash in the main Production panel list and choose Reveal in Finder/Explorer. 
From within Finder or Explorer delete any items you are sure you no longer need. 

Remember that deleting items on network storage cannot be undone�

A note on duplicate projects
Every project file has a unique ID inside of it that Premiere Pro uses to keep track of clips as they 
move across projects inside a Production. It is important that no two projects in a Production 
folder have the same ID. Avoid duplicating projects in Finder or Explorer. 

Always use the Add Project To Production command when bringing a project into your Production. 
Use the Make a Copy command if you want an exact copy of an existing project.

If projects with duplicate IDs are found in the Production folder Premiere Pro will show an alert 
event notification in the bottom right corner of the screen. 

Make a copy of a project 
using the Make a Copy 

command.

⚠ Do not make copies 
directly in your file system. 
Do not use Save As or Save 

a Copy into the production 
folder.

⚠ Careful when emptying 
the trash.  

⚠ Avoid duplicating projects 
in Finder or Explorer.  

This will create exact duplicates, 
and you'll have two projects 

with the same ID. 
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If you see an alert about Duplicate IDs
If two projects in the Production share the same ID, functions like Reveal in Project and others can 
be negatively impacted. Premiere Pro displays a warning to let you know that one or more projects 
in the Production folder share the same ID.

Click the red alert icon to open the Events panel where you will get more information about the 
problem—plus a guide for solving the problem.

When Premiere Pro detects duplicate project IDs in the Production folder, a text file is also created 
in the root of the Production folder that lists the duplicate projects so you can easily find and 
remove them. You can use the Reveal Production in Finder/Explorer command in the Production 
panel menu to quickly open the Production folder. 

Look for a text file called Duplicate Projects List.txt. This text file will disappear when there are no 
more duplicates in the Production.

If you need both copies of a duplicated project, move one outside the Production folder and then 
add it back using the Add Project to Production command found in the Production panel menu.

When duplicate Project IDs 
are detected, Premiere Pro 

throws an alert.

Opening the Events panel 
explains how to resolve the 

issue.
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Production Settings
Similar to project settings in a standalone project file, each Production has settings that are applied 
to the entire Production. When collaborating inside a Production every editor will see the same 
shared settings for the Production. Choose File > Production Settings to find the settings as 
described below.

General settings
The renderer setting applies to all systems that are working in the Production. For situations where 
a system isn’t able to match the exact renderer specified in the Production settings Premiere Pro 
will choose the closest available. 

Scratch disk settings
A Production’s scratch disks default to Same as Production which means the folder that contains 
your Production folder will also contain your scratch disk folders. For editorial teams collaborating 
on shared storage it is important that the scratch disk folders be set to a shared location that all 
edit systems will be able to access. 

Media referenced using Motion Graphics Templates or Creative Cloud Libraries will only be 
available to all edit systems if the scratch disk setting is set to a shared location.

Auto Save
If you need to recover a file from Auto Save, navigate to the scratch disk location for Auto Save and 
locate the project file that matches the name of the project you are looking for. There will always 
be one copy of the project with no user name or timestamp in the file name – this will always be 
the most recent Auto Save. 

Older copies of the project will have a timestamp and the user name appended in the format 
ProjectName-YYYY-MM-DD_HH-MM-SS-UserName.prproj

Ingest settings
Ingest settings are disabled for Productions. Proxy files can still be created by selecting clips and 
choosing Proxy > Create Proxies or Attach Proxies from the context menu. See "Frequently Asked 
Questions" on page 76 for more information on ingest settings.

Preview files rendered by one 
editor can be available for all 
editors who use that project.
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Understanding Clips in a Production
Before Productions, if a clip existed in a sequence it would always have a corresponding Source 
Clip in the same project as the sequence. Moving sequences across projects resulted in all the 
dependent clips coming across as well, often meaning projects contained duplicate Source Clips.

Productions in Premiere Pro bring a new model of clip referencing. While it may seem like a small 
technical detail, this new model is arguably the most important part of how productions work. To 
understand this new model of clip referencing imagine a production simplified down to two 
projects: a media project containing clips and a timeline project containing a sequence with those 
clips in it:

In a production, as clips are edited from the media project into the sequence in the timeline project, 
no new Source Clips appear in the timeline project. If the media project has 100 clips and all of 
them are cut into the sequence, the timeline project will still only have 1 item: the sequence. The 
clips in the sequence instead refer back to the original Source Clips in the media project. As 
sequences are moved between projects in a production, no duplicate clips are created in the 
projects!

This new clip referencing model only applies when working inside a production. If two standalone 
projects are open like in the above scenario, you will see the same behavior Premiere has always 
had: a clip in a sequence requires a corresponding Source Clip somewhere in the project.

There is no preference to turn on this referencing model outside of a production nor is there a way 
to turn it off if working inside a production; it is a fundamental feature to working with productions. 
This new clip referencing model also changes the default behavior when dragging items (clips, 
sequences, etc) between projects in a production. Outside of productions this operation would be 
the equivalent of a copy and paste: both projects would end up with copies of the items. In a 
production, the default behavior is a move. The items leave the origin project and land in the 
destination project.

Clips in the Scene 01 project 
exist in the sequence in the Cuts 

project without duplicates.

For workflows requiring 
duplicate clips to be created, 

using the Duplicate command 
or Copy/Paste or holding Cmd/

Ctrl and dragging will create 
duplicate items.
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Reveal in Project
Right-clicking on a clip in a sequence and choosing Reveal in Project will bring forward the 
appropriate project containing the original Source Clip and select the clip in question. If the project 
file is not currently open it will be opened. If the project is opened but the original Source Clip is no 
longer in the project, Premiere will offer to scan any other open projects to attempt to locate the 
clips. 

In the rare case that doesn’t work, see the Reassociate Source Clips command below.

Generate Source Clips for Media
This command in the Edit menu applies to a selection of clips in a timeline. When used, any 
selected clips in the active timeline will lose their links back to the original Source Clips and have 
new Source Clips created for them in the same project as the sequence. 

This is useful, for example, if you receive a project file from a Production containing only a 
sequence and wish to restore it to a standalone state with Source Clips.

Another use for Generate Source Clips is to prepare a sequence for turnovers. Duplicate the 
sequence into an empty project, then select all the clips in the sequence and choose Edit > 
Generate Source Clips for Media. The project is now self contained and ready to send.

Reassociate Source Clips
This command in the Edit menu applies to a selection of clips in a timeline. When run you will be 
asked to select a .prproj file to search for Source Clips matching any of the selected clips and 

“reassociate” them. This can be necessary in some cases where Source Clips that were cut into a 
timeline have been moved from the project they were in at the time of the edit. 

This command, while powerful, is not intended to be a common part of Production workflows but 
rather to help in rare cases when projects have been reorganized or disrupted.

Clip Markers
Premiere Pro’s clip marker paradigm does not change when working in a Production. However, 
because Source Clips can live in projects separate from sequences where they are used there are 
some things to keep in mind:

• If a project with Source Clips and a project with a sequence containing those clips are both 
open in read/write mode then adding a clip level marker to either clip instance will cause the 
marker to appear on the other clip instance.

• If a clip marker is added in a sequence but the project containing the Source Clip is not open in 
read/write mode, the marker will exist only in the sequence. The next time both projects “see” 
each other (meaning they are both open read/write) the marker will appear on the Source Clip 
and vice versa

Clip Name & Label color
Clips cut into a sequence take the same name and label color of the Source Clip. From that point on, 
the name and label color are unique to that instance of the clip. This is useful for workflows where 
editors want to modify the name or label color in their sequence, but not update other sequences 
that use the same clips.

Click the wrench button in the Timeline panel and choose Show Source Clip Name and Label to 
show the name and label color of the original Source Clip. With this preference on, changes made 
to the name or label color will update the original Source Clip.

Nested Sequences
In a production, sequences do not link across projects like clips do. If you have a nested sequence 
inside a container sequence and move or copy the container sequence across projects, a copy of 
the nested sequence travels with the container sequence.

Assign a keyboard shortcut to 
Reveal in Project.
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Source Clip effects
Adding, modifying, or removing Source Clip effects in a Production requires opening the original 
Source Clip project in a read/write state. If you select a clip in a sequence and view the Source tab 
in the Effects Control panel, any Source Clip effects will be displayed but not able to be modified. 

The visual results of Source Clip effects will still always be shown in the Program Monitor. Using the 
Global FX Mute will bypass Source Clip effects in the timeline. 

Right-click on a clip in the timeline and choose Reveal in Project to find the Source Clip and add, 
modify, or remove Source Clip effects.

Multi-Camera Source Sequences
Multi-Camera Source Sequences (multicams) are handled like ordinary Source Clips from the 
perspective of Productions. Like with Source Clip effects, opening a multicam to modify the 
positions of the clips inside requires having the project containing the multicam to be open in a 
read/write state. 

Cmd/Ctrl + double click on a multicam clip will open the project that contains the multicam and 
open it in the Timeline panel for you.

Additional Useful Commands in a Production

Save All
This command saves all open, writeable projects with unsaved changes. It is useful to assign an 
easy to remember keyboard shortcut—or even re-mapping Cmd/Ctrl+S so that every save will save 
all projects.

Close All Projects
This command will close all open projects and is located in the Production panel menu or the File 
menu.

Refresh All Projects
This command will refresh any projects open in a Read Only mode that have updates to be shown.

Reveal in Finder/Explorer
Right-click on any project or folder in the Production panel to show it in Finder or Explorer.

Reveal Production in Finder/Explorer
This command is located in the panel menu of the Production panel and will open the root level of 
the Production folder in Finder or Explorer.

Source Clip effect parameters 
can’t be edited from timeline 

clip instance.
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Migrating an Existing Project to a Production
Traditional Premiere Pro projects that exist inside a single .prproj file can be easily transitioned into 
a Production using the following steps.

If your work uses a single project file
1. Create a new Production. 

A new Untitled project is created and can be used as one of the projects in Step 4.

2. Use the Add Project to Production command to bring the existing standalone project into the 
Production.

3.  Open the added project and with the Project panel selected, choose Edit > Consolidate 
Duplicates.

4. Create a new project for each bin, then move the contents of each bin into a corresponding 
project in the Production. Leave all the projects open while doing this step.

5. When the original project file is empty it can be renamed to be used later or put in the trash.

If your work uses the earlier Shared Projects workflow
While Productions do replace the existing Shared Projects workflow, there are enough differences 
between them that it is recommended to finish any existing work using Shared Projects rather than 
attempt to migrate them into a Production.

If you must move to using Productions, combine all the media and sequences across your various 
projects into a single project file. Then use the Edit > Consolidate Duplicates command and use 
that new single project file to break it apart into a Production using the above steps.

If your work uses Team Projects
1. Open your Team Project.

2. Choose Edit > Team Project > Convert Team Project to Project…

3. Save the project file to your disk.

4. Follow the steps above to break the single project apart into a Production.

Make sure to drag the clips 
across projects to move them. 

Do not Copy and Paste.

Shared Projects are now called 
"Project Shortcuts".
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Decentralized Collaboration with Productions
A common workflow today involves multiple editors and assistants in separate locations editing 
with copies of the same project file linking to identical copies of the same media. Editors share 
project files and import new sequences to stay up to date with each other. 

Team Projects is an excellent fit for many of these situations but isn’t appropriate for all. For those 
cases Productions can be used similarly to the existing single project workflow. In fact, the concept 
is essentially identical but allows for key improvements:

• Rather than sending your entire copy of the project file to another editor you can put your 
sequence into an empty project file, send it, and the receiving editor will use the Add to 
Production command to bring the project file into their copy of the Production

• When receiving new sequences via the above method the clips in the sequence will 
automatically point to the Source Clips in the receiver’s Production

• No duplicate clips will be created via this process

Building a decentralized offline workflow
1. The bulk of media should be ingested by one editor in one Production

2. In Preferences > Media enable “Write XMP ID to files on import”

3. Once initial media is imported and organized in a Production, clone the media and Production 
to the other locations

a.  While Premiere Pro can relink and remember multiple recent paths for media if the paths 
are different in each location, it is best if the media is cloned in such a way that the paths 
are identical on each system

4. Each editor works in their copy of the Production

5. To share sequences or other elements move them into a new project

6. Send that new project file to the other editor

7. The receiving editor uses the Add Project command to bring the project into their Production

Decentralized collaboration 
using project files to share 

sequences.
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Updating or Renaming a Production
Before updating or renaming a Production make sure that all other users have closed Premiere Pro. 
Update or rename is done by a single instance of Premiere Pro.

Updating a Production
When opening a Production from an older version of Premiere Pro the Production may need to be 
converted. 

Clicking Convert will make a copy of the Production folder and not touch the original. The new 
copy will have the new version number appended to the end of the Production folder name. All of 
the project files inside the Production will be converted and the newly converted Production will 
be opened.

Renaming a Production
1. Make sure any other editors in the Production have closed Premiere Pro.

2.  Choose File > Close All Projects�

3.  In the Production panel menu choose Rename Production.

4. Enter a new name and click OK.

Using the Project Manager with a Production
The Project Manager continues to operate on one project file at a time and can be used on any 
project inside a Production. If a project contains one or more sequences but the Source Clips are in 
other projects, the resulting project after using Project Manager will not have new Source Clips 
created. 

Use the Generate Source Clips command in the resulting project file to create new Source Clips.

After Effects & Dynamic Link in Productions
Productions retain the full use of Dynamic Linking to After Effects compositions. Store any After 
Effects project files outside of the production folder; the Production panel will not show .aep files, 
only Premiere Pro projects. 

Importing After Effects projects using Dynamic Link or using the Replace With After Effects 
Composition command from the Timeline panel work as expected in a production.
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Frequently Asked Questions

Is Creative Cloud for Teams required to use Productions?
No. Every user with Premiere Pro can take advantage of Productions. Collaborating with multiple 
editors requires a networked shared storage solution.

Are Productions replacing single project files or Team Projects?
No. While solo editors can use Productions and benefit from some of the features, it is up to each 
editor whether they prefer to work in a single project file, a Production, or a Team Project.

Can I upload my Production to Team Projects?
No. A Team Project can be saved as a standalone project file and then added to a Production, but 
not the other way around.

Has Shared Projects been removed from Premiere Pro?
Productions replace Shared Projects, but the functionality remains in Premiere Pro with the 
concept of a Project Shortcut. With a Project panel active, choose File > New > Project Shortcut. 

Project Shortcuts can be useful for editors working in a single project but still wanting to link to 
commonly used projects. Project Shortcuts can be created inside projects in a Production, though 
most workflows would benefit more from using the Add Project command to bring the project 
inside the Production.

Do I need a server or shared storage to use Productions?
No. Individual editors can use Productions while storing them anywhere they would normally keep 
a single project file. A networked shared storage solution is only required for collaborating with 
other editors in the same Production.

Is there a difference between a standalone project file and a project file created inside a 
Production?
At a basic level, no. Project files created inside a Production have the same .prproj extension and 
are fully complete Premiere Pro project files. They can be moved outside of a Production and 
opened as a standalone project. 

Note in that scenario that if clips in a sequence link to Source Clips in a different project, you will 
not see those Source Clips when the project is opened outside of the Production. Use the Generate 
Source Clips command if you want the project to exist as a standalone project.

Can I add a project saved in an older version of Premiere Pro to my Production?
Yes. Use the Add Project command to add your project file to your Production. During this process 
Premiere Pro will update the project file if necessary.

Do Productions support macOS and Windows systems collaborating inside the same 
Production?
Yes. In the same way that a standalone project file can be opened on either macOS or Windows, 
Productions support both systems at the same time. The first time opening a Production on a new 
platform you may be asked to confirm the scratch disk location. 

Make sure to set it to the same location on the server and Premiere can handle the translation of 
drive mounting between the two operating systems.

If the Renderer chosen in File > Production Settings > General is not available on one of the 
systems, Premiere will choose the next best renderer automatically. For example if a Production is 
created on Windows with the CUDA renderer chosen, when it is opened on macOS, Metal will be 
used automatically.
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Can I work in multiple Productions?
Only one Production can be open at a time, but there is no limit to the number of Productions you 
can create or use. Choose File > Open Production to see a drop down menu of recently opened 
Productions or select recent Productions from the list of recent items on the welcome screen.

What is the �prodset file that lives inside a Production folder?
This file is used by Premiere Pro to store Production settings and other information. Do not move 
or modify this file.

Is there a limit to how many projects I can have in my Production?
No. Productions have been tested with large numbers of projects and performance generally 
scales well depending on factors such as storage bandwidth and number of simultaneous users. 
For better performance working in the Production panel it is advised to keep projects organized in 
folders of a reasonable size and to avoid a monolithic folder containing every project.

Can I use Ingest Settings with a Production?
Ingest settings are disabled in the Production Settings dialog because they are designed to apply to 
a single computer at a time. To use Ingest Settings first close your Production and create a 
standalone project that is saved outside of the Production folder. Set your desired Ingest Settings 
and import your media. 

After all ingest operations have finished, save your project and close it. Open your Production and 
use the Add Project command to bring the project file into your Production. From there you can 
use the ingested clips normally.

Can I save other media or files in my Production folder?
Do not store any other files or media inside your Production folder. While the Production panel will 
only show folders and project files, any other files placed in the Production folder do have to be 
scanned by Premiere Pro and therefore could cause performance issues.

Can I do all my Production organization in Finder or Explorer?
For best results it is recommended to do organizational work inside the Production panel. While it 
is true that operations done on disk (moving files, renaming, etc) are reflected in the Production 
panel, doing those operations inside Premiere avoids some potential pitfalls. 

For example Finder or Explorer may let you rename a project file in an instance where Premiere 
Pro would not due to another editor working in it. Always avoid duplicating project files in Finder 
or Explorer�

Can I take a Production home with me to continue editing and then integrate my changes to the 
Production living on shared storage at work?
Yes. Assuming you have a copy of the media on your laptop or external drive, you should take a 
copy of your whole Production folder with you. To keep things simple, do your home editing in as 
few projects as possible. 

For best results, create a new project that contains only the sequences you are editing at home. 
When you return to work, open the original Production on shared storage and use the Add Project 
command to bring the home project or projects into your original Production. 

See the section "Decentralized Collaboration with Productions" on page 74.
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Chapter 7

Multi-Camera 
Editing
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Multi-Camera Editing
A Multicam is a special kind of sequence that holds synced video and audio clips� 
The Multicam allows you to insert these into your editing sequence as one single 
clip� A Multicam can be very simple, like an interview with just one video clip and 
an audio clip, or more complex, containing multiple camera angles and audio 
channels� 

When editing, the Multi-Camera View in the Program Monitor lets you see every 
camera angle and switch between them� 

 

Multicams are essential to syncing picture and sound for any turnover-based workflow, even if only 
a single camera and an audio recorder is used. Multicams will preserve metadata of the source clip 
when exporting for turnover. For this reason, you should use Multicams to sync even just one video 
angle with one audio clip, instead of using Merge Clips.

Creating Multicams
When creating a Multicam you must choose a 
syncing method. But you’ll also make choices 
that affect the sequence settings, including the 
audio output, of your Multicam. These settings 
will determine how the Multicam behaves 
when you cut it into your editing sequence. 

It is important to get these settings right when 
you create a Multicam, because they cannot be 
changed easily after the fact. 

To start creating a Multicam, select the audio 
and video clips in the bin, right-click, and 
choose Create Multicamera Source Sequence. 
You can also choose Clip > Create Multicamera 
Source Sequence or make a custom keyboard 
shortcut. This will open a dialog box where you 
can tell Premiere Pro exactly how you want it to 
create the Multicam.

The order in which you select the clips in the 
bin will affect the order of the tracks in the 
Multicam. 

The first clip you select will be Camera 1. If 
instead you select an entire bin, alphabetical 
order will be used.

Source files are synced 
into a Multicam, and the 

Multicam is edited into your 
edit sequence.

The official term used in 
the software is a Multicam-
era Source Sequence, but in 

this chapter, we’ll use the 
term Multicam for short.

Multicams require a mini-
mum of one video clip. It’s 
important that you select 

only video and audio files. If 
somethings else, like image 
files or bins, are part of the 

selection, the option will be 
grayed out.
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Choose a Name for the Multicam
You can tell Premiere Pro to name the new Multicam based on the video or audio clip names 
followed by your custom text – or choose Custom to ignore the clip names.

If you choose to use the video or audio clips names, the selection order before choosing Create 
Multi-Camera Source Sequence is important. The Multicam will use the name of the first video or 
audio clip you selected. If the syncing results in more than one Multicam, the same principle 
applies to each of them. Pay attention to the selection order when you create your Multicams.

Choose the Syncing Method
Now you can decide how the audio and video will be synced together. The most common methods 
are timecode and audio waveforms. 

The preferred method is timecode, provided the video and audio clips have matching timecode 
embedded. In professional multicamera shoots, each camera or recording device gets the same 
timecode, either from a timecode generator, or by jam syncing them. Premiere Pro will read the 
timecode and align the files, and this happens almost instantaneously.

Like syncing with timecode, syncing by audio can be done in a batch. The matching will be done by 
comparing waveforms, so all sources must have usable audio. Syncing by audio is a good option if 
the sources don’t have matching timecode. For long recordings it will be slower than timecode 
sync.

It’s also possible to sync based on clip markers or In/Out points that you’ve set manually, but these 
methods require you to create each Multicam individually. After the points are set, this kind of 
syncing is also almost instantaneous.

Syncing by Timecode 
When syncing by timecode you have a few options that are unique to timecode syncing. The Create 
single multicam source sequence option will do exactly that: put all the synced clips in one single 
sequence—even if there are gaps in the timecode where no camera was running. 

Reality TV shows often choose to record with Time of Day timecode, and not all cameras are 
necessarily recording at the same time. If Create single multicam source sequence is not enabled, 
Premiere Pro will create a new Multicam every time it encounters a timecode gap.

Name section 
of the panel.

Timecode section 
of the panel.

To properly sync clips and 
create Multicams the Time-

code option in Preferences > 
Media should be set to Use 

Media Source.
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You can assign a Camera Label or Camera Angle to groups of clips to let Premiere Pro know which 
camera clips are from. These metadata categories are not shown by default in your project window 
and must be enabled in the metadata display panel. Right-click a column header in the Project 
panel or use the panel menu, and choose Metadata Display, then enter camera in the search field, 
and choose the column you need. 

Move the header in the Project panel to place the column further to the left if you want. Even 
though the Camera Angle column has a drop-down menu, you can override it by typing in 
numbers or words.

If no camera angle or camera label is assigned, Premiere Pro does not know which clips come from 
what camera. If a camera has been stopped during a shoot, resulting in multiple clips, these will be 
interpreted as different cameras in your multicam. 

When you add info to Camera Label or Camera Angle and choose it under Track Assignments, 
Premiere Pro will place all clips with matching metadata on the same track. Field audio will be 
placed on the first audio tracks. Premiere Pro only uses Track Assignment when syncing by 
Timecode.

Another option when syncing by timecode is Ignore Hours. It’s common practice to use the hours 
part of timecode to indicate the camera angle. A clip with timecode starting with 01 would be 
camera 1, a clip starting with 02 would be camera 2, and so on. 

01:02:13:11 Camera 1

02:02:04:09 Camera 2

06:02:23:14 Camera 6

 
If Premiere Pro would try to sync these using the whole timecode, it would fail, because there is no 
common timecode. When Ignore Hours is checked, Premiere Pro will read these as 02:13:11, 
02:04:09, and 02:23:14, and will be able to sync them.

Camera Label and  
Camera Angle metadata 

fields can be found by 
searching for camera.

You may want to create a 
new View preset, for quick 

access to these metadata 
columns later. 

Choose Save as New View 
Preset in the Project panel 

menu.

Left: Camera Angle 
drop-down menu.

Right: Bin with Camera 
Label and Camera Angle 

columns populated.

Each video track in a 
Multicam shows as a camera 

angle in Multicamera View, 
so you can think of Track 

Assignment as camera 
assignment. 
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If the timecode from one source is off, open the clip in the Source Monitor and find the sync point. 
Most often this will be a clapper. Click Clip > Modify > Timecode. Choose Current Frame and enter 
the correct timecode that matches the other clips. 

Syncing by Sound Timecode 
In order to use Sound Timecode for syncing, the video clips need to have values in the Sound 
Timecode metadata field. The Sound Timecode value corresponds to the value of timecode in the 
sound roll that matches the first frame of the video clip. 

The most common way to bring this in is via an ALE, but it’s also possible to add this manually. 

Syncing by Audio
If your clips don’t have a common timecode, you can sync by audio waveforms—provided that all 
the clips have decent audio. If you know which track has the best audio, choose it in the Track 
Channel drop-down menu. If the audio is on different tracks on different sources, choose Mix Down.

When you sync by audio, Premiere Pro will create multiple Multicams if it finds groups of clips with 
similar waveforms. This means you can batch sync multiple takes or scenes, which will create 
multiple Multicam clips.

Syncing by In Point, Out Point, or Markers
If you choose to sync using In points, Out points or Markers you must enter these manually for 
every clip you need to sync. You could add markers or In/Out points where a slate is snapped, 
where hands are clapped, or when something easily identifiable happens, like a door slam. 

The benefit of using Markers instead of In points is that the part of the clips before the sync point 
will be available. Out point syncing is useful when an end clapper has been used.

When syncing by Clip Markers or In/out Points, each Multicam must be set up manually, which is of 
course very time-consuming, compared to batch syncing with timecode or audio waveforms

Sound Timecode can 
be found by searching 

for sound.

Choose the channel with 
the best audio.

If you do not name the markers 
(Unnamed Marker 1) will show in 

the drop-down menu.

If the clips have multiple identi-
cal markers, they will show in 

the drop-down menu. 

If one or more clips don’t have 
matching markers, Clip Marker 

sync will not be available. 
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Choosing a Sequence Preset
No matter what syncing method you’ve chosen, the next step is to choose a Sequence preset for 
the Multicam. This sets the video parameters for the multicam sequence, meaning frame size, 
frame rate, fields, pixel aspect ratio and working color space.

It’s recommended that you always choose Automatic� 

When you select Automatic, the video preset is based on the video format of the first video clip you 
selected before you chose Create Multi-Camera Source Sequence. 

The Offset Audio option is used when the audio recording is slightly out of sync with the video. This 
can happen when the camera is far away from the microphone, when there will be a delay in the 
audio that’s recorded on the camera, even though the timecode matches. Some cameras, notably 
some DSLR cameras, also notoriously record audio one or more frames out of sync.

Creating a Processed Clips Bin
The Move source clips to Processed Clips bin choice is useful for seeing what did or didn’t sync up. 
This will create a Processed Clips bin and move all clips that synced successfully to the new folder. 
Any clips that do not match another asset will remain in the original location, and must be synced 
using a different method. 

The Video options in 
the resulting Sequence 

are affected by the 
sequence preset you 

choose.

Video settings in a 
sequence can be changed at 

any time, so you don’t have 
to re-sync your clips if the 

Multicam is created with a 
wrong size or frame rate. 

Just open the Mulitcam in the 
Timeline panel and choose 

Sequence > Sequence Settings 
and make the necessary 

changes.

Choose Automatic for 
Sequence Preset.

To make clips automati-
cally scale up or down to 

the frame size of the 
sequence, set Default Media 

Scaling to Set to Frame Size 
in Preferences > Media.

Offset Audio section 
of the panel.



85Best Practices & Workflow Guide | Multi-camera editing 

Audio Related Settings When Creating a Multicam
Productions have different needs when it comes to audio. If you’re editing a conversation where 
three people were recorded on their respective cameras, you may want audio to follow video, at 
least when you’re doing your rough cut. If it’s a Reality Show, you will probably want to keep all the 
audio tracks, with immediate access to all the microphones. If it’s a performance piece, you will 
want to use audio from just one camera or from a separate audio recorder.

Your Multicam has an audio output—most likely either stereo or multichannel. The audio tracks in 
the Multicam are also routed to different outputs, and the different tracks may or may not be 
muted, and they may or may not be linked to clips in video tracks. All these things are controlled 
by your choices in the Audio Sequence Settings and the Audio Channel Presets.

Multicam audio is more complex than Multicam video. If you experience issues like missing 
waveforms, wrong camera order, wrong panning, too many or too few audio tracks, etc—it’s likely 
because a wrong choice was made in one of the two audio related settings in the Create Multi-
Camera Source Sequence dialog.

A solid understanding of the audio features and handling is the key to effective Multicam 
workflows.

Audio Sequence Settings
These settings determine how the audio tracks in the source sequence are populated, how the 
panning and channel assignments are set, and which tracks are muted. You have three choices: 
Camera 1, All Cameras, and Switch Audio.

A Multicam has multiple sources and can end up having a lot of audio tracks. If your source clips 
have empty audio tracks, or tracks that will not be used in the final mix, disable these in the Clip > 
Modify > Audio Channels dialog (Shift+G) before creating the Multicam.

Audio Sequence 
settings.

Original source has 
four stereo tracks.

Make sure you delete 
empty tracks before 
creating a Multicam. 
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Camera 1
When you choose Camera 1 in Audio Sequence Settings, Premiere Pro mutes audio from all 
cameras other than the first video clip in your selection. The audio from that clip will be panned 
left/right to achieve separate outputs for every source channel. 

If you have audio-only clips among the selected files, these will be used instead, and the audio 
from all the cameras will be muted. This is well-suited for most dailies workflows� 

With this setting, only the video portion of the source sequence is Multicam enabled.

All Cameras
Choose All Cameras in the Audio Sequence Settings drop-down if you want your Multicam to 
include all the audio from your selected clips. 

This will put all audio tracks from all cameras and audio recorders into the Multicam. Audio-only 
clips will be placed first in the track order.

All audio tracks are unmuted—up to 32 channels. If you have more than 32 channels, track 33 and 
above will be muted by default. You can mute and unmute tracks manually, but no more than 32 
tracks can be unmuted. The number of unmuted channels of source audio determines the number 
of active output channels of the sequence.

With this setting, only the video portion of the source sequence is Multicam enabled. 

The editor decides 
to use only one of the 
existing tracks (L-3) as 

a mono track.

Re-opening the clip 
in the Modify Clip > 

Audio Channels dialog 
shows it's now got 

only one mono track.
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Switch Audio
The Switch Audio option will create one adaptive audio track per camera, so that audio and video 
can be switched together. The number of outputs will be determined by the source clip that has the 
most audio tracks. 

Audio-only clips will be placed last in the track order, and they will be linked to empty video tracks. 
One empty camera/track will be created for every audio only clip.

With this setting, both the video and the audio portion of the source sequence is Multicam enabled. 
Enable Multi-Camera Audio Follows Video in the editing sequence or in the Multi-Camera Monitor 
for this to work.

Audio Channels Preset
The Audio Channels preset determines how the audio is grouped and mapped within the Multicam, 
which again affects the type and number of audio tracks that are dropped when the source 
sequence is nested into the editing sequence.

 ◆ Automatic reads the audio type of the first clip and uses this mapping.  
This may not be what you want.

 ◆ Mono maps to as many mono channels as there are output channels in the Multicam.

 ◆ The other choices map to Stereo, 5.1 or Adaptive tracks based on the number of output 
channels in the Multicam.

The preset you choose must have as many, or more, tracks than the source clips to avoid tracks 
being mixed together.

In most cases for scripted workflows, the audio clips will be mono, and Mono should be 
selected here� This will ensure that the Multicam is set up properly to pass through all the 
channels from the sound roll� 

Selecting Mono will create an equal number of mono tracks to the sound roll files, and will create a 
Multichannel sequence with an equal number of output channels. The tracks will be routed 1:1 
with the output, so that Track 1 will go out Channel 1, and so on. In other words, this will route 
those channels out directly, so that the multicam has access to all the audio channels when cut in. 

For most workflows, the following procedure will yield a good result:

 ◆ Modify Audio for all clips to mono before creating the Multicam

 ◆ Use mono for Audio Channel Preset in the Multicam creation dialog

Custom presets 
you’ve made in the 

Modify > Audio Chan-
nels panel will also 

show in the list.

The mix track type cannot 
be changed later. Avoid 

choosing Stereo for most 
workflows. 

Choosing Mono or 
Automatic will make a 

Multichannel mix track, 
where you can change 
the number of tracks if 

necessary. 
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Setting Camera Names
When creating a Multicam, you can choose between displaying camera numbers, clip names or 
track names from the Multicam. These labels appear in the Multi-camera View and in the monitor 
overlays.

Enumerate Cameras.

Footage courtesy of 
Jarle Leirpoll.

Use Clip Names.

Use Track Names. 
(track names have been 

changed manually).

Result After Syncing
After clicking OK you will get one or more Multicams depending on timecode breaks. If no camera 
or audio recorder was running at a certain point in time, a new sequence will be made for the later 
clips—unless you’re syncing with timecode, and Create single multicam source sequence is 
selected.
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Editing With Multicams
To ensure a good experience when cutting Multicams in Premiere Pro, it’s a good idea to create 
your edit sequence manually, and to check some settings in the Program Monitor, in preferences, 
and in the edit sequence.

When using Multicams with multichannel audio it’s recommended that you create a standard 
editing sequence manually, and not based on the Multicam. If you use the New Sequence from Clip 
feature in a bin, or drag the Multicam to the New Item icon, you will get an edit sequence with 
audio configured ways you most likely don’t want, like all clips being panned to the left.

When you put the Multi-Camera Source Sequence into your editing sequence, make sure the 
Nest-or-Not button (Insert and Overwrite Sequences as nests or individual clips) is highlighted in 
blue to enable nesting, which is required for Multi-camera cutting. 

Create your edit 
sequence manu-

ally to avoid audio 
problems.

Use the keyboard 
shortcut Ctrl/Cmd+N 

to create a new 
sequence.

Set your sequence's 
Mix format in the 

Tracks tab to match 
your audio monitor-

ing environment.

Make sure that the 
Nest-or-Not  button 

is blue.
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If your Multicam has more audio outputs than the number of tracks in your edit sequence, a small + 
sign will appear when you select the Multicam in a bin, telling you that Premiere Pro will add the 
necessary tracks when you add the Multicam to the edit sequence. You can also click the + icon to 
add the tracks before you do the edit.

You can read more on audio related Multicam settings in the section "Advanced Multi-camera 
Workflows" on page 92. 

Using the Multicam Monitor
The Program Monitor can show Multi-camera View, where you can preview all cameras and cut 
between them. You can also choose what to show on a monitor through Transmit, improve 
playback performance, and tell Premiere Pro to switch audio when you switch video. 

To enable and disable the Multi-camera View, click the Toggle Multi-Camera View button in the 
Program Monitor, or use the keyboard shortcut Shift+0. You can also choose Multi-Camera from 
the settings menu in the Program Monitor. 

Notice the + sign in 
the Source Patching 

area.

To add the Toggle Multi-
Camera View button to 

your Program Monitor 
button row, use the Button 

Editor. 

Click the + sign in the 
lower right corner of the 

Program Monitor and drag 
the button to where you 

want it.

Footage courtesy of 
Michael Burton, Pretty 

Moving Pictures, LLC.

Multicamera related 
settings in Program 

Monitor Setting 
menu.
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You can choose Multi-Camera Audio Follows Video here. To make audio switch with video you also 
need to enable Switch Audio in the Create Multi-Camera Source Sequence dialog. This is the only 
option where the audio clips are multicam-enabled, therefore the Multi-Camera Audio Follows 
Video option only work as expected for Multicams created with this setting. 

Switching Cameras
Hit Play to start cutting between cameras by clicking the camera previews in the Multi-camera 
View, or by using keyboard shortcuts. The default keyboard shortcuts for cutting to camera 1-9 is 
numbers 1-9 on the main keyboard, not on the numeric keypad.

If you cut to the wrong camera, just stop, go back to where you need another camera to show, and 
click the preview image of the camera you need.

If you’re not in Multi-Camera View, you can also change camera while parked by clicking Clip > 
Multi-Camera and choosing the correct camera. You’ll find the same choices in the right-click 
menu.

Flattening Multicams
When you’re done editing a Multicam, you can choose to flatten it, replacing the Multicam clips 
with just the active angle. It’s a good idea to duplicate the sequence before you do this, in case you 
want to go back to the Multi-Camera editing mode later. 

To flatten Multicam clips, select them and choose Multi-Camera > Flatten in the right-click menu—
or create a custom keyboard shortcut. For simplicity you can select all clips in your sequence, even 
if they aren’t all Multicams, and still use Multi-Camera > Flatten to flatten just the Multicams.

When exporting to AAF, Premiere Pro will automatically flatten any Multicams.

Multi-Camera Audio Follows 
Video and Multi-Camera Selec-

tion Top Down can also be found 
in the panel menu of the edit 

sequence.

You can cut Multi-Camera at 
any playback speed you want. 

So if you encounter a tricky 
edit, slow down the playback. 

Need to get the edit done 
before dinner? Play at double 

speed. 
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Advanced Multi-camera Workflows
Sometimes, Multicam edits will be more complex than what you’ve seen in the previous sections in 
this chapter. You may have a lot of cameras in a Multicam, and even multiple Multicams in your edit 
sequence—or you may have specific needs for the audio. This section offers a thorough 
walkthrough of the more advanced aspects of Multicam editing.  

Multi-Camera Settings in the Program Monitor 
We covered Multi-Camera Audio Follows Video in the section on Editing with Multicams. When this 
is enabled, this will switch audio and video together—but only for Multicams created with the 
Switch Audio choice under Audio Sequence Settings. This setting is mirrored in the edit sequence 
panel menu.

If you have an external monitor showing the output preview, you don’t need to see it in the 
Program Monitor. Deselect Show Multi-Camera Preview Monitor to only show the camera angles in 
the Program Monitor, possibly giving you larger previews.  

Choose Auto-Adjust Multi-Camera Playback Quality in the Program Monitor settings menu to 
automatically use fractional playback resolutions if the system struggles to play back all sources.

Enable Transmit Multi-Camera View in the Program Monitor settings menu to show all the cameras 
plus the output preview on an external monitor via Transmit. 

Multi-Camera 
related choices in 

the Program Monitor 
settings menu. 
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You can turn Overlays on and off by choosing Overlays in the Program Monitor settings menu. To 
choose what kind of metadata to show in overlays, choose Overlays Settings > Settings in the same 
menu – or select a preset. 

When you have done your choices, you can click the Save Preset button in the top right corner of 
the panel to save the settings as a preset for quick and easy access later.

In the same panel you’ll find a choice to Enable Overlays for Transmit. Switch this on to show the 
same overlays on an external monitor through Transmit.

You can reach the same settings from the Source Monitor settings menu.

The Overlay 
Settings panel has a 

section for Multi-
Camera Sources, and 
a choice for overlays 

via Transmit.

External monitor 
without overlays.

Footage courtesy of 
Jarle Leirpoll.

External monitor with 
overlays for Transmit 

activated.

Here, sequence time-
code is also shown in the 

output preview.

Footage courtesy of 
Jarle Leirpoll.



94Best Practices & Workflow Guide | Multi-camera editing 

Using Track Targeting to control Multicam Visibility
When you have multiple Multicams in an edit sequence, track targeting affects which Multicam 
you see in Multi-Camera View in the Program Monitor. By default, the Multi-Camera View always 
shows the Multicam on the lowest targeted track.

   

Enabling Multi-Camera Selection Top-Down in the Program Monitor settings menu reverses the 
default setting, making the Multicam on the top-most targeted track show in Multi-Camera View. 
That means you can target V2 while making your edits without having to un-target V1. This can be 
helpful when you have many cameras spread between multiple Multicams. This setting is also 
found in the panel menu of the edit sequence.

Organizing Camera Angles Using Edit 
Cameras
You can organize and select the angles to view in 
the Source Monitor and the Program Monitor 
Multi-Camera View via the Edit Cameras choice in 
the settings menu in either monitor. 

The settings are unique to each monitor, so you 
can have different settings in each monitor.

In the Edit Cameras dialog box, the clips are listed 
in the order that they were arranged in the 
sequence tracks. You can drag-and-drop the clips 
to change the order. 

You can also enable or disable camera angles by 
selecting or deselecting them. 

The lowest targeted 
track is V1, and 

the Multicam on V1 
(green) will show in 

the Multi-Camera 
View.

The lowest targeted 
track is V2, and 

the Multicam on V2 
(mango colored) will 

show in the Multi-
Camera View.

The Edit Cameras 
dialog lets you rear-

range and enable/
disable cameras.

You can also organize 
them in Pages. 

Footage courtesy of 
Michael Burton, Pretty 

Moving Pictures, LLC.
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A disabled camera angle in the Edit Cameras dialog box is still using system resources. To improve 
performance of large Multicam setups, open the Multicam sequence in the timeline and mute 
video tracks to avoid using system resources for those camera angles.

When you have many camera angles, it makes sense to organize cameras across multiple pages. 
You can set the number of camera sources to show per page, and navigate between pages as 
needed. When you change the order of cameras, the pages reorder accordingly. 

In the Program Monitor, you can browse through the Multicam pages using the controls in the 
lower left of the panel—or by using custom keyboard shortcuts.

The Pages controls 
in Multi-Camera View 

Showing Page 1 of 3.

Footage courtesy of 
Michael Burton, Pretty 

Moving Pictures, LLC.

Multi-camera View 
showing Camera 

name and Source 
timecode, plus 

Sequence timecode.

Footage courtesy of 
Michael Burton, Pretty 

Moving Pictures, LLC.
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Keyboard Shortcuts for Multi-Camera Editing

Premiere Pro has many commands for Multicam editing. Some of them are mapped by default, 
while others must be created by you.  The online Premiere Pro User Guide has an overview of 
useful keyboard shortcuts for Multi-camera editing. 

You will find more mappable commands if you search for multi-cam (remember to type the 
hyphen) in the Keyboard Shortcuts editor.

Viewing Multicams in the Source Monitor
You can view Multicams in the Source Monitor if you want to select which camera angle and audio 
tracks to use from it before inserting it in the timeline. You can also add markers and In and Out 
points. Double-click the Multicam in a bin or use the keyboard shortcut Shift+O to open it in the 
Source Monitor. 

You can also select the Multicam in a timeline and use Match Frame (F) to achieve this.

In the View menu, under Display Mode, you can choose between Multi-Camera view and Composite 
Video. 

Search field in 
Keyboard Shortcuts 

dialog.

https://helpx.adobe.com/premiere-pro/user-guide.html/premiere-pro/using/keyboard-shortcuts.ug.html
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Both in Composite Video and in Multi-Camera view, you can select different camera angles by 
choosing them in the Multi-Camera submenu in the right-click menu—or by using the keyboard 
shortcuts (number keys 1-9). In Multi-Camera view you can also click the camera angles directly. 

When you use the Insert or Overwrite buttons in the Source Monitor, or the Comma and Period 
keys, and the Insert and overwrite sequences as nests or individual clips button in the timeline is 
enabled, the chosen camera in the Source Monitor is used, and the source patching in the timeline 
controls which video track it lands on.  

When the Insert and overwrite sequences as nests or individual clips button in the timeline is 
disabled, it doesn’t matter which camera angle you’ve chosen in the Source Monitor. You are 
bypassing the Multi-Camera features, and Premiere Pro sees the Multicam as a normal sequence. 
That means only the Source patching in the timeline affects what camera angles and audio tracks 
you’re inserting. 

When inserting Multicams from the Source Monitor you may want to enable Targets Follow Inserts 
and Overwrites. 

This makes the Track Targeting buttons 
match the Source Patching buttons 
immediately after you’ve done an 
insert or overwrite edit—making the 
newly edited tracks ready for adding 
transitions etc. 

Right-click on one of the Track 
Targeting buttons in the timeline to 
enable it.

Multi-Camera 
section of the right-

click menu.

Right-click menu 
showing Targets 

Follow Inserts and 
Overwrites.

Source Monitor in 
Multi-Camera View 

and Composite view.

Footage courtesy of 
Jarle Leirpoll.

The Source Monitor has 
the same Overlay Settings 

as the Program Monitor. 
Changing them in either 
monitor will affect over-

lays in both monitors. 
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Opening a Multicam in Timeline Mode
Since a Multicam is in fact a sequence, you can open it in a timeline to move clips, name tracks, 
change audio routing, add clips etc. 

Please note that if you change anything inside of a Multicam, it affects all the instances where 
that Multicam has been edited into a sequence—so it should only be done when you need to 
fix problems or mistakes�

To open a Multicam in Timeline Mode, right-click it in a bin and choose Open in Timeline, or 
double-click it while holding Ctrl on Windows or Cmd on macOS. You can also assign a custom 
keyboard shortcut.

When you sync the clips using timecode, you have the option to add Camera Angle or Camera 
Label metadata. When you do this, all clips from the same camera should end up in the same track. 

When you sync using markers or audio, Premiere Pro doesn’t know that some clips come from the 
same camera, and puts them on different tracks. You must move them to the same track manually 
by dragging or using keyboard shortcuts.  

Every track in the Multicam ends up being a camera angle in the Multi-Camera View. Empty tracks 
result in more angles, which again causes smaller previews. It’s a good idea to delete any empty 
tracks in the sequence after re-ordering the clips.

If any clips are out of sync for some reason, you can slide them and nudge them around to 
manually get them into sync. Choose Show Audio Time Units in the panel menu of the sequence to 
zoom in all the way to sample level for exact waveform matching. 

When the Multicam is opened in a timeline you can also open the Audio Track Mixer to see the 
panning and routing. You can change the routing and panning if necessary, and the number of 
channels in the multichannel mix track. If you made the right choices when you created the 
Multicam, that will not be necessary.

Result from syncing with 
timecode and camera 

metadata.

Note the Mix Track is a Multi-
channel mix, with matching 

number of channels.

Some audio tracks may be 
muted depending on what 

audio settings were used to 
create the Multicam

Result from syncing same 
clips with audio

Move clips to other tracks 
by Alt/Option-clicking 

them and then pressing 
Up Arrow or Down Arrow 

while still holding Alt/
Option. You can lock other 

tracks first, to avoid over-
writing existing angles. 

Correcting sync inside a 
Multicam will update the 

sync in all sequences where 
that Multicam is used.



99Best Practices & Workflow Guide | Multi-camera editing 

Changing the Audio Output of the Multicam
You can tell Premiere Pro to interpret the audio output from a Multicam differently when it’s put in 
an edit sequence. You do this in the same way you would modify the audio channels from a video 
or audio clip. This is especially useful when the Multicam has lots of tracks, and you only need 
audio from a few of them. 

Keeping the number of tracks down will keep the edit sequence tidier, and if you use this method, 
you don’t have to deselect lots of tracks with Source Patching while editing.

Select one or more Multicams in a bin and choose Clip > Modify > Audio Channels or use the 
keyboard shortcut Shift+G, and change the number of audio channels to 1, 2 or 4 etc. and decide 
what source channels to include.

You can Modify 
Audio Channels on 
multiple Multicams 

at the same time. 

Multicam clip 
modified to use 

only tracks 1 and 2.

The Apply changes to all 
matching clips in sequence 

option will affect all the 
instances of the Multicam 

in all sequences. 

Make sure you really want 
this before you click OK. If 
you’re not sure, disable it.

Audio Track Mixer 
showing panning, 

routing and mix 
track.

Notice that every 
track is mapped to a 

separate output.

Closer look at 
the first four 
tracks.
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Preserving Waveforms in Multicam Clips
Premiere Pro only shows waveforms against audio files that exist on disk. This means that if your 
Multicam is configured such that audio channels are being combined in any way, the resulting mix 
does not exist on disk and therefore will not have a waveform displayed, even though the audio 
will play correctly.

A typical example of this is having 4-8 mono mics, and using a Stereo mix track. The mono tracks 
are mixed together into a stereo track, and a waveform is not displayed. The correct way to do this 
is with mono tracks and a Multichannel mix track in the Multicam sequence. You can check this by 
opening the Multicam in a timeline.

The Multicam must pass across all the individual channels contained into the editing sequence. 
This means using a Multichannel Mix audio track, and panning each audio track to a discrete 
output. 

See https://premierepro.net/multicam for tips on how to create a Multichannel “Direct Out” 
Sequence Preset that will always show audio waveforms.

Selective Audio Editing with Multicam
Audio files delivered in dailies may include multiple audio channels. You may get a stereo mix on 
two tracks and the ISO mics on separate tracks. To keep the timeline tidy, you may want to keep 
the number of tracks to a minimum and work with the main mix most of the time, but you need 
access to the ISO mics. You can match-frame back to the ISO tracks.

You can set the multicam to show only audio track 1, or maybe track 1 and 2, and still have easy 
access to the other tracks when you need them. This also prevents the auto-addition of audio 
tracks that may otherwise occur. 

If the audio track you need is not currently available in the edit timeline, you can still access and 
use all the source channels: 

The easiest way to access these extra audio channels is via the right-click menu in the timeline. 
Right-click on a clip in the timeline, choose Audio Channels, and switch to any other channel. You 
can also use the keyboard shortcut Shift+G. If you need to add additional channels to the edit, use 
option-drag to drag the existing clip up/down to duplicate it, and then use Audio Channels to 
change the channel on the duplicate. 

If you prefer to load all the audio channels into the Source monitor, to have more precise insert/
overwrite capability, there is a method of doing this. With the playhead parked over the Multicam 
where you want the new audio clip, press Alt/Option and click on the audio waveform to select it, 
then hold Cmd/Ctrl and double-click it. This takes you inside the Multicam.

Select the audio clip you want and hit F to do a Match Frame. Set In and Out points in the Source 
Monitor, go back to edit sequence. Here you can patch the audio to a suitable track, and press 
Overwrite (Period key). The new audio clip will be in sync.

If you’re unsure what 
audio track you need 
when you’ve done the 
match frame, click the 
Drag Audio Only button 
in the Source Monitor to 
see the waveforms. 

The waveforms will often 
give you an indication of 
what kind of audio the 
tracks have. 

You can watch a video 
tutorial by Adobe’s Karl 

Soule about Selective 
Audio Editing with Multi-
cam here: https://youtu.

be/FW2yLx7-r7w.

If the source audio track 
you need is not available 

you can re-modify the 
source clip by press-

ing Shift+G from the 
Source Monitor, and then 

increase the number of 
tracks and add the track 

you want. 

You can also use 
the Drag Audio Only 

button in the Source 
Monitor to drag 

the audio into the 
timeline.

https://premierepro.net/multicam/
https://youtu.be/FW2yLx7-r7w
https://youtu.be/FW2yLx7-r7w
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If you’re still not sure, play the multicam and solo individual tracks in the Audio Meters by clicking 
the Solo buttons until you hear the audio you need. This tells you what source patching you need 
to do before adding the clip to your edit sequence, but you must find your in-point again.

Proxies in a Multicam Workflow
If you are cutting multiple high-res sources in a Multicam and your system struggles, use the proxy 
workflow so you can cut without lagging. Make sure you use QuickTime proxies, since H.264 
proxies do not support multichannel audio—and your proxies must match the audio channels of 
the original files.

Use the Toggle Proxies button in the Program Monitor to easily switch between proxies and the 
originals. See the chapter "Proxy Workflows" on page 39.

Left: Audio Meters show-
ing all source tracks.

Right: Two tracks have 
been soloed.

QuickTime ProRes 
proxies support all frame 

sizes and up to 32 audio 
channels.
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Chapter 8

Dynamic Link 
with After 
Effects
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What is Dynamic Link?
Dynamic Link is an Adobe technology that allows for unrendered frames to pass between After 
Effects and Premiere Pro. Rather than having to render frames of your After Effects composition to 
disk and then import them into Premiere Pro, you can instead view the frames After Effects creates 
directly in your Premiere Pro sequence without rendering. This can save hours of rendering passes, 
simplify management of render files, and save storage space by eliminating multiple iterative 
exports.

There are situations where it may make sense to use the traditional method of exporting from After 
Effects and importing into Premiere Pro. A rendered video file will always play more smoothly in 
Premiere Pro than an After Effects Dynamic Link. If your After Effects composition relies on 
plug-ins that are not installed on other Premiere Pro systems, you will be better served exporting 
the video from After Effects.

Dynamic Link Workflow between Premiere Pro and After Effects
There are many ways to establish a Dynamic Link between After Effects and Premiere Pro. In 
Premiere Pro, you can click File > Adobe Dynamic Link > New After Effects Composition. Or you 
can import an existing After Effects Composition with File > Adobe Dynamic Link > Import After 
Effects Composition, or by dragging a composition from the Project panel in After Effects to the 
Project panel in Premiere Pro.

The most common method is to select one or more clips in the Premiere Pro timeline, right-click 
and choose Replace With After Effects Composition. The result is that all the clips you selected are 
sent to After Effects and are replaced with one single dynamically linked clip. The composition 
opens automatically in After Effects.

If you already have an open After Effects project, the clips and a new composition (a.k.a. comp) will 
be added to that project. If you did not have an open After Effects project, you will be prompted to 
save a new one. 

You can keep your Dynamic Link comps in as many or as few After Effects projects as you like. 
Many editors keep them all in a single project for easier organization.   

You’ll find Replace With After 
Effects Composition in the 

right-click menu.

Source footage courtesy of 
Jarle Leirpoll.

The clips that were sent 
to After Effects via Dynamic 

Link have been replaced 
by a Linked Comp in the 

Premiere Pro Timeline.  

Note: When using Replace 
With After Effect Composition, 

audio in the Premiere  Pro 
timeline is not part of the 

new composition item.



105Best Practices & Workflow Guide | Dynamic Link with After Effects

Render & Replace 
Playing complex After Effects comps in a Premiere Pro timeline can be very taxing to the system, 
and the result is dropped frames and poor performance. In addition, every Dynamic Link between 
Premiere Pro and After Effects uses some RAM.

To improve performance, replace the Dynamic Link comps in the timeline with rendered video files. 
Right-click the clips, choose Render and Replace, then choose a high-quality option like ProRes 422 
HQ. ProRes 4444 is a good option if you need an alpha channel.

 

Render all Dynamic Link Comps 

If you have many Dynamic Link comps in your timeline, you can render them all at once. Select all 
the comps in your sequence by using Find in Timeline (Ctrl+F/Cmd+F). Search for “DLYM” and 
select Find All. 

This will select all the Dynamic Link comps in the timeline, since "DLYM" is what you'll find in the 
Video Codec metadata for Dynamic Link comps. Comps that have already been rendered will not 
be selected.

Next, right-click on one of the selected clips and choose Render and Replace (or use a custom 
Keyboard Shortcut) to render all of them at once—during lunch, while you’re on the phone, or 
overnight. 

Choose a high-quality 
codec for your render files. 

Render & Replace will 
replace the linked After 

Effects comp with a 
rendered video file.

Source footage courtesy of 
Jarle Leirpoll.
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Restore Unrendered
Render & Replace is not a one-way street. If you need to make changes after using Render & 
Replace, right-click and choose Restore Unrendered to get the Dynamic Link comp back.

Create your own keyboard shortcuts for Render and Replace and Restore Unrendered to speed up 
the process.

After doing a Render and 
Replace, you can still get 
back to the original clips 
with Restore Unrendered. 

Source footage courtesy of 
Jarle Leirpoll.



107Best Practices & Workflow Guide | Dynamic Link with After Effects

Additional Tips for Dynamic Link 

Make a Copy before Dynamic Linking 
Creating a Dynamic Link composition will replace the original clip in the timeline, but keeping a 
copy of the original clip is helpful for when you want to refer back to it later. Duplicate the clip onto 
a track above, then create a Dynamic Link composition from the duplicate.

If you forgot to make copies, and the clips are lost from your timeline, you can copy and paste the 
clips from After Effects back to the Premiere Pro timeline.

Select only the Video part 
of the clips by pressing Alt/

Option when you select them. 

Create copies by continuing to 
press Alt/Option while moving 

the clips to a higher track. 

Source footage courtesy of 
Jarle Leirpoll.

Because only the copies are 
sent to the Dynamic Link, you 

still have the originals in the 
timeline.
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Add Handles before linking
Adding handles to clips before sending them to After Effects can be helpful if the edit may change 
later. First, drop a marker on the first and last frame of the clip because these markers will be 
visible in After Effects. 

Extend the beginning and end of the shot as desired. Then use Replace Clip With After Effects 
Composition.

If you send the clips via 
Dynamic Link without handles, 

there will be no handles avail-
able in After Effects.

Source footage courtesy of 
Jarle Leirpoll.

Adding handles gives the 
After Effects editor some room 

for further trimming.

The handles carry over to 
After Effects, along with the 

clip Markers.
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Flatten Multicam clips before creating the Dynamic Link
Dynamic Link will preserve Multi-Camera Source Sequences in After Effects. If you don’t want to 
include all the Multicam angles, right click on the Multicam and choose Multi-Camera > Flatten 
before creating a Dynamic Link.

The result of not flattening 
the multicam clip before 

linking. A lot of unnecessary 
clips are imported, and all 

the clips have been placed in 
precomps.

Source footage courtesy of 
Jarle Leirpoll.

The result of flattening the 
multicam clip before linking. 
No extra clips are imported, 
and no precomps are made.
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Use a Guide Layer
Sometimes, what you need from After Effects is just an overlay, which does not include the original 
clip. An example would be a call-out title or a text message effect. In these cases, you need the 
original clip in After Effects as a guide, so you can place the elements correctly. But you don’t need 
the original clip to be part of the Dynamic Link.

A quick and easy way to achieve this is to send the clip to After Effects using Replace With After 
Effects Composition as usual, but immediately make the clip a Guide Layer in After Effects.

This is done by choosing Layer > Guide Layer—or right-clicking on the clip and choosing Guide 
Layer. Guide Layers are not rendered, they’re just visible while you’re working in After Effects. The 
Dynamic Link clip in Premiere Pro will only contain the overlay, not the original clip.

Dynamic Linking and Proxies
If your clips have proxies attached, they will also be available in After Effects. . By default, After 
Effects will use the original media but you will be able to display the proxy clip instead by toggling 
the Proxy button to the left of the file name.

The video layer with the 
boat is not needed in this 

call-out, because it's already 
in the Premiere Pro timeline. 

Making it a Guide Layer 
makes sure the layer is not 

rendered.

Source footage courtesy of 
Sune Alexandersen Narud.

The Guide Layer icon 
shows to the left of the 

layer name, telling you it's 
not going to be rendered.

Toggle the small button 
to the left of the layer 

name in After Effects to 
switch between proxies 

and the original media.
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After Effects Color Settings
Premiere Pro and After Effects have different color management settings. Understanding how they 
work will ensure you see the correct colors in both applications. Two key parameters are pixel bit 
depth and Composite in Linear Color.

Premiere Pro works in 32-bit float mode if using a GPU Accelerated Renderer, which is on by 
default. Composite in Linear Color is a Sequence Setting, also on by default. In After Effects, both of 
those settings are found in project settings and are off by default..

In After Effects, the back-
ground of this lower third is a 
black Shape Layer set to 50% 

Opacity. 

The After Effects project 
is set to 8-bit Non-Linear 

Rec.709.

Source footage courtesy of 
Jarle Leirpoll.

When brought into 
Premiere Pro via Dynamic 

Link, the background 
appears lighter than in After 

Effects.

The same comp, with After 
Effects Project set to 32-bit 

Linear Rec.709. 

This is much closer to what 
you see in Premiere Pro.
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If you want your After Effects comps to look the same in Premiere Pro, it’s important to match their 
blending and color depth settings. Choose File > Project Settings > Color in After Effects and set 
the Depth to 32 bits per channel (float), Workings Space to None, check Blend Colors Using 1.0 
Gamma, and set Gamma to 2.4 (Rec 709).

Choose GPU Acceleration (CUDA, OpenCL or Metal) in Project Settings for better rendering 
performance.

Open the correct After Effects project from Premiere Pro 
When creating a Dynamic Link from Premiere Pro, the resulting comp will be created in the 
currently open After Effects project. If no After Effects project is open, a new one will be created. 
Keep your Dynamic Link projects organized by opening or creating the desired After Effects 
project before creating a Dynamic Link from Premiere Pro.

Smaller projects allow for simultaneous work by multiple assistant editors and After Effects artist, 
since only the project for one scene will be in use by each artist/assistant editor.

Choose between GPU and 
Software Only rendering 

under File > Project Settings > 
Video Rendering and Effects.

These are the recom-
mended color settings 

in After Effects if you want 
the closest possible match 

to what you will see in 
Premiere Pro. 

Use the same After Effects 
project for all the Dynamic 

Links in each scene/day/
sequence etc.—but not for a 

whole episode or feature film. 
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Incrementing After Effects Project File Names
If you use File > Increment and Save when saving your After Effects projects, it will automatically 
save a new copy of the project with a version number appended to the filename (i.e. “The_
River_09.aep”). Premiere Pro will continue to link to the previous version of the project. 

Choose Preferences > General in After Effects and turn on Dynamic Link with After Effects Uses 
Project File Name with Highest Number to have Premiere Pro always use the highest version 
number.

Leave this preference unchecked if you use numbers in your project files that are not an 
incrementing scheme. 

Enable Disk Cache in After Effects
Your Dynamic Linked comps will perform better without rendering if you enable Disk Cache in 
After Effects. To get to this setting, choose Edit > Preferences > Media & Disk Cache. Choose a fast 
drive for the Disk Cache.

Firewalls and Dynamic Link
Dynamic Link uses a background process to sync between Premiere Pro and After Effects. Some 
system firewalls can prevent this communication. If you have trouble using Dynamic Link, check 
your firewall settings.

This preference in After 
Effects, makes Premiere Pro 

assume these are versions of 
the same project and import 

the one with highest number.

Enabling Disk Cache lets 
After Effects store RAM 
Previews and rendered 

frames on disk.

If you see the wrong portion 
of a comp is showing in your 

Premiere Pro timeline, try 
deleting the render files or 

your media cache files.
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Using Dynamic Link on a network server with multiple users
When working on a single machine, changes made in After Effects appear in Premiere Pro via 
Dynamic Link instantaneously—even without saving the After Effects project. When working with 
multiple machines on a network server, changes do not automatically appear in Premiere Pro. 
Instead, follow the below steps to trigger Premiere Pro to display the latest After Effects changes.

Example workflow with an editor and effects artist on different systems:

1. In Premiere Pro, the editor creates a Dynamic Link.  
After Effects opens and a project is created.

2. The editor saves the After Effects project on the network server.

3. The editor then closes the After Effects project and notifies the effects artist that a new 
comp is ready to be worked on.

4. The effects artist opens composition in After Effects and completes the effects work.

5. The effects artist saves and closes the After Effects project and notifies the editor that the 
project is ready.

6. The editor opens the After Effects project by right-clicking the Dynamic Link clip in Premiere 
Pro and choosing Edit Original.  
Premiere Pro will refresh the clip to show the work done by the effects artist.
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Chapter 9

Turnovers
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Introduction
The term “Turnovers” refers to the process of exporting project data and media 
from Premiere Pro in a format that can be understood by another application so 
that another artist or editor can do their work� 

The process can be one-way, but for many productions it involves receiving 
material back to incorporate into the Premiere Pro timeline� If you are doing all 
your finishing (color, sound mix, and VFX) in Premiere Pro and Adobe tools, you 
essentially avoid the turnover process altogether and can skip this chapter�

Best Practices
The single best thing you can do to ensure success with turnovers is to communicate early and 
often with the teams who will be receiving your turnovers. This chapter outlines an ideal, best-case 
scenario to serve as a guide. The unique details of any given production and workflow may call for 
different steps or considerations. Proactively asking your finishing teams what they need ahead of 
time means your turnovers have the best chance of going smoothly.

The second best thing you can do to ensure a successful turnover is to do a test turnover once you 
have actual footage to work with. Any issues found are usually easy to remedy at the beginning of a 
production; discovering and fixing them at the end of the process is often costly and time 
consuming.

Following the best practices laid out in "Working with Dailies" on page 21 will also help ensure a 
smooth turnover process.
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Audio Turnover
An audio turnover to a sound mixer can happen multiple times over the course of a production. 
Due to the smaller nature of audio files, uncompressed audio media is usually sent with each 
turnover.

A typical audio turnover consists of the following:

 • An interchange file (AAF) describing the sequence, effects, volume, and other parameters

 • The audio media used in the sequence, embedded in the AAF or rendered separately

 • A reference export of the sequence with burned in timecode

 • A change list, if editorial changes have been made since the previous turnover

 • Some workflows require an EDL of the dialog tracks to be used to conform against the 
original audio material that wasn't used in the offline edit. Discuss with your sound mixer.

Using AAF
Premiere Pro supports multiple interchange formats that could be used for audio turnovers. AAF 
(Advanced Authoring Format) is the recommended interchange format to use for most audio 
software, including Avid Pro Tools. Use the latest version of Premiere Pro and your audio software 
to ensure the best compatibility with AAF.

When exporting an AAF, new audio media is written to disk. Premiere Pro can write the audio into 
the AAF file (embedded) or as separate media in a folder next to the AAF file. Using separate audio 
is the more flexible option and will include more audio metadata than exporting using embedded 
media.

Audio Turnover Steps

1. Make a copy of your sequence� Preparing your sequence for turnovers often involves 
removing or re-organizing elements, and you will want to have a copy of the original 
sequence before changing anything. If you are working in a Premiere Pro Production, make a 
new audio turnover project and work with your copy of the sequence there.

2. Export a reference video file� Your sound mixer may have a preferred video format that 
works best in their audio software. Use the Timecode effect on an adjustment layer over 
your entire sequence to visually burn in timecode.

3. Prepare the sequence� Work with your sound mixer to determine how they would like the 
sequence organized. 

a. Use Sequence > Simplify Sequence to remove any unneeded elements from your audio 
tracks.

b. Separate your Dialogue, Music, and Sound Effects clips onto dedicated tracks so that each 
track has only one type of sound clip.

c. If you have tracks that have both mono and stereo clips, consider separating them so that 
your audio tracks only have clips of one type. The resulting AAF will be easier to 
understand when imported into audio software.

d. Un-nest any nested sequences so the original audio clips are present. Multicams are 
automatically flattened for you when exporting to AAF.

4. Export the AAF� With your timeline in focus, choose File > Export > AAF. Work with your 
sound mixer to determine the specific settings most appropriate for your project. Refer to the 
screenshot below for sensible defaults if you’re not sure which settings to use.  
 

https://helpx.adobe.com/premiere-pro/using/export-aaf-files.html
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Note: If your picture and sound was synced together using Merge Clips, some audio metadata will 
not translate via AAF. Use Multi-Camera syncing instead of Merge Clips.  See the chapter "Before 
Getting Started" on page 4 for more information.

Change Lists
A change list is a text file that details each change between two versions of a sequence. It is used to 
update the audio software’s version of the sequence if any editorial changes are made after the 
initial audio turnover. There is no one standard format for a change list, so make sure to work with 
your sound department to decide on which format and third-party change list software you will 
use.

While there are many paid tools for generating change lists, you can start with a simple free tool 
available in the Adobe Marketplace called Change Note Bot. In the Creative Cloud desktop 
application under Marketplace, search for plug-ins called Change Note Bot and filter by Premiere 
Pro. After installation you can find this plug-in in Premiere Pro by choosing Window > Extensions 
> Change Note Bot.

These settings are a good 
default when exporting 

an AAF for sound mixing. 
Check with your audio post 

facility for their preferred 
settings.

https://exchange.adobe.com/creativecloud.details.104462.change-note-bot.html
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Color Turnover
Turning over to your colorist works a bit differently from an audio turnover in that usually the 
interchange itself does not contain any media. This is because while audio is uncompressed and 
can be exported without generational quality loss, any exporting of video involves losing some 
amount of data. Instead, colorists usually start from the OCF (Original Camera Files) to maintain 
the highest quality.

A typical color turnover consists of the following:

• An interchange file (XML or EDL) describing the sequence

• A reference export of the sequence with burned in timecode

• The original camera media against which the interchange file can link

Which Interchange Format to Use
Premiere Pro supports multiple interchange formats that could be used for a color turnover. In 
most cases, XML is the best format as it can preserve useful clip information like scale, position, 
rotation, and more. Work with your colorist to decide which interchange format is appropriate for 
the workflow and color application your production is using.

Color Turnover Steps

1. Make a copy of your sequence� Preparing your sequence for turnovers often involves 
removing or re-organizing elements, and you will want to have a copy of the original from 
before you started. If you are working in a Premiere Pro Production, make a new color 
turnover project and work with your copy of the sequence there.

2. Export the reference video file� Your colorist may have a preferred video format that works 
best in their color software. Use the Timecode effect on an adjustment layer over your entire 
sequence to visually burn in timecode and other necessary metadata.

3. Prepare the sequence� Remove any clips or elements that will not be translated into the color 
software or that are not intended to be colored. 

a. Use Sequence > Simplify Sequence to remove any unneeded elements from your 
sequence and collapse it to as few video tracks as possible.

b. Consider removing all audio clips and tracks as most colorists will not use them.

c. Un-nest any nested sequences and flatten any Multi-Camera Sequences so the original 
clips are present.

d. Organize different types of clips (footage, titles, VFX, etc) onto specific tracks.

4. Export the XML. With your timeline in focus, File > Export > Final Cut Pro XML. If any effects 
or elements in the sequence can’t be translated to XML, an alert will appear and a translation 
report text file will be placed next to the XML on disk so you can review which clips at which 
time have any issues.

If your sequence contains color effects (like Lumetri color) when you export the XML, those effects 
are written into the XML. Other color applications won’t understand the effect and they will be 
ignored. Be aware that if the color software exports a new XML as part of its export process, the 
new XML may pass along the effects from Premiere Pro. 

This means if you import the XML and graded media back into Premiere Pro, you may see the old 
effect applied on top of the colorist’s grade. In this case, select all the clips in the colored timeline 
and choose Edit > Remove Attributes to remove any unnecessary effects.
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Turning Over a High-Resolution Export to Color
In some cases where a timeline is too complex to translate between applications or there is not 
time for a full conform, color turnover happens by exporting a high-resolution version of the 
timeline with no color effects enabled so that the colorist can use that export as the media against 
which to apply their color. 

Documenting all the considerations for this kind of workflow is beyond the scope of this chapter. 
As always it is important to have a conversation with your colorist to agree on how to implement 
this workflow.

When exporting a high-resolution file for a color turnover, keep the following in mind:

• In Sequence > Sequence Settings, turn on Maximum Bit Depth and Maximum Render 
Quality

• In your Export settings, make sure to turn on Render at Maximum Depth and Use Maximum 
Render Quality. These options ensure you are exporting at the highest fidelity but will 
increase export time.

• If exporting to a format that supports it, set the Bit Depth to the highest available in the 
Export settings

• In your Sequence settings and Export settings make sure the correct color space is selected

• If your sequence contains RAW video media, work with your colorist to make sure the clips 
are using the settings appropriate for this workflow, which may differ from what looked best 
while editing

• Make sure there are no visual elements left in the sequence that would interfere with the 
color grade such as titles or graphics

Your colorist may prefer to receive an EDL or XML of the sequence to help in identifying the cuts 
and transitions in the high-resolution file you exported.



122Best Practices & Workflow Guide | Turnovers

Visual Effects (VFX) Turnover
Turnovers to visual effects differs from audio and color turnovers in that they are dealing with 
individual shots rather than an entire sequence. How VFX turnovers are handled varies widely 
based on the type of production and workflow, so a full description is beyond the scope of this 
chapter.

A typical VFX turnover includes the following:

• A reference export of the shot including the shot before and after

• An EDL of the shot including handles and markers as well as clip name and clip markers as 
comments

EDLs base their events on Tape Name (also known as Reel) and Timecode, but Premiere Pro will 
also write a comment into each EDL event with the clip name as it was shown in the timeline at the 
time of exporting the EDL. This means you can use the “Show Source Clip Name and Label” option 
found in the Timeline panel wrench menu to control if the timeline clip name or the Source clip 
name is visible, and thus which one is written into the EDL.

Clip markers are commonly used to denote the start and end of a shot when handles are present, 
or to include information for the VFX team. When exporting an EDL from Premiere Pro you can 
choose “Include Clip Markers” to write the clip markers into the EDL data as a comment. Any 
markers hidden by filtering in the Markers Panel will not be exported.

See this Netflix reference for VFX Best Practices for more good advice on handling VFX turnovers.

https://partnerhelp.netflixstudios.com/hc/en-us/articles/360000611467-VFX-Best-Practices
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Introduction

Numerous scenarios for remote workflows and collaboration have been in place 
since the advent of digital production� Bespoke remote solutions, once requiring 
expensive and proprietary gear (and only available to the highest budget 
productions) have evolved into a wide variety of easy to use and affordable 
solutions that meet the most stringent security standards�

“Remote workflows” refer to the process of accessing existing infrastructure, including corporate 
on-premise storage, networking and workstations, from a remote location. “Cloud workflows” 
refers to the process of accessing and using a public or private datacenter for media production.

Our guide lists a variety of Premiere Pro remote and cloud-based workflows. Several specialized 
Adobe Technology Partners are listed below, but there are many others in our broad ecosystem.  
You can browse Adobe’s Technology Partner Solutions in our Partner Finder site: https://adobe-
videopartnerportal.com/find-a-partner/

Peer to Peer Screensharing
This technology enables connecting to and viewing the desktop of a remotely located editing 
machine, controlling it with one’s mouse or stylus and keyboard. A typical scenario consists of a 
group of centrally located workstations attached to a NAS, where editors can log in from anywhere 
and control their machines from their remote computer. In this case the editing experience is as if 
the editor were on premise.

HP ZCentral Remote Boost with Teradici CAS and Teradici PCoIPClient 
https://www.hp.com/us-en/workstations/zcentral-remote-boost.html

Jump Desktop 
https://jumpdesktop.com/

Microsoft Remote Desktop 
https://www.microsoft.com/en-us/p/microsoft-remote-desktop/9wzdncrfj3ps

Splashtop Business 
http://www.splashtop.com

TeamViewer 
https://www.teamviewer.com/

CAS = Cloud Access Software

 PCoIP = PC-over-IP

https://adobe-videopartnerportal.com/find-a-partner/
https://adobe-videopartnerportal.com/find-a-partner/
https://www.hp.com/us-en/workstations/zcentral-remote-boost.html
https://jumpdesktop.com/
https://www.microsoft.com/en-us/p/microsoft-remote-desktop/9wzdncrfj3ps
http://www.splashtop.com
https://www.teamviewer.com/
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Cloud Storage Solutions
Cloud Storage can be useful when you already have capable workstations with each remote editor 
but need to have a common storage shared. You can use cloud storage to host your project files (or 
Premiere Pro Production), acting like a NAS in the cloud. If your editors have a strong, low-latency 
internet connection (minimum 50 Mbps), some cloud storage solutions can even handle hosting 
your media files.

Solutions like LucidLink (below) offer intelligent caching on the local machine, requiring only a 
small amount of dedicated storage. In these scenarios, users can play footage stored in the cloud in 
real time, with nearly instantaneous synchronization of project metadata. Make sure to consider 
egress charges if hosting your media in the cloud.

Amazon Web Services S3 
https://aws.amazon.com/pm/serv-s3/

Google Cloud Platform 
https://cloud.google.com/gcp

LucidLink 
https://www.lucidlink.com/

Microsoft Azure Blob 
https://azure.microsoft.com/en-us/services/storage/blobs/

OpenDrives Atlas Cloud 
https://opendrives.com/products/atlas-cloud/

Qumulo Cloud Studio – Enterprise Cloud Storage running on AWS 
https://qumulo.com/wp-content/uploads/2020/07/SB-Q216-072020_Adobe_v4_FINAL.pdf

SNS-EVO 
https://www.studionetworksolutions.com/products/

Tiger Technology (Tiger Bridge) [Windows only] 
https://www.tiger-technology.com/software/tiger-bridge/

https://aws.amazon.com/pm/serv-s3/
https://cloud.google.com/gcp
https://www.lucidlink.com/
https://azure.microsoft.com/en-us/services/storage/blobs/
https://opendrives.com/products/atlas-cloud/
https://qumulo.com/wp-content/uploads/2020/07/SB-Q216-072020_Adobe_v4_FINAL.pdf
https://www.studionetworksolutions.com/products/
https://www.tiger-technology.com/software/tiger-bridge/
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Editing Solutions Enabling Video Review Over the Internet
Remote viewers can watch the editor work in real time, collaborating and commenting with video, 
voice, text and graphic annotation. These ‘over-the-shoulder’ scenarios are the closest experience 
to being present in the actual edit bay.

BirdDog 
https://birddog.tv/cloud-overview/

ClearView Flex (Sohonet) 
https://www.sohonet.com/

Evercast 
https://www.evercast.us/home-c

NDI 
https://www.ndi.tv/ 
see also: https://go.vizrt.com/Cloud-Live-Production_AWS/Demo/OnDemand

Pacific Post Live 
https://pacpost.live/

Remote Review and Approval
Editors can securely collaborate with other members of the production team, asynchronously 
commenting on projects beginning with dailies all the way through delivery of final assets. Frame.
io (now part of Adobe) and the others listed below allow users to comment, visually annotate, and 
keep track of versions with precision timecode accuracy. Mobile devices are also supported in 
most scenarios.

Frame.io (now part of Adobe) 
https://www.frame.io/

Ftrack 
https://www.ftrack.com/en/review

Iconik 
https://www.iconik.io/collaboration

PIX System 
https://pix.online/

Shift.io 
https://shift.io/

Wipster 
https://wipster.io/

5th Kind

https://www.5thkind.com

https://birddog.tv/cloud-overview/
https://www.sohonet.com/
https://www.evercast.us/home-c
https://www.ndi.tv/
https://go.vizrt.com/Cloud-Live-Production_AWS/Demo/OnDemand
https://pacpost.live/
https://www.frame.io/
https://www.ftrack.com/en/review
https://www.iconik.io/collaboration
https://pix.online/
https://shift.io/
https://wipster.io/
https://www.5thkind.com
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Extending Professional Workflows with Panels & Integrations

The Adobe Video & Audio applications feature an extensive toolkit that allows 
developers to integrate with, control, and extend their core functionality� This has 
created a thriving ecosystem of plug-ins and professional development, but it’s 
also relatively easy for individuals with a technical mindset to get started with their 
own custom panel in Premiere Pro� Editorial teams often need specific, custom 
behavior that they can build themselves using the tools described in this chapter�

Extensions, Plug-ins, and Custom Panels
Broadly speaking, an extension is any code that interfaces with Premiere Pro and takes the form of 
a plug-in or a custom panel. The term plug-in can refer to a number of things, but for the purposes 
of this chapter we are going to focus on custom panels. 

Unlike the plug-ins shown below which use the C++ API, a custom panel is essentially a web page 
serving as a user interface which sends scripting commands to Premiere Pro using ExtendScript.

The user interface of your panel can be as simple as a button to do the one task you need, or as 
complex as a full web-based UI, complete with configurable options and communicating with a 
web service. Examples of potential uses for a custom panel include: 

 ◆ Combining common actions into one step

 ◆ Importing media, XML, and existing projects

 ◆ Modifying clip metadata including file paths

 ◆ Using scripting commands to build bespoke, new functionality

 ◆ Automating VFX pulls and cut-ins

 ◆ Exporting sequences, projects, XML, etc

 ◆ Sending data to or receiving data from a local or web source

 ◆ Media Asset Management.

Extensions in Premiere Pro 
are either C++ API plug-ins or 

custom panels.
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How to Find Existing Panels

Adobe Exchange & Creative Cloud application
Most panel makers submit their panels to the Adobe Exchange: https://exchange.adobe.com/
creativecloud.premiere-pro.html

The Creative Cloud application also has a Marketplace section which is another way to search 
extensions found on Adobe Exchange.

Installing from Outside Adobe Exchange
Custom panels for Premiere Pro can be sent or hosted like any other file. You should only install 
and use custom panels from a trusted source. 

Custom panels are usually distributed as ZXP files. You will need to use an installer tool to install 
the ZXP:

 ◆ ZXPInstaller - https://zxpinstaller.com

 ◆ Anastasiy’s Extension Manager - https://install.anastasiy.com

 
Both installer tools are endorsed by the Adobe extensibility team.

Change Note Bot, shown 
here, creates change notes 

files for audio turnovers.

https://exchange.adobe.com/creativecloud.premiere-pro.html
https://exchange.adobe.com/creativecloud.premiere-pro.html
https://zxpinstaller.com
https://install.anastasiy.com
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Using Custom Panels in Premiere Pro
Once a custom panel has been installed, you can find it in Premiere Pro under Window > 
Extensions� The panel can be added to your workspace like any of the built-in panels.

Uninstalling Custom Panels
Follow these steps to uninstall a custom panel:

1. Quit Premiere Pro

2. Open this folder:

 ◆ macOS:  /Library/Application Support/Adobe/CEP/extensions

 ◆ Windows:  C:\Program Files (x86)\Common Files\Adobe\CEP\extensions 
          or:   C:\Program Files\Common Files\Adobe\CEP\extensions

3.  Inside the extensions folder, locate the custom panel’s folder by name and delete it

Opening Change 
Notes Bot.

Change Notes Bot 
panel in Premiere Pro.



133Best Practices & Workflow Guide | Panels and integrations

How to Write a Custom Panel
A full guide to writing a custom panel is beyond the scope of this chapter, but the following 
information will get you set on the right path. At a high level, these 5 steps will get you started:

1. Install VS Code:  
https://code.visualstudio.com

2. Install ExtendScript debugger for VS Code:  
https://marketplace.visualstudio.com/items?itemName=Adobe.extendscript-debug

3. Download and install the PPro Panel:  
https://github.com/Adobe-CEP/Samples/tree/master/PProPanel

4. Watch this video on debugging ExtendScript and JavaScript:  
https://shared-assets.adobe.com/link/e2f1bde9-4b50-47a6-4878-58883da4b552

5. Modify and build up the PPro Panel to your needs. The PPro Panel is full of examples of how 
to use the Scripting API so that you can easily modify them.

Additional Useful Links
 ◆ ReadMe with thorough steps for set up:  

https://github.com/Adobe-CEP/Samples/blob/master/PProPanel/ReadMe.md

 ◆ API Documentation:  
http://ppro.aenhancers.com

 ◆ CEP HTML Test Panel, which shows off what’s possible at the JavaScript level:  
https://github.com/Adobe-CEP/CEP-Resources/tree/master/CEP_11.x/Samples/CEP_HTML_
Test_Extension-10.0

 ◆ PPro Sample Panel, with exhaustive examples of scripting API functionality:  
https://github.com/Adobe-CEP/Samples/tree/master/PProPanel

 ◆ How to debug JavaScript in VS Code:  
https://shared-assets.adobe.com/link/72f30d2d-77a0-4781-5e8c-2e9731377107

 ◆ How to debug ExtendScript in VS Code:  
https://shared-assets.adobe.com/link/d70499f6-a45b-40e2-4443-2624b9ec71ba

https://code.visualstudio.com
https://marketplace.visualstudio.com/items?itemName=Adobe.extendscript-debug
https://github.com/Adobe-CEP/Samples/tree/master/PProPanel
https://shared-assets.adobe.com/link/e2f1bde9-4b50-47a6-4878-58883da4b552
https://github.com/Adobe-CEP/Samples/blob/master/PProPanel/ReadMe.md
http://ppro.aenhancers.com
https://github.com/Adobe-CEP/CEP-Resources/tree/master/CEP_11.x/Samples/CEP_HTML_Test_Extension-10.0
https://github.com/Adobe-CEP/CEP-Resources/tree/master/CEP_11.x/Samples/CEP_HTML_Test_Extension-10.0
https://github.com/Adobe-CEP/Samples/tree/master/PProPanel
https://shared-assets.adobe.com/link/72f30d2d-77a0-4781-5e8c-2e9731377107
https://shared-assets.adobe.com/link/d70499f6-a45b-40e2-4443-2624b9ec71ba
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Resources & Tutorials
The following is a list of useful resources for Premiere Pro� Please be advised that 
Adobe is not responsible for the content of third-party websites� 

Basic & Advanced Help
Adobe Learn & Support

Free Tutorials on Adobe.com

PremierePro.net

Inside Hollywood’s Cutting Rooms

LinkedIn Learning (paid subscription required)

Vashi Visuals

Learn From the Pros in Premiere Pro

Tech with Mike First

Books
The Cool Stuff in Adobe Premiere Pro

Adobe Premiere Pro Classroom in a Book (2021 release)

Using Productions
Introducing Productions in Premiere Pro

Productions in Premiere Pro documentation (Adobe Help)

The Ultimate Guide to Productions (Sofi Marshall)

Jason Levine and Karl Soule Productions Livestream

Video Demo of Productions

How to use Premiere Pro Productions as an Individual Editor

Post-Production
Hollywood Post-Production Master Class with Vashi Nedomansky, ACE

Hollywood Post-Production with David Fincher’s Editorial Team

Frame.io Insider Blog

Frame.io Workflow Guide

Mastering MultiCamera Techniques  (book)

Hardware & Optimizations
Premiere Pro System Requirements

Premiere Pro Hardware Recommendations

DAV Tech Table 
https://www.youtube.com/user/dhelmly/videos

https://helpx.adobe.com/support/premiere-pro.html
https://helpx.adobe.com/premiere-pro/tutorials.html
https://premierepro.net/author/jarleleirpoll/ 
https://www.youtube.com/playlist?list=PLD8AMy73ZVxWHAxEcFMSp5jkz1aR0J5YP
https://www.linkedin.com/learning/topics/premiere-pro
https://vashivisuals.com/blog/
https://www.youtube.com/playlist?list=PLzTRmaCL97quRSVy9vGCP6HGhEh4HWrZY
https://www.techwithmikefirst.com/tag/adobe/
https://www.dpbolvw.net/click-7666885-12898971?url=https%3A%2F%2Fwww.springer.com%2Fgp%2Fbook%2F9781484228890
https://www.amazon.com/Adobe-Premiere-Classroom-Book-release/dp/0137280920/
https://theblog.adobe.com/introducing-productions-in-premiere-pro/
https://helpx.adobe.com/premiere-pro/using/production-panel.html
https://sofimarshall.com/the-ultimate-guide-to-productions-premiere-pros-most-underrated-new-feature/
https://www.youtube.com/watch?v=YFMm2arr8GA
https://www.youtube.com/watch?v=qO9VXBLz2mA
https://www.youtube.com/watch?v=9uRaWEbfERc
https://www.youtube.com/playlist?list=PLB7pbNktGmfQN2WfflGrPlST32KjTFsO_
https://www.youtube.com/playlist?list=PLB7pbNktGmfRN4jqgdKU-8qW4n6s6b03W
https://blog.frame.io/
https://workflow.frame.io/
https://www.amazon.com/Mastering-MultiCamera-Techniques-Preproduction-Deliverables/dp/0240811763/ref=sr_1_4
https://helpx.adobe.com/premiere-pro/system-requirements.html
https://helpx.adobe.com/premiere-pro/kb/hardware-recommendations.html
https://www.youtube.com/user/dhelmly/videos
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Extension Panels & App Integrations
Adobe Exchange

Premiere Pro Sample Panel

Premiere Pro API Documentation

Customer Support
Fastest way to reach Adobe Care Team for support questions: https://twitter.com/AdobeCare

Phone: (+1) 800-585-0774

Adobe Technology Partners
Video Partner Portal

https://exchange.adobe.com/
https://github.com/Adobe-CEP/Samples/tree/master/PProPanel
https://ppro-scripting.docsforadobe.dev
https://twitter.com/AdobeCare
tel:+1-800-585-07
https://adobe-videopartnerportal.com/find-a-partner/
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