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Introducing Autodesk
Inventor

Welcome to Autodesk® Inventor™. This book explains the fundamental skills to start using
Autodesk Inventor. In these chapters, the basic features are presented through examples and
step-by-step procedures. The data files used in the procedures are installed with the Autodesk
Inventor software.

Getting Started

Autodesk Inventor provides options during installation. The options selected
determine what you see the first time you start Autodesk Inventor. If you indicate
during installation that you are a new or returning Autodesk Inventor user, you
are presented with the Open dialog box. If you indicated that you are
transitioning to Autodesk Inventor from AutoCAD®, an empty part file is
displayed (like opening a new DWG file during AutoCAD start-up). The main
Autodesk Inventor Help page is displayed with slightly different selections
depending on the selected install options. No matter how Autodesk Inventor
was installed, you can tailor the start-up experience through settings in the
Application Options dialog box to suit your needs. You can specify that Autodesk
Inventor always starts with the Open dialog box or always starts in a new file.
You can decide if you want to see Help on start-up or not (and which version
of the main Help page to see).

Projects

Autodesk Inventor uses projects to represent a logical grouping of a complete
design project. A project organizes your data by maintaining information about



where design data is stored, where you can edit files, and maintains valid links
between them. You use projects when you work in a team, work on multiple
design projects, and share libraries among several design projects. See
ProductName Utilities on page 273, for detailed information about setting up
and using projects.

Data Files for Exercises

When you install Autodesk Inventor, a project called tutorial_files is created.
Make this project active so that you can locate the data files that are used for
some exercises in this book.

TRY IT: Make the tutorial_files project active
1 In Autodesk Inventor, on the Standard toolbar, click Files » Projects.
2 On the Project Editor, Select Project pane, double-click the tutorial_files

project to make it the active project.

In the Edit Project pane, in Location, the path to the folder containing
the tutorial data files is displayed. It is the folder where the files you create
and edit while performing the exercises are saved.

3 Close the Project Editor dialog box.

4 Click File » Open.

The data files contained in the tutorial_files project are listed in the Open
File dialog box.

5 Click a file to see a preview of it, and double-click a file to open it in
Autodesk Inventor.

File Types

Once you activate a project, you can open an existing file or start a new file.
Click New to see the New File dialog box with templates for a new part,
assembly, presentation file, sheet metal part, weldment, or drawing. You can
choose from several templates with predefined units.

Templates are stored in the Autodesk\Inventor(version number)\ Templates
directory or in the English or Metric subdirectories. Subdirectories in the
Templates directory are displayed as tabs in the Open New File dialog box. You
can create and save custom templates in the Templates directory.

2 | Chapter | Introducing Autodesk Inventor



A template can contain property information, such as part and project data,
and drawing views. You can see information stored in a file by viewing its
properties.

TRY IT: View the Properties dialog box

B With a file open, right-click a component in the browser or in the graphics
window, and then choose Properties from the menu.

B Click the tabs to see properties.

Application Options

You can change the look and feel of Autodesk Inventor using settings on the
Application Options dialog box. On the Standard toolbar, select Tools »
Application Options. Use the tabs on the Options dialog box to control the
color and display of your Autodesk Inventor work environment, the behavior
and settings of files, the default file locations, and a variety of multiple-user
functions.

Application options remain in effect until you change them.

Document Settings

You can specify settings in individual files. On the Standard toolbar, select
Tools » Document Settings to display the Document Settings dialog box.
Click the tabs to view and specify settings for the active document, such as
indicating the active styles, units of measure, sketch and modeling preferences,
bill of materials, and default tolerance.

Styles and Standards

You select a drafting standard when you install Autodesk Inventor, and it
includes a default set of styles that control most objects used in documents,
such as balloons, dimensions, text, layers, parts lists, symbols and leaders,
materials, and lighting. Usually the default styles are enough to get you started,
but you can use the Styles and Standards Editor to create, modify, and purge
unused styles.

Application Options | 3



By default, actions such as creating or modifying styles affect only the current
document. You can choose to save the style to the style library, a master library
that contains definitions for all available styles associated with a drafting
standard. Usually, the style library is managed by a CAD administrator. This
practice ensures that the style definitions, used by all documents that use the
drafting standard, are not accidentally replaced by a custom style.

Style libraries make it easy to share formatting conventions across projects
because they contain the definitions of formatting objects. Using a style library,
you can update a style for all documents, such as revising the arrow heads of
dimensions, by editing the style and saving the revision to the master style
library. All documents that use that drafting standard have access to the library
and any new or changed styles that are added to it.

TRY IT: View the Styles and Standards Editor dialog box
1 In Autodesk Inventor, click File » New and select the drawing template.
2 On the Standard toolbar, click Format » Styles Editor.

3 On the Styles and Standards Editor dialog box, click Standard in the Style
Type browser, and then double-click a listed standard.

4 Click the General tab to see the values controlled there, and then click
the Available Styles tab to see the list of styles. As you click through the
style type list, you may notice that most names are checked. If the check
box is cleared, that style is not available for use in the current document.

5 In the left pane of the Styles and Standards Editor, click the Dimension
style, and then double-click one of the dimension styles to display it in
the right pane. Click through the tabs to see the settings for units,
alternate units, text, tolerance, options, and notes and leaders. Click a
different dimension style to see if any of the values differ.

6 In the top-right corner of the dialog box, click the Filter list and change
the filter type. Notice how the list of available styles changes if you select
All Styles, Local Styles (for the current document), or Active Standard.

You may notice differences in the lists because the local styles may have
had some unused styles purged to make the file size smaller.
7 Click Done. Any changed values are discarded.

If you click Save to preserve changes, the changes are saved only in the
current document.
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Using Shortcut Keys and Command Aliases

Autodesk Inventor provides shortcut keys and command aliases to help you
perform certain tasks more quickly. A command alias is an alphanumeric
character or character sequence used to start a command. Define a shortcut
by using any of the following keys or key combinations:

A punctuation key (including “-=[]\;"', . /), or one of the following
virtual keys: Home, End, Page Up, Page Down, Up Arrow, Down Arrow.

A combination of the SHIFT key along with a numeric key (0-9),
punctuation key, or one of the following virtual keys: Home, End, Page
Up, Page Down, Up Arrow, Down Arrow.

Any combination of SHIFT, CTRL, and ALT keys along with an alphanumeric
character.

Remember that some shortcut keys and command aliases are active in specific
environments only.

TRY IT: View a complete guide to shortcut keys and command aliases

1
2

Open Autodesk Inventor.

On the Standard menu, click Tools » Customize » Keyboard tab. For
each category, there is a list of the command name and its associated
shortcut or alias, if one exists.

Click through several categories to see the associated commands.

The following is a list of some of the commonly used shortcut keys and
command aliases.

Key Result

F1 Displays Help for the active command or dialog box.
F2 Pans the graphics window.

F3 Zooms in or out in the graphics window.

F4 Rotates objects in the graphics window.
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Key Result

F5 Returns to the previous view.

F6 Returns to isometric view.

B Adds a balloon to a drawing.

C Adds an assembly constraint.

D Adds a dimension to a sketch or drawing.
DO Adds an ordinate dimension to a drawing.

E Extrudes a profile.

FC Adds a feature control frame to a drawing.

H Adds a hole feature.

L Creates a line or arc.

P Places a component in the current assembly.
R Creates a revolved feature.

S Creates a 2D sketch on a face or plane.

T Tweaks a part in the current presentation file.
ESC Quits a command.

DELETE Deletes selected objects.

BACKSPACE In the active Line tool, removes the last sketched segment.

ALT + drag mouse

In assemblies, applies a mate constraint.
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Key Result

In a sketch, moves spline shape points.

SHIFT + right-click  Activates the Select tool menu.

SHIFT + Rotate Automatically rotates model in graphics window. Click to quit.
tool

CTRL + ENTER Return to previous editing state.

CTRL+Y Activates Redo (revokes the last Undo).

CTRL+ Z Activates Undo (revokes the last action).

Spacebar When the 3D Rotate tool is active, switches between dynamic ro-

tation and standard isometric and single plane views.

NOTE Click Help » Shortcut Quick Reference to see the list of command names
and associated shortcuts and aliases in the active environment.

Viewing Models

Use viewing tools to view a model:

B Use the ViewCube to orbit your 3D model and to switch between standard
and isometric views.

B Use the SteeringWheels to access a variety of navigational tools.

B Select one of the viewing tools in the Standard toolbar to achieve a specific
view.

B Right-click in the graphics window, and then select Isometric View from
the menu. The view vector changes to the isometric orientation.

B Right-click in the graphics window, and then select Previous View from
the menu. The view changes back to the previous view.

B Press FS to return the model to the last view.
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To rotate a view in 3D, use the Free Orbit or Constrained Orbit tool in the
Standard toolbar to rotate a view around one of the coordinate axes.

Zoom Tools

The zoom tools are located in the Standard toolbar and are also available from
the SteeringWheels.

Zoom

Use the Zoom tool on the Standard toolbar to enlarge or reduce the image in
the graphics window. Click the tool. In the graphics window, press the cursor
as you move it up or down to zoom the view dynamically in or out. You can
zoom the view while other tools are active.

Zoom All

Use the Zoom All tool on the Standard toolbar to resize the image of a part or
assembly so that all elements are displayed in the graphics window. You can
zoom a drawing so that the active sheet fits within the graphics window.
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Zoom Window

Use the Zoom Window tool on the Standard toolbar to define an area of a
part, assembly, or drawing to fill the graphics window.

Zoom Selected

Use the Zoom Selected tool on the Standard toolbar to zoom a selected edge,
feature, or other element to the size of the graphics window.

Pan

Use the Pan tool on the Standard toolbar to move the view in the graphics
window in any direction planar to the screen. You can pan the view while
other tools are active.
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Look At

Use the Look At tool on the Standard toolbar to zoom and rotate the display
in the graphics window. You can position a selected planar element parallel
to the screen or position a selected edge or line horizontal to the screen.

Rotate

Use the Orbit tools on the Standard toolbar to:
B Rotate a part or assembly in the graphics window.

B Display standard, isometric, and single plane projections of a part or
assembly.

B Redefine the isometric view.
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Shaded, Hidden Edge, and Wireframe Display

Use one of the Change Display tools to switch among the three display modes:
Shaded, Hidden Edge, and Wireframe. You can apply display modes to part
and assembly models, and to views in the Engineer's Notebook.

| &N

Ground Shadow Display

Use the Ground Shadow tool to cast a shadow on the plane beneath the model.

Orthographic and Perspective CameraViews

The Camera View tool has two settings: Orthographic Camera mode and
Perspective Camera mode.

In Perspective Camera mode, part or assembly models are displayed in
three-point perspective, a visual effect where parallel lines converge on a
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vanishing point. It is the way real objects are perceived by the human eye or

by a camera.

=
y

The following chart shows how the other viewing tools behave and how they
can be modified in each camera mode.

Zoom or Orthographic Perspective Keys/Commands
Pan Type Camera mode Camera mode

Camera Translation Pan  Yes Yes F2 Pan

Camera Pivot Pan Yes Yes SHIFT+F2 Pan
Camera Position Zoom  Yes Yes F3 Zoom

Camera Position/Cam-  No Yes SHIFT+F3 Zoom

era Target Point Zoom

Lens Focal Length No Yes CTRL+F3 Zoom

Zoom

Set Perspective Distor-
tion

SHIFT+CTRL+F3 Zoom

Importing and Exporting Data

You can import Pro/ENGINEER®, Parasolid®, SolidWorks™, UGS NX, SAT,
STEP, IGES, and AutoCAD and Autodesk® Mechanical Desktop® (DWG) files
for use in Autodesk Inventor. You can export AAutodesk Inventor parts and
assemblies to many file formats, including Pro/ENGINEER and Parasolid, and
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you can export Autodesk Inventor drawings as DXF™ or AutoCAD drawing
(DWG) files.

The options for importing and saving AutoCAD files in Autodesk Inventor
are:

Selection of layers.
Window selection of entities.
Saving files in DWG format.

Support for DXF files back to version 12.

Creation of AutoCAD® Mechanical files, if AutoCAD Mechanical is
installed.

NOTE Mechanical Desktop files can be linked to Autodesk Inventor assemblies
without importing.

AutoCAD Files

When you open an AutoCAD file in Autodesk Inventor, you can specify the
AutoCAD data to translate. You can select:

B Model space, a single layout in paper space, or 3D solids.

B One or more layers.

You can also place 2D translated data:

B On a sketch in a new or existing drawing.
B As a title block in a new drawing.

B As a sketched symbol in a new drawing.
|

On a sketch in a new or existing part.

If you translate 3D solids, each solid becomes a part file containing an ASM
solid body. Blocks are translated as sketched symbols.

When you import AutoCAD (DWG) drawings into a part sketch, a drawing,
or a drawing sketch overlay, the converter takes the entities from the XY plane
of model space and places them on the sketch. In a drawing, certain entities,
such as splines, cannot be converted.
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When you export Autodesk Inventor drawings to AutoCAD, the converter
creates an editable AutoCAD drawing and places all data in paper space or
model space in the DWG file. If the Autodesk Inventor drawing has multiple
sheets, each is saved as a separate DWG file. The exported entities become
AutoCAD entities, including dimensions.

You can open a .dwyg file and then copy selected AutoCAD data to the clipboard
and paste into a part, assembly, or drawing sketch. The data is imported at
the cursor position.

Autodesk Mechanical Desktop Files

Autodesk Inventor can translate Autodesk Mechanical Desktop parts and
assemblies so the design intent is preserved. You can import a Mechanical
Desktop file as either an ASM body or a full conversion when Mechanical
Desktop is installed and running on your system. Using the DWG/DXEF File
Import Wizard, you can import Mechanical Desktop data, including parts,
assemblies, and drawings. The data is associative to Autodesk Inventor drawing
views and annotations.

Features that are supported in Autodesk Inventor are converted. Unsupported
features t are not translated. If Autodesk Inventor cannot translate a feature
it skips that feature, places a note in the browser, and then completes the
translation.

Files from Other Applications

You can open and change models created in Pro/ENGINEER, Parasolid,
SolidWorks, and UGS NX. Autodesk Inventor translates assembly and part
files, solids, multi-solids, surfaces, and more. After the import operation is
complete, you can change the model as if it was originally created in Autodesk
Inventor.

After changing a file, you can continue to use it as an Autodesk Inventor file
or export it to other file formats, including Pro/ENGINEER and Parasolid.
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SAT Files

SAT (*.sat) files contain nonparametric solids that can be Boolean solids or
parametric solids with the relationships removed. You can use a SAT file in
an assembly and add parametric features to the base solid.

When you import a SAT file that contains a single body, it produces an
Autodesk Inventor part file with a single part. If it contains multiple bodies,
it produces an assembly with multiple parts. Surface data in a SAT file is also
supported.

STEP Files

STEP files are the international format developed to overcome some of the
limitations of data conversion standards. Past efforts in developing standards
have resulted in localized formats such as IGES (U.S.), VDAFS (Germany), or
IDF (for circuit boards). Those standards do not address many developments
in CAD systems. The STEP converter for Autodesk Inventor is designed for
effective communication and reliable interchange with other CAD systems.

When you import a STEP (*.stp, *.ste, *.step) file, only 3D solid, part, surface,
and assembly data are converted. Drafting, text, and wireframe data are not
processed by the STEP converter. If a STEP file contains one part, it produces
an Autodesk Inventor part file. If it contains assembly data, it produces an
assembly with multiple parts.

IGES Files

IGES (*.igs, *.ige, *.iges) files are a standard in the United States. Many NC/CAM
software packages require files in IGES format. Autodesk Inventor imports and
exports IGES files, including wireframe data.

DWEF Files

Design Web Format (DWF™) is a compressed, secure format used to publish
CAD data. DWF files are fast to open and view, and can easily be shared by
e-mail with customers, vendors, marketing, and others who do not have

Autodesk Inventor installed. Use the DWF Publisher to publish an accurate
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visual representation of 2D and 3D data in one file. Download and install the
free Autodesk Design Review viewer to view a DWF file.

Learning Autodesk Inventor

You can select a learning tool that suits your preferred learning style. You can
get help for the current task, follow a workflow in a tutorial or Show Me
animation, learn a new skill using a Skill Builder, or click through Help topics.
You can gain 3D knowledge as you transition from 2D and watch animations
of operations.

Be more productive with Autodesk software. Get trained at an Autodesk®
Authorized Training Center (ATC®) with hands-on, instructor-led classes to
help you get the most from your Autodesk products. Enhance your productivity
with proven training from over 1,400 ATC sites in more than 75 countries.
For more information about Autodesk Authorized Training Centers, contact
atc.program@autodesk.com or visit the online ATC locator at
www.autodesk.comy/atc.

Using Technical Publications

Autodesk Inventor integrates software tools, knowledge, and interactive
learning for assistance in specific work tasks and to increase your productivity.
The complete set of technical publications includes:

Printed Getting Started manual

Help

Help for the AutoCAD user

Welcome modules

Tutorials

Show Me animations

New Features Workshop to explore what’s new in Autodesk Inventor

User comments links

Skill Builders
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atc.program@autodesk.com
www.autodesk.com/atc

Help

Click Help » Help topics for easy access to the Help topics, Skill Builders,
and Tutorials. You can also navigate through the Table of Contents or use the

Index and Search functions.

(' Autodesk Inventor Help

=JC

FEE A el
Hide Back Home  Print  Options

Contents | Index | Search | Favorites

= (0 Autodesk Inventor
= @ Autodesk Inventor Fundarmentals
= @& Parts
= @ Assemblies
= @ Drawings
= @ Collaboration and Yisualization
3 Glossary
= @ Cable and Hamess
= @ Tube and Fipe
= @ |DF Translator
@ @ Dynamic Simulation
= @ Stress Analysis
= @ Autodesk Inventor Vault
@ @ Autodesk Inventor CAD Manager Fundameritals

Autodesk Inventor Professional 2009
Help

@ Returning / New Inventor
users

© Users transitioning from
AutoCAD

I~ Show Help on startup

New Users

Set Inventor or AutoCAD style preferences

online Help - The Inside Track «»% (4.7 minutes)
Getting Started Manuals

Introducing Constraints

All Users

Learning Resources

Show Me Animations

Try It Tutorials

New Features Workshop

Readme Files

Toolbar Quick Reference

2D Sketch Constraints Quick Reference
Skill Builders

Resources on the Web

autodesk.com

Autodesk Manufacturing Community
Inventor

Discussion Group

Hardware

Technical Support

Training Resources

Consulting

Help Updates

When using Autodesk Inventor, click Help buttons on dialog boxes to retrieve
a reference topic automatically that describes options for the dialog box.
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Help for AutoCAD Users

In Autodesk Inventor, click Help. If you selected “Users transitioning from
AutoCAD” as your preference during the installation, your Help home page
opens with topics and tutorials that ease the transition from 2D to 3D. You
can also navigate to them through the AutoCAD Topics section in the Table
of Contents. There are explanations of the differences between designing in
2D and 3D, equivalents to AutoCAD commands, tutorials, and a workflow to
explain everything from sketching to presentations.

‘@ Autodesk Inventor Help

B

Qptions

8 fa)
Hide Home  Print

Contents | ndex | Search | Favorites

@ Autodesk Inveritor
@ Cable and Hamess

@ |DF Translator

I Show Help on startup

Autodesk Inventor Professional 2009 Help

 Returning / New Inventor users
@ Users transitioning from AutoCAD

@ Dynamic Simulation
@ Stress Analysis
® @ Autodesk Invertor Vault
= @ Autodesk Irvertor CAD Manager Fund

= @ Tube and Pipe
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AutoCAD-specific Topics

Set Inventor or AutoCAD style preferences
2D to 3D Transition Guide

3D Modeling Concepts

Command Icon Comparison

Tutorial - Using DWG Geometry

Tutorial - Basic Modeling

New Users

Online Help - The Inside Track ¢ (4.7 minutes)
Getting Started Manuals
Introducing Constraints

All Users

Learning Resources

Show Me Animations

Try It Tutorials

New Features Workshap

Readme Files

Toolbar Quick Reference

2D Sketch Constraints Quick Reference
Skill Builders

Resources on the Web

autodesk.com

Autodesk Manufacturing Community
Inventor

Discussion Group

Hardware

Technical Support

Training Resources

Consulting

Help Updates
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Tutorials and Show Me Animations

Online tutorials are step-by-step illustrated lessons that show you how to
create and document your designs. You can access them from the Help home

page or click Help » Tutorials.

Show Me animations are videos that show step-by-step instructions how to
complete an operation. You can access Show Me animations from the Standard
toolbar, the Help home page, and in individual help topics.

Feedback Links

Click the Comments Link on a Help topic page to address specific topics,
provide general feedback about the topic, and submit input about what you
want and need from the Autodesk Inventor Technical Publications team.

&
H oo« o & m
Hide Back Home  Print  Options
Contents | Index | Search | Favarites ..
= (@ Autodesk Inventor
= @ Autodesk Inventor Fundarmentals Autodesk Inventor
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Using this form sends your comments to the Autodesk Technical
Publicati group respensible for this d i ection

Topic title and location (do not edit):

entor Fundamentals

Mame (optional): Email (optional):

Comments:

® ®oE ® E E

and Visualization

Please send us your comment about this page
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Skill Builders

Autodesk Inventor provides extended learning through its Skill Builders
learning modules. Skill Builders are posted throughout a release cycle on the
Web to address customer needs and requests.

You can access them (if you have Internet access) by clicking the link on the
Help home page.

Autodesk Inventor Professional 2009 Help

I~ Show Help on startup @ Returning / New Inventor
users
© Users transitioning from
AutoCAD

New Users

Set Inventor or AutoCAD style preferences
Online Help - The Inside Track %% (4.7 minutes)
Getting Started Manuals
Introducing Constraints

All Users

Learning Resources

Show Me Animations

Try It Tutorials

New Features Workshop

Readme Files

Toolbar Quick Reference

2D Sketch Constraints Quick Reference
{gki\\ Builders

Resources on the Web

autodesk.com
Autndesl Manifactiring Community

20 | Chapter | Introducing Autodesk Inventor



Creating Sketches

In Autodesk® Inventor™, sketching is the first step in creating a part. This chapter gives you
an overview of the sketch environment and the workflow for creating sketches.

Understanding Sketches

Most parts start with a sketch. A sketch is the profile of a feature and any
geometry (such as a sweep path or axis of rotation) required to create the feature.

All sketch geometry is created and edited in the sketch environment, using
Sketch tools on the panel bar. You can control the sketch grid, and use sketch
tools to draw lines, splines, circles, ellipses, arcs, rectangles, polygons, or points.
You can fillet corners, extend or trim curves, and offset and project geometry
from other features.

To start a sketch from scratch, open a new part file, select a Sketch tool, and
then start sketching in the graphics window. As you sketch, constraints are
automatically applied to the various sketch elements as you sketch. For example,
if you sketch a line nearly horizontal, a horizontal constraint is implied. You
can modify or delete any implied sketch constraint. You can also add constraints
manually to any sketch element. To exit a given sketch tool right-click, and
then select Done, or press ESC.

You create a 3D model from a sketch by extruding the profile or revolving it
around an axis.
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From sketch to 30 model

The model you create in Autodesk Inventor is linked to its underlying sketches
and sketch information. If you change a sketch, the model is automatically
updated.

Sketch Environment

When you create or edit a sketch, you work in the sketch environment. The
sketch environment consists of a sketch and sketch tools to control the sketch
grid, and to draw lines, splines, circles, ellipses, arcs, rectangles, polygons, or
points.

When you open a new part file, the sketch environment is active. The 2D
Sketch button is selected, and the Sketch tools are available, along with a
sketch plane on which to sketch. You can control the initial sketch setup by
using template files or settings on the Sketch tab of the Application Options
dialog box. Click Tools » Application Options » Sketch tab to customize
the settings.

When you create a sketch, a sketch icon is displayed in the browser. When
you create a feature from a sketch, a feature icon is displayed in the browser
with the sketch icon nested under it. When you click a sketch icon in the
browser, the sketch is highlighted in the graphics window.

After you create a model from a sketch, re-enter the sketch environment to
make changes or start a new sketch for a new feature. In an existing part file,
first activate the sketch in the browser. This action activates the tools in the
sketch environment. You can create geometry for part features. The changes
you make to a sketch are reflected in the model.
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Sketch Coordinate System

When you start a new sketch, the sketch coordinate system is displayed as X
and Y axes of the sketch grid. You can turn on the 3D indicator to display it
at the sketch origin. (Click Tools » Application Options » Sketch tab. In
the Display box, select the Coordinate System Indicator check box.) The default
grid lies on the sketch plane.

You can reposition and change orientation of the sketch coordinate system

to:

B Change the orientation of dimensions you create.

B Aid in precise input for sketch geometry.

TRY IT: Reposition the sketch origin in the coordinate system

1

Open a part file. In the browser, click the plus sign in front of a feature
to expand the display.

In the expanded feature display, right-click the sketch, and then click
Edit Coordinate System on the menu.

In the graphics window, the axis icon is displayed for the highlighted
sketch.

On the axis icon, click the red arrow to realign the X axis, the green arrow
to realign the Y axis, or the blue centroid to relocate the origin.

Select one of the following methods to relocate the highlighted axis:
B A feature vertex to move the coordinate system.

B A feature edge to rotate the coordinate system.
To flip the axis, right-click and select Flip axis from the menu.

Right-click, and then click Done to activate the new coordinate system.

The sketch origin in the coordinate system is repositioned.
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Using Model Edges as References for Sketches

While you sketch, you can:

B Automatically project edges of the part to the sketch plane as you sketch
a curve.

B Create dimensions and constraints to edges of the part that do not lie on
the sketch plane.

B Control the automatic projection of part edges to the sketch plane.

Workflow overview: Project part edges to a sketch plane
B Click the Project Geometry tool, and then select any part edge.

B Select an edge of the part while creating a dimension or constraint.

NOTE You can also use model edges as references for continuous loops or points.

Precise Values

In the sketch environment, you can enter relative X and Y distances from the
last point selected. The tools for precise input are located on the Precise Input
toolbar. It is only available when a sketch tool that requires placement of a
point is activated. For example, you can use precise input to define a line, a
sketch point, and a three-point arc, among others.

Enter precise values for geometry as you sketch. The Precise Input toolbar has
X and Y fields. You can enter both values to define a point, or enter only X
or Y to limit the placement of the point to a vertical or horizontal line.

TRY IT: Input precise values
1 In the sketch environment, click a Sketch tool to make it active.

2 On the standard toolbar, click View » Toolbar » Autodesk Inventor
Precise Input.

The toolbar is displayed in the graphics window.

3 Click a start point, or on the Precise Input dialog box, enter a value in
the X field.
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4 Press TAB to activate the Y field, and then enter a value.

5 Press ENTER to accept your input.

The sketch is drawn according to the input.

6 Right-click and select Done to end the sketch tool.

Creating Sketches

In this exercise, you create a part file, and then create sketch geometry using
basic sketching techniques. The following illustrates a completed sketch and
sketched feature.

Create Sketches

When you open a new patrt file, the Sketch environment is active.

The current grid setting provides a visual clue to the size of sketches. Use
Application Options and Document Settings to define the grid display.

TRY IT: Modify the sketch grid display
1 Click Tools » Application Options.

2 On the Sketch tab, define the grid line display. You can also select the
Snap to Grid setting.

TRY IT: Modify the grid spacing
1 Click Tools » Document Settings.

2 Select the Sketch tab and make adjustments, as needed.
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TRY IT: Start a sketch

1 On the standard toolbar, click File » New. On the Metric tab,
double-click Standard(mm).ipt.
The new part is listed in the browser, and the sketch environment is
active.

2 On the 2D Sketch panel bar, click the Line tool. Click the left side of the
graphics window to specify a first point, move the cursor to the right
approximately 100 units, and then click to specify a second point.

As you sketch, the position of the current point, length, and angle of the
line are dynamically displayed in the lower right border of the graphics
window.

NOTE Use the Zoom tool to zoom out if a line of 100 units does not fit in the
graphics window.

The position of the current line point is relative to the sketch 0,0 coordinates.
The line angle is relative to the sketch X axis. Symbols to indicate implied
constraints are displayed next to the current line point as you sketch.

horizontal constraint symbol

20413 men, 18.217 mm Length=36 372 mn Angle=0.00 deg

TRY IT: Complete the sketch

1 Move the cursor up approximately 40 units, and then click to create a
perpendicular line.

2 Move the cursor to the left and create a horizontal line of approximately
30 units. The parallel constraint symbol is displayed.
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Move the cursor down and create a vertical line of approximately 10

units.

W

/i

Move the cursor to the left to create a horizontal line of approximately

40 units.

7

-

Move the cursor up until the parallel constraint symbol is displayed and
a dotted line appears. Click to specify a point.

7

Move the cursor left until the parallel constraint symbol is displayed and
a dotted line appears, and then click to specify a point.

S
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7 Move the cursor down until it touches the first point you specified at the
beginning of the exercise. When the coincident constraint symbol is
displayed, click to close the sketch.

=R A=

8 In the graphics background, right-click and select Done.

(R

9 Right-click again and select Finish Sketch.
The sketch is completed. Do not save the file.

Create Profiles with Tangencies

In this exercise, you create a part file, and then use basic sketching techniques
to create a simple profile. The profile consists of lines and tangential arcs.

TRY IT: Create a sketch

1 Click the New tool on the standard toolbar, select the Metric tab, and
then double-click Standard(mm).ipt.

A new part and sketch are listed in the browser. The sketch environment
is active.
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2 On the standard toolbar, click View » Toolbar » Autodesk Inventor
Precise Input to display the Precise Input toolbar.

3 Click the Line tool on the panel bar or on the 2D Sketch panel toolbar.
Click the center of the graphics window, and then enter 65 in the X field
of the Precise Input toolbar. Move the cursor to the right to display the
horizontal constraint symbol, and then click to create a 65-mm horizontal
line.

4 On the Precise Input dialog box, click the Y field, and then enter 75.
Move the cursor to display the perpendicular constraint symbol, and
then click the second point. A perpendicular line of 15 units is sketched.

NOTE Use the Zoom tool to zoom out and view the entire line if it is not
visible in the graphics window.

Tl

5 Move the cursor up and to the left, and then click to create a sloping line.
The exact angle is not important.

TRY IT: Complete the sketch

1 Click the end of the line, hold, and drag the endpoint to create a tangent
arc. Release the mouse button to place the endpoint of the arc.
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2 Move the cursor to the start point of the profile and click when the

coincident constraint symbol is displayed.

In the graphics background, right-click, and select Done, and then
right-click and select Finish Sketch.

The sketch is completed. Do not save the file.

Drag Sketch Geometry

After you create sketch geometry, and while it is unconstrained or
underconstrained, you can drag it to resize it.

Drag to resize geometry

Tips for Sketching

Start a line by dragging off a circle or an arc.
Drag radially for a perpendicular line or drag tangentially for a tangent
line.

Start a line by dragging off the interior (not the endpoints) of another line
and drag in a perpendicular direction.
The new line is constrained perpendicular to the existing line.

Create an arc by dragging off the end of a line.
Return the pointer to the endpoint of the line to change the direction of
an arc.

Start a spline tangent to a line by dragging off the line.
Select the endpoint of a line, and then drag it in the direction of tangency
to end a spline tangent to a line.

Create coincident constraints.
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When you start a new line, arc, or circle from an existing line, Autodesk
Inventor can infer a coincident constraint to the midpoint, endpoint, or
interior of the line.

B Use SHIFT to drag.
All drag features, except for a tangent spline, are also available by pressing
and holding SHIFT while moving the cursor.

B Drag multiple lines, curves, or points at the same time.
Select the geometry, and then drag the last item you selected.

W Switch between the Trim and Extend tools.
Press SHIFT or select the other tool from the context menu to switch
between Trim and Extend.

Constraining Sketches

Constraints limit changes and define the shape of a sketch. For example, if a
line is horizontally constrained, dragging an endpoint changes the length of
the line or moves it vertically, but does not affect its slope. You can place

geometric constraints between two objects in the same sketch, or between a
sketch and geometry projected from an existing feature or a different sketch.

Constraints are automatically applied when you sketch. For example, if the
horizontal or vertical symbol is displayed when you create a line, then the
associated constraint is applied. Depending on how accurately you sketch,
one or more constraints may be required to stabilize the sketch shape or
position.

Although you can use unconstrained sketches, fully constrained sketches result
in more predictable updates.

NOTE The term constraints is often used in Autodesk Inventor to refer to both
geometric constraints and dimensions. Remember that dimensions and geometric
constraints work together to create a sketch that meets design intent.

Add Constraints

Define your design intent by adding geometric constraints to the sketch. You
can use autodimensioning to confirm whether a sketch is fully constrained
and apply any needed constraints. You can also create constraints by inference
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by dragging geometry until the cursor brushes the geometry you want to

constrain.
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Constraint symbol appears when the dragged
geometry touches the endpoints

To view or remove constraints, use the Show Constraints tool on the 2D Sketch
panel toolbar. Alternatively, right-click in the graphics window, and then use
options on the menu to show or hide all constraints at once. To delete a
constraint, select a constraint symbol, right-click, and then select Delete.

Some geometric constraints work only with lines, while others work only with
arcs, circles, or radial features.

Open Data Files for Exercises

The location of data files for the exercises in this manual are specified in the
project called tutorial_files. This project must be activate so you have access
to the required files. Once the project is active, you can open the tutorial files.

TRY IT: Activate the project file and open the tutorial file for an exercise

1
2
3
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Close any open Autodesk Inventor files.
On the standard toolbar, click File » Projects.

On the Project Editor, top pane, double-click the tutorial_files project to
make it the active project. Click Done.

Click File » Open.

On the Open dialog box, click the file consketch.ipt see a preview of it,
and double-click it to open it.

The file opens in Autodesk Inventor. You are ready to start the exercise.

Creating Sketches



Add Constraints to the First Sketch

In this exercise, you practice adding geometric constraints to an existing sketch
containing three closed loops. In some cases, you can greatly reduce the
number of dimensional constraints required on a sketch.

This exercise contains geometry that does not meet design criteria and requires
additional geometric constraints to comply with the design intent.

TRY IT: Add constraints to the first sketch

1

On the standard toolbar, click the Look At tool, and then select any curve.
The plan view is displayed.

Click the Zoom All tool on the standard toolbar to view the three loops.

In the browser, double-click Sketch1 to make it active.
On the standard toolbar, click the Zoom Window tool, and then draw a
window around the sketch loop on the left.

The sketch loop is centered on your screen.

Right-click the graphics window, and select Show All Constraints. The
current sketch constraints are displayed.

Move the cursor over the constraint glyphs to highlight the sketch
geometry that is constrained.

In this example, you want the sloping lines in the sketch to be vertical,
so you now add a vertical constraint.

Right-click the graphics window, and select Hide All Constraints.

Click the down arrow beside the Constraint tool in the 2D Sketch panel
bar, and then click the Vertical constraint tool.

NOTE The cursor displays the constraint type. In this case, the vertical symbol
is displayed.
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Click the three sloping lines (be sure that you do not select the midpoint
of the lines).

Your sketch should look like the one in the following figure.

9 Right-click the graphics window, and select Done.
10 Right-click the graphics window, and select Show All Constraints.
11 All constraints display as shown in the following figure.
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12 Right-click the graphics window, and select Hide All Constraints.

13 Click Return on the standard toolbar to exit the sketch.

Add Constraints to Existing Sketches

Constraints can be added to a sketch after it is created. In this procedure, you
add constraints to the second sketch.

To redisplay all of the sketches, use the Zoom All tool on the standard toolbar.

TRY IT: Add constraints to a sketch
1 Double-click Sketch2 in the browser.

2 On the standard toolbar, click the Zoom Window tool, and then drag a
window around the second sketch loop.

The second sketch loop is centered on your screen.
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3 Click the arrow beside the Constraint tool on the panel bar or on the 2D
Sketch panel toolbar to open the pop-up menu. Click the Collinear
constraint tool. Click the horizontal lines at the top of the sketch.

Your sketch should look like the following figure. Note the collinear lines
identified by the red arrows.

1

4 Press ESC to cancel the Collinear constraint tool. Drag the top-right
horizontal line down and note how the sketch changes. This technique
is known as constrained drag.

5 Click the down arrow beside the Constraint tool again, and then click
the Equal constraint tool. Click the horizontal line at the lower left of
the sketch and then click the horizontal line at the upper left.

Make the two horizontal lines on the right side equal to the line at the
lower left.

Your sketch should look like the following figure.

6 Press ESC to cancel the Constraint tool. Drag the right vertical line and
note how the sketch changes. With the equal constraint applied, the
sketch retains its symmetry as you drag the vertical lines.
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7

In the graphics background, right-click and select Done, and then
right-click Finish Sketch to exit the sketch.

Delete and Add Constraints

Constraints can be removed from sketches. Show constraints, and then use
the Delete option on the context menu.

TRY IT: Delete a constraint and add a constraints

1
2
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Activate Sketch3.
On the standard toolbar, click the Zoom Window tool, and then drag a
window around the third sketch loop.

The third sketch loop is centered on your screen.

Click the Show Constraints tool on the panel bar or on the 2D Sketch
panel toolbar. Pause the cursor over the vertical line at the left of the
sketch. The constraints are displayed.

Move the cursor over the Equal constraint symbol, and then click to select
it. Right-click, and then select Delete to remove the constraint.

Click the down arrow beside the Constraint tool on the panel bar or the
2D Sketch panel toolbar to open the pop-up menu. Click the Horizontal
constraint tool.

Click the center point of the arc at the left of the sketch, and then click
the center point of the arc in the center of the sketch.
Repeat this process for the third center point.

Your sketch should look like the following figure.
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6 Apply a tangent constraint to the arc and line at the left side of the sketch.

7 Apply equal constraints to the radii of the three arcs.
Your sketch should look like the following figure.

8 In the graphics background, right-click and click Finish Sketch to exit
the sketch.

Do not save the file.

Tips for Constraining Sketches

B Turn off automatic constraints. Press and hold CTRL while sketching.

B Infer a constraint. Move the cursor over other geometry while sketching
to infer a constraint.

B Define dimensions with equations. Double-click a dimension to open the
Edit Dimension dialog box. Click the reference geometry, and its dimension
identifier appears on the dialog box. You can use the dimension identifier
in a mathematical expression (for example, D1*2). Dimensions that are
based on equations are marked with the fx: prefix.

B Override the units on a particular dimension. For example, in a part file
set to metric dimensions, you can enter 1 inch on the Edit Dimension
dialog box.
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Dimensioning Sketches

To retain design intent, sketch geometry generally requires dimensions in
addition to geometric constraints to maintain size and position.

Geometric constraints, such as horizontal, vertical, or parallel can be applied
while you sketch. Dimensions are typically added after your sketch geometry
is in place.

In general, all dimensions within Autodesk Inventor are parametric. You can
modify the dimension to change the size of the item dimensioned. You can
also specify that a dimension be driven. The dimension reflects the size of the
item but cannot be used to modify the size of the item.

When you add parametric dimensions to sketch geometry, you are applying
constraints that control the size and position of objects in the sketch. The
sketch is automatically updated when changes are made to the dimension
values.

Examples of dimensioned sketches are shown in the following illustration.
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To create dimensions, use the General Dimension tool on the panel bar or on
the 2D Sketch panel toolbar. You select the sketch geometry you want to
dimension, and then click to place the dimension.

The selection of geometry and the placement of the dimension determine the
kind of dimension that is created. For example, if you select the edge of one
circle, a radial dimension is created. If you select the edges of two circles, a
linear dimension is established between their center points.

Place Dimensions

Parametric dimensions define the size of your sketch. After you add a
dimension, you cannot change the size of a line or curve by dragging it. In
Autodesk Inventor, you cannot apply double dimensions to a sketch.
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TRY IT: Create a parametric dimension

1
2

Create a sketch, or open an existing sketch.

In the Sketch environment, on the panel bar or on the 2D Sketch panel
toolbar, click the General Dimension tool.

Select the sketch geometry you want to dimension, and then drag to a
point to display the dimension.

Double-click the dimension to open the Edit Dimension box.

Enter a dimension value. You can enter numeric values or the parameter
names associated with other dimensions or equations. Dimensions based
on equations, as shown in the following image, are preceded by the fx:

prefix.
q_1.0004>|
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Automatic Dimensions

You can also use the Auto Dimension tool on the panel bar or from the 2D
Sketch panel toolbar to speed up the dimensioning process. You individually
select sketch geometry such as lines, arcs, circles, and vertices and dimensions
and constraints are automatically applied. If you do not individually select
sketch geometry, all undimensioned sketched objects are automatically
dimensioned. The Auto Dimension tool provides a fast and easy way to
dimension sketches in a single step.

You can:

B Use Auto Dimension to fully dimension and constrain an entire sketch.

B Identify specific curves or the entire sketch for constraining.

B Create only dimensions, only constraints, or both.
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B Use the Dimension tools to provide critical dimensions, and then use Auto
Dimension to finish constraining the sketch.

B Use AutoDimension in complicated sketches when you are unsure which
dimensions are missing to constrain the sketch fully.

B Remove automatic dimensions and constraints.

NOTE To ensure that your sketch is fully dimensioned, use the Project Geometry
tool to project all reference geometry to the sketch before using the Auto
Dimension tool.

You can define dimensions with other dimension values. The names of
dimensions are parameters. When you edit a dimension, you can enter an
equation that uses one or more parameters.

You can display sketch dimensions in one of three forms:

B Calculated value

B Parameter name

B Parameter name and calculated value

You can modify dimensions using the Edit Dimension box. To display the

Edit Dimension box, click the dimension when it is placed, or double-click
the dimension when the General Dimension tool is not active.

There are two ways to display the Edit Dimension box upon placement of a
dimension:

B Click Tools » Application Options » Sketch tab, and turn on Edit
Dimension when Created

B With General Dimension active, right-click in the graphics window and
select Edit Dimension.

Dimension Types

In some cases, the dimension preview does not meet the design intent. You
can change the dimension type by repositioning the dimension, or you can
right-click, and then select the type from the menu. You can also control

which type of linear dimension is applied by selecting and edge or a vertex.
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For example, when you dimension an edge to a vertex, the dimension
automatically aligns itself with the edge.

Diametric Dimensions

In the design process of creating a revolved part, you can add a centerline as
the axis of rotation. If this centerline is used in a sketch dimension, it is placed
as a diametric dimension by default.

Driven Dimensions

You can place driven dimensions with Autodesk Inventor, and you can change
the dimension type of an existing dimension to driven. A driven dimension
reflects the size of the geometry, but you cannot edit the dimension value.
Use driven dimensions to display dimension values for reference purposes
only.

Workflow overview: Apply a driven dimension

B For an existing dimension, select the dimension, and then select the Driven
dimension button from the standard toolbar.

B To create driven dimensions on the fly, while the General Dimension tool
is active, select the Driven dimension button from the standard toolbar.
Driven dimensions are displayed in parentheses.

You can also create driven dimensions automatically on constrained sketch
objects. When you try to place a dimension on a constrained sketch object,
a dialog box is displayed where you can choose to accept a driven dimension
or cancel the placement.

Dimension Profiles

In this exercise, you add dimensional constraints to a sketch. The completed
exercise is shown in the following figure.
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TRY IT: Apply dimensions to linear objects

1

With the project tutorial_files active, open the file dimsketch.ipt.

The sketch geometry requires dimensional constraints to maintain its
overall size. Geometric constraints were already applied to maintain the
shape of the sketch.

In the browser, double-click Sketch1 to make the sketch active.

Click the Look At tool on the standard toolbar, and then select any line
to obtain a plan view of the sketch.

Click the Zoom All tool to view the entire sketch.

Click the General Dimension tool on the panel bar or on the 2D Sketch
panel toolbar.

Click the top horizontal line of the sketch, and then place the dimension.

et 140,000 Lan
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6 Click the dimension to display the Edit Dimension box. Enter 135 and
press ENTER.

&
¥
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In this example, you clicked the dimension to display the dialog box. If
you are placing many dimensions, you can display the Edit Dimension
box automatically.

7 With the General Dimension tool active, right-click the graphics window
background, and select Edit Dimension from the context menu.

8 Complete the dimensional constraints as follows:

Add a dimension of 70.

et 135:000 £
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Add a dimension of 60.

Dimension Profiles | 43



&

13

5000

¥

L]

£0.000

10.000

Add a dimension of 35.

135:000

¥

.

£0.000

10.000
25 00
Add a dimension of 70.
et 135.000 £or
.
60.000
10000 —]Em
1 } v
10.000
35 Qoo

44 | Chapter 2 Creating Sketches




Add dimensions of 25 and 30.
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9 Right-click the graphics window and select Done from the context menu
to exit the General Dimension tool.

Delete and Add Dimensions

Next, you remove the existing dimensions and use the Auto Dimension tool
to quickly dimension the sketch.

TRY IT: Remove dimensions and add dimensions to the sketch

1 Hold down the SHIFT key while you select each of the dimensions on
your sketch.

2 When all the dimensions are selected, press DELETE to remove them.
3 Click the Auto Dimension tool on the 2D Sketch panel bar.

4 When the Auto Dimension dialog box is displayed, click Apply to accept
the default settings and begin to dimension the sketch.

Auto Dimension |:|
Curves ¥ Dimensions
¥ Constraints
10  Dimensions Required

@ Apply %J Remove | Done |

The dimensions are applied to the sketch.
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Notice that the Auto Dimension dialog box now indicates that two
dimensions are required. This is due to two missing Fix constraints.

5 Click Done on the Auto Dimension dialog box.

6 In the sketch, select and reposition dimensions so they are easier to read.
Your dimensions should look like the following figure.

50,00

2058

9.42 1000
L]

=16.00%
==

130.00
140.00

Close the file without saving changes.

Tips for Creating Dimensions

B Place critical dimensions using the General Dimension tool, and then use
Auto Dimension to speed up the dimensioning process. For remaining
objects to dimension, you may find it faster to automatically dimension
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all sketch geometry. You can then delete unwanted dimensions instead of
selecting sketch geometry individually for automatic dimensioning.

If Auto Dimension does not dimension your sketch appropriately, you can
experiment with selecting some of the sketch geometry to control how
automatic dimensions are applied.

If you use automatic dimensions, you may find it easier to accept sketch
default dimension values, and then edit them with correct values in an
order (large to small) so you can control sketch behavior.

Use geometric constraints when possible. For example, place a
perpendicular constraint instead of using a dimension value of 90 degrees.

Place large dimensions before small ones.
Incorporate relationships between dimensions.

Consider both dimensional and geometric constraints to meet the overall
design intent.

Modifying Sketches

After you create sketch geometry, you can refine and adjust the proportions
of the sketch by applying dimensions or geometric constraints. You can also
drag any unconstrained or underconstrained geometry.

Patterning Sketches

You can use the Circular and Rectangular pattern tools on the Sketch toolbar
to create patterns of your original sketch. The pattern geometry is fully
constrained. These constraints are maintained as a group, If you remove the
pattern constraints, all constraints to the pattern geometry are deleted.

Workflow overview: Create a circular sketch pattern

1
2

Use sketch tools to create the geometry to include in the pattern.

Click the Circular Pattern tool on the Sketch toolbar, and then select the
sketch geometry to pattern.

On the Circular Pattern dialog box, click Axis, and then select the point,
vertex, or work axis to use as the pattern axis.
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4 In the Count box, specify the number of elements in the pattern.

5 In the Angle box, specify the angle to use for the circular pattern.

6 Optionally, click More, and then choose one or more options:

Click Suppress to select individual pattern elements to remove from
the pattern. The geometry is suppressed.

Click Associative to specify that the pattern updates when changes
are made to the part.

Click Fitted to specify that pattern elements are equally fitted within
the specified angle. If not selected, the pattern spacing measures the
angle between elements instead of the overall angle for the pattern.

7 Click OK to create the pattern.

Workflow overview: Create a rectangular sketch pattern

1
2
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Use sketch tools to create the geometry to include in the pattern.

Click the Rectangular Pattern tool on the Sketch toolbar, and then select
the sketch geometry to pattern.

Click the Direction 1 button, and then select geometry to define the first
direction for the pattern.

In the Spacing box, specify the spacing between the elements.

Click the Direction 2 button, select geometry to define the second
direction for the pattern, and then specify the Count and Spacing.

Optionally, click More, and then choose one or more options:

Click Suppress to select individual pattern elements to remove from
the pattern. The geometry is suppressed.

Click Associative to specify that the pattern updates when changes
are made to the part.

Click Fitted to specify that pattern elements are equally fitted within
the specified angle. If not selected, the pattern spacing measures the
angle between elements instead of the overall angle for the pattern.

Click OK to create the pattern.

Creating Sketches



Tips for editing sketch patterns

You can modify the spacing between pattern elements, change the pattern
count and direction, change the pattern calculation method, and suppress
geometry in the sketch pattern. Right-click the sketch in the browser and
select Edit Sketch. Then right-click a pattern member in the graphics
window, and select Edit Pattern. On the pattern dialog box, revise values
as needed.

You can edit pattern dimensions. In the sketch, double-click the dimension
to change, enter a new value on the Edit Dimension box, and then click
the check mark. You can enter dimensions as equations, parameter names,
or specific values.

You can remove the associative relationship among pattern elements but
the geometry becomes individual curves and pattern editing options are

no longer available. Right-click a pattern member and then, on the pattern
dialog box, click More. Clear the Associative check box and then click OK.

Suppress one or more pattern elements to remove them from the pattern.
Right-click the sketch in the browser, and select Edit Sketch. Right-click
the pattern geometry to suppress and select Suppress Elements. Suppressed
pattern elements are not included in profiles and do not appear in drawing
sketches.

Pattern elements, including dimensions and sketch geometry used to define
axis and directions, can be deleted but not while the pattern is associative.
If you want to retain the relationships among the pattern elements, but
need to remove one or more instances, consider using Suppress to remove
them.

Delete Sketches

If a sketch was used in a feature, you cannot delete the sketch. You can edit
the feature sketch and delete sketch geometry, but the feature might not
update properly. You may need to edit the sketch or feature to recover the
feature.

Workflow overview: Delete a sketch

In the browser, select the sketch to delete.

2 Press DELETE or right-click and select Delete.
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NOTE To delete individual sketch curves, edit the sketch, select the curve, and
then press Delete.

You can remove dimensional constraints from a sketch, and allow the sketch
to resize as needed. Parts with adaptive features resize in when they are
constrained to fixed geometry.

Workflow overview: Delete sketch dimensions
1 Right-click the sketch in the browser and choose Edit Sketch.
2 Click the Select tool.

3 Right-click the dimension in the graphics window and select Delete.

NOTE If the sketch is part of a feature, click Update after you delete dimensions.

You can delete a sketch pattern or suppress selected elements of a sketch
pattern.

Workflow overview: Delete sketch patterns
1 In the browser, select the sketch, right-click and then select Edit Sketch.
2 Select the sketch pattern geometry to delete.

3 Right-click and select an option. The selection options are determined
by selected geometry:

B Non pattern geometry: Click Delete to remove the selected geometry.

B Pattern geometry: Select Delete Pattern to remove the entire pattern
or Suppress Elements to suppress selected pattern geometry.

B Non pattern and pattern geometry: Select Delete to remove non
pattern geometry, and select Delete Pattern to remove the entire
pattern, or select Suppress Elements to suppress selected pattern
geometry.

Learning about 3D Sketches

You are now familiar with sketching in 2D because it is much like sketching
on paper. You can also sketch in 3D, connecting points on X, Y, and Z planes
to create a three-dimensional shape. A 3D sketch provides a way to create a

path for 3D sweep features, such as those used in wiring, cabling, and tubing.
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When working in a 3D sketch, points can lie on any plane. Like 2D sketches,
you can constrain sketch geometry to control its shape, add dimensions, and
precisely position points relative to the last placed point.

One way to learn about sketching in 3D is to create a box.

TRY IT: Create a box and sketch 3D lines on X, Y, and Z planes

1 On the 2D Sketch panel bar, click the rectangle tool and create a rectangle
and then enter £ on your keyboard to use the shortcut to start the Extrude
command.

2 On the Extrude dialog box, enter any distance and click OK.

3 Right-click in the graphics window and choose Isometric View. On the
standard toolbar, click Display and choose Wireframe Display.

Now you have a 3D “space” in which to visualize the sketch.

4 On the standard toolbar, click the arrow beside the Sketch button and
select 3D Sketch. In the browser, a 3D sketch icon is added and the 3D
Sketch panel bar is activated.

5 On the 3D Sketch panel bar, click the Line tool. Notice that the 3D triad
displays with arrows to indicate the X, Y, and Z axes. The Autodesk
Inventor Precise Input toolbar may display, but you can sketch without
entering coordinates.

Click anywhere in space to start the line. On the 3D triad, click a plane
or arrow to change the sketch plane and then click to place another sketch
point. As you change sketch planes, notice the sketch grid for that plane
becomes active.

Bends might be automatically added as you sketch the lines. This setting
is controlled on the Sketch tab of the Application Options dialog box.

6 Continue to place points as needed, changing sketch planes as you go to
make sure that you are sketching in all dimensions. When finished,
right-click and select Done.

7 On the standard toolbar, click the Rotate tool and rotate the box in all
directions.

You can see that the 3D line has points on X, Y, and Z planes.

Now that you can see the line in the context of the box, start a new file and
experiment with creating a 3D sketch without the box. Because the file opens
with a 2D sketch active, click Return on the standard toolbar to close the
sketch, and then click Sketch » 3D Sketch.
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Sketch some 3D lines and then use some of the other tools on the 3D Sketch
panel bar:

B Use the General Dimension tool to dimension the lines.
B Use constraint tools to constrain 3D lines to other lines or points.

B Optionally, change the setting on the Sketch tab of the Application Options
dialog box to add or remove automatic bends in 3D lines.
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Working with Sketched
Features

In this chapter, you learn about parametric part modeling and the process for creating sketched
features on parts.

Parametric Part Modeling

A part model is a collection of features. Parametric modeling gives you the
flexibility to adjust the parameters that control the size and shape of a model,
and automatically see the effect of your modifications.

To create a 3D part model in Autodesk® Inventor™, you extrude sketch geometry,
sweep or project sketch geometry along a path, or revolve sketch geometry
around an axis. These models are often called solids because they enclose volume,
unlike wireframe models which only define edges. The solid models in Autodesk
Inventor are constructed of features.

You can also create surfaces with many of these operations. Use surfaces to
define shapes or aspects of the part body. For example, a curved surface can be
used as a termination plane for cuts in a housing.

You can edit the characteristics of a feature by returning to its underlying sketch
or changing the values used in feature creation. For example, you can change
the length of an extruded feature by entering a new value for the extent of the
extrusion. You can also use equations to derive one dimension from another.

Using Autodesk Inventor, you can create several kinds of features, including
sketched, placed, work, pattern, and library. Some features require that you
create sketches or paths, while others do not. Some represent visible geometry,
and some, such as work features, help you precisely position geometry on a
part. You can edit a feature at any time.
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Parent/child relationships exist between features, which means that one feature
controls another. There can be multiple levels of parent/child relationships.
A child feature is created after the parent feature, and cannot exist without a
parent feature. For example, you can create a boss on a casting, and it may or
may not have a hole drilled in it, depending on the application. The boss (the
parent) can exist without the hole (the child), but the hole cannot exist without
the boss.

base part child features rermoved finished part

Part Modeling Environment

The part modeling environment is active any time you create or edit a part.
In the part modeling environment, create or modify features, define work
features, create patterns, and combine features to create parts. Use the browser
to edit sketches or features, show or hide features, create design notes, make
features adaptive, and access properties.

Your first sketch for a part can be a simple shape. You can edit features after
you add them, so you can develop your design quickly. Throughout the design
process, add geometric and dimensional detail and constraints to improve
your models. Evaluate design alternatives by changing relationships and
constraints, or adding and deleting features.

The browser displays the part icon, with its features nested below. Surface
features and work features are nested, or consumed by default. To edit a feature,
right-click it in the browser or the graphics window. From the context menu,
select Edit Feature to revise the feature creation parameters or Edit Sketch to
revise the underlying sketch. To control nesting, or consumption of surface
and work features for all features, set the option using the Tools »
Applications Options, Part tab. To override consumption on a per-feature
basis, right click the feature in the browser, and then select Consume Inputs.
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Workflows

Before you begin, analyze the part to determine which features to create, and
the most efficient order in which to create them.

Answer these questions before you start to model your design:

B Are you creating a stand-alone part, a component in an assembly, or the
first of a family of parts?
Determine whether to create the part in a part file or within an assembly
file, and whether you create constraints using fixed values or equations.

B Which view of the part best describes its basic shape?
The most prominent feature in that view is usually the best feature to begin
modeling. The first feature in your part is called the base feature.

B Which features require the use of work planes and work points to position
the model geometry?

B What are the most important features of your part?
Create these features early in the modeling process so that the dimensions
of other features can be based on their dimension values.

B Which features of your part can be added with sketched features, and
which features can be added with placed features?

B Based on these feature decisions, which features should be created first?

Base Features

The first feature you create in a part is the base feature. The base feature is
most commonly based on a sketch profile, and represents the most basic shape
in the part. The base feature may also be an imported base solid (.sat or .step
file format). You can also create a work feature as the base feature.

You create additional features to complete your part. Since these features are
dependent on the base feature, good planning can dramatically reduce the
time required to create a part. After you plan your strategy, decide how to
create the base feature.
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Workflow overview: Create a parametric solid model and associated drawings

1 Create a part in a part file (.ipt) or assembly (.iam) file. If you are working
on a small assembly or it is early in the design process, consider creating
your part in a part file.

2 Use tools on the Sketch toolbar or panel bar to sketch the basic shape of
the base feature.
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Geometric constraints define the shape of objects in your sketch.

3 Analyze your sketch geometry and, if necessary, choose the appropriate
geometric constraint from the panel bar or from the Sketch toolbar.
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You can add or delete constraints later to modify the shape of the sketch.

Dimensions define the size of the objects in your sketch.

4 Click the General Dimension tool in the panel bar or from the Sketch
toolbar and apply dimensions.
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You can change the lengths of lines and the radii of arcs within the sketch
at a later time.

Extrude, revolve, sweep, loft, or coil the parametric sketch to create the
first, or base feature of the part.

Repeat the process to create additional features, selecting join, cut, or
intersect to complete the part.

Document the part in an Autodesk Inventor drawing file to create the
desired annotated 2D drawing views.

Any time during the part modeling process, you can create a drawing file
(.idw) and begin making a fabrication drawing of your part. Changes you
make to your part are automatically reflected in drawing views of the
part.
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Adding Sketched Features

Sketched part features depend on sketch geometry. The first feature of a part,
the base feature, is typically a sketched feature.
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You can select a face on an existing part, and sketch on it. The sketch is
displayed with the Cartesian grid defined. If you want to construct a feature
on a curved surface, or at an angle to a surface, first construct a work plane.

Each of the following operations creates a solid extrusion from a sketch profile.
Extrude, Revolve, Sweep, and Loft can also create surface extrusions:

Extrude

Revolve
Sweep
Loft

Coil
Rib

Projects a sketch profile along a straight path. Use to
create surfaces as well as solids.

Projects a sketch profile around an axis.
Projects a sketch profile along a sketched path.

Constructs a feature with two or more sketch profiles
sketched on multiple part faces or work planes. The
model transitions from one shape to the next, and can
follow a curved path.

Projects a sketch profile along a helical path.
Creates a rib or web extrusion from a 2D sketch.

The same procedure for creating a sketched base feature is used to create
additional sketched features.

Extrude Features

Use the Extrude tool to create a feature by adding depth to an open or closed

profile or a region.

B [n the Assembly environment, the Extrude tool is available on the Assembly
Panel bar when you are creating an assembly feature.

B In the Weldment environment, the Extrude tool is available on the
Weldment Panel bar when you are creating a preparation or machining

feature.

B In the Part environment, the Extrude tool is available on the Part Features
panel bar when you are creating an extrusion for a single part.

Workflow overview: Create a parametric solid model and associated drawings

1 Start with a sketch, or select a profile or region that represents the cross
section of the extruded feature you want to create. Open profiles cannot
be used when creating extrusions as assembly features.
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@T Click the Extrude tool to display the Extrude dialog box.
If there is only one profile in the sketch, it is automatically selected.

If there are multiple profiles, on the Shape tab, click Profile, and then
select the profile to extrude. Use Select Other to cycle through selectable
geometry, and then click to select.

In Output, click either the Solid or Surface button.

For base features, only Surface is available for open profiles. For assembly
extrusions, only Solid is available.

Click the Join, Cut, or Intersect button.

For assembly extrusions, only the Cut operation is available.

In Extents, on the drop-down menu, select the method to terminate the
extrusion. Some methods are not available for base features.

Distance: Enter the distance of the extrusion.

To Next: Click the direction of the extrusion.

NOTE To Next is not available for assembly extrusions.

To: Click a sketch point, work point, model vertex, work plane, or the
End termination plane.

From-To: Click the Start and End termination planes.
By default, the extrusion terminates on the maximum-distance plane

To and From-To extents: Click Minimum Solution to terminate on the
nearest-distance plan.

all: Click the direction of the extrusion or to extrude equally in both
directions.

NOTE If termination options are ambiguous, such as on a cylinder or irregular
surface, click the More tab, and then use Flip to specify direction

On the More tab, enter a Taper angle, if necessary.

In the graphics window, an arrow shows the taper direction.
Click OK.

The sketch is extruded.
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Close the file without saving.

Revolve Features

Use the Revolve tool on the Part Feature panel bar to create a feature by rotating
one or more sketched profiles around an axis. The axis and the profile must
be coplanar. If this is the first feature, it is the base feature.

Workflow overview: Create a revolved feature

1
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To begin, sketch a profile that represents the cross section of the revolved
feature you want to create. Except for surfaces, profiles must be closed
loops.

=)

If there is only one profile in the sketch, it is automatically selected.

Click the Revolve tool to display the Revolve dialog box.

If there are multiple profiles, on the Shape tab click Profile, and then
select the profile to extrude.

Use only unconsumed closed sketches in the active sketch plane.
Click Axis, and then select an axis from the active sketch plane.

Click Join, Cut, Intersect, or Surface. Surface outputs, along with cut and
intersect operations, are not allowed as base features.

In Extents, select Angle or Full.

Click a direction button to revolve the feature in either direction or
equally in both directions.

Results are previewed on the model.
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Sweep Features

Use the Sweep tool on the Part Features panel bar to create a feature by moving
or sweeping one or more sketched profiles along a selected path. The path
may be an open or closed loop, but must pierce the profile plane. Except for
surfaces, profiles must be closed loops.

There are three ways to create sweeps. You can create a sweep surface by:
B Sweeping a profile along a path.

B Sweeping a profile along a path and guide rail. The guide rail controls scale
and twist of the swept profile.

B Sweeping a profile along a path and guide rail. The guide rail controls scale
and twist of the swept profile.
Workflow overview: Create a sweep feature along a path

1 To start, sketch a profile and then sketch a path on an intersecting plane.

2 % Click the Sweep tool.
If there is only one profile in the sketch, it is automatically highlighted.

If there are multiple profiles, click Profile, and then select the profile to
sweep.

3 Click Path, and select a 3d sketch or planar path sketch
4 From the Type list, select Path.

5 Click the orientation for the path.
B Path holds the sweep profile constant to the path.

B Parallel holds the sweep profile parallel to the original profile.
6 Enter a Taper angle, if desired.
In the graphics window, a symbol shows taper direction.

7 Click Join, Cut, Intersect with another feature. Some methods are not
available for base features.

8 Click Solid or Surface.
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Click OK.
The sweep feature is created.

Loft Features

Use the Loft tool on the Part Features panel bar to blend or transition between
the shapes of two or more profiles (called sections) on work planes or part
faces. You can create a simple loft, a loft with rails (path), or a centerline loft.
You can also select a point for one or both end sections of an open loft.

To use an existing face as the beginning or end of a loft, create a sketch on
the face so the edges of the face are selectable for the loft. If using the loop of
a planar or non planar face, select it directly without creating a sketch on the
face.

Workflow overview: Create a loft or loft with rails feature

1
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Sketch profiles on separate planes to represent cross sections of the loft
feature.

@ Click the Loft tool to display the Loft dialog box.
On the Curves tab, in Output, click solid or surface.

Click in Sections and then click the profiles to loft in the sequence you
want the shapes to blend. If you select multiple profiles on any plane,
they must intersect.

NOTE If there is more than one loop in a sketch, first select the sketch, and
then select the curve or loop.

Optionally, click the Rails button to designate guide paths, and then click
to add 2D or 3D curves for shape control. Sections (profiles) must intersect
rails (guide paths). This option is not available when rail curves are
specified.
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6 If appropriate, click the Closed Loop check box to join the beginning
and ending profiles of the loft.

7 If appropriate, click the Merge Tangent Faces check box so that an edge
is not created between tangent faces.

8 In Operation, click Join, Cut, or Intersect.

9 On the Conditions tab, the start and end profiles are listed. Click each,
and specify a boundary condition:
Free Condition Apply no boundary conditions. It is the default.

Tangent Condition If you selected a loop or the profile is in a separate
sketch on the boundary of a face. Creates a loft
tangent to the adjacent faces.

Direction Condition Specify an angle measured relative to the section
or rail plane. Set the angle and weight of the condi-
tion.

Smooth (G2) Condi- Creates a loft curvature continuous to the adjacent
tion faces.

10 On the Transition tab, Automatic Mapping is selected by default. If
desired, clear the check box to modify automatically created point sets
or add or delete points.

B Click the point set row to modify, add, or delete.

B A default calculated map point is created for each profile sketch. Click
position to specify a unitless value. Zero represents one end of the
line; one represents the other end. Decimal values represent positions
between ends.

11 Click OK to create the loft.

Coil Features

Use the Coil tool on the Part Features panel bar to create a helix-based feature.
Use this feature to create coil springs and threads. If the coil is the first feature
created, it is the base feature.
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Workflow overview: Create a coil spring

1 To begin, sketch a profile that represents the cross section of the coil
feature, and then use the Line tool or the Work Axis tool to create an axis
of revolution for the coil.

2 g Click the Coil tool. The Coil dialog box is displayed.
If there is only one profile in the sketch, it is automatically highlighted.

3 If there are multiple profiles, click Profile, and then select the profile.

4 Click Axis.
It can be at any orientation but cannot intersect the profile.

5 On the Coil Size tab, click the down arrow on the Type box, and then
select one of the following types:
Pitch and Revolution
Revolution and Height
Pitch and Height
Spiral
Enter the Pitch, Height, Revolution, or Taper as appropriate. Taper is not
available for a Spiral.

6 On the Coil Ends tab, choose one of the following methods to define the
start and end of the coil, for example, to stand upright on a flat surface:

Flat Create a transition in the pitch of the coil. Enter a
Transition Angle and then a Flat Angle (up to 360
degrees).

Natural End the coil without transition.

&

Rib and Web Features

Use the Rib tool to create ribs (thin-walled closed support shapes) and webs
(thin-walled open support shapes).
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Use the Zoom and Rotate tools to position the part so the face where the rib
is located is visible.

Workflow overview: Set the sketch plane and create profile geometry for a
rib
1 Create a work plane to use as the sketch plane.

2 On the Standard toolbar, click the 2D Sketch tool, and then click the
work plane or a planar face to set the sketch plane.

3 Use the Look At tool to reorient the sketch.

4 Use tools on the 2D Sketch panel to create an open profile to represent
the rib shape.

Workflow overview: Create a rib

1 &l Click the Rib tool on the Part Features panel bar, and then click the
profile, if it is not already selected.

2 Click the Direction button to set the direction of the rib.
Pause the cursor over the open profile to see direction arrows that indicate
if the rib extends parallel or perpendicular to your sketch geometry.

3 The Extend Profile check box is displayed if the ends of the profile do
not intersect the part.
The ends of the profile automatically extend. If you prefer, clear the check
box to create a rib or web the exact length of your profile.

4 In the Thickness box, enter the rib thickness.
Click a Flip button to specify the direction of the rib thickness.

5 Click one of the following buttons to set the depth of the rib:

(Y
B

To Next Terminate the rib on the next face.

Finite Enter a value in the box to set a depth.
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6 Optionally, in the Taper box, enter a taper or draft value. The direction
must be perpendicular to the sketch plane to apply a taper value.

7 Click OK to create the rib.

NOTE To create a rib or web network, sketch multiple intersecting or non-
intersecting profiles on the sketch plane, and then follow the previous steps.

Modifying Features

There are several methods available to modify an existing feature. In the

browser, right-click a feature, and then use one of three options on the menu:

Show Dimensions  Displays the sketch dimensions so you can edit them.
B Change the dimensions of a feature sketch.

B Change, add, or delete constraints

Edit Sketch Activates the sketch so it is available for edit.
B Select a different profile for the feature

After you modify a part sketch, exit the sketch and the
part is updated automatically.

Edit Feature Opens the dialog box for that feature.
B Choose a different method to terminate the feature

B Choose whether the feature joins, cuts, or intersects
another feature.

3D Grips Uses grip handles to drag a feature or face, or snap to
other geometry to resize a feature. Arrows indicate the
drag direction. The feature preview shows the expected
results before you commit to the change.
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Creating and Editing
Placed Features

In this chapter, you learn about placing and editing part features. Exercises step you through
creation of holes, fillets, chamfers, threads, shells, circular and rectangular patterns, mirror

features and analyzing faces.

Adding Placed Features

Placed features are common engineering features that do not require a sketch
when you create them with Autodesk® Inventor™. When you create these
features, you usually provide only the location and a few dimensions. The
standard placed features are shell, fillet, chamfer, face draft, hole, and thread.

Here are some of the tools for placed features, located on the Part Features panel

bar:

Fillet
Chamfer

Hole
Thread

Shell
Rectangular Pattern
Circular Pattern

Mirror Feature

Places a fillet or round on selected edges.

Breaks sharp edges. Removes material from an outside
edge and can add material to an inside edge.

Places a specified hole in a part, optionally with thread.

Creates regular and tapered external and internal threads
on cylindrical or conical faces.

Produces a hollow part with a wall thickness you define.
Creates a rectangular pattern of features.
Creates a circular pattern of features.

Creates a mirror image across a plane.
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Dialog boxes define values for placed features, such as the Hole dialog box in
the following illustration.

Hole Features

With Autodesk Inventor, you can create different types of holes:

Drill
Counterbore
Countersink

Spotface

You can specify hole depth using one of three termination options: Distance,
Through All, and To.

Use the Drill Point option to set flat or angle drill points.

Holes also can be classified as simple hole, clearance hold, tapped hole, or
taper tapped hole. However, you cannot create a taper tapped hole of
counterbore type.

When you create a tapped hole or taper tapped hole, the tap data is stored
with the hole, and the threads are displayed when any isometric view is active.

TRY IT: Create a hole feature on a part

1
2
3
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With the project tutorial_files active, open the file Upper_Plate.ipt.
On the Part Features panel bar, click the Hole tool.

On the Holes dialog box, Placement, select Linear from the drop-down
list.

Click the Face button, and then in the graphics window, click the face
where you want to place the hole

Click an edge of the face to specify Reference 1, and then click another
edge of the face to specify Reference 2.

The reference dimensions from each edge are displayed. You can
double-click each dimension and enter changes to define placement of
the hole.

Select the first hole type, Drilled, and then enter a diameter of .25 in.
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7 In Termination, select Through All.

Hole =

Flacement:
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8 Click OK.

The hole you defined is placed on the face.

Close the file without saving or save the file under a different name to
preserve the original data file.

You can specify hole depth using one of three termination options: Distance,
Through All, and To.

TRY IT: Place a hole feature using arc centers

1 With the project tutorial_files active, open file hole.ipt.
The part looks like the following figure.

2 Click the Sketch tool on the Standard toolbar, and then click the
rectangular face.
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The edges of the face and arc centers are projected onto the new sketch,
allowing you to position the hole features.

3 In the graphics background, right-click, and then click Finish Sketch to
close the sketch.

4 Click the Hole tool in the Part Features panel bar to display the Holes
dialog box.

In the preview window, edit the value of the hole diameter to read 6 mm.
5 Click the four arc centers.
6 In Termination, select Distance.

7 In the preview window, edit the value of the hole diameter to read 6 mm.
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8 Click OK.

The hole feature is created, and is added to the browser. Notice that one
feature defines all four holes.
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Close the file without saving or save the file with a new name to preserve
the original data file.

Fillet Features

Fillet features add fillets or rounds to one or more part edges, between two
faces or face sets, or between three adjacent faces or face sets. Fillets add
material to interior edges to create a smooth transition from one face to
another. Rounds remove material from exterior edges. You can create
constant-radius and variable-radius edge fillets and edge fillets of different
sizes in a single operation. For edge fillets, tangent (G1) or smooth (G2)
continuity can be applied to adjacent faces. You specify values in a dialog box
and select the edges to create the fillet.

For edge fillets you can use the All Fillets and All Rounds selection modes to
apply fillets to multiple edges as shown in the following figure.

O O

The corner style can be set to either rolling ball or blend.
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When you create variable radius edge fillets and rounds, you choose between
a smooth blend from one radius to another and a straight blend between radii.
The method you choose depends on your part design and the way adjacent
part features blend into the edge.

You can also specify points between the start and endpoints of a selected edge,
and then define their relative distances from the start point and their radii.
This technique provides flexibility when creating variable radius edge fillets
and rounds.

This illustration shows smooth and straight transitions on variable-radius
rounds.

You can model special fillet applications where more than three edges
converge. Choose a different radius for each converging edge, if needed.

&6

To find the radius of an existing fillet, right-click the feature in the browser,
and then choose Show Dimensions. The fillet radius is displayed on your part.

For information on face fillets and full round fillets, refer to “fillet features”
in the Help index.
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Chamfer Features

Chamfers are like fillets, except that the edge is beveled rather than rounded.
When you create a chamfer on an interior edge, material is added to your
model. When you create a chamfer on an exterior edge, material is cut away
from your model.

When you create a chamfer, you can specify one of three operations:
B Distance
B Distance and Angle

B Two Distances

e

A distance chamfer creates a face at an equal distance along the two faces that
meet at the selected edge. A Distance and Angle chamfer is established at a
distance from the edge and at an angle from a selected face. A two distances
chamfer creates a face at different offset distances from the edge.

] I i
{7 |+ |1

distance distance and angle two distances

Chamfers and Fillets

In this exercise, you add chamfer and edge fillet features to complete the shaft
socket bracket model.

The completed model is shown in the following figure.
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TRY IT: Add a chamfer

1 With the project tutorial_files active, open the file chamfillet.ipt.
The file contains a model of a shaft socket bracket.

2 Click Chamfer from the Part Features panel bar.

3 On the Chamfer dialog box, click the Edges button, and then select the
four vertical edges of the base.

NOTE You may need to rotate the model to select the appropriate edges.
Press F6 to return to the default isometric view.

4 In Distance, enter 10 mm, and then click OK.

The chamfers are added to the model and the browser
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Next, you add equal distance chamfers to top-hole edges.

Click Chamfer, and then select the top edge of each of the three holes
in the part.

On the Chamfer dialog box, change the distance to T mm, and then click
OK.

Next, you add different distance chamfers to complete the basic shape
of the socket support.

Click Chamfer, and then click the Two Distances button. Select the edge
shown in the following figure.
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edge selection

&

8 Enter the following values:

Distance 1: 14 mm
Distance 2: 18 mm

Click the Direction button to see how the preview changes when the
distances are switched.

9 Click the Direction button again to return to the original settings, and
then click OK to create the chamfer feature.

10 Repeat this process to add the same size chamfer to the other side of the
part.

Your part should now look like the following figure.

Next, you add fillets to complete the final shape of the part.
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TRY IT: Add fillets to a part

1 Click Fillet from the Part Features panel bar and ensure that the Edge
Fillet button is selected. Select the two edges shown in the following
figure.

two selected edges

2 Rotate the part, and then select the same two edges on the other side. In
the Fillet dialog box, on the Constant tab, change the radius to 16 mm.

3 Under the edges and radius text, click the line that reads Click to Add.
For the next set of edges, select the two vertical edges at the corners at
the top of the part.

4 Change the radius for the fillet to 32 mm. When your dialog box and
preview look like the following figures, click OK.

Fillet EE
(5 constart | (5 varisble | £ setbacks |
b

| Edges | Radius |
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Click to add

Select mode
& Edge

" Loop

£ Featurs

[~ AllFilets
[ all Rounds

@I [o]4 I Cancel | il
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The fillet feature is added to the part and to the browser.

&

5 Click Fillet, and then select the two horizontal edges on the front of the
rib, as shown in the following figure.

two selected edges

6 On the Fillet dialog box, enter 30 mm for the radius.

7 To add another set of edges, click the Click to Add text, and then select
the two horizontal edges shown in the following figure.
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two selected edges

8 On the Fillet dialog box, change the radius for the second selection set
to 22 mm. Click the Click to Add text to create a third set of edges.

9 Rotate the model and select the horizontal edge on the back face directly
opposite the second selection set. Enter 10 mm for the radius. When your
dialog box and preview look like the following figures, click OK.
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Fillet preview
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11

12

13

14

Fillet feature added to part

Click Fillet, and then select the three edges where the rib meets the
cylinder at the top of the part. Change the radius to 2 mm, and then click

OK.
.

intersection of rib
and cylinder

Click Fillet. Select the two front edges of the rib, and then select the back
edge of the rib (A). These edges are added to the selection set.

Select the three edges on each side where the base meets the other features

(B).

On the Fillet dialog box, select the Loop option in the Select Mode section.
Select anywhere on the back edge of the part above the base (C). Notice
how the Loop option automatically selected additional edges.

Verify that the fillet radius is set to 2 mm. When your preview looks like
the following figure, click OK. The fillet fails, and an error box is displayed.
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15 In the Error box, click Edit.

16 On the Fillet dialog box, select the Edge selection mode. Press SHIFT while
you select the six edges where the base meets the other features of the
part. When these edges are removed from the selection set, click OK.

17 Add a 2 mmfillet to the edges where the base meets the other features of
the part. Notice how the fillets from Fillet 4 connect all the edges so only
one selection point is required on each side.

The completed part looks like the following figure.
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Close the file without saving or save the file with a new name to preserve
the original data file.

Tips for Working with Fillets

To edit a fillet, right-click the fillet name in the browser and select Edit
Feature.

To edit only the dimensional value of a fillet, double-click the fillet name
in the browser. In the Edit Dimension box, change the value of the fillet.

Alternately, you can change the select priority to Feature Priority, and then
double-click a fillet on the part to display the dimensions.

After editing a fillet, click the Update tool to update the part.

Thread Features

In this exercise, use the Thread tool to create a thread feature on mating faces
of a plastic bottle and cap.

TRY IT: Add threads

1 With the project tutorial_files active, open the file threads.iam. The file

contains a model of a plastic bottle and cap.
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2 Use Zoom Window to zoom in on the bottle top and cap.

3 Use Zoom Window to zoom in on the bottle top and cap.
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4 In the graphics window or browser, select the cap, and then right-click
and clear the check mark on Visibility in the context menu.

5 In the graphics window or browser, double-click the bottle to activate
editing mode.

6 Click the Thread tool on the Part Features panel bar.

7 On the Location tab, enter settings to match the following figure.

Thread Feature (5]
Location |Specificati0n ]

h Face Iv Display in Model

Thread Length

Iv Full Length J
| O ol

@ oK | Cancel |

8 Select the split surface as shown in the following figure.

Notice how the thread is previewed on the model.

9 Select the Specification tab, adjust settings as necessary to match the
following figure, and then click OK.
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10

11
12
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The Thread feature is created, as shown in the following figure, and is
added to the browser.

NOTE You can temporarily change the part color to see the threads more
easily. On the Standard toolbar, click the arrow on the Styles box and choose

a different color.

Click the Return button to exit edit mode for the bottle, and then turn

off visibility for the bottle.

In the browser, double-click cap:1 to activate editing mode.

Repeat steps 5 through 8 and select the inside surface of the cap as shown

in the following figure.

The thread is completed, as shown in the following figure.
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13 Double-click the assembly in the browser, turn on visibility of the bottle,
and then restore the Isometric view.

Your completed model should look like the following figure.

Close the file without saving or save the file with a new name to preserve
the original data file.

Shell Features

The Shell tool creates a hollow cavity in a part with walls of a specific thickness.
It removes material from a part by offsetting existing faces to create new ones
on the inside, outside, or both sides of the part. Use the shell feature to create
multisided parts like casings or enclosures. A part can have multiple shell
features.

—
When you start the shelling process, you specify which part faces to remove
or offset, and you can specify a unique wall thickness for each face on a part.

Use the Shell tool on the Part Features panel bar to remove material from a
part interior, creating a cavity with walls of a specified thickness. By default,
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Autodesk Inventor provides a precise shell feature. If a precise solution does
not exist and approximation is enabled, an approximation is attempted.

Start with a single feature, a part, or a part in an assembly.

Workflow overview: Create a shell feature

1

2
3

5
6

For this exercise, create a simple block or cube.

z After you extrude the sketch profile, click the Shell tool.

In the graphics window, select the face or faces to remove.

On the Shell dialog box, click one of the three direction buttons, Inside,
Outside, or Both, to specify the direction of the shell from the surface of
the selected face.

Enter a value for the face thickness.

Click OK.

This time, create a shell feature with varying shell thicknesses.

Workflow overview: Create a shell feature with varying thicknesses

1
2
3

Select the shell feature in the browser, and then press the Delete key.
Click the Shell tool, and then select the faces to remove.

On the Shell dialog box, click a direction button (Inside, Outside, or Both)
to specify the direction of the shell from the surface of the selected face.

Enter a value for the face thickness.
Click the More button in the Shell dialog box.

Select Click to Add, and then select a face and enter a specific shell
thickness for it.

In Unique Face Thickness, enter a value that is different from the value
for the main shell thickness.

Click OK to create the shell.

Close the file without saving or save the file with a new name to preserve
the original data file.
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Creating Pattern Features

Many designs call for the repetitive use of one or more features on a single
part. Single features or groups of features can be duplicated and arranged in
patterns. A pattern feature is a rectangular, circular, or mirrored duplication
of features or groups of features. Individual occurrences in a pattern can be
suppressed, as necessary. An example of a pattern feature is a rectangular
pattern of identical holes cut from a calculator case.

NOTE Features that you can pattern include part features, surface features, and
assembly features.

The pattern tools require reference geometry to define the pattern. You can
create patterns using the Rectangular Pattern, Circular Pattern, and Mirror
Feature tools. You can set the number of occurrences in the pattern, the angular
spacing between occurrences, and the direction of the repetition.

Pattern creation methods include:

Identical All occurrences use an identical termination.

Adjust to Model The termination of each occurrence is calculated indi-
vidually.

Optimized Creates a copy and reproduces faces instead of features.

Optimizes patterns for faster calculation.

You can suppress components in a component pattern without removing
them from the assembly. It makes it easy to replace parts and to create unique
members in assemblies.

Rectangular Patterns

Features can be duplicated and arrayed in a rectangular or circular pattern. In
the first part of this exercise, you create a single hole and then use it to add a
rectangular pattern of holes to a plastic cover plate. You also complete an
exercise that uses a circular pattern.

The following is an illustration of the completed exercises.
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TRY IT: Create a hole feature

1 With the project tutorial_files active, open the file recpattern.ipt.

2 On the Part Features panel bar, click the Hole tool.

3 On the Hole dialog box, in the Placement box, select Linear. Click the
Face button, and then select the top face of the part.

4 In the Hole dialog box, click the Referencel button.

5 In the graphics window, click the leftmost edge of the part for Reference
1, and then the bottom edge for Reference 2.

Dimensions from the part edges to the hole center are displayed.

6 Edit the dimensions to 20 mm from the leftmost edge, and 710 mm above
the bottom edge, as shown in the following illustration.

&
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7 On the Holes dialog box, Termination, select Through All, and verify that
the hole diameter is 3 mm.
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8 Click OK to create the hole in the part according to the specifications
you entered.

Add Hole Patterns

Use the hole feature you just created to create a hole pattern.

TRY IT: Create a hole pattern from a hole feature
1 On the Part Features panel bar, click Rectangular Pattern.

2 In the graphics window, click the hole feature.
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3 On the Rectangular Pattern dialog box, click the Direction 1 button, and
then click the bottom horizontal edge of the part.

Click the Flip button to change the direction, if needed.

4 Verify that Spacing is selected in the drop-down list, and then in the
Column Count field enter 5, and in Column Spacing enter 17.5 mm.
A preview of the pattern is displayed in the graphics window for Direction
1.

5 Click the Direction 2 Select button, and then click the leftmost vertical
edge of the part.

6 Verify that Spacing is selected in the drop-down list, and then in the
Column Count field enter 4, and in Column Spacing enter 17.5 mm.

In the graphics window, the preview of the pattern includes the
occurrences in Direction 2.
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7 Click OK to create a rectangle hole pattern.

In the next portion of this exercise, you suppress pattern occurrences.
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Suppress Pattern Occurrences

A review of the design intent for the part shows that two unneeded occurrences
were added. You can suppress all or individual occurrences in a pattern.

TRY IT: Suppress pattern occurrences

1 In the browser, Expand Rectangular Pattern1 to display the occurrences.

Point to the occurrences. As the cursor points to each occurrence, it is
highlighted in the graphics window.

2 Highlight the occurrence that did not execute. Press CTRL as you
right-click the occurrence, and then click Suppress on the menu.

3 Suppress the two occurrences shown in the following figure.

_‘\\

. ‘—‘_|7 ocourrences to

SUppress

The occurrences are suppressed, and your part looks like the following
figure.

Close the file without saving or save the file with a new name to preserve
the original data file.
Circular Patterns

In a previous exercise, you added hole features to a cylinder head for a face
valve pump. In this exercise, you create a circular pattern using the
counterbored hole.

94 | Chapter 4 Creating and Editing Placed Features



TRY IT: Create a circular pattern

1 With the project tutorial_files active, open file circpattern.ipt.

4

2 On the Part Features panel bar, click the Circular Pattern tool.
3 On the lower flange of the part, click the counterbored hole feature.

4 On the Circular Pattern dialog box, click the Rotation Axis button, and
then in the browser, click Work Axis1.

A preview of the pattern is displayed.

5 In Placement » Count, verify that the value is 6.

In this example, you can enter an incremental value of 60 or a fitted
value of 360 for the positioning method.

6 Click the More button. In Positioning Method, verify that Fitted is
selected.
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7 Click OK to create a circular pattern.

Close the file without saving or save the file with a new name to preserve
the original data file.

Mirror Features

You can mirror part, surface, and assembly features to create and maintain
symmetry. By using a mirror feature, you can also reduce the amount of time
required to create a model. You can mirror individual solid features, work
features, surface features, or the entire solid. A mirror of the entire solid allows
mirroring of complex features such as shells included in the solid.
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Workflow overview: Mirror a part

1

Create a part body to mirror. Create a work plane to serve as a mirror
plane or, if you prefer, use a planar face as the mirror plane.

/N

On the Mirror Pattern dialog box, click the Mirror Entire Solid button.

On the Part Features panel bar, click the Mirror Feature tool.

Click the Mirror Plane button, and then select a work plane or planar
face.

Click OK.

Patterns Along Paths

Use the Rectangular Pattern tool to create patterns of features that are placed
along a 3D path. You can choose a surface or model body edge, work axis,
line, arc, planar face, work plane, spline, or trimmed ellipse as the path for
creating patterns.

Workflow overview: Create a rectangular pattern along a path

1 Create a part with a feature to pattern. Create a 3D path to use for

patterning. If desired, you can use the edges of the feature to indicate
direction for the path.
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Click the Rectangular Pattern tool.

In the Rectangular Pattern dialog box, select the Pattern Individual
Features option.

Click the Features button and in the graphics window or in the model
browser, select features to arrange in a pattern.

Click the Path selection button, and then select the path. Click Flip to
change the column direction, if appropriate.

Enter the count (number of features) for the column, and then click the
drop-down arrow to specify pattern length. Select one of the following
options:

spacing: Enter distance between features.

Total distance: Enter distance of the column.

curve length: Length of selected curve is automatically entered.
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To create a pattern with multiple rows, click Direction 2, and then set
the row direction, count, and spacing, distance, or curve length.
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If appropriate, click the More button to set a start point for one or both
rows, set Termination Method, and Orientation Method:

B If appropriate, click Start, and then click a point on the path to
indicate the start of one or both columns. If path is a closed loop, a
start point is required.
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B Under Compute, select Optimized to create optimized pattern,
Identical to create identical features, or Adjust to Model to terminate
features when encounter a face.

B Under Orientation, select Identical to orient all features the same as
the first selected, or Direction 1 or Direction 2 to specify which path
controls the rotation of pattern features.

9 Click OK.

Suppress Pattern Occurrences

You can temporarily suppress the display of one or more solid or surface
features in a pattern. You can also hide all or some work features. Features
remain suppressed until you restore them.

Workflow overview: Control visibility of solid features

B To suppress all occurrences, select the pattern icon in the browser,
right-click, and then select Suppress.

B To suppress an individual occurrence, expand the pattern icon in the
browser, select the occurrence, right-click, and then select Suppress.

B To restore all occurrences, select the pattern icon in the browser, right-click,
and then select Unsuppress Features.

m To restore individual occurrences, expand the pattern icon in the browser,
select the occurrence, right-click, and then select Unsuppress.

NOTE Occurrences that were suppressed individually must be restored individually.
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Analyzing Parts

Analyzing solids and surfaces provides information for validating the geometric
quality before manufacturing. You can save several different analyses of the
same or different types for a specific model. For example, you can define
several ways to analyze a particular set of surfaces on the same model.

Once an analysis is applied, an Analysis folder is created in the browser and
the analysis is placed in the folder. Each saved analysis is added to the browser
in the order it is created. In the browser, the name and visibility of the active
analysis is displayed along with the analysis folder name. For example, Analysis:
Zebral (On).

You can use the Analysis folder in the browser to change the visibility of the
active analysis and create new analyses. Expand the Analysis folder to view
and manage all other saved analyses. You can switch the active analysis or
edit, copy, and delete any saved analysis in the list.

The types of analysis you can perform include:

Zebra Analyzes surface continuity by projecting parallel lines
onto the model. Results show how light reflects off the
surface to help you identify areas where the surface
quality must be improved.

Draft Evaluates if a model has adequate draft between a part
and mold (based on the pull direction) and can be
manufactured by casting. A spectrum shows draft angle
changes within a specified range.

Curvature comb Provides a visual analysis of the curvature and overall
smoothness of model faces, surfaces, sketch curves,
and edges.

Gaussian curvature Evaluates areas of high and low surface curvature using
a color gradient display on part surfaces. The gradient
display is a visual indication of surface curvature that
uses the Gaussian curvature analysis calculation.

Cross section Provides a basic graphic view of the part at one section
or detailed information and corresponding graphic
about multiple sections of the interior of solid parts.
It also analyzes whether the part adheres to the mini-
mum and maximum wall thickness.
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Workflow overview: Create and use analyses
1 Open a part file or double-click a part in an assembly.

2 Click Tools » Analysis or click the arrow on the Analysis Visibility tool,
and then select the type of analysis to create.

3 On the setup dialog box for the analysis, adjust the analysis settings as
needed.

Apply the analysis.
Change visibility on the active analysis as needed.

Use the Model browser to edit, copy, delete, and rename saved analyses.

N O w»n »

Optionally, create additional analyses for selected models and switch
between them as needed.

Create Zebra Analyses

The zebra analysis evaluates faces by projecting parallel lines onto the model.
Results show curvatures on the face to help identify areas that may be flat
(stripes are parallel) or that are not continuously tangent (stripes are jagged
where the curvature is not constant).

The active analysis is marked as On, for example, Analysis: Zebral (On). You
can create an analysis based on an existing analysis. You specify the direction
that shows the most contrast between stripes to indicate transition between
surfaces, stripe thickness by relative proportion of black to white, and opacity
of stripes.
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Workflow overview: Create a Zebra Analysis

1
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Open a part file or double-click a part in an assembly to in-place edit the
part.

Click the arrow by the Analysis Visibility tool, and then select New Zebra
Analysis from the list.

NOTE After the initial analysis is saved, you can right-click the Analysis folder
in the Model browser, and then select New Zebra Analysis from the context
menu.

If appropriate, double-click the name to enter a custom name.
Specify horizontal, vertical, or radial direction.

Specify stripe thickness and density.

Specify the opacity of stripes.

Specify the display quality.

Select All, Faces, or Quilts and then select the appropriate geometry.

Click OK to analyze. If you prefer, click Apply to analyze and keep the
dialog box open and continue to change settings and analyze as needed.

Create Draft Analyses

The draft analysis evaluates model faces for adequate draft between a part and
mold based on the pull direction. Results show as a range of colors on the
model by a specified angle range.

You can create an analysis based on an existing one. You specify the degree
range to analyze for draft or draft angle, and select if draft analysis results are
displayed in a gradient or in discrete color bands.

Workflow overview: Create a draft analysis

1

Open a part file or double-click a part in an assembly to in-place edit the
part.

Click the arrow by the Analysis Visibility tool, and then select New Draft
Analysis from the list.

If appropriate, enter a custom name.
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Click New. If appropriate, double-click the name to enter a custom name.

Specify the degree range (relative to the pull direction) to analyze for
draft angle.

Select Gradient to display results in a gradient rather than stripes.
Select All, Faces, Quilts, and then select the appropriate geometry.

Click an edge, axis, or planar face to specify pull direction or click Flip
to reverse the direction.

Click OK.

For details on creating other types of analyses, refer to the Autodesk
Inventor Help index under analysis.
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Creating and Editing
Work Features

In this chapter, you learn about creating and editing work features.

Defining Work Features

Work features are abstract construction geometry that you can use when other
geometry is insufficient for creating and positioning new features. To fix position
and shape, constrain features to work features.

Work features include work planes, work axes, and work points. The proper
orientation and constraint conditions are inferred from the geometry you select
and the order in which you select it.

The work feature tools provide on-screen prompts to help you with selection
and placement. You can:

Create and use work features in the part, assembly, sheet metal, and 3D
sketch environments.

Use and refer to work features in the drawing environment.
Project work features into a 2D sketch.

Create in-line work features to help you define a 3D sketch or position a
part or assembly feature.

Make work features adaptive.
Turn the visibility of work features on or off.

Drag to resize work planes and work axes.
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Work Planes

A work plane is a flat plane extending infinitely in all directions along one
plane. A work plane is similar to the default origin YZ, XZ, and XY planes.
However, you create the work plane as needed, using existing features, planes,
axes, or points to locate the work plane.

Use a work plane to:

B Create a sketch plane when no part face is available to create 2D sketched
features.

Create work axes and work points.

Provide a termination reference for an extrusion.
Provide a reference for assembly constraints.
Provide a reference for drawing dimensions.

Provide reference for a 3D sketch.

Project into a 2D sketch to create curves for profile geometry or reference.

The following illustrations show some of the methods you can use to define
a work plane.

Work Axes

A work axis is a straight vector extending infinitely in two directions. A work
axis is similar to the default origin X, Y, and Z axes, however, you create the
work axis as needed, using existing features, planes, or points to locate the
work axis.

Use a work axis to:
B Create work planes and work points.
B Project into a 2D sketch to create curves for profile geometry or reference.

B Provide a line of rotation for a revolved feature.
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Provide a reference for assembly constraints.
Provide a reference for drawing dimensions.
Provide reference for a 3D sketch.

Provide reference for a circular pattern.

Create lines of symmetry.

The following illustrations show some of the methods you can use to define
a work axis.

R Y

Work Points

A work point is a point that exists relative to, and is dependent on, features
or work features. A work point is similar to the default origin center point,
however, you create the work point as needed, using existing features, planes,
or axes to locate the work point.

Use a work point to:

To create work planes and work axes.

Project into a 2D sketch to create a reference point.
Provide a reference for assembly constraints.
Provide a reference for drawing dimensions.
Provide a reference for a 3D sketch.

Define coordinate systems.

The following illustrations show some of the methods you can use to define
a work point.
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Grounded Work Points

A grounded work point, like all work points, depends on an associated feature
to determine its location. A grounded work point uses features or work features
to initiate the grounded work point tool, but its position is then fixed in space
and not dependent on, or associated to, those or other features.

You can use a grounded work point in the same ways that you would a work
point. However, the grounded work point remains fixed in space regardless
of changes to model geometry. You can move a grounded work point with
the 3D Move/Rotate tool.

Workflow overview: Define a grounded work point

1 On the Part Features panel bar, click the arrow on the Work Point tool
and click Grounded Work Point.

2 Select a vertex, sketch point, or work point to initiate the 3D Move/Rotate
tool. A pushpin cursor symbol indicates the selection is grounded.

3 The 3D Move/Rotate tool axes are aligned with the principal axes of the
part. Click or drag an axis or center of the tool, and then enter values in
the 3D Move/ Rotate dialog box, and click Apply.
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4 Continue to revise the position of the work point. When finished, click
OK.

Modifying Work Features

Other than the grounded work point, all work features are associated to the
features or geometry used to create them. If you modify or delete the locating
geometry, the work feature changes accordingly. Conversely, any feature or
geometry that is dependent on a work feature for its definition is also affected
by changes to the work feature. Both scenarios are shown in the following
illustrations.

The work plane was created at a 45 degree angle to the top face.

=

The hole was created from a sketch on the work plane, making the hole
dependent on the work plane.
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A work axis was added to the hole, making the work axis dependent on the
hole.

If the angle of the plane is modified to 15 degrees, the hole and work axis
adjust accordingly.
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Using Projects to
Organize Data

In this chapter, you learn how projects help you organize and manage your data. You learn
to plan and set up your projects based on your design needs.

Key Terms

Term Description

active project The project that Autodesk® Inventor™ au-
tomatically defaults to when opening,
saving, or editing components. There can
be only one active project in an Autodesk
Inventor session. Can be a project you have
specified or the default installed project.

default project A blank project installed with Autodesk In-
ventor. In the absence of a defined project,
the default project is active.

editable locations Folders where parts, drawings, assemblies,
and presentations you create are stored.
In a project, editable locations are the
workspace and workgroup search paths.
Use only one editable location per project.




Term

Description

frequently used subfolders

Named subfolders of project folders (includ-
ing libraries) that are frequently accessed.
Folders are not used to resolve references
or store references. They are listed on file
access dialogs so that you can easily locate
the folders. The path to frequently used
subfolders always begins with the name of
the project location.

libraries

Libraries are project locations containing
read-only files that are referenced, but not
edited. Within a project, each library must
have a unique name. Within a library, give
each file a unique name.

options

Project settings that define such things as
the number of old file versions to keep and
whether unique file names are being used.
Release ID (such as a project version) and
Owner (such as who controls the released
project) are intended for use with released
projects.

project

An XML file with an .ipj extension that de-
fines the folders that contain the files and
folders of external data that the project
files reference.

proxy file

When you place an Autodesk® Mechanical
Desktop® part as a component in an assem-
bly, Autodesk Inventor creates a proxy file
that contains links to the Mechanical
Desktop file and the translated data. Typi-
cally, the original Mechanical Desktop file
is stored in a library and the translated
proxy files are stored in a proxy library. The
proxy library has the same name as the
Mechanical Desktop library except that it
is preceded by an underscore (_) character.
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Term Description

referenced file A file used in the current design. A refer-
enced file may be editable or it may be
read-only, as in the case of library parts.

relative path In projects, paths are relative to the loca-
tion of the projects file (.ipj). Autodesk In-
ventor uses relative paths to locate refer-
enced files.

root folder A top-level folder defined as a library,
workspace, or workgroup in a project. Data
files in subfolders nested under the root
folder are located by a relative path from
the root folder. Store all files that belong
to the current project in a root folder or
one of its subfolders.

single user project Data file locations are located in the
workspace of the project. Files within the
project are accessed by one user and one
Autodesk Inventor session at a time. Files
are not checked in or out.

styles library A folder defined in the project Folder Op-
tions that specifies where the style defini-
tions used in the project are located. The
default is the Design Data folder.

templates folder A folder defined in the project Folder Op-
tions that specifies where the templates
used to create new files for the project are
located. The default is the Templates folder
created during setup.

workspace A root folder or subfolder that contains
your personal copy of design files. For sin-
gle-user and vault projects, the workspace
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Term Description

should be the only defined editable loca-
tion.

Learn About Projects

A project represents a logical grouping of a complete design or product,
including its model files, drawings, presentations, and design notes. Project
information is stored in XML files with the .ipj extension that specify where
you edit files, how many versions are retained when you save a file, where
referenced data is stored, and other settings.

The project identifies the root folders where files are stored and the hierarchy
of the project design. Data files can be stored directly in these root folders or
in their subfolders.

You can create two project types: single user and, if you have installed
Autodesk® Vault, a vault project. Single User projects are for designers working
alone. When Autodesk Vault is installed, you use Vault projects to collaborate
on projects with multiple designers. Common files are stored in a vault and
never accessed directly, and each designer has a personal project that defines
where the files are copied for viewing and editing. The vault also maintains
version history of files as well as additional attributes.

Default Project

When you first start Autodesk Inventor, a default project is automatically
active. The default project does not define an editable location, but you can
use it to create designs immediately, and save files anywhere without regard
to projects and file management. Generally, you use the default project for
experimentation only, not actual design work. It is more difficult to migrate
your files to a project when the design gets complex than it is to set up a
project before you start designing.

Set an Active Project

In an Autodesk Inventor work session, only one project can be active. The
active project specifies the options and paths to folders containing design files

114 | Chapter 6 Using Projects to Organize Data



and libraries for the session. When you work on a different design project,
you must make its project active before you can create or edit data files.

TRY IT: Make a project active
1 Verify that all Inventor files are closed.

2 Click File » Projects, or on the Microsoft® Windows® Start menu, click
Programs » Inventor (release number) » Tools » Project Editor.

3 On the Projects dialog box, top pane, the existing projects are listed.
Double-click a project to make it the active project. A check mark indicates
the active project.

The lower pane of the Projects dialog box shows information about the
selected project in the top pane.

How Referenced Files are Found

When Autodesk Inventor searches for a file, it looks in the locations defined
by the active project for the stored file name and relative path.

File references are stored according to the following rules:

B File references are stored as a relative path from the project root folder. If
the file is in a library, the library name is also stored.

B If the referenced file is not in a project root folder, but the file is stored in
the same folder or a subfolder of the file that references it, the reference is
stored as a relative path.

To avoid file resolution problems, projects always use relative paths rather
than absolute paths. This allows the project or its root locations to be easily
moved or copied without breaking or needing to update references.

Always save new files in the workspace defined for the active project or one
of its subfolders.

Except for library files, a file can be moved to a different non library location
specified in the project, as long as the relative path is maintained.

Library locations contain library components that are referenced by another
file, but not edited. Inventor searches for a library reference in the library
location named in the project.
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A project searches for nonliterary files in the editable locations. For best results,
specify only one editable location in each project.

Because other design groups may also use the same library parts, library
locations may be specified in multiple projects. It is a good practice to make
library locations and the files in them read-only.

Setting Up Projects

Set the project type when you create or edit a project. The type determines
where files can be edited and saved, who has access to files, and check-in and
check-out behavior.

It is a good practice to set up your file structure and understand who can access
the file data before you create a project.

Project Types

You can create these project types:

B Single user

B Vault (Autodesk Vault must be installed to use this project).

When multiple designers must have access to data, we recommend that you
install Autodesk Vault. Its extensive data management capabilities let you

keep all versions of a file and give you the ability to search and query design
data.

Use single-user projects if you work alone or if no one else needs access to
your files.

NOTE In the Project wizard, Semi-isolated and Shared project types are unavailable
by default. It is recommended that you use Autodesk Vault to manage multi-user
projects. If you have a requirement to create legacy project types, click Tools »
Application Options » General tab. Select the Enable creation of legacy project
types check box. Consult the online Help for more information about those project
types.
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Single-user Projects

Use single-user projects for individual designers:

B All design files are in one folder (the workspace) and its subdirectories,
except for files referenced from libraries.

B Store the project file (.ipj) in the workspace (root) folder and specify .\ as

the workspace.

B The file check-out status is not available in the browser.

Typical Single User project setup

Type

Single User

Workgroup Location

None

Location One workspace defined at .\.

Included file None

Libraries One or more may be defined.

Frequently Used Subfold-  One or more may be defined, each specifying a subfolder

ers of the workspace or one of the libraries.

Folder Options Defines folders containing project-specific Styles, Templates,
and Content Center Files.

Options Old versions to keep on save = 1

Using unique file names = Yes

Name = “Project Name”

Shortcut = “Project Name”

Owner = owner of the project

Release ID = version of the released data
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Vault Projects

To use the vault project, Autodesk Vault software must be installed. A different
dialog box opens so that you can create a Vault project. Characteristics of a
vault project include:

Designers never view or work directly on the vaulted version of a file.

Each designer uses a project file that defines a personal workspace where
Autodesk Vault copies the vaulted files for viewing and editing.

Changes to files made by other designers, and checked back into the vault,
are not visible until you refresh your files to get the latest versions in your
workspace.

Autodesk Vault maintains copies of all of the previous checked-in versions
of data files, and stores additions about edit history, file properties, and
file dependencies in its database.

You can set up queries on file properties, track file references, and retrieve
past configurations.

For a vault project, you must have a workspace located at a path relative to
the project file folder (such as .\ or .\workspace) and no other editable
locations.

Typical Vault project setup

Type Vault

Location One workspace defined at .\.
Workgroup locations None

Included file None

Libraries One or more defined.

Frequently Used Subfold-  One or more may be defined, each specifying a subfolder

ers

of the workspace or one of the libraries.
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Set Up

Folder Options Defines the folders containing project-specific Styles,
Templates, and Content Center files.

Vault Options Values are typically set in Autodesk Vault.
Virtual folder = virtual folder within the vault database that
maps to the root folder for the project.
Publish folder = specifies where Streamline data is pub-
lished.

Options Old versions to keep on save = 1
Using Unique File Names - Yes
Owner = team leader or blank
Release ID = version of the released data

NOTE For more information about creating and using Vault projects, see the
manual called Autodesk Vault (version) Managing Your Data in your product box.
The manual is also available in PDF format on your product DVD at ais
(version)\dsk1\docs.

Folder Structures

A typical project might have parts and assemblies unique to the project,
standard components unique to your company, and off-the-shelf components
such as fasteners, fittings, or electrical components.

To help Autodesk Inventor locate referenced files, it is a good idea to set up
subfolders under your project workspace or workgroup folder. You can keep
all your design files for a project in the subfolders.

As a design project grows, you often must move data. For example, you might
change drives, move to a different server, add designers, or share data that
was previously unshared. When you maintain a simple folder structure, it is
easier to accommodate increased design complexity, more designers, and
distributed data.

Use these guidelines to create a folder structure for project files:

B Follow your company standards and naming conventions for the project
folders.

B If you plan to edit files from existing designs, copy them to a subfolder of
the workspace.
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B If you intend to reference released design files, copy them to a library
folder, or define a library in your project that locates the root folder of the
released project. If the released project also references libraries, include
them in the project or use Pack and Go to flatten the file structure into a
single folder.

B Keep the subfolder structure relatively flat and do not store files that are
unrelated to the project under the root folder. Avoid storing more than
one hundred files in a single folder.

NOTE Set the project option Using Unique File Names to Yes. Avoid using duplicate
names, even when naming files in different paths, so that you do not confuse
locations or documents, or overwrite files.

If you set the “Using Unique File Names” option in the project file, Autodesk
Inventor tries to locate a file within the project folder structure, even if moved
to a different location or renamed. If the file cannot be located, the Resolve
Link dialog lets you search for it manually. To find duplicate file names in
project folders, use the Find Duplicate Files button on the Project Editor.

Because references are stored as relative paths from project folders, if you
change the folder structure, move, or rename folders, you are likely to break
file references, unless you set the Using Unique File Names option to Yes.

Creating Projects

The default projects folder location is My Documents/Inventor, but you can
change to a different location.

The Project Wizard creates a workspace in the same folder as the project file.
If you change that setting, keep the workspace as subfolders of the folder
containing the project file.

This table summarizes recommendations for each project type.

Single User Vault
Project type Single User Vault
Included file None None
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Workspace locations  One defined at .\ One defined

at .\
Workgroup loca- None None
tions
Libraries One or more One or more not nested under workspace
TRY IT: Create a project with the Project Editor

1 Close all documents in Autodesk Inventor.

When files are open, the active project is read-only. The only exception
is that you can add libraries without closing all files.

2 In Inventor, click File » Projects to activate the Project Editor, or
outside Autodesk Inventor, click the Microsoft Windows Start menu »
Programs » Autodesk » Autodesk Inventor (version) » Tools »
Project Editor.

3 When the Project Editor opens, click the New button to start the Inventor
project wizard.

In the Inventor project wizard, the default is a new single user project,
which creates a workspace.
You must install Autodesk Vault to use the New Vault Project option.

4 In the Project File box of the project wizard, specify required project

information.

B In Name, enter the project name or accept the default.
The Project wizard creates a subfolder with that name as a subfolder
of the projects folder.
If you browse to a different location, Autodesk Inventor uses the name
of the folder you locate, or creates a new folder only if the folder name
does not exist.

B In the project folder (the location of the .ipj at .\), a workspace is
created for single-user and vault projects.

B In Project File to be created, the path and project file name is
displayed.
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Inventor project wizard

Project File

Mame

| ‘fourProjectMarme

Project {Workspace) Folder
| CiiMy Documents| Inventor YourProjectMame!, .

Project File to be created

| CiiMy DocumentsiInventort YourProjectMame! YourProjectame.ipj

@ | et | Finish Cancel

5 Click Next to specify libraries.

New projects often use the same libraries as existing projects. In the left
pane, libraries are collected from all project files in the projects list.

B In theright pane, click the right arrow to add a library location to the
New Project.

B Click the left arrow to remove a library location from the New Project.

Inventor project wizard
Select: Libraries
all Projects: Mew Project:
Logical name | Location | Logical name: Lacation
Library C:\Program Fil... Library1 C:\Program Fil...
Library1 C:\Program Fil...

D]
Kl

Library Location:

@ Back. Finish h| Cancel
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The Library location box shows the location of a library selected in the
left or right panes.

6 Click Finish.

Once the project is created, double-click it in the Project Editor, and then
customize it by setting options. In the next sections, customize the project
you just made by following the procedures.

Set Project Options

The project type, the default workspace, and library names and locations are
set in the project wizard. Set the remaining project options to suit your design
environment, and then specify project search paths.

If useful, review the option definitions and the setups for each project type
discussed earlier in this chapter:

B “Single-user Projects”

B “Vault Projects”

= @ Options

EI: 0ld Versions To Keep On Save (-1 =al=1
EI: Using Unique File Mames = Mo

[ab] Name = tutorial_files

il Shorkcut = butorial_files

EI: Cwner =

[ab] Release ID =

Workspace

A workspace contains files that you edit. They are not accessible by other
designers and changes you save to the workspace are not visible to other
designers. The workspace may be a network location, but your files open faster
if you specify a folder on your local hard disk.

You can specify a workspace in single-user projects. In vault projects, the
workspace is required and is the only editable location. It must be in a subfolder
or the same folder as the folder containing the project (.ipj) file.
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When setting the workspace path:

B Specify only one location in a workspace, preferably at the root location
containing the project file or in a subfolder of the project file. The
recommended location is .\.

In a single user project, the workspace should be the only location in your
project, except for library locations.

B For best results, use Autodesk Vault to check out rather than manually
copy files. Check out automatically sets the correct relative path so that
Autodesk Inventor can resolve your file. If you manually copy, the file is
not marked as checked out and the risk of overwriting edits is increased.

B Workspace is the first location searched for non library references.

Workflow overview: Set the workspace search path

1 On the Project Editor dialog box, click the Expand button to show the
Workspace path.

2 If no workspace is defined, right-click Workspace, and then click Add
Path or expand the existing workspace and click Edit.

3 Accept the path shown, edit the path, or browse to and select a workspace
folder.

4 Click Save.

Library Locations

A library is a storage location for read-only parts or other files that will not be
edited. You specify one or more library locations when you create a project.
Libraries can be used in multiple projects.

NOTE When naming libraries, remember that files using a library part store the
library name and relative path from the library folder. If you later need to rename
the library, all the library references will be broken.

Libraries can be created implicitly (when linking to a Mechanical Desktop
part) or explicitly (you create the search path in the project).

Keep in mind:

B The location of the Content Center library is defined in the Project Editor
Folder Options.

124 | Chapter 6 Using Projects to Organize Data



B A library creates an association between a library name and the folder for
the current project.

B Therelative path stored in the referencing file is relative only to the library
folder, not to any other project locations. Only the named library is
searched when resolving a library reference.

Workflow overview: Set library locations

1 In the Edit Project pane of the Project Editor, right-click Libraries, and
then select an option:
Add path Enter a folder name and path in the box or browse
to the location.

Paths from file Browse to, select a project (.ipj) file, and then click
Open. The local search paths from the selected file
are added to the current project.

Paste path Paste a copied path into the box.
Delete section paths Delete all paths.

2 Click Save.

3 If appropriate, right-click a library location, and then select menu options.

Library Locations for Mechanical Desktop Parts

Mechanical Desktop parts are stored in libraries. Mechanical Desktop parts
are linked to Autodesk Inventor assemblies through a proxy file that contains
linking information, so that the assembly component updates when the part
is edited in the Mechanical Desktop.

Before you add Mechanical Desktop parts to an assembly, set a library location
in the project for both the folder containing the Mechanical Desktop part files
and a corresponding proxy folder. The library names are the same except that
an underscore character (_) precedes the proxy library.

Because Mechanical Desktop files can contain more than one part, multiple
Autodesk Inventor parts might be retrieved from a single file.

About proxy files:

B A proxy file is created when you place a Mechanical Desktop part as a
component in an assembly. Parts retrieved from a Mechanical Desktop file
are stored in a corresponding proxy library location.
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B You cannot open or edit a proxy file.

B Proxy files are updated only when you open or save the assembly that uses
the corresponding Mechanical Desktop file.

B Proxy files contain the Mechanical Desktop design data for a single part,
translated to the Inventor data format.

B Design properties (iProperties) are stored in proxy files, and are lost if you
lose the proxy file.

Workflow overview: Set Library locations for Mechanical Desktop parts and
proxy files

1 Verify that all Inventor files are closed.
2 In the Project Editor, double-click a project to activate it.

3 In the lower pane, right-click Libraries, and then click Add Path on the
menu. Add a new named path for the Mechanical Desktop file.

4 Right-click the newly created library location, and then click Add Proxy
Path on the menu.

5 Continue to define libraries as needed, assigning a descriptive name to
each library.

Library Locations for iParts and iAssemblies

If you plan to store iPart or iAssembly factories on a network and share them
with others, add the factories as libraries. You need to specify a proxy path.

If no proxy path is used, when you insert an iPart or iAssembly in an assembly,
a subfolder is automatically created in the same location as the factory. The
subfolder has the same name of the factory and stores the members.

When you use a proxy path, the subfolder is created in the proxy path and
the members are created in the subfolder in the proxy path.

Keep these guidelines in mind:

B Store iParts and iAssemblies in a named library and the corresponding
published members in the associated proxy library.

B You cannot change the location or name of a proxy library.
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B You cannot open or edit a proxy file.

B iPart and iAssembly Factory proxy files are catalog elements from the
factory, published with a specified set of parameters.

m Update proxy files by opening or saving the assembly that uses the
corresponding factory member file.

B Do not make an iPart or iAssembly proxy library folder read-only, because
the factory has to create new members there.

Workflow overview: Set library locations for factories and proxy files
1 Verify that all Inventor files are closed.
2 In the project editor, double-click a project to activate it.

3 In the lower pane, right-click Libraries, and then click Add Path on the
menu. Add a new named path for the factory location.

4 Right-click the new library location, and then click Add Proxy Path on
the menu.

5 Continue to define library locations as needed, assigning a descriptive
name to each library.

Content Center Files

When you select a component from the Autodesk Inventor Content Center,
it is created from parameters stored in a Content Center library. If the file is
not a custom file, it will be saved in a folder specified in the Project Editor
Folder Options.

The Content Center library also generates custom parts that have a standard
cross section, such as structural steel shapes. You can create an infinite variety
of parts by specifying other parameters such as length. You need to specity
the file name and save location for all such parts. If you intend to make other
edits, such as insert bolt holes or other cutouts, place the custom files in a
subfolder of your workspace location.
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Other Types of Libraries In Projects

Most projects use libraries such as third party components, company collections
of commonly used parts, Mechanical Desktop parts, iAssemblies and iParts.
However, you may find that your organization has other component files that
you would like to reference but do not intend to edit.

Because library references include the library name, and only that library
location is searched to resolve a library reference, library file names need only
be unique within that library.

Library examples include:

Another design set as a library.
You can use project libraries as a way to subdivide projects among divisions,
geographic boundaries, small teams, or subcontractors.

A design set library can be a single part or a set of complete assemblies of
a released design, an assembly or component purchased from a third party
and that you cannot change, or a snapshot of another team's design project
that is in development.

Components that your organization commonly uses across design projects,
such as preferred components readily stocked or provided by preferred
suppliers.

Components that you have designed in the past and do not need to recreate
for successive projects.

Workflow overview: Define a set of files as a library

1

2
3
4

Place the files in a folder under a common root folder.
In the Project Editor, right-click Libraries.
Browse to the desired top-level folder.

Press ENTER to set the path.

When a parent file is opened in a project, only the library named in the
reference is searched.
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Avoid Duplicate File Names

In general, it is not a good idea for different files to have the same file name,
even if they reside in different folders. Inventor uses search rules to resolve
references and duplicate names can lead to difficulty in locating a file. Avoid
using duplicate file names and set the project option Using Unique File Names
to Yes.

Libraries are an exception to this rule. Often the files come from third-party
vendors that have their own file naming schemes. As a result, different libraries
can have files with the same name, but files within a library should have
unique names.

For simplicity and clarity, when you have a choice, avoid using duplicate file
names for library parts and regular parts.

Library references differ from editable references because the library name
associated with the library location is stored as part of the reference.

Creating and Opening Files In Projects

To open the files associated with a project, you must first make the project
active. Close any open Inventor files.

TRY IT: Create or open a file in a project
1 Click the Open tool on the Inventor toolbar.

2 On the Open dialog box left pane, click the Projects button and then
double-click the project you want to make active. The active project is
identified with a check mark.

3 Inthe What to Do pane, click the New button to list file templates. Select
a template to create a new file, and then click OK.

When you save the new file, browse to the desired subfolder (if any) of
the Workspace and specify a unique file name.

4 On the Inventor toolbar, click the Open tool. In the Open dialog box, in
the Locations pane, project categories are listed in a browser tree. A
selected location is highlighted and marked with a blue folder. Its files
are listed in the Look In pane. Double-click a category or subfolder to
change the file list.
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NOTE If you specified Frequently Used Subfolders in the project options,
they are also listed in the Locations pane.

5 Double-click a file to open it.
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Managing Assemblies

This chapter introduces assembly modeling. You will learn about the assembly environment,
assembly browser and working in the assembly environment.

Assembly Environment

In Autodesk® Inventor™, you place components that act as a single functional
unit into an assembly document. Constraints define the relative position these
components occupy with respect to each other.

When you create or open an assembly file (.iam), you are in the assembly
environment. Assembly tools manipulate whole subassemblies and assemblies.
You can group parts that function together as a single unit and then insert the
subassembly into another assembly.

When you open a part file (.ipt), you are in the part environment. Part tools
manipulate sketches and features, which combine to make parts. You insert
parts into assemblies and constrain them in positions they will occupy when
the assembly is manufactured.

You can insert parts into an assembly or use sketch and part tools to create parts
in the context of an assembly. When you do this, all other components in the
assembly are visible.

To complete a model, you can create assembly features that affect multiple
components, such as holes that pass through multiple parts. Assembly features
often describe specific manufacturing processes such as post-machining.

The assembly browser is a convenient way to activate components you want to
edit, edit sketches, features, and constraints, turn component visibility on and
off, and other tasks.
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Assembly Design Strategies

Traditionally, designers and engineers create a layout, design the parts, and
then bring everything together in an assembly. With Autodesk Inventor, you
can create an assembly at any point in the design process instead of at the
end. For a clean sheet design, you start with an empty assembly and create
the parts as you develop the design. To revise an assembly, you create the new
parts in-place so they mate with existing parts. This design methodology
supports top-down, bottom-up, and middle-out design strategies.

The optimal order in which you create parts and subassemblies depends upon
your answers to the following questions:

B Can you modify an existing assembly or do you have to start a new one?
B Can you break the larger assembly down into subassemblies?

B Can you use existing parts or iFeatures?
|

Which constraints drive the functionality of the design?

Changes you make to external components are automatically reflected in your
assembly models, and the drawings you use to document them.

Bottom-Up Assembly Design

When you design from the bottom up, you place existing parts and
subassemblies into an assembly file, and position components with assembly
constraints, such as mate and flush. If possible, place components in the order
in which they would be assembled in manufacturing.

Unless component parts are built from adaptive features in their part files,
they might not fit the requirements of an assembly design. You can place such
a part in an assembly, and then make the part adaptive in the assembly
context. The part is resized in the current design when you constrain its
features to other components.

If you want all underconstrained features to adapt when positioned with
assembly constraints, designate a subassembly as adaptive. When a part in
the subassembly is constrained to fixed geometry, its features are resized as
needed.
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Top-Down Assembly Design

When you design from the top down, you begin with design criteria and create
components that meet those criteria. Designers list known parameters and
may create an engineering layout (a 2D design that evolves throughout the
design process).

A layout can include contextual items such as the walls and floor where an
assembly will stand, machinery that feeds into or receives output from the
assembly design, and other fixed data. Other criteria such as mechanistic
characteristics may also be included in the layout. You can sketch the layout
in a part file, then place it in the assembly file. You develop sketches into
features as the design evolves.

The final assembly is a collection of interrelated parts that are uniquely
designed to solve the current design problem.

Middle-Out Assembly Design

Most assembly modeling combines the strategies of bottom-up and top-down
design. Some requirements are known and some standard components are
used, but new designs must also be produced to meet specific objectives.

Usually, you begin with some existing components and design other parts as
required. You analyze the design intent, then insert or create the grounded
(base) component. As you develop the assembly, you place components or
create new ones in place, as required.

Assembly Coordinate System

A new assembly file has three default work planes and work axes. The point
of intersection of the work axes is the origin of the assembly coordinate system.

In the browser, the default work planes, work axes, and the center points are
listed under the Origin icon. These features are initially hidden in the graphics
window, but you can right-click them in the browser and select Visibility to
display them. You can constrain components to the work planes and the
origin.

In the following illustration, visibility has been activated for the assembly
default work planes, axes, and center point, with the default isometric view.
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Each default workplane is coplanar with its respective axes. For example, the
YZ plane is coplanar with the Y axis and the Z axis.

YZ plane

Y axis
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Assembly Constraints

Assembly constraints are applied to components to define positional
relationships in the assembly. For example, you can force two planes on
separate parts to mate, or specify that a hole and a bolt always remain
concentric. These constraints bind your assembly model together and tell
Autodesk Inventor how to adjust the model as its component definitions
change over time.

Assembly Analysis

After you create your assemblies, you can calculate mass properties and check
for part interference. Properly constrained assemblies can be animated through
a range of motion, so you can check for design problems.

Storing Data Files In Projects

Projects point to locations where data files for a design project are stored. In
most cases, you will be working with a design team that houses data files in
a main location. Individual designers create projects that specify a private
workspace.
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Projects manage component locations by specifying such things as:

B The master location of files (the workgroup), when you work in a design
team.

B A private workspace specified by each designer, where files are created and
edited.

B Libraries of standard and custom components.

B Locations of templates and style libraries.

B The names of frequently used subfolders, to make file location faster.

In addition to locations, projects also set preferences for other options such
as whether you use unique file names in a project file structure (which can

help locate files more easily), how many versions of a file to keep, and release
information.

Working with the Assembly Browser

The Assembly browser shows the hierarchy of components in the assembly,
as well as their relationships and dependencies. Each occurrence of a
component is represented by a unique name. From the browser, you can select
a component for editing, move components between assembly levels, control
component status, rename components, edit assembly constraints, and manage
representations.

In-Place Activation

You can only edit components or features in the active assembly. Double-click
a subassembly or component occurrence in the browser to activate it, or
right-click the occurrence in the browser, and then select Edit. In the browser,
all components not associated with the active component are shaded.

The following actions can be performed on the first-level children of the active
assembly:

B Delete a component.
B Display the degrees of freedom of a component.

B Designate a component as adaptive.
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B Designate a component as grounded.

B Edit or delete the assembly constraints between first-level components.

The features of an activated part can be edited in the assembly environment.
When you activate a part, you are working in the part environment.

Double-click a parent or top-level assembly to reactivate it.

Visibility of Components

Controlling component visibility is critical to managing large assemblies. You
may need some components only for context, or the part you need may be
obscured by other components. Assembly files open and update faster when
the visibility of nonessential components is turned off.

The visibility of any component in the active assembly can be changed, even
if the component is nested many layers deep in the assembly hierarchy.
Workflow overview: Change the visibility of a component

1 Expand the browser until the component occurrence is visible.

2 Right-click the occurrence, and then clear the check mark on Visibility.

Combinations of visible components can be stored in design view
representations, described later in this chapter.

Assembly Structures

The structure of an assembly is the organization of the components. Grouping
parts into subassemblies simplifies the browser. Subassemblies can also reflect
manufacturing processes. With Autodesk Inventor, you can change the
contents of subassemblies or create new ones at any point during the design
process and over the life span of a product.

The top level of an assembly structure can consist of parts and subassemblies.
Each subassembly can consist of parts and more subassemblies. Moving a
component (a part or subassembly) into a subassembly is demoting. Moving a
component out of a subassembly is promoting.
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assembly after restructure

Components restructured as a group maintain constraints between them.
Constraints to components outside the group are lost.

Restructure Assemblies

In the browser, components are initially listed in the order in which they were
placed in the assembly. You can rearrange components by dragging them to
a new position in the browser or by using the context menu. Collapse
subassemblies at the same level in the browser to ensure that the dragged
components remain at the same assembly level. Moving components in the
browser does not affect their position in the graphics window.

You can also create a new subassembly by selecting a group of components.
The subassembly name is entered into the browser and the related components
are nested under it.
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Workflow overview: Create a new subassembly containing selected
components

1 Start with an open assembly.
2 Select components from the assembly browser or in the graphics window.

3 Right-click, and then select Component » Demote. The Create In-Place
Component dialog box displays.

4 Enter a file name for the new assembly, select a new template if necessary,
and then click OK.

A new subassembly is created and populated with the selected
components.

Promote is not available if the selected component is a child of the top-level
assembly.

Workflow overview: Promote components within the assembly hierarchy
1 Select components from the assembly browser or in the graphics window.

2 Right-click, and then select Component » Promote.

The selected components are moved to the parent assembly.

NOTE For more information, see Changing File Structure on page 290.

Browser Display

Display controls are located in the Browser toolbar:

Browser Filters Lists browser filters that limit and organize what is
shown in the Assembly browser. The filters can be
turned off and on, and multiple filters can be applied
to the browser at the same time.

Design View Represen- Lists recently created Design View representations. Also
tations gives access to activating and creating new Design View
representations by selecting the Other... option.

Design View representations preserve an assembly dis-
play configuration that captures component visibility,
sketch and feature visibility, color and style character-
istics, zoom magnification, and viewing angle.
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Assembly View Nests assembly constraint symbols below both con-
strained components. Part features are hidden. Select-
ing this button disables Modeling View.

Modeling View Places assembly constraint symbols in a folder at the
top of the browser tree. Part features are nested below
parts, just as they are in part files. Selecting this button
disables Assembly View.

Graphics Window Display

The physical appearance of a part in a shaded view of an assembly is initially
determined by the material or color style assigned in the part file.

Parts use the color style defined by the material applied in the part file. The
color style can be overridden either in the part file or in an assembly file. A
color style override in the part file becomes the default or As Material color
of the part in all assemblies. A color style override of a part or subassembly in
an assembly is local to that assembly only.

Some examples of color overrides are:
B Changing the color style of adjacent parts to provide contrast

B Assigning a semitransparent color style to a component for better
visualization

B Grouping components based on similar functionality or origin, such as all
hydraulic components, all components from a specific vendor, or all critical
failure parts

Component color styles can be repeatedly changed and saved in separate
assembly design view representations. You can specify a design view
representation when creating a drawing so that only needed components are
visible.

Autodesk Inventor includes a range of standard materials and color styles, as
well as tools to create custom color styles and material definitions.

To define a color or to modify the characteristics of a defined colot, such as
its brightness, intensity, or opacity, click Format » Styles Editor » Colors.
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Producing Bills of Materials

You can create a bill of materials (BOM) for an assembly. A bill of materials is
a table that contains information about parts in an assembly, such as
quantities, names, costs, vendors, and all of the other information someone
manufacturing the assembly might need.

Bill of materials information is automatically collected from iProperties. You
can modify values on the bill of materials by changing the design properties
on the Properties dialog box or on the Bill of Materials dialog box.

Within a drawing, you can create a similar table called a parts list. The parts
list uses data in the assembly bill of materials.

Tips for Working with Assemblies

Turn off visibility of nonessential components so you can access parts you
need and update graphics faster.

Create design view representations that highlight specific design problems
or assembly subsystems, and apply them when opening the assembly
model.

Turn off part adaptivity after you size a component, to speed up solutions
and prevent accidental changes.

Assign different colors to components. Select colors from the Color list on
the Standard toolbar.

Click a component in the browser to highlight it in the graphics window.

Right-click a component in the browser and use Find in Window to locate
a component in a complex assembly.

Use color to identify component groups. Using attributes, find components
in specific subsystems or from specific vendors and color code them in
named representations.

140 | Chapter 7 Managing Assemblies



Placing, Moving, and
Constraining
Components

In this chapter, you learn how to place and constrain components, and to edit constraints
using the Edit Constraints dialog box.

Placing Components In Assemblies

In the assembly environment, you can add existing parts and subassemblies to
create assemblies or you can create new parts and subassemblies in-place.

A component (a part or subassembly) can be an unconsumed sketch, a part, a
surface, or any mixture of both.

When you create a new component in-place, you can sketch on one of the
assembly origin planes, click in empty space to set the sketch plane to the current
camera plane, or constrain a sketch to the face of an existing component.

When a component is active, the rest of the assembly is dimmed in the browser
and graphics window. Only one component can be active at a time.

When you place the first component in an assembly, choose a fundamental
part or subassembly (such as a frame or base plate). Except for the first placed
component, all placed components are unconstrained and ungrounded. You
add the constraints you need.
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The first component placed in an assembly is automatically grounded (all
degrees of freedom are removed). Its origin and coordinate axes are aligned
with the origin and coordinate axes of the assembly. It is a good practice to
place assembly components in the order in which they would be assembled
in manufacturing.

Click in the graphics window to place additional ungrounded occurrences of
the first component in the assembly. To finish placing the first component,
right-click, and then select Done.

To place subsequent components from external files, continue to click in the
graphics window to place additional occurrences, and then right-click and
select Done.

Use the Create In-Place Component tool to create a component in the assembly
context. The created component is nested under the active main assembly or
subassembly in the browser. If a sketch profile for the in-place component
uses projected loops from other components within the assembly, then that
sketch profile is associatively tied to the projecting components.
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Drag Components into Assemblies

You can place multiple components in an assembly file in a single operation
by dragging them into the graphics window. You can drag components to an
open assembly window from the following locations:

B From an open folder in Windows Internet Explorer®. Use this technique
to quickly populate a new assembly with components.

B From an open Inventor part file. Drag the top-level icon from the part
browser to the assembly graphics window.

B From an open Inventor assembly file. Drag parts, subassemblies, or the
top-level assembly from the browser to the assembly graphics window.

You must drop the files over the graphics window where the assembly model
is displayed. A single occurrence of each component is placed in the assembly
file. The dropped components appear at the bottom of the browser in the
receiving assembly.

Simplify Assemblies

In an assembly, you can employ several techniques to make it easier to work
in the graphics window and to removed unneeded components from the
display or memory. Techniques include:

B Turn visibility on and off
B Turn enable status on or off

B Suppress unneeded components

Sometimes a component obscures a component you need to work on. You
can turn its visibility off or turn off visibility for all components you are not
working on to simplify the graphics window.

Enabled components are fully loaded in the assembly and are available for
any operation within the assembly environment. A component that is not
enabled is selectable in the browser, but is not available for operations in the
graphics window. You can in-place edit a component that is not enabled,
which automatically switches the component to Enabled. Components that
are not enabled consume fewer computer resources than enabled components,
giving better performance in large assemblies.
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If you are working in shaded mode, components that are not enabled are
nearly transparent in the graphics window. In wireframe mode, they are
displayed in a distinct color in the graphics window. An icon in the Assembly
browser identifies the component as not enabled.

Parts and subassemblies that are required only for context, or components
that do not require editing, are good candidates to be designated as not
enabled. To set a component to not enabled, right-click the component in
the browser, and then clear the check mark next to Enabled.

You can also suppress unneeded components. When you suppress a
component, it is not loaded into computer memory, which makes editing the
assembly much faster. In the browser, a suppressed component is indicated
by strikethrough text. In a large assembly, consider, for example, suppressing
interior components that are not needed in current operations.

Grounded Components

Grounded components are fixed in position, relative to the assembly coordinate
system. A grounded component will not move when you apply assembly
constraints. The first component placed or created in an assembly is
automatically grounded, so that subsequent parts may be placed and
constrained in relation to it. You can remove the grounded status of a
component, including the first component.

To restore the degrees of freedom (unground) of a component, right-click the
component occurrence in the graphics window or the Assembly browser, and
then clear the check mark beside Grounded. Grounded components are
displayed with a pin icon in the assembly browser.

There is no limit to the number of grounded components you can have in an
assembly, but most assemblies have only one. Grounded components are
appropriate for fixed objects in assemblies because their position is absolute
(relative to the assembly coordinate origin), and all degrees of freedom are
removed.

Other Sources of Components

Most assembly components are parts and subassemblies you have previously
created with Autodesk® Inventor™ or are generated by the Component Center,
a library of standard parts installed with Autodesk Inventor.
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You can use the DWG/DWF™ File Wizard to import parts and assemblies from
the Autodesk® Mechanical Desktop®. You should migrate Mechanical Desktop
files to the latest version before you translate to Autodesk Inventor. You have
an opportunity to fix any errors before the translation.

Autodesk Inventor can also place components created in other CAD systems
that have been saved as SAT files (ACIS) or IGES files, or exported through a
STEP translation process. Imported SAT, STEP, and IGES files do not retain the
parametric information used to create their features. You can add parametric
features to these files, but you cannot edit their existing features.

Moving and Rotating Components

When constraining assembly components, you may need to temporarily move
or rotate a constrained component to enhance the visibility of other
components, or position a component to facilitate constraining. Rotating or
moving a component temporarily suspends a component’s constraints. The
next assembly update restores the position of the component as determined
by its constraints.

If a component is not grounded, or is unconstrained or underconstrained,
you can click it and drag it to a new location in the assembly graphics window.

Constraining Components

After you place or create components in an assembly file, use assembly
constraints to establish the orientation of the components in the assembly
and to simulate mechanical relationships between components. For example,
you can mate two planes, specify that cylindrical features on two parts remain
concentric, or constrain a spherical face on one component to remain tangent
to a planar face on another component.
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Each time you update the assembly, the assembly constraints are enforced.

You can make some parts adaptive. Autodesk Inventor allows adaptive
part features to change size, shape, and position based on the applied
assembly constraints.

Assembly constraints remove degrees of freedom from components,
positioning them relative to one another. As you modify component
geometry, assembly constraints ensure that the assembly stays together,
following the rules you have applied.

The correct application of assembly constraints also permits interference
checking, collision and contact dynamics and analysis, and mass property
calculations. When you apply constraints properly, you can drive the value
of an essential constraint and view the movement of components in the
assembly.

Place Constraints

In Autodesk Inventor, four types of 3D assembly constraints define positional
relationships between components: mate, angle, tangent, and insert. Each
type of constraint has multiple solutions defined by the direction of a vector
normal to the component. The constraint solution is previewed to show the
orientation of the affected components before you apply the constraint.

In addition, motion and transitional constraints simulate intended movement.

Motion constraints specify the intended motion between components.
Because they operate only on open degrees of freedom, they do not conflict
with positional constraints, resize adaptive parts, or move grounded
components.

A transitional constraint specifies the intended relationship between
(typically) a cylindrical part face and a contiguous set of faces on another
part, such as a cam in a slot. A transitional constraint maintains contact
between the faces as you slide the component along open degrees of
freedom.

Use the Place Constraint dialog box to control the type, solution, and offset
for the constraint.

Use the Selection buttons to specify the geometry to be constrained. The
selection buttons are color cued to the corresponding geometry in the
graphics window.
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Use the Predictive Offset and Orientation button with Mate, Flush, and
Angle constraints. When turned on, it gives the offset value for the current
location for the selections you are constraining. It also changes the
orientation to a flush constraint if you have it set to mate, then pick two
faces with the vectors pointing in the same direction, and visa versa.

The dialog box remains open as you place constraints, so you can place
multiple constraints of all types.

In the following workflow, the Constraint tool on the Assembly toolbar is
used to place a tangent constraint between assembly components. A tangent
constraint positions faces, planes, cylinders, spheres, cones, and ruled splines
tangent to one another.

Workflow overview: Place a tangent constraint in an assembly

1
2

To begin, place the components to constrain in an assembly file.
On the Assembly panel, click the Constraint tool.

On the Place Constraint dialog box, Assembly tab, in Type, click the
Tangent button.

The First Selection button is already active. Select a face, curve, or plane
for your first selection.

The Second Selection button is activated after you pick the first selection.
Select the geometry that will be tangent to the first.

If applicable, select Inside or Outside to specify the tangency position.
Enter an offset value, if applicable.

If Show Preview is selected, observe the effects of the applied constraint.
If either component is adaptive, constraints are not previewed.

Click Apply to continue to place constraints or click OK to create the
constraint and close the dialog box.

NOTE Availability of objects for selection differs, depending upon the particular
constraint tool you select in the Place Constraint dialog box.

If other components obscure the required geometry, do one of the following:

Temporarily turn off the visibility of the foreground objects before you
place a constraint.
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On the Place Constraint dialog box, select Pick Part First. Click the
component you want to constrain. Clear the check box to restore the
ability to select all components.

Selectable geometry is limited to features on the selected component.

Point the cursor to the required geometry. Right-click, and then choose
Select Other.

Click the arrows in the Select Other box to cycle through the underlying
face, curve, and point selections.

Click the green center button to accept the highlighted selection.

If you find it difficult to select faces, edges, or points, you can adjust the Locate
Tolerance option to change selection priority. Click Tools » Application
Options » General tab.

Workflow overview: Edit constraints

1

In the browser, right-click a constraint you previously placed.

The Edit Constraint dialog box is displayed.

On the Edit Constraint dialog box, specify a new constraint type (Mate,
Angle, Tangent or Insert).

Enter a distance to offset constrained components from one another.

If you apply an angular constraint, enter the angle between the two sets
of geometry. You can enter positive or negative values. The default value
is zero.

If Show Preview is selected in the Constraint dialog box, the position of
the components is adjusted to match the offset or angle value.

Apply the constraint through the Constraint dialog box or the context
menu.

The dialog box remains open, and you can apply as many assembly
constraints as required.

The following figures show before and after examples of applied assembly
constraints.

Mate Constraint

The mate constraint makes a set of geometry on one component coincident
with geometry on another component.
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Mate Type - Mate So- Use the mate constraint with the mate solution to make

lution

two planes face each other and make them coplanar,
make two lines collinear, or place a point on a curve
or plane.

Mate Type - Flush So- Use the mate constraint with the flush solution to align

lution

two components so that the selected planes face the
same direction, or have their surface normals pointing
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in the same direction. Faces are the only geometry that
can be selected for this constraint.

Angle Constraint

The angle constraint specifies an angle between planes or lines on two
components.

Angle Type Specifies an angle between planes, axes, or lines on
two components. The two sets of geometry need not
be of the same type. For example, you can define an
angle constraint between an axis and a plane. Con-
straints of this type are often used to drive assembly
motion.

Angle Solution Orients the surface normal of a selected plane or the
direction of the axis described by a selected line. When
you select a face or line, an arrow shows the default
direction of the solution.

Direct Angle Applies the right-hand rule. Some cases, such as zero
or 180°, may flip in the opposite direction.

Undirected Angle Applies either right-hand or left-hand rule. The left-
hand rule is applied automatically if the solved position
more closely resembles the last-calculated position.
This is the default behavior.
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Tangent Constraint

The tangent constraint causes surfaces of planes, cylinders, spheres, or cones
to contact at the point of tangency.

Tangent Type At least one surface must be non planar. Surfaces de-
fined by spline curves cannot be used in a tangent
constraint. Tangency may be inside or outside a curve,
depending on the direction of the selected surface
normal.

Outside Solution Positions the first selected part outside the second se-
lected part at their tangent point. Outside tangency is
the default solution.

Inside Solution Positions the first selected part inside the second select-
ed part at their tangent point.
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Insert Constraint

The insert constraint causes a circular edge on one component to be concentric
and coplanar with a circular edge on another component. The offset value for
an insert constraint is the distance between the two faces containing the
circular edges. For example, you can use this constraint to place a pin or a
capscrew in a hole.

Solutions Specifies the direction of the face normal for the planes
containing the circular edges. An arrow indicates the
normal direction. The opposed solution has the two
planes facing each other, as in a mate constraint. An
aligned solution has the normals pointing in the same
direction.

Motion Constraints

You can add motion constraints to components in an assembly to animate
the motion of gears, pulleys, rack and pinions, and other devices. By applying
motion constraints between two or more components, you can drive one
component and cause the others to move accordingly.

Two types of motion constraints are possible:

Rotation Use to apply motion constraints to wheels, pulleys,
and gears.
Translation Apply motion constraints to rack and pinion or wheel

and rail components. These constraints are bidirection-
al and accept a specified ratio or distance.

Motion constraints do not maintain positional relationships between
components.

Fully constrain assembly components before you apply motion constraints.
Then, suppress constraints that restrict the motion of the components you
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want to animate. To return components to their original positions, unsuppress
any suppressed constraints.

iMates

An iMate is a constraint that is saved with a component to tell it how to
connect with other components in an assembly. When you insert a component
with an iMate, it snaps into place with another component with a matching
iMate. The component can be replaced by another component while preserving
these intelligent iMate constraints. Components with iMates speed accurate
placement and replacement of components in assemblies.

Autodesk Inventor can infer iMates based on a special algorithm that places
the constraint in a location likely to be the most useful. For example, you can
infer iMates on a closed-loop circular edge for extruded, revolved, and hole
features.

An iMate is usually an insert or mate constraint, but can be any constraint
type that is useful for quickly positioning components. You may want to
consider which other components may be substituted for the present
component and which constraint strategy is most useful for an iMate.

A composite iMate is a collection of individual iMates into a single entity.
Parts drawn from standard libraries snap together quickly with composite
iMates. Visual and audio cues are provided to assist in the placement of
components with iMates.

Viewing Constraints

The assembly browser provides two schemes for showing assembly constraints.
You select Position View or Assembly View on the assembly browser toolbar
to switch between the two schemes.

Modeling View Shows each constraint under component occurrences
in the browser. Constraints are listed under both con-
strained components.

Assembly View Shows all assembly constraints collected into a folder
labeled Constraints, located immediately below the
top-level assembly. Each constraint is listed only once,
in the order of placement.
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When you hover the cursor over an assembly constraint in the browser, the
constrained components are temporarily highlighted in the graphics window.
Selecting the constraint in the Assembly browser highlights the geometry in
the graphics window until you click again in the graphics window or the
browser.

Editing Constraints

You can edit assembly constraints two ways.

Workflow overview: Edit constraint values by selecting in the browser

1 In the assembly browser, select an assembly constraint.

The offset or angle value is displayed in the edit box at the bottom of the
browser.

2 Enter a new value in the edit box, open the drop-down list to select recent
values, or use the Measure tool to find a value.

Workflow overview: Edit constraint values in the Edit Constraints dialog box

1 Right-click a constraint in the assembly browser, and then select Edit
from the menu, or double-click a constraint in the assembly browser.

2 On the Edit Constraint dialog box, edit any of the constraint parameters
displayed.

You can change the selected geometry for one or both components, change
the solution, and revise the offset, angle, or depth value of the constraint.
Under certain conditions, the constraint type can be changed without losing
the current selections. For example, you can change a mate constraint between
two planar surfaces to an angle constraint. The OK button is not available if
you select a new constraint type that cannot be applied.

Tips for Managing Assembly Constraints

B Start constraining components by mating planar faces. Add tangent,
angular, and flush constraints later.

B Apply constraints after features are stable. Avoid constraints between
features that might be removed later in the design process.
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B Drag components to check translational degrees of freedom. You can see
how a component is constrained.

B Create component iMates for repeated use. Using iMates, you can define
placement information on parts and assemblies to use repeatedly.
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Creating Assemblies

In this chapter, you learn how to create parts and assemblies in place, about adaptive parts,
patterns, assembly features, and other procedures for managing assemblies.

Creating Assembly Components

Assembly modeling combines the strategies of placing existing components in
an assembly, and creating other components in place within the context of the
assembly. In a typical modeling process, some component designs are known
and some standard components are used, but new designs must also be created
to meet specific objectives.

Parts In Place

Use the Create Component tool to create a component in an assembly. When
creating an in-place component, you sketch on the face of an existing assembly
component or a work plane, a sketch plane in the camera view of the main
assembly, or you can place the sketch plane normal to the view with the origin
at a selected point. On the Create In-Place Component dialog box, you can
choose an option to automatically constrain the sketch plane to the selected
face or work plane.

When you specify the location for the sketch, the new part immediately becomes
active, and the browser, panel bar, and toolbars switch to the part environment.
The Sketch tools are available to create the first sketch of your new part. Edges
and features of existing components can be selected as reference geometry for
sketching.

Most components are created in relation to existing components in the assembly.
Optionally, you can click the graphics window background to define the current
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view orientation as the XY plane. If the YZ or XZ plane is the default sketch
plane, you must reorient the view to see the sketch geometry.

After you create the base feature of your new part, define additional sketches
based on the active part or other parts in the assembly. When defining a new
sketch, click a planar face of the active part or another part to define the sketch
plane on that face. You can also click a planar face and drag the sketch away
from the face to automatically create the sketch plane on an offset work plane.

When you create a sketch plane on a face of another component, an adaptive
work plane is created and the active sketch plane is placed on it. The adaptive
work plane moves as necessary to reflect any changes in the component on
which it is based. When the work plane adapts, your sketch moves with it.
Features based on the sketch then adapt to match its new position.

In the following illustration, the grid shows the sketch plane for an in-place
part created on the plane used for a section view.

The following illustration shows the sketch plane for an in-place part created
by clicking in the graphics window.
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Workflow overview: Set a default sketch plane to create a component in place

1 Click Tools » Application Options » Part tab.

2 In the Sketch on New Part Creation box, select a sketch plane for the
default.

3 Click OK.
4 Double-click the assembly name in the browser to return to the assembly.

5 In the browser header, click the arrow and select Assembly View.

In the assembly view of the browser, assembly constraints are nested below
the component with which they are associated. (In Model View, all constraints
are collected in a single folder at the top of the browser).

If you selected the Constrain Sketch Plane to Selected Face or Plane option
when you created your new part, a flush constraint appears in the assembly
browser, and it can be deleted at any time. No flush constraint is generated if
you create a sketch by clicking in the graphics window.

Projected Edges and Features

Parts created in place often need to match one or more features on existing
components. Holes may be required to be concentric, or the outer edges of
the new part must match those of an existing component. Faces, edges, and
features on any visible component can be projected onto the current sketch.
You can then use the projected points and curves to form sketch profiles or
paths, or you can combine projected geometry with new sketch geometry if
necessary.

The following illustration shows how edges from an adjacent part are projected
into the sketch for an in-place part.
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Projected geometry remains associated with the part from which it was
projected and automatically updates to match changes in the original part's
geometry.

When you project geometry from an existing component onto a new sketch
it becomes reference geometry. You can use reference geometry to create an
adaptive matching part that automatically updates to reflect any modifications
to the outer boundary of the component from which the geometry was
projected.

Use the Project Geometry tool on the Sketch toolbar to project faces, edges,
and features onto the current sketch.

Projected geometry is positioned normal to the current sketch plane. If the
selected edge lies in a plane that is not parallel to the sketch plane, the
projected geometry is different from the original sketch. Reorient the view to
the sketch to see a true view of the projected geometry.

Subassemblies In Place

When you create a subassembly in place, you define an empty group of
components. The new subassembly automatically becomes the active assembly,
and you can start to populate it with placed and in-place components. When
you reactivate the parent assembly, the subassembly is treated as a single unit
in the parent assembly.

Optionally, you can select components at the same assembly level in the
browser, right-click, and then select Component » Demote to place them
into a new subassembly. You are asked to specify a new file name, template,
location, and default bill of materials structure. You can then move
components between assembly levels by dragging components in the browser.
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Subassemblies can be nested many layers deep in a large assembly. By planning
and building subassemblies, you can efficiently manage the construction of
very large assemblies. Additionally, you can create subassemblies that match
the intended manufacturing scheme to facilitate creating your assembly
documentation.

Guidelines for Selecting Subassembly Components

When designing a subassembly for modeling, select:
B Component groups that repeat in an assembly.
B Combinations of standard parts that are common to many assemblies.

B Components that combine to perform a common function in an assembly.

When designing a subassembly for documentation purposes, select components
that match your intended manufacturing scheme.

As you change the active assembly, the appearance of components in the
graphics window changes. If you are working with a shaded display, the active
subassembly is shaded and all other components appear translucent. If you
are working with a wireframe display, all components other than the active
subassembly are shaded light gray.

Any placed or new in-place components become part of the active assembly
or subassembly. Double-click the parent assembly in the browser to make it
the active assembly.

Creating Component Patterns

Components can be arranged in a rectangular or circular pattern in an
assembly. Using component patterns can increase productivity and efficiently
match your design intent. Typically, you may need to place multiple bolts to
fasten one component to another or place multiple parts or subassemblies
into a complex assembly.

As with feature patterns, you can create a rectangular pattern by specifying
column and row spacing, or a circular pattern by specifying the number of
components and the angle between them.

In addition, you can create associative component patterns of parts or
subassemblies by selecting an existing pattern. For example, you could create
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a component pattern of a nut and bolt by selecting an existing bolt hole
pattern. Edits to the bolt hole pattern control the location and number of
bolts and nuts.

Associative component patterns:

Include and retain constraints of the original component. If the original
component is constrained, then the component pattern is constrained.

Are associative to a part feature such as a pattern of bolt holes.

Contain individual elements that can be suppressed for display or
functional purposes.

Workflow overview: Create an associative component pattern

1

2
3
4

Place a component in an assembly file.
Constrain the position of the component relative to a feature pattern.
Click the Pattern Component button, and then select the Associative tab.

From either the browser or in the graphics window, select the placed
component.

On the Associative tab, click the selection arrow, and then select an
occurrence of a feature in a pattern from the graphics window.

Click OK.

The placed component is patterned relative to the placement and spacing
of the feature pattern. Changes made to the feature pattern automatically
update the number and spacing of the components.

Workflow overview: Create a rectangular component pattern

1
2

Place a component in an assembly file.

Click the Pattern Component button, and then select the Rectangular
tab.

From either the browser or in the graphics window, select the placed
component.

On the Rectangular tab, click the Column Direction selection arrow and
then select an edge or work axis from the graphics window. Click flip to
the column direction, if necessary.
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5 Enter the number of components to be created in the column and the
spacing between each.

6 On the Rectangular tab, click the Row Direction selection arrow, and
then select an edge or work axis from the graphics window, enter the
number of components in the row, and the distance between the
components.

Click flip to the row direction, if necessary.

7 Click OK.

Workflow overview: Create a circular component pattern
1 Place a component in an assembly file.
2 Click the Pattern Component button, and then select the Circular tab.

3 From either the browser or in the graphics window, select the placed
component.

4 On the Circular tab, click the Axis Direction selection arrow, and then
select an edge or work axis from the graphics window. Click flip to the
axis direction, if necessary.

5 Enter the number of components to be created in the circular pattern
and the angular spacing between each.

6 Click OK.

Independent Instances
You can also make one or more component pattern elements independent of
a pattern. When you make an element independent:
B The selected pattern element is suppressed.

B A copy of each component contained within the element is placed in the
same position and orientation as the suppressed element.

B The new components are listed at the beginning of the assembly browser.

B Replacement components obey the rules for component replacement.
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Workflow overview: Make a pattern element independent of a pattern
1 Expand the pattern in the browser.

2 Right-click an element other than the source component, and then select
Independent.

The element is suppressed and a copy of the components it contains is
added to the browser.

NOTE To create a new component based on another component, save a copy
with a different name and place the copy in the assembly.

You can restore an independent element to the pattern at any time by
right-clicking it in the browser, and then clearing the check mark on
Independent. The copied components created when the element was made
independent are not automatically deleted from your model.

Creating Assembly Features

Assembly features are similar to part features except that they are created in
the assembly environment, can affect multiple parts, and are saved in the
assembly file.

Assembly features include chamfers, fillets, sweeps, revolved features,
extrusions, holes, move face, rectangular feature pattern, circular feature
pattern, and mirror. They also include the work features and sketches used to
create them. The workflow and dialog boxes are the same as for part features,
but some operations are not available (such as creating a surface for extruded
and revolved features).

You can edit, add to, suppress, or delete assembly features. You can also roll
back the state of the assembly features and add or remove components that
participate in the feature.

Use Assembly Features

Assembly features describe processes that are applied after a model is assembled.
Use assembly features to:

B Define a single logical feature that spans multiple parts, such as an extrusion
cut through multiple connecting plates.
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B Describe a specific manufacturing process, such as match drilling or
post-machining.

Components can be constrained to assembly features. You cannot, however,
place a constraint between an assembly feature on one part and the same
assembly feature on another part.

You can roll back the state of assembly features to view the effect of each
assembly feature on the model or to place additional assembly features in the
desired context. When rolled back, newly created assembly features are added
above the End of Features (EOF) symbol in the browser.

Using Work Features in Assemblies

In the assembly environment, work features help you construct and position
components and check for clearance in an assembly. You can also use work
planes to help you generate section views of your assemblies. Create work
planes and axes between parts in an assembly by selecting an edge or point
on each part. These work features are associated with both parts and adjust
accordingly as the assembly is modified.

By default, all work geometry is initially visible. You can turn visibility off
and on for all work features at once. This is important in the assembly
environment, where the display of work features from individual parts can
quickly clutter the graphics window.

Workflow overview: Control visibility of work features in an assembly
1 On the Standard toolbar, click View » Object Visibility.

2 On the menu, turn off or on the work features by type or select All Work
Features.
This overrides the visibility setting for individual work features of that
type in the assembly and in each part in the assembly. Although the work
feature visibility in the assembly is suppressed, individual visibility control
remains turned on.

Replacing Components

You may need to replace a component in an assembly as the design evolves.
A simple representation of a component may be used during the design concept
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stage, which is replaced by the actual part or subassembly when detailed design
is required. Parts from one vendor may be replaced with similar parts from
another supplier.

In the following illustration, the Replace Component tool is used to replace
a simple sketched representation with the actual part.

When you replace a component in an assembly, the new component is
positioned with its origin coincident with the origin of the component it
replaces. All assembly constraints from the original component are lost. You
must place new assembly constraints to eliminate degrees of freedom of the
new component

If the replacement part has an iMate constraint, and the part to which it must
be constrained has a matching iMate, the parts snap together automatically
with all constraints intact.

If the part you are replacing is an ancestor of the original part (a copy of the
part that contains edits), then constraints are not lost during component
replacement.

An assembly can be converted to an iAssembly, a special assembly that may
contain many members with different characteristics such as length or
diameter, constraint offsets, or other variations. When you use a member of
an iAssembly as a component, you can exchange one member for another in
the active assembly. To switch one member for another of an iAssembly nested
deeply in the browser hierarchy, you must first make the immediate parent
assembly active.

Mirroring Assemblies

The Mirror Component tool is useful for designing symmetrical parts. Use it
to create a mirror of a source assembly and its components across a mirror
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plane. You create half of the assembly, and then mirror it to create the second
half. The mirrored components are exact copies, positioned relative to the
mirror plane.

You can either save a new assembly file with mirrored components and open
it in a new window, or reuse components and add the mirrored components
to the existing assembly file.

TRY IT: Mirror assembly components

1
2

6

Open the assembly you want to mirror.
On the Assembly panel bar, click the Mirror Components tool.

In the graphics window or the assembly browser, select all of the
components of the assembly. Select the assembly, or a parent subassembly
to automatically select all of the children.

The assembly and its components are listed in the Mirror Components
dialog box browser.

On the Mirror Components dialog box, click Mirror Plane, and then select
the plane in the graphics window or the assembly browser.

Click the status button of a component to change its selection status as
needed.

Status Description

Mirrored Creates a mirrored instance in the current or a new
assembly file.

Reused Creates a new instance in the current or a new
assembly file.

Excluded Subassembly or part is not included in the mirror
operation.

Mixed Reused/Excluded  Indicates that a subassembly contains components
with reused and excluded status, or that a reused
subassembly is not complete.

¢ & ¢ O

To change the orientation of a reused component, right-click the
component, and select a Symmetric Plane.
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7 Click the More button to select preview options and specify handling of
content library components:

B To enable the mirrored state for library components, clear the Reuse
Content Library Components check box.
By default, only instances of the library parts are created in the current
or new assembly file.

m To display status of mirrored components in the ghost color in the
graphics window, In Preview Components, select check boxes.

8 Click OK.
9 On the Mirror Copy: File Name dialog box, review the copied files and
make changes as needed:

B To edit the file name, click in the New Name box.
To search in listed file names, right-click in the New Name column.

To find and replace a string, click Replace.

B To change the location from Source Path to Workspace or User Path,
right-click in the File Location box. If you select User Path, click in
the File Location box and set the path.

Keep the default location so the file can be located when you reopen
the assembly.

10 In the Naming Scheme box:
B Select the Prefix check box, and then enter a prefix, if appropriate.
B To increment numbered files, select the Increment check box.

B Accept the default suffix ( MIR) or enter a different suffix. Clear the
check box to remove the suffix.

NOTE If you remove the suffix, give the file a unique name to avoid
overwriting the original file.

11 Click Apply to update the file names, or click Revert to return to the
original values.

12 In the Component Destination box, choose one of the following:

B To place components in the current assembly or a new assembly file,
click Insert in Assembly.

B To open a new assembly file, click Open in New Window.
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13 If you need to change status or select new components, click Return to
Selection. Otherwise, click OK to accept and close the dialog box.

Copying Assemblies

Use the Copy Component tool to create a copy of a source assembly or its
components.

You can either create a new assembly file and open it in a new window, or
add copied components to an existing assembly file. Each copied component
creates a new file. You can reuse components instead of copying them.

The resulting copied components are not associative, and are not updated if
the original components are modified.

TRY IT: Mirror assembly components
1 On the Assembly panel bar, click the Copy Components tool.

2 In the graphics window or the assembly browser, select components to
copy. The selected components are listed in the Copy Components dialog
box browser.

To automatically select all of the children, select the parent assembly or
a subassembly.

3 Click the status button of a component to change its component status

as needed:
Status Description
’ Copied Creates a copy of the component. Each copied
component is saved in a new file.
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Status Description

# Reused Creates a new instance in the current or new assem-
bly file.

a Excluded Subassembly or part is not included in the copy op-
eration.

* Mixed Reused/Excluded  Indicates that a subassembly contains components
with reused and excluded status, or that a reused
subassembly is not complete.

4 To enable copying of library components, click the More button and
clear the Reuse Content Library Components check box.

5 Choose OK to open the Copy Components: File Name dialog box.
6 On the Copy Components: File Name dialog box, review the copied files

and make changes as needed: to search in listed file names

B To edit the file name, click in the New Name box. To search in listed
file names, right-click in the New Name column, and choose Find.
To find and replace a string, choose Replace.

B To change the location from Source Path to Workspace or User Path,
right-click in the File Location box. If you select User Path, click in
the File Location box and set the path.

B Keep the default location so the file can be located when you reopen
the assembly.

7 In the Naming Scheme box:
B Select the Prefix check box, and then enter a prefix, if appropriate.
B To increment numbered files, select the Increment check box.

B Accept the default suffix (_CPY) or enter a different suffix if
appropriate.

B To remove the suffix, clear the check box.
If you remove the suffix, give the file a unique name to avoid
overwriting the original file.
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10

To update the filenames, click Apply. To return to the original values,
click Revert.

On the Component Destination box, choose one of the following:

B To place components in the current assembly file, click Insert in
Assembly.

B To open a new assembly file, click Open in New Window.

To change status or select new components, click Return to Selection.
Otherwise, click OK.
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Analyzing Assemblies

In this chapter, you learn to analyze assembly components for interference by simulating the
motion of the assembly components.

Checking for Interference

In the physical assembly built from your design, two or more components
cannot occupy the same space at the same time. To check for such errors,
Autodesk® Inventor™ can analyze assemblies for interference.

The Analyze Interference tool checks for interference between sets of components
and among the components in a set. If an interference exists, Autodesk Inventor
displays the interference as a solid and displays the volume and centroid in a
dialog box. You can then modify or move the components to eliminate the
interference.

Analysis takes longer for complex assemblies. An efficient strategy is to analyze
only a few components at a time, such as those in close proximity to one
another. It is a good idea to analyze, reposition, and redesign components on
a regular basis rather than analyzing the complete assembly all at once.

To check interference within a set, select all components in the set. All parts in
the set are analyzed against each other, and interferences are shown in red.

To speed up the process, you can select only the components that you want to
check. For example, if you revise a part in an assembly, you can limit the
interference check to the components affected by the change. The volume and
location data are displayed when you click More in the dialog box, as shown
in the following illustration.
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Interference Detected

A total of 1 interferenceds) were detected with a total

1 E wvolume of 0,000 in in in.
L
2 oK | <2 |

Additional Information: =)

Ttem | Park 1 Patt 2 Centroid % | Centroid ¥ | Centroid 2
Inkl Pivot_Bas... Simple_ar... -0,239 -1.273 0,791
interference ———————————»

NOTE Creating components in place, using faces of adjacent components as
sketch planes, and projecting geometry from other component faces for use in
sketches reduces the chance of interference between parts.

Workflow overview: Analyze interference between parts

1 Activate the assembly that you want to analyze. Interference analysis is
only available in the assembly environment.

Click Tools » Analyze Interference.
Select the two sets of components to be analyzed.

Click OK. The Interference Detected dialog box is displayed.

wn A W N

Expand the dialog box to see a detailed analysis report in table form. The
report table can be copied to the clipboard or printed.

Checking for Degrees of Freedom

Each unconstrained component in an assembly has six degrees of freedom
(DOF). It can move along or rotate about each of the X, Y, and Z axes. The
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ability to move along X, Y, and Z axes is called translational freedom. The
ability to rotate around the axes is called rotational freedom.

Whenever you apply a constraint to a component in an assembly, you remove
one or more degrees of freedom. A component is fully constrained when all
degrees of freedom (DOF) have been removed.

Autodesk Inventor does not require you to completely constrain any
component in an assembly. You can save time by removing only critical DOF
for your model. There are situations in which you do not remove DOF. For
example, do not remove DOF so that Inventor can correctly interpret the
design intent when the assembly is animated, or to leave yourself design
flexibility for a later phase in the design process.

To show the DOF symbol for all components in an assembly, select Degrees
of Freedom from the View menu.

The straight lines with arrows at one end represent the translational degrees
of freedom along the X, Y, and Z axes. The arcs represent rotational degrees
of freedom about each axis.

Unconstrained Drag

You can move unconstrained components by dragging them in the graphics
window.

Partially constrained components sometimes need to be moved or rotated to
facilitate constraint placement. Use the Move Component and Rotate
Component tools to temporarily release all assembly constraints so you can
reorient a component. Any assembly constraints that have been placed are
reapplied to the assembly as soon as you click Update.

Constrained Drag

Dragging a single constrained component causes other components in the
assembly to move, according to the relationships defined by their assembly
constraints. This technique is very useful in determining the suitability of
assembly constraints placed on a component.

Drag a component after applying an assembly constraint to quickly gauge the
effects of the constraint. Grounded components cannot be moved in this
manner.
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Careful planning and placement of assembly constraints is the key to obtaining
proper assembly motion. Apply as many assembly constraints as needed to
position, or in the case of an adaptive part, size your component. Temporarily
suppress assembly constraints that interfere with assembly motion.

Constraint Drivers

Dragging a small component in a large assembly, or dragging a component
about an axis of rotation can be difficult. Autodesk Inventor provides a unique
tool to drive the value of an assembly constraint. You can specify movement
range and step size, determine movement cycling, and set a pause time between
steps. Mate and angle constraints between faces are common choices for driven
constraints.

Assembly motion can be halted if interference is detected between components.
Refine the increment value and drive the constraint to determine a precise
constraint value where interference occurs. When interference is detected, the
motion stops and the interfering components are highlighted in the browser
and graphics window.

Adaptive parts can be resized to match the varying assembly constraint.
Adaptive features and parts are presented earlier in this manual.

The motion can be recorded as an AVI file using any code available on your
computer.

Drive Constraints

After you constrain a component, you can animate mechanical movement
by changing the value of the constraint. The Drive Constraint tool repositions
a part by stepping through a range of constraint values. You can rotate a
component, for example, by driving an angular constraint from zero to 360
degrees. The Drive Constraint tool is limited to one constraint. You can drive
additional constraints by using the Parameters tool to create algebraic
relationships between constraints.
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Drrive constraint used to simulate a clock.
Minute and hour hands are constrained to the
dial. Drive constraint rotates the minute hand.
Parameters tool defines the hour hand position
as a function of minute hand position.

Use the Drive Constraint tool on the context menu to simulate mechanical
motion by driving a constraint through a sequence of steps. Right-click the
constraint in the browser and then enter information in the Drive Constraint
dialog box to define the drive constraint and to control motion.

Drive Constraint {0.00in) B
Stop
Stark End Pause Delay
0.000 i 10,00 0.000
Forward — " LI I L L! ! 2 Reverse Step
¥
Reverse —p= )l 4 | u | |«| «l »|»|| — Maximum
.fl
Record —— @& | v Min%ze dialog during recording Forward step
inimum
@l | Apply I Cancel | >>|

Constraints may limit the motion of parts. Depending on the geometry,
degrees of freedom are removed or restricted. For example, if you apply a
tangent constraint to two spheres, all six degrees of freedom remain, but you
can'’t translate one of the spheres in just one direction.

Tangent constraint applied to two spheres. All six
degrees of freedom remain, but they are restricted.

Tangent constraint applied to cylinder and hole.
Cylinder and hole are the same size, so only two
degrees of freedormn remain
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Animating Assembly Components

Mechanical assemblies are rarely static. By animating the movement of
constrained assemblies with Autodesk Inventor, you can examine your model
throughout its range of motion. Use Inventor assembly animation to visually
check for component interference and examine mechanism movement to
improve your designs.

In this two-part exercise, you first constrain a component in a lift fixture
assembly. You examine degrees of freedom as constraints are applied, and
examine the motion of the assembly by dragging a strategic component in
the graphics window.

In the second part of the exercise, you replace a simplified representation of
a component in an assembly, define an angle constraint for a pivot, and then
animate the assembly using the unique constraint driving capabilities of
Inventor to check where component interference occurs.

You can view degrees of freedom for a part in the Properties dialog box
available from the right-click menu in the browser. In the Properties dialog
box, on the Occurrence tab, you can turn the Degrees of Freedom option on
or off. The Degrees of Freedom option is also located in the View menu.

This exercise demonstrates how to properly constrain an assembly for motion
analysis.

The completed exercises are shown in the following figure.

TRY IT: Remove a degrees of freedom constraint

1 With the project tutorial_files active, open the file remDOFs.iam. The
assembly should look like the following figure.
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2 Click View » Degrees of Freedom. The NewSleeve.ipt part is
unconstrained, so all six degrees of freedom are available.

degrees of freedom
symbol

3 Click the Constraint tool in the panel bar or from the Assembly toolbar.
Place a mate constraint between the major axis of NewSleeve.ipt and the
axis through the cylinder feature of NewSpyder.ipt. This constraint removes
two translational degrees of freedom and two rotational degrees of
freedom from the sleeve.

4 Remove the last rotational degree of freedom from the sleeve. Place a
mate constraint between the axis (not a hole center) through the open
bolt hole of the NewAdjust_Link.iam, and the axis through the bolt hole
in one of the sleeve tabs. If required, zoom in or use the Select Other tool
to select the axes.
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second selection

first selection

N\

5 The sleeve is now constrained to move only along the axis of the spider.
Click View » Degrees of Freedom to hide the DOF symbols.

6 Use the Rotate and Zoom tools to orient your view of the assembly as
shown in the following figure.

7 Slowly drag the NewLiftRing.ipt. All components with constraints that are
linked to the dragged component move in response, while honoring their
own assembly constraints.

Close the file without saving or save the file with a new name to preserve
the original data file.

Selecting Components

When working in an assembly, you often need to select a set of components
for a common operation, such as turning off visibility or verifying which
components are underconstrained. You may need to select components by
size, location, relation to other components, or other criteria.

You can select components using one of several methods, and then apply one
of several options, such as invert the selected order or revert to the previous
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selection set. You can isolate the selection set by turning off visibility of all
components that are not selected.

Before you try the following exercises, open an assembly and click the Select
button on the Standard toolbar, and then select the priority mode:

Part Priority Selects parts or assemblies instead of features, faces or
edges.

Component Priority Selects only the first-level components of the edited
assembly.

Feature priority Selects features (including work features) on any part
in the assembly.

Select Faces and Selects faces or individual curves that define faces on

Edges any part in the assembly.

Select Sketch Features Selects sketch geometry used to create features or
sketches or the individual curves that define sketches.

Select Visible Only Includes only visible components in a selection set. Is
applied to all selection methods.

The priority selection mode makes it easier to select the geometry you want
to include in a selection set. Particularly in complex assemblies, narrowing
the range of selections can help you select the correct object.

In addition to selecting a particular type of geometry, you can also base
selections on criteria such as components constrained to a selected component,
components of a particular size, or offset by a distance, or on a specified side
of a plane.

In this example, you select components constrained to one or more
components.

TRY IT: Select by constraints
1 In the graphics window or the browser, select one or more components.

2 On the Assembly Standard toolbar, click Select » Constrained To. All
components constrained to the preselected component are highlighted
in the graphics window and in the browser.

After you isolate the selection set, you may notice that some components you
expect to be included are not visible. This is a quick way to see which
components are not constrained to the first-selected component.

In the next example, highlight components relative to the size of the selected
component.

Selecting Components | 181



TRY IT: Select by component size
1 On the Assembly Standard toolbar, click Select » Component Size.
2 If not preselected, use the Select tool in the Select by Size box to select a

component.

Selections are contained in a virtual box called a bounding box. Its size
is determined by the outermost extremities of the selected component.

3 The size is shown, determined by the bounding box of the selected
component. Click At Most or At Least to specify the relative size to select,
and then click the green arrow.

Selected components are highlighted in the graphics window and the
browser.

You can highlight components contained within a bounding box of the
selected component, plus and offset distance.

TRY IT: Select by offset distance

1 On the Assembly Standard toolbar, click Select » Component Offset.

2 If not preselected, use the Select tool in the Select by Offset box to select
a component.

Selections are contained in a virtual box called a bounding box, whose
size is determined by the outermost extremities of the selected component.

3 The offset distance is shown, determined by the bounding box of the
selected component. If desired, click a bounding box face and drag to
resize. Select the check box to also include components partially contained
in the bounding box, and then click the green arrow.

Selected components are highlighted in the graphics window and the
browser.

Try using some of the other selection methods, including:
Select All Occurrences

Sphere Offset

Select by Plane

External Components

Internal Components
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B All in Camera

W Visible Filter
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Using Design Accelerator

In this chapter, you learn about Design Accelerator and how to work with generators and
calculators.

What is Design Accelerator

Design Accelerator represents an important component of Functional Design,
providing engineering calculation, and decision support to identify standard
components or create standards-based geometry. Design Accelerator tools
simplify the design process, by automating these selections and geometry
creation, improving initial design quality by validating against design
requirements, and increasing standardization by selecting the same components
for the same tasks.

Design Accelerator provides a set of generators and calculators that can create
mechanically correct components automatically by entering simple or detailed
mechanical attributes. For example, you can use the bolted connection generator
to insert a bolted connection at once by offering to select the right parts, select
holes, and assemble components together.

To insert components using Design Accelerator generators and calculators, you
must be within the assembly environment. Open the Design Accelerator panel
bar. The available generators and calculators commands are displayed. Generators
and calculators are grouped according to functional areas. For example, all welds
are grouped. The panel bar displays the last calculator or generator used for the

group.

NOTE Before you start working with any generator or calculator, your assembly
must be saved.

To open generator or calculator, click the appropriate command. Generators
are opened on the Design tab, calculators on the Calculation tab, by default. In
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the Design tab, you specify the placement options and select the type of
components you want to insert. In the Calculation tab, you enter the
calculation values. For Bolted Connection Generator and for some calculators,
the Fatigue Calculation is also available to specify values for fatigue calculation.

NOTE Only one generator/calculator can be open at a time - when one
generator/calculator is opened and you want to open a new one, the first one is
automatically closed.

If you want to perform the calculation, click the Calculate button.

When you want to insert designed components and calculations to Autodesk
Inventor assembly, click OK.

What operations can | perform within Design
Accelerator?

When you open the Design Accelerator panel bar (click the arrow in the
Assembly panel bar), a set of tools is displayed. They are divided into three
groups:

B Component Generators
B Mechanical Calculators

B Engineer’s Handbook

Work with Generators

Using Component generators you design desired components. You can also
perform calculations. Some generators use Content Center components, for
example Bolted Connection Generator, or Clevis Pin generator. Connect to
the Content Center to insert components using such generators. Without
being connected to Content Center, you can perform various calculations of
the components.

You can use the following Design Accelerator generators:
B Bolted Connection

H Shaft
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Involute Splines
Parallel Splines
Key Connection
Disc Cam
Linear Cam
Spur Gears
Bevel Gears
Worm Gears
Bearing

V-Belts
Synchronous Belts
Roller Chains
Clevis Pin

Joint Pin

Radial Pin

Secure Pin
Workflow overview: Insert components using Design Accelerator
generators/calculators

1 On the Assembly panel bar, open the Design Accelerator panel bar, and
click the appropriate generator or calculator.

2 On the Design tab, select the type of components you want to insert and
complete the placement options.

3 On the Calculation tab, enter the calculation values.
4 Click Calculate to perform the calculation and verify results.

5 Click OK to insert component or calculations to the Autodesk® Inventor™

assembly.
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Work with Bolted Connections

Use the Bolted Connection generator to design and check pretensed bolted
connections loaded with axial or tangential force. The purpose of the design
calculation is to select an appropriate bolted connection after specifying the
required working load. The strength calculation performs a check of bolted
connection (for example, pressure in the thread and bolt stress during joint
tightening and operation).

When you can create and design bolted connections, you can enter them as
one group into Autodesk Inventor.

The generator supports two ways of designing bolted connections. The first
uses an aperture you have already created in the Inventor model and, on the
basis of the parameters of the aperture, selects the correct dimensions for the
components in the bolted connection. The second method designs the whole
connection, including the aperture which is then created during entry (or
drilling) into the selected connection.

You can use either method to select fastener components directly from Content
Center. You can display the standard components dialog box to add more
information (for example, material values, information from external databases,
or other company information).

In this two-part exercise, you create a bolted connection. You select the bolted
connection components and the bolted connection placement. In the second
part of the exercise, you change the type of component of the already inserted
bolted connection.

The completed exercises are shown in the following figure.
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TRY IT: Insert a bolted connection

1 With the tutorial_files project active, open Bolted_connection.iam. The
assembly should look like the following figure.

2 On the Assembly panel bar, click the Bolted Connection tool.
3 On the Design tab, Type section, select Through All.

g Design [

Type

E3
¥

4 In our assembly, we have a hole where we want to insert the bolted
connection. In the Placement selection list, select By hole.

| By hole j
Linear

Concentric

5 Click the Start Plane button. In the assembly, select the start plane as
shown in the following figure.
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6 Select Existing Hole. In the assembly, select the hole as shown in the
following figure.

7 Select Termination. In the assembly, select the termination plane as
shown in the following figure.
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8

10

Specify the thread type and dimension as follows:
As Thread: ISO Metric profile

Insert Diameter: 6mm

Begin populating the bolted connection. Select Click to add a fastener.

A filtered list of available fastener content (from Content Center) displays.
It is based upon previously set Thread settings (Standard and Thread size).
You can narrow the displayed list of fasteners by selecting a standard.

In the displayed list of bolts, select Slotted Flat Countersunk Hex bolt.

The selected bolt displays in the Design tab of the bolted connection
generator. In the Inventor assembly, the bolt preview is created.

ountersunk He. .. HI
£3

Click to add a fastener

Selected Hole
ZQ:Z Existing. ..

% :ZISO Crilled hole
Mormal 600 mm

Click to add a hale

Click to add a fastener
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11 Select Click to add a fastener. In the washer selection list, select Plain
washer (metric).

The selected washer displays in the Design tab of the bolted connection
generator. In the Inventor assembly, the washer preview is created.

12 Select Click to add a fastener. In the nut selection list, select Hex jam
Nut.

The selected nut is displayed in the Design tab of the bolted connection
generator. In the Inventor assembly, the nut preview is created.
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13

14

15

16

17

Click OK.

Now, when the bolted connection is inserted, it is easy to change any
component with the bolted connection. We will change the type of
washer.

In the file Bolted_connection.iam assembly, select the inserted bolted
connection.

Right-click and select Edit Using Design Accelerator. The Bolted
Connection generator displays.

Click the arrow at the end of the Plain washer (Metric) edit field to display
the washer selection list.

B,

In the selection list, select the External Tooth Lock Washer and click OK
to update the bolted connection assembly.
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Insert All Components At Once

It is also possible to insert all types of components (component, feature,
calculation) at one time.

In the following exercise, you insert key and shaft groove using the Key
Connection generator.

TRY IT: Insert Key connection

1 With the project tutorial_files active, open the file bearing.iam. The
assembly should look like the following figure.

194 | Chapter || Using Design Accelerator



2 On the Design Accelerator Assembly panel bar, click the arrow next to
Shaft item and select Key Connection.

The Key Generator displays.

3 On the Design tab, first specify the placement of the shaft groove. Make
sure that Create New is selected in the Shaft Groove selection list. Click
the shaft element to select reference for shaft groove insertion as shown
in the following figure.

4 Select the second reference as shown in the following figure. In the
assembly, the shaft groove preview is presented. Click the grips in the
preview to change the shaft groove length, position, and angle (rotation).
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5 According to the selected shaft element, the shaft diameter value was
inserted to the Key Generator and edit field became disabled. Edit the
Key Length by either selecting the value from the selection list or use the
preview grip in the assembly.

6 On the Design tab, Select objects to Generate, click the Hub Groove
button to disable hub groove insertion.

Only the key and shaft groove icons are enabled to insert key and shaft
groove.

"Select Chbjects to Generate

7 Click OK.
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Work with Calculators

Design Accelerator offers a set of tools to perform mechanical calculations of
selected components. Engineering calculators use standard mechanical
formulas and physical theories in design and validation of mechanical systems.
You specify calculation criteria and calculators perform the calculation and
displays report about a calculation. If the calculation doesn’t indicate the
calculation compliance, error message is displayed advising you what values
need to be updated. Using Design Accelerator calculators you do not insert
components into the Autodesk Inventor, only calculation is inserted when
you click OK.

The following calculators are available:
Plain Bearing
Plug and Groove Weld
Butt Weld

Spot Weld
Filled Weld (Spatial Load)

Butt Solder Joint

|

|

|

|

B Filled Weld (Connection Plane Load)
|

|

B Bevel Solder Joint

|

Lap Solder Joint
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Step Tube Solder Joint
Step Solder Joint
Separated Hub Joint
Slotted Hub Joint
Cone Joint
Tolerance

Limits and Fits
Press Fit

Power Screw

Beam and Column
Plate

Shoe Drum Brake
Disc Brake

Cone Brake

Band Drum Brake

TRY IT: Calculate separated hub joint
1 On the Design Accelerator panel bar, click Separated Hub Joint.
2 On the Calculation tab, enter calculation parameters.

3 Click Calculate to perform the calculation. Results are displayed in the
Results area.

4 If the calculation results are satisfactory, click OK to insert separated hub
joint calculation to the assembly.

Author User Parts

The Component Authoring tool enables the authoring of custom content for
use with AutoDrop and content-based Design Accelerator generators. Guided
step-by-step prompts prepare components with iMates and properties necessary
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for efficient use of functionally smart content ready for publishing to the
Content Center Library.

During the authoring of user parts, you specify:
Content Category
Part placement (iMates)

Category parameters

Parameter and iPart table mapping

You can author and publish all standard parts:
Bearings
Bolts

Clevis Pins

|

|

|

m Cotter Pins

B Retaining Rings (Circlips)
m Keys

m Nuts

B Washers

Use the Component Authoring tool to prepare an iPart or a normal part for
publishing to the Content Center Library. In the Component Authoring dialog
box, items listed in red are required settings for publishing.
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Orientation Axds
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TRY IT: Author user parts

1
2
3
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Open a custom iPart in Autodesk Inventor.
Click File » Component Authoring.

Select the part category. The Category selection list displays the list of
available publishing categories. Once you select a Category, the graphics
and selection prompts change depending upon the Category of
component selected.

Create the iMates following the tooltips and graphical guide for the
specific component.

Move to the Parameter Mapping Tab where you map the parameters to
the related column name in the iPart table. Map all required parameters
in the list.

When authoring is successful, click OK.
Click the Publish Now button to start the Publish Part command.

Continue working with the Content Center Publish tool to publish parts
to the Content Center.
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NOTE Since you selected a category early on in the process, the Content Center
displays this category for publishing. For example, a bolt can now be published
directly into the Bolt category, an existing subcategory of Bolt, or you can create
a category under Bolt.

NOTE You can rename the iMates as needed. These new names populate the
iMate list in both the panel browser and the Component Authoring dialog under
the iMate list.

Set File Names

The Design Accelerator Settings dialog box is available to change or redefine
the Display name and the File name for Design Accelerator generators and
calculators.

Use the File Naming dialog to specify the name of the connection and newly
created components lets you change the filename and location on disk.

When you work in any generator or calculator, V-Belts Generator foe example,
you click the File Naming icon in the right upper corner. The File Naming
icon is available within all tabs (Design, Calculation, Fatigue Calculation).

Double-click the row to enter the Displayed name, V-Belt transmission1, for
example. The name can contain letters, numbers, or any symbol.

To specify the file name location, click the button next to the selected row.
The button is available only for one selected row at a time. In the selected
folder, the component is stored.

When you select the Always prompt for filename option, you are prompted
to specify file name and display name every time you insert a new DAcc
component into the assembly. During edit, the dialog is displayed only if you
add a new component, a new pulley using V-Belts Generator, for example.
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File Naming 5]

Ttem Display name File: name
W-Belt transmission  C:iMy Documentsi AssemblysiDesign Acceleratoriy-Belt transmission] iam
W-Belt CiAMy DocumentstAssemblyaiDesign Acceleratoriv-Beltlipt
Grooved Pulleyl CiiMy DocumentstAssemblyaiDesign AcceleratoriGrooved Pulleyl1.ipt
Grooved Pulley2 CiAMy DocumentstAssemblyaiDesign AcceleratoriGrooved Pulley21.ipt

[¥] always prompt For filename | [a]'4 | [ Cancel ]

NOTE In the File Naming dialog, you can only edit items in white edit fields.

TRY IT: Set file names

1 In the Design Accelerator Generators and Calculators, click the file
Naming icon.

2 Double-click the Display name to insert the display name.

3 Click the button next to the edit filed to specify the folder where
component is stored.

4 Click OK to confirm the settings and close the File Naming dialog box.
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Setting Up Drawings

In this chapter, you learn about setting up drawings, using drawing styles, and using drawing
resources such as sheet layouts, title blocks, and borders.

Creating Drawings

After you create a model, you can create a drawing to document your design.
In a drawing, you place views of a model on one or more drawing sheets. Then
you add dimensions and other drawing annotations to document the model.

SECTION A-A
SCALE 1:1

TRARING Autodesk, Inc

A3 |
i 1 IPTTE
T T T

You can change the alignment, label, line style, scale, and displayed dimensions
in any view. You can also edit your part by changing the parametric model
dimensions from within the drawing file, if when you installed Autodesk®
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Inventor™. Set the option to allow drawing dimensions to resize the model.
Similarly, your drawing file automatically updates with any changes saved in
the model file.

Autodesk Inventor comes with standard templates to use as the starting point
for your drawings. Template files have the standard drawing extension (.idw,
.dwg). Autodesk Inventor stores template files in the Autodesk \Inventor (version
number)\ Templates folder. You can also create your own templates, specifying
unique characteristics, and save them in the Templates folder.

NOTE When you select New Drawing from the drop-down menu next to the New
button, Autodesk Inventor looks for a file named Standard.idw or Standard.dwg in
the Autodesk\Inventor (version number)\Templates folder. The setting specified in
the Default Drawing File Type option in the Drawing Tab in Application Options
controls the default drawing type used (.idw or .dwg) when creating a drawing
using the New Drawing button in the Standard toolbar.

You start with a drawing template when you create a drawing.

Workflow overview: Create a drawing

1 Click the New button on the Standard toolbar, and then choose a drawing
template from the Default, English, or Metric tab.

The default drafting standards are based on the settings you specified
when you installed Autodesk Inventor. The default drawing is a blank
sheet with a border and title block. The English and Metric tabs contain
the templates for those units of measure.

2 On the Drawing Views panel bar, click Base View.

3 On the Drawing View dialog box, click the Browse button beside the File
box to locate a part or assembly. If you already have a model open, it is
used by default for the view.

4 Accept the default scale, label, and other settings. A preview of the view
is attached to the cursor. Click a point on the drawing sheet to place the
view and close the dialog box.

If the view is not positioned as you would like it, click its dotted line
boundary and drag to a new location.

Autodesk Inventor maintains links between components and drawings, so
you can create a drawing at any time during the creation of a component. By
default, the drawing updates automatically when you edit the component.
However, it is a good idea to wait until a component design is nearly complete
before you create a drawing. Edit the drawing details (to add or delete
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dimensions or views, or to change the locations of notes and balloons) to
reflect the revisions.

Sometimes it is more efficient to create a quick 2D drawing using a sheet sketch
or draft view than it is to design a solid model. With Autodesk Inventor, you
can create 2D parametric drawing views, which you can also use as sketches
for 3D modeling.

NOTE You can directly open AutoCAD® DWG (.dwg) files in Autodesk Inventor
using the open command and then view, plot, and measure the file contents. The
AutoCAD obijects remain as AutoCAD obijects in Autodesk Inventor, and display
exactly as they do in AutoCAD. In addition, all the AutoCAD data is available for
copy and paste. You can open an AutoCAD DWG file in Autodesk Inventor, and
then copy and paste AutoCAD entities into any Autodesk Inventor sketch.

Edit Model Dimensions in Drawings

In addition to model changes updating the drawing, you can also revise parts
and assemblies by changing model dimensions in a drawing. This two-way
associativity helps ensure that documentation represents the latest version of
a component.

NOTE When you installed Autodesk Inventor, you specified if you wanted drawing
dimensions to update models. To change this setting, re-install Autodesk Inventor.

To view and edit model dimensions in a drawing, use the Retrieve Dimension
command on the Drawing Annotations panel bar. Autodesk Inventor updates
all instances of the part to reflect your changes.

Whenever you revise a part in the drawing environment, check any assemblies
where the part is used to confirm there are no interferences.

Formatting Drawings with Styles

Use styles to format objects in Autodesk Inventor documents. Assembly and
part modeling styles format color, lighting, and materials. Drawing styles
format dimensions, hole tables, hole notes, text, parts lists, tables, balloons,
and many other attributes associated with drawing annotations.

When you install Autodesk Inventor, you specify a drafting standard. Each
drafting standard comes with a default set of styles that are enough to get you
started. You can add and edit styles as needed.
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All styles associated with a drafting standard are stored in a style library. You
can customize the style library and link it to a project file (.ipj). All files
included in the project then use the same styles for formatting.

If you use style libraries on projects, share styles among designers. Documents
are uniformly formatted, and updates are easy. When you update the main
style definition in the library, all documents that use the style library can
update their formatting.

NOTE Usually, when you create or edit a style in a document, it remains in the
document. If you want to include the style in the style library, click Format »
Save Styles to Style Library. When you save a style to the library, you replace the
master definition of the style with the new version. Use caution because it can
affect other documents that reference the style library and use the style for
formatting.

Use Styles In Templates

Legacy documents were formatted using styles stored in template files. You
can still use templates with styles and reference a style library as well. To avoid
making your file size larger than necessary, to use Format » Purge Styles to
remove unused styles from the document. Only styles that are not in use can
be purged, so you do not risk losing formatting you need.

Some styles reference other styles as substyles. One example is the dimension
style, which uses the text style to format dimension text. If you change a text
style, it affects a dimension style that references the text style. If you purge a
style that references another style, confirm if you also want to purge the
referenced style.

Styles and templates each have their uses and advantages:

B Templates are a good place to store information that stays the same, such
as title blocks, borders, default views, sheet sizes, and so on.

W Style libraries are a good way to control formatting. If a style is stored in
a template, it is only available to future documents created with the
template, so previously created documents must be manually updated.
With style libraries, a style definition is available in any document simply
by refreshing the library.
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Share Styles Between Documents

You can share styles between documents in two ways:

Use Format » Save Styles to Style Library to save a new or edited style to
the style library. Then it is available for use in any document.

Use the Styles Editor Import/Export tool to select one or more styles and
export them at once. The same process is used to import styles.

Use Styles Available In Drafting Standards

Each drafting standard has a complete set of styles. Before you create views
of your model, review the available styles to become familiar with the
formatting settings. If necessary, you can adjust values and save them to the
style library.

All

formatting for styles is controlled within the Styles and Standards Editor.

Create or open a drawing document and then review the styles.

TRY IT: Examine the available styles for the drafting standard

1
2

With an .idw file open, click Format » Style and Standard Editor.

On Style and Standard Editor, select All Styles from the Filter Styles
dropdown in the top right corner.

On the left pane of the Style and Standard Editor dialog box, review the
list of object included in the style.

Expand the Standard item. All available standard styles are displayed.
Click a style name to display the Standard window.

On the Standard window, review the settings and values associated with
the standard style.

On the left pane, expand the Dimension item and click a dimension
style. Notice that dimension style settings are edited on seven tabs. Click
the Display tab, for example, to see preferences for how dimensions are
represented in the graphics window and on the drawing sheet.
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NOTE Some styles are used on several tabs. For example, the Dimension Text tab
specifies appearance of text used in dimensions. The formatting originates in the
Text style, accessed in the browser pane. When a style references another style
for some of its formatting, the referenced style is called a substyle.

Create Styles

You can create a style by modifying an existing style. The changed style is
saved in the current document and is not available to other documents until
it is saved to the style library.

TRY IT: Create a style in the current document

1 On the Style and Standard Editor dialog box, click a style you want to
use as the basis for the new style. For example, click Leader in the browser
pane and then select a leader style to display its attributes in the window.

2 Click New. On the New Style Name dialog box, accept the default “Copy
of ....” name or give it a unique name.
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Select the Add to Standard check box so that the style is listed among
available styles for the standard. You can check later by clicking the
Standard style and then clicking the Available Styles tab. Your new style
is listed and its check box is selected.

3 The new style name is listed in the browser pane under Leader. Select the
name and change values as desired.

4 Click Save to save the new style in the current document, and then click
Done.

Object Defaults Styles and Layers

The Object Defaults style assigns a style to all objects created in a drawing. It
lists the object type, the style on which it is based, and its associated layer.
The Object Defaults style is referenced in the Standard style.

Use the Object Defaults list to customize the default object style and the layer
on which the object resides. For example, for balloons, you can change the
default layer from Symbol to Dimension. Any previously created balloons that
use the default layer are moved to the Dimension layer. New balloons are also
placed to the Dimension layer.

Consider using layers as a grouping mechanism, like AutoCAD. Click the
column headings to sort the columns. For example, all objects that use the
Symbol layer are grouped, so you can see if you want to change any.
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Using Drawing Resources

You can modify the drawing border and title block to comply with your

company specifications.

NOTE Always save customized settings to drawing resources in the template.
Otherwise, they are available only in the current document.

The first folder at the top of the browser is Drawing Resources. You can expand
Drawing Resources to show the sheet formats, borders, title blocks, and

sketched symbols that are available to use in the drawing. You can customize,
add to, or delete items from Drawing Resources.
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Sheet Layouts

When a new drawing is created, it automatically has at least one sheet. You
can change the default sheet size to a standard or custom sheet size, and specify
its orientation.

You can insert borders, title blocks, and views onto the sheet. Available borders
and title blocks are listed in the Drawing Resources folder in the browser. Icons
in the browser represent the sheet and all its component elements.

You can add multiple sheets to a drawing. Use the browser to move views
between sheets. Only one sheet is active at a time. Inactive sheets are dimmed
in the browser.

L@ User Symbals

= Sheet

2~} Default Border
i ANS| - Large
¢ Wiewl:Part? ipt
w3 pillove block.iam

m— displayed

view dragged to Sheet 1

Edit Default Sheets

cursar touching Sheet 1 icon

insertion bar indicates where view is

Edit the default sheet to modify the following information:

Sheet name
Sheet size
Sheet revision
Orientation
Count attribute

Print attribute

To edit the sheet attributes, right-click the sheet in the browser, and then
select Edit Sheet. The Edit Sheet dialog box is displayed.
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[ Exclude From printing

Format Sheets

You can create a sheet with a predefined layout of border, title block, and
views by using a sheet format from Drawing Resources » Sheet Formats.
Right-click the sheet resource, and then select New Sheet. The format
corresponds to a standard sheet size with an appropriate title block and border.

If the format you choose contains one or more views, the Select Component
dialog box is displayed when you create a sheet. Use the Browse button to
specify the model to document. Default views of the model are then created
automatically.

Sketch Overlays

You can create a sketch overlay sheet to add graphics or text to your drawing
without affecting drawing views. You can redline a drawing, for example, by
working on the sketch overlay.

Drawing Borders

The Default Border is parametric. It automatically adjusts its size and labeling
if the sheet is resized. When you insert a border, the Default Drawing Border
Parameters dialog box is displayed. The default setting for the number of
horizontal and vertical zones depends on the current sheet size.

Click the More button to modify the text, zone layout, and sheet margins.
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You can create and save custom borders in the current drawing. Unlike the
Default Border, custom borders are not parametric and do not resize when a
sheet is resized. Once a custom zone border is inserted, right-click the border
and select Edit Definition or Edit Instance. Make changes and save it according
to the option selected (to the instance or the definition). If it exists within
the Drawing Resources folder under Borders, you can right-click and select
Edit.

To insert a border, expand Borders in the browser, right-click the border you
need, and select Insert Drawing Border. If you select the Default Border, the
Default Drawing Border Parameters dialog box is displayed.

Default Drawing Border Parameters

Horizontal Zones——— | [ Vertical Zones

4 Mumber of Zones | 4 MNumber of Zones

Label —————— Label -

" Alphabetical " alphabetical

% Numeric " Mumeric

" None " Mone

@) OK | Cancel |
Text Style: Text Laver: Line Layer:
[By Standard j [B\; Standard ;I |By Standard Ll
—Label Zones From Delimit Zones By

(¢ Bottom/Right " Line ¥ Center Marks

" TopfLeft " Arrowhead
—Sheet Margins

Top Right Bottom Left

| 0.500 | 0750 | 0.500 | 0,750

To insert a custom border, expand Borders in the browser and then click Define
New Border. Use tools on the Sketch panel bar to create the border, and then
right-click in the sketch window and select Save Border. Enter a name for the
new border and then click Save. You cannot save a custom border in a template.
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Title Blocks

The title blocks in an Autodesk Inventor drawing reflect information about
the drawing, the sheet, and the design properties. As this information changes,
the title block is automatically updated to display the current information.

Examples of the information that can be displayed in a title block include:

Title

Author

Part number
Creation date
Revision number
Sheet size
Number of sheets

Approved by

The information in a title block is referred to as a property field. Use the
Drawing Properties dialog box to enter most of the information for your title
block.
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The standard drawing templates contain title block formats that you can
customize and use. You can also create your own title block formats.

Workflow overview: Define a new title block

1 With an .idw file open, click Format » Define New Title Block. The
current sheet becomes an active sketch plane, and the Drawing Sketch
panel bar is activated.

2 Use the tools on the Drawing Sketch panel bar to draw the title block.
Define and use a grid to accurately sketch the lines for the title block.

3 On the Sketch toolbar, click the Text tool and then click in the title box
to indicate the insertion point.

4 On the Format Text dialog box, click Type, and then select a property
type from the list. Click Property, and then select a specific property.
Specify other setting as needed, and then click OK.

5 Right-click in the graphics window, and then click Save Title Block. Enter
the name for the new title block, and click save.
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NOTE The new title block is added to the Drawing Resources folder in the drawing
browser.

Align Title Blocks

Position a title block in any of the four corners of your drawing sheet. You
can set the default position for title blocks using the Title Block insertion
control in the Drawing tab of the Options dialog box. To access the Options
dialog box, click Tools » Application Options.

Autodesk Inventor uses that point to position the title block in the specified
corner of the sheet.

You can also edit the position of the title block on any drawing sheet in the
Edit Sheet dialog box. In the browser, right-click the sheet you want to modify
and select Edit Sheet.

Edit Title Blocks

You can edit a title block and save the changes in the drawing. All sheets in
the drawing using that title block is updated. When you select a title block
for editing, the Drawing Sketch panel bar is activated, and you can add or
modify geometry and text fields.

The tools for sketching in the drawing environment are the same tools used
for sketching part profiles. Tools to place text fields are unique to the drawing
environment.

Select these tools from the Drawing Sketch panel bar.

Tips for Creating Drawings

B Use a style library to ensure uniform formatting in drawing documents.
Use either the default style library provided with each drawing standard
or customize as needed. Save needed custom styles in the style library so
that all documents can access them.

B Purge unused styles from legacy templates to avoid increasing your file
size.
You cannot purge styles that are in use.
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Use drawing formats with predefined views.

To make sheet formats available to new drawings, create them in a template
file that you use to create new drawings. Define a sheet for each sheet type
you use.

Use the Select filters.
In addition to the Edge, Feature, and Part filters, you can specify various
drawing elements for the Select filter.

Drawing formats override units of measure.

If components in an assembly have different units, the drawing format
overrides them. The model dimensions have consistent units in the drawing
environment.

Use templates to maintain drawing standards and ensure consistent title
blocks and borders among drawings. Add other information in templates
that does not change, such as company logos.

Use the default border to ensure that the border resizes if the sheet size
changes.

Use formats to save the sheet size, title block, border, and views on the
sheet for quick layouts.
You cannot save section, auxiliary, or detail views in a format.

Select multiple objects within a drawing or within a drawing view using
a selection or containing window.

Move a drawing view by clicking and dragging the border.
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Creating Drawing Views

In this chapter, you learn about the types of drawing views you can create using Autodesk ®
Inventor™.

Drawing Views

Drawing views are referenced from, and associative with, external assembly or
part files. You can produce multiview drawings of principal orthographic views
and auxiliary, detail, section, and isometric views. You can also create views
from assembly representations such as design views, positional, and level of
detail, and presentation views. Autodesk Inventor calculates and displays hidden
lines as required.

The first view in any drawing is a base view. This view is the source for
subsequent views, such as projected and auxiliary views. A base view sets the
scale for dependent views, except detail views. A base view also sets the display
style for dependent projected orthographic views.

For a part model, the first view is usually a standard view such as a front or
right-side view.

NOTE A draft view is a special view in a drawing that does not contain a
representation of a 3D model. A draft view has one or more associated sketches.
You can place a draft view and construct a drawing without an associated model.
You can also use a draft view to provide detail that is missing in a model.

Drawing View Types

With Autodesk Inventor, you create and manipulate a variety of views using
tools on the Drawing Views panel bar. Click the Base View button on the
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Drawing View toolbar to create a base view and set the options on the Drawing
View dialog box. Use the base view to create a projected, auxiliary, overlay,
section, and detail views.

You can also create an isometric view using the projected view tool. When
placing a projected view, move the preview to change the orientation of the
projected view to an isometric view.

The following types of drawing views are available:

projected view Projects from the base view to a desired location. The
orientation of the projected view determines the rela-
tionship of the projected view to the base view. Use
this tool to create an isometric view.

auxiliary view Projects from an edge or line in a base view. The result-
ing view is aligned with its base view.

section view Creates a full, half, offset, or aligned section view from
a base, projected, auxiliary, detail, or broken view.
Creates a view projection line for an auxiliary or partial
view. A section view is aligned with its parent view.

detail view Creates and places a detailed drawing view of a speci-
fied portion of a base, projected, auxiliary, break-out,
or broken view. The view is created without an align-
ment to the base view.

overlay view Overlays use positional representations to show an as-
sembly in multiple positions in a single view. Each
overlay can reference a design view representation in-
dependent of the parent view.

draft view Creates a blank view with the sketch environment ac-
tivated for drafting. You can import AutoCAD® data
into a draft view, and you can copy a draft view and
paste it into the same or another drawing.

Use the following operations to change drawing views:

break Create a break in a view if the component view exceeds
the length of the drawing, or contains large areas of
nondescript geometry, like the center portion of a shaft.

break out Removes a defined area of material to expose obscured
parts or features in an existing drawing view. The par-
ent view must be associated to a sketch that contains
the profile defining the break out boundary.
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crop Provides control over the view boundary in an existing
drawing view. Set the type of boundary (rectangular
or circular) and specify crop boundaries.

slice Produces a zero-depth section from an existing drawing
view. The Slice operation is performed in a selected
target view.

Base Views

The first view in a new drawing is a base view. Use the Base View button on
the Drawing Views panel bar to create additional base views as needed.

Projected Views

After you create a base view, you can create projected views with a first-angle
or third-angle projection, depending on the active drafting standard. Projected
views can be orthographic or isometric. You can create multiple views with a
single activation of the tool.

Orthographic projections are aligned to the base view and inherit scale and
display settings. If the base view is moved, view alignment is maintained. If
the scale of the base view is modified, the scale of the projected view changes.

NOTE Isometric projections are not aligned to the base view. They default to the
same scale as the base view, but do not update if you change the scale of the base
view.

The position of the cursor relative to the base view determines the orientation
of the projected view. A view preview is displayed as you move the cursor.
Click a point on the sheet to place the view. You can continue to place views
until you right-click, and then select Create.

Editing Views

After you create a view, you can edit it. If the view is a base view, changes to
the view parameters are reflected in the dependent views. You can remove
the association between dependent views and base views by editing the
dependent view. Then set independent scale, style, and alignment for the
derived views.
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To edit view parameters, select the view, right-click, and then select Edit View
to open the Drawing View dialog box.

Creating Multiview Drawings

A multiview drawing contains a set of single plane orthographic views which
are used to display an object through one view plane per projection. For
example, a first angle projection is one view in a multiview projection set.

Base Views

In this exercise, you create a base view, and then project views to create a
multiview orthographic drawing. Finally, you add an isometric view to the
drawing.

TRY IT: Create a base view

1 With the project tutorial_files active, open the file baseview-2.idw. The
drawing file contains a single sheet with a border and title block.

2 Click the Base View tool on the Drawing Views panel bar. The Drawing
View dialog box is displayed.

3 Click the Browse button, and then double-click basevsource.ipt to use it
as the view source.

4 Verify that Front is selected in the View list. Set the Scale to 1.
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6 Position the view preview in the lower left corner of the sheet, in Zone

B7. Click the sheet to place the view.

Base Views | 223




7 Click the Projected Views tool in the Drawing Views Panel.

Click the base view and move the cursor vertically to a point above the
base view. Click the sheet in Zone E6 to place the top view.

8 Move the cursor to the right of the base view. Click the sheet in Zone C2
to place the right-side view.

9 Right-click, and then select Create from the context menu.
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Now create an isometric view.

10 Click the Projected View tool in the panel bar or from the Drawing Views
panel bar.
Click the base view and move the cursor above the right-side view. Click
the sheet in Zone E3 to place the isometric view.

11 Right-click the sheet, and then choose Create.
Your drawing should look like the following illustration.
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Section Views

Autodesk Inventor can create a full, half, offset, or removed section view from
a base view. The crosshatching, section line, and labels are placed
automatically.

You can also use the Section Views tool to create a view projection line for an
auxiliary or partial view. By default, a section view is aligned to its base view.

Press and hold CTRL as you position the section view to place it without
alignment.

The section line arrowheads on the base view automatically orient to reflect
the position of the section view relative to the base view. You can reverse the
direction by dragging the view, or by editing it later.

You can also display multi segmented section lines by clicking the section
line and disabling the Show Entire Line option in the right-click context menu.

Edit section view labels at any time by right-clicking the section view and
choosing Edit View.

Defining Section Views

Use the Section Views tool to define a projection line for a section view. You
can hover the cursor over view geometry to infer the position or orientation
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of the cutting line. The cutting line can consist of a single straight segment
or multiple segments.

When you have defined the view projection line, the Section View dialog box
is displayed.

NOTE You can use the CTRL key to prevent constraining the view projection line.

In this exercise, you create section, detail, and auxiliary views.

TRY IT: Create a section view

1 With the project tutorial_files active, open the file sectionview.idw. The
drawing contains orthographic views and an isometric view.

2 Click the Zoom Window tool on the Standard toolbar, and then create
a window around the top view.

3 Click the Section View tool in the Drawing Views panel.

4 Click inside the top view.

Place the cursor over the midpoint of the left edge of the part (A'). Move
the cursor to extend the projection line away from the part (A), and then
click to place the start point of the section line.
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5 Drag horizontally past the center of the part (B), and then click to define
the first segment of the section line.

6 Drag the cursor to create an inferred constraint along the slot center (C').
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Next, drag horizontally until a perpendicular constraint appears (C), and
then click to define the second segment of the section line.

7 Drag horizontally to the right of the part (D), and then click to create the
last segment of the section line.
Right-click, and then select Continue.

The projection line is defined, and the Section View dialog box is
displayed.
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8 Zoom out. Drag the section preview down to Zone D6, and then click to
place the view.

e

9 The section view is placed in the drawing.
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NOTE Press F5 to return to the previous view after zooming in to place the
cutting plane.

Auxiliary Views

With Autodesk Inventor, you can create and place a full auxiliary view of a
selected view. The auxiliary view is projected from and aligned with a selected
edge or line in the base view. The selected edge or line in the base view defines
the projection direction.

Auxiliary views are labeled, and display a projection line to the base view.

Use the Auxiliary View tool to create views aligned to non orthogonal geometry
in a selected view. When you select the base view, the Auxiliary View dialog
box is displayed. You can set the view Label, Scale, and Display options.

NOTE To create a partial auxiliary view, select the objects to remove from the
auxiliary view, right-click, and then set Visibility off. Or, use the Section View tool
to place a projection line that excludes the geometry you do not want in the view.

An auxiliary view is required to document the features on the inclined face.

TRY IT: Create an auxiliary view
1 Click the front view.

2 Click the Auxiliary View tool on the Drawing Views panel bar to open
the Auxiliary View dialog box.

3 Select the edge that defines the auxiliary projection.
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4 Move the preview down and to the left. Click the sheet in Zone B7 to
place the auxiliary view.

Detail Views

With Autodesk Inventor, you can create and place a detail view of a specified
area of a drawing view. A detail view is created without alignment to its parent
view.

By default, the scale of the detail view is double the scale of the parent view,
but you can specify any scale.

Autodesk Inventor labels the detail view and the area it is derived from on its
parent view. Either a circular or rectangular fence can be set for the detail.

Use the Detail View tool to define a detailed view of a selected area of any
view. Specify the area to detail, and then drag the detail view to any location.
When you select the parent view, the Detail View dialog box is displayed. You
can set the detail label, scale, and view display options.
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The center point of the fence positions the detail, and the fence determines
the extent of the viewed detail. Right-click to select fence shape, click the
center point of the detail, and then click a point to set the fence for the detail.

Next, you create a detail view to show a portion of the parent view at an
enlarged scale.

TRY IT: Create a detail view
1 Zoom in on the top view.

2 Click the Detail View tool in the panel bar or from the Drawing
Management toolbar. Select the top view to open the Detail View dialog
box.
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3 Select Rectangular Fence Shape.
4 Select Smooth Cutout Shape.

5 Click in the top view to set the center of the detail and then drag to size
the fence.

6 Zoom out enough to drag the preview to the left of the top view, and
then click.
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The view is placed. If necessary, click the view boundary and adjust its
position.
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Close the file without saving or save the file with a new name to preserve
the original data file.

Break Views

You can create breaks in existing base, projected, section, detail, and auxiliary
views. You select the existing view, define the appearance of the break, and
then specify the location of the break lines in the view. The broken view
retains the scale of the original view.

Use the Break tool to modify a view of a long component that cannot be scaled
to fit the drawing sheet without obscuring important details. Select the view,
and then place the break lines to specify the portion of the view to remove.

When you select the view to break, the Break dialog box is displayed. You can
set the break style, orientation, gap, symbol size, and number of symbols
displayed in the break lines.
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Select the Rectangular or Structural style to define the general appearance of
the break lines in your view. Then use the Orientation controls to specify the
direction of the break lines. Use the Gap control to set the distance between
the remaining segments of the view after it was broken. Adjust the value in
the Symbols field to control the number of break symbols displayed each break
line. You can set the symbol size in proportion to the gap size by using the
slider control. Finally, click in the drawing view to specify the location of each
break line.

DraftViews

A draft view is a special view in a drawing that does not require a representation
of a 3D model. A draft view has one or more associated sketches. You can
place a draft view and construct a drawing without an associated model. You
can also use a draft view to provide detail that is missing in a model.

When you import an AutoCAD file to an Autodesk Inventor drawing, the data
is placed in a draft view. Dimensions, text, and other annotations are placed
on the drawing sheet and geometry is placed in the associated sketch.

Modifying Views and Sections

You can constrain the relative positions of two views. One of the views acts
as the base view. If the base view moves, the aligned view also moves. If a
view is aligned vertically, the position of that view relative to the base view
is constrained to points along the Y axis of the base view. Horizontal alignment
constrains the position to points along the X axis of the base view.

An in-position alignment establishes the relative angular position between
the view and the base view. An auxiliary view is an example of in-position
alignment. The view is constrained to maintain the alignment as the base

view is repositioned.

To remove the constraints between views, select the view from which to
remove the alignment. Right-click, and then select Alignment » Break.

You can restore broken alignments to views. Select the view to align, right-click,
and then select Alignment » Horizontal, Vertical, or In Position. Click the
base view to set the alignment.

NOTE To place a section view without an alignment constraint, press and hold
the CTRL key as you place the view.
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Delete Views

You can delete views that are no longer necessary. If you delete a base view,
dependent projected and auxiliary views can either be deleted or retained.
Section and detail views require a base view and cannot be retained.

To delete a view, select the view, right-click, and then select Delete. In the
Delete View dialog box, click the More button (>>) to select the dependent
views to retain.

TRY IT: Delete a base view

1 With the project tutorial_files active, open the file delbasev.idw. The
drawing contains three orthographic views, an isometric view, and a
section view.
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2 In the browser, right-click View1: view1-4.ipt, and then choose Delete to
show the Delete View dialog box.

3 Click the More button to expand the dialog box. In the Dependent Views
box, highlight View2, and then click Yes in the Delete column to switch
it to No.

4 Repeat for View3.

5 Click OK to delete the base view and retain the two dependent views.

Delete View

Do you want ko delete view "WIEW1" and its dependents?

@ Ok Cancel |

Dependent. Yiews Delete
VIEW?Z Yes
VIEWS Yes
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Align Views

Alignment is the constraint relationship between a dependent view and its
parent view. An aligned view can be moved only within its constraints. If the
parent view is moved, the aligned view moves to maintain its alignment.

Most dependent views are created with an alignment, but you can add, change,
or remove alignment relationships. There are four possible alignment
relationships between a dependent view and its parent view: Vertical,
Horizontal, In Position and Break.

TRY IT: Align views

1 Select the projected view in zone B2, right-click, and then select Alignment
>» Break.

2 Select this view again, right-click, and then select Alignment »
Horizontal.

3 Select the section view as the base view.
4 Select the section view, and then drag the view vertically to the location

previously occupied by the front view.

The right-side view remains aligned to the section view. A view direction
indicator is added to the original, projecting base view, and a view label
is added to the projected view. It ensures that an indication of the
projected view orientation and view direction is retained, regardless of
where you move the view.

5 Right-click the isometric view and select Alignment » In Position.
6 Select the section view as the base view.

7 Move the section view, and notice that the isometric view now moves
with the section view.
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Edit Hatch Patterns

You can apply double-hatching, and you can modify the following aspects of
a section view hatch pattern:

Pattern
Angle
Line weight

Scale

Shift

In the following steps, you edit the section view hatch pattern to represent
the material as bronze using the ANSI 33 hatch pattern.

TRY IT: Modify a hatch pattern

1 Right-click the hatch pattern in the section view, and then choose Modify
Hatch. The Modify Hatch Pattern dialog box is displayed.

2 Select ANSI 33 from the Pattern list, and then click OK.

Edit Hatch Pattern
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Line ‘Weight Shift
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Close the file without saving or save the file with a new name to preserve
the original data file.
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Rotate Views

You can rotate views by edge or by angle. Views rotate as rigid bodies, including
any sketches. When a view is rotated, annotations maintain their associativity
to the view and model geometry. Depending upon the drawing standard used,
additional information may be provided in the View label indicating that the
view is rotated out of its normal position.

NOTE When you rotate a view, if a section view cutting plane line is not updated,
you can edit the section line as you would edit a sketch, including constraints.

Move Views

You can move a view by clicking and dragging the red border. You can move
multiple views with a crossing selection window. Specify a crossing selection
window by clicking, dragging your mouse from right to left, and then clicking
again. Views that are fully or partly within its borders are selected. To move
the selected views, click and drag one of the red borders.

Viewing Multiple Positions of Assemblies

Overlay drawing views use positional representations to show an assembly in
multiple positions in a single view. Overlays are available for unbroken base,
projected, and auxiliary views. Each overlay can reference a design view
representation independent of the parent view.

In the drawing browser, overlays are shown as child nodes to the parent view,
displayed as "PosRepName: ViewNumber: ModelName." Right-click an overlay
node to open the model file using the positional representation set by the
overlay.

Add dimensions between overlay views to show the distance or angle a
component has moved from its position in another representation. Drawing
dimensions automatically update if the model position changes.

Some guidelines for using overlay views include:

B In the assembly, create design view representations that include only
components of interest. In the overlay view, specify such a design view
representation.
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In the assembly, create as many positional representations as are needed
to show different positions.

To change to a different positional representation for an overlay view,
delete the overlay and specify a new positional representation when
creating an overlay.

Tips for Creating Drawing Views

Create nonaligned section views.
Press and hold CTRL while placing section views to break the alignment.

Move views between sheets.
Click a view in the browser and drag it to another sheet. The cursor must
be on a sheet name or icon to enable drop.

Copy views or sheets between drawings.
Right-click the view or sheet, and then select Copy. Paste it into the other
drawing.

Redline drawings.
Use sketch overlay to redline drawings without affecting the drawing views
or annotations.

Use the context menus for quick access to editing operations and common
commands.
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Annotating Drawings

In this chapter, you learn about annotating drawings using dimensions, center marks,
centerlines, hole tables and hole notes, parts lists and tables, and leader text.

Annotation Tools

Drawing annotations provide additional information to drawing views to
complete documentation of a component. In Autodesk® Inventor™, styles define
annotations, according to the active drawing standard. Each standard has a
default set of available styles, which can be customized as needed.

NOTE Legacy documents usually had styles defined in a template. When using style
libraries, import styles as needed from template-based documents to the library.
Then purge all unused styles to avoid making the file size larger. You cannot purge
styles that are in use.

The following are some of the tools on the Drawing Annotation toolbar:

Annotation Tool  Description

General Dimension Adds drawing dimensions to a view.

Baseline Dimension  Adds baseline drawing dimensions to a view to create a dimen-
and Baseline Dimen-  sion set. Baseline dimensions add multiple dimensions to drawing
sion Set views in an automated fashion.

Ordinate Dimension  Adds two types of ordinate dimensions to your drawings. Indi-
Set, and Ordinate vidual ordinate dimensions provide support for importing Auto-
Dimension CAD® drawings containing ordinate dimensions.
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Annotation Tool

Description

Hole/Thread Notes

Adds hole and thread notes to features created using the Hole
feature or Thread feature tools in parts.

Bend or Punch
Notes

Adds bend or punch notes to drawing views of sheet metal parts.

Chamfer Note

Adds a chamfer note to a drawing view.

Center Mark

Automatically sizes center mark extension lines to fit the geom-
etry. You can copy and paste center marks.

Centerlines

Autodesk Inventor supports three types of centerlines: bisector,
centered pattern, and axial.

Symbols

Adds symbols for surface texture, welding, feature control frames,
and feature identifiers. You can create leaders for symbols.

Datum Identifier
Symbol and Datum
Target leaders

Creates one or more datum target symbols and leaders. The
active drafting standard determine the color, target size, line
attributes, and measurement units of the symbol.

Text or Leader Text

Both Text and Leader Text use formats such as font type, bold,
and special symbols. Leader Text attached to geometry is asso-
ciative, and moves with the drawing view.

Table Inserts a table in the drawing. You can create a generic, config-
uration, or bend table.

Balloons Adds balloons to individual parts or all parts at once. You can
add balloons to a custom part after it is added to the parts list.

Parts list Inserts a parts list into a drawing.

Hole table Adds a hole table to a drawing view.
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Annotation Tool  Description

Caterpillar Adds a caterpillar annotation to geometry in a drawing view.
The annotation is not associated with weldments in the model.

End Fill Adds a 2D end fill annotation to geometry in a drawing view.
The weld bead style determines the size and formatting.

Revision table Places a revision table on a drawing sheet.

User Defined Sym- Adds sketched symbols to a drawing or a template. User-defined
bols symbols may include bitmaps, AutoCAD geometry, and 2D ge-
ometry created with sketch tools.

Retrieve Dimensions  Selects the model dimensions to display in a drawing view.

Using Styles to Format Annotations

In Setting Up Drawings on page 203, you learned about Style and Standard
Editor. Default styles associated with the drafting standard are available in the
Style and Standard Editor, where they can be edited, and new styles created,
as necessary.

Styles control the annotation formatting. Using the Style and Standard Editor,
you can see that some styles refer to other styles. For example, the settings in
the text style specify the dimension text. Whenever the text style changes, all
styles that reference it also update.

Working with Tables

Tables in drawings are useful for data that can be presented in tabular format.
They are formatted by styles, and can be customized to suit many purposes.
Hole Tables are formatted by the Hole Table style, Parts Lists are formatted by
the Parts List style and Configuration and General tables are formatted by the
Table style.
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Hole Tables

Hole tables in drawings show the size and location of some or all of the hole
features in a model. Hole tables eliminate the need to add notations for each
hole feature in a model.

In addition to drilled, counterbored, and countersunk holes, you can add
center marks, iFeatures, holes in patterns, and extruded cuts to a hole table.

The format for hole tables is set in the hole table style. You can specify the
title, text style, heading, line format, default column settings, and the defaults
for row merging, hole tags, tag order, and view filter.

If you want to include extruded cuts and iFeatures in hole tables, edit the Hole
Table style and select them. Click Format » Style and Standard Editor. In
the Hole Table style, click the Options tab. In the Default Filters (View) box,
select Circular Cuts and Centermarks.

General and Configuration Tables

Use the Table tool on the Drawing Annotation panel bar to add a general,
bend, or configuration table to a drawing. The Table style sets the default
format of tables.

You can create a general table with a default number of rows and columns,
or customize its size. The general table can reference external data from .xIs,
.xIsx or .csv files or you can enter any other type of data you need.

General and configuration tables are versatile. You can sort data, export data
to an external file, change the table layout, add or remove rows, and change
the format of a row or column.

In drawings of iParts and iAssemblies, configuration table rows represent the
members of the factory. You can specify the columns to include in the
configuration table, such as exclusion status and values that are different
among members.

Parts Lists

To create a parts list in a drawing in Autodesk Inventor, use the Parts List tool.
Its default formatting is set in the Parts List style associated with the active
drafting standard.
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You can generate a parametric parts list for an assembly. The properties for
each part or subassembly are displayed in the parts list. You can specify the
items you want in the list, such as part number, description, and revision
level. You can edit a parts list.

Creating Dimensions In Drawings

The tools you use to create drawing dimensions are different from the tools
used for model dimensions. When you select a feature or relationship between
features to dimension, Autodesk Inventor creates a horizontal, vertical, or
aligned dimension, depending on the direction you move the cursor. Snap is
activated to help place a dimension at a standard distance from the view and
to align dimensions with each other.

Snap indicator shaws that you selected this As you drag the new dimension into position, the snap
dimension s the reference for aligning a newr indicator tums on when you are aligned with the selected
dimension dimension

Place Dimensions

You can use two types of dimensions to document your design in a drawing:
model dimensions and drawing dimensions.

Model Dimensions

Model dimensions define the sizes of features. If you change a model
dimension in a drawing, the source component updates to match. Model
dimensions are also referred to as a bidirectional or driving dimensions.

Only model dimensions parallel to the view plane are available in a view. If,
when installing Autodesk Inventor, you select the option, Modify a Model
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Dimension from a Drawing, you can edit a model dimension and the source
component also updates.

Use the Retrieve Dimension tool to display model dimensions. After you select
the dimension to retrieve, right-click a dimension to delete or edit. You can
drag dimensions to adjust their positions.

When you place a view, you can choose to display model dimensions. Usually,
model dimensions are in the first, or base view in a drawing. In subsequent
projected views, only those model dimensions not shown in the base view
are displayed. If it is necessary to move a model dimension from one view to
another, right-click the dimension in the first view and select Move. Click the
second view to move the dimension. As an alternative, you can add a drawing
dimension to the second view.

NOTE If you choose to change the model dimensions in the drawing, make only
minor changes to single dimensions. If there are significant changes, or if you need
to modify dimensions that are referred to by other dimensions, open the part and
edit the sketch or feature there.

To avoid accidentally modifying a standard part, you can prevent the editing
of driven dimensions in read-only parts that are referenced to the drawing
file.

If you change the size of a part that is used multiple times in an assembly or
is used in multiple assemblies, all occurrences of the part are resized. Check
other assemblies to see if the changed size causes interference.

Drawing Dimensions

Drawing dimensions are unidirectional. If the part size changes, the drawing
dimension updates. However, changing a drawing dimension does not affect
the size of a part, unless you specified differently when you installed Autodesk
Inventor. Usually, drawing dimensions are used to document, but not to
control, the size of a feature.

You use the same tools to place drawing dimensions as sketch dimensions.
Linear, angular, radial, and diameter dimensions are all placed by selecting
points, lines, arcs, circles, or ellipses, and then positioning the dimension.

Constraints are inferred to other features as you place drawing dimensions.

Autodesk Inventor displays symbols that indicate the type of dimension being
placed. Visual clues are also used to position dimensions at fixed intervals
from the object.
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Change Dimensions

Dimensions styles control the appearance of dimensions in drawings. When
you apply the style to a dimension, it takes on the characteristics defined in
the style. Within the dimension style, the text style is referenced as a substyle
to format dimension text. Alternate units, the preferred display style, tolerance,
leaders (which reference the leader style) and text are also specified in the
dimension style.

After you place a dimension, you can right-click the dimension and use options
on the context menu. You can change:

B Options for arrow head position and appearance and if a leader is created.
W Set precision.

B Open the Edit Dimension dialog box to edit dimension text, change
precision and tolerance. Specify the dimension as an inspection and set
its appearance, or override the model value.

B Open the Format Text dialog box to add or change parameters, and modify
text attributes such as justification, position, font, spacing and other
settings.

B Hide dimension value or extension line.
W Edit first and second arrowheads.

B Create a style or edit the dimension style.

Controlling Dimension Styles

A dimension style is a named group of dimension settings that determine the
appearance of a dimension to which it is applied. Autodesk Inventor controls
drawing dimensions through the Style and Standard Editor. The available
dimension styles are listed in the browser pane of the dialog box. You can
click a dimension style to view and edit its settings.

This figure shows several dimensions that were modified by dimension styles.

Change Dimensions | 245



+1

46 -2

*Lﬁ
L I

(22)
15 I
L

Use dimension styles to control dimension text, arrowheads, dimension lines,
and extension lines. A dimension style is provided for each drafting standard,
but you can create new styles to suit your own annotation requirements.

These examples show a dimension that uses the default ISO dimension style,
and one with custom style settings applied.
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default IS0 dimension style custom dimension style

TRY IT: View dimension styles in the Styles and Standards Editor dialog box
1 Open an existing drawing or create a drawing.
2 Choose Format » Style and Standard Editor.

3 Expand Dimension in the browser pane and then double-click a
dimension style. Click the tabs to see how attributes are defined, and
then click Done to close the dialog box.

You can change the settings for the default dimension style, or you can create
your own variation of the dimension style and save it with a new name. You
can apply a dimension style to any number of drawing dimensions.

TRY IT: Override dimension style settings

1 In the drawing, right-click a dimension, and then choose New Dimension
Style.

2 In the New Dimension Style dialog box, click a new dimension style to
apply it, and then click OK.
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NOTE If you apply a dimension style to a dimension, overrides on that dimension
are lost.

Copy Dimension Styles among Drawings

The Style Library Manager provides a convenient way to copy dimension styles
(and other styles) from one drawing to another.

Close Autodesk Inventor before using the Style Library Manager.

TRY IT: Access the Style Library Manager

1 On your desktop, click Start » Programs » Autodesk » Autodesk
Inventor [version] » Tools » Style Library Manager.

2 In the Style Library Manager dialog box, double-click the Dimension
style. All dimension styles available in the current document are listed.

If you prefer, click the Browse button in the Style Library 1 pane and
locate a different style library.

3 In Style Library 2 pane, click the Create New Library button or browse to
an existing library. Accept the default or give the new library a name and
click OK.

4 Select the styles from Library 1 to add to Library 2 and click the right
arrow button to add the styles. Optionally, you can click buttons to Show
All Styles, Show Mismatched Styles (style names are the same but
definitions differ in the two libraries), or Unique Styles (definition exists
in one library, but not the other).

5 Click Exit.

NOTE Do not create a style in an existing library unless you have authority to do
so. You could replace an existing definition that could affect the formatting of
other documents.

Placing Center Marks and Centerlines

Autodesk Inventor has simplified the tasks of placing center marks and
centerlines. There are four tools to assist you:

m Center Mark
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m Centerline
B Centerline Bisector

m Centered Pattern

Add center marks and centerlines before adding drawing dimensions. You can
dimension to the ends of the center marks and centerlines and maintain
correct gaps.

You can add center marks to extruded circular cut features and include these
cuts in a hole table. Add the center marks to the hole table style so they are
recognized in the drawing.

TRY IT: Add center marks, circular cuts, and hole features to the hole table
style.

1 Open a drawing file.
2 Click Format » Style and Standard Editor.

3 In the browser pane of the Style and Standard Editor dialog box, expand
Hole Table and double-click the style to edit.

4 Click the Options tab. In the Default Filters (View) box, in the Included
Features category, select hole features, circular cuts, and center marks.

5 Click Done and then click Yes to save edits.

Now, hole features, circular cuts, and center marks can be selected for inclusion
in a hole table.

In addition to manually placed centerlines, you may be able to use automated
centerlines in a drawing view. When you set up a drawing, use options in
document Settings to define the default criteria for adding automated
centerlines. If you want to use them in all drawings, set them in drawing
templates. You specify the types of features to receive centerlines and if the
geometry is normal or parallel projection, as well as thresholds to exclude
circular features smaller or larger than a specified radius and smaller than a
minimum angle.

Adding Notes and Leader Text

Use the Text tool to add general notes to a drawing. General notes are not
attached to any view, symbol, or other object in the drawing.
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Use the Leader Text tool to add notes to elements in a drawing. If you attach
the leader line to geometry in a view, the note is moved or deleted when the
view is moved or deleted.

The Format Text dialog box is used to enter text and to set the text parameters.

Using Hole and Thread Notes

Hole and thread notes document both internal and external hole features or
threaded objects. These notes typically contain information necessary to
manufacture a threaded feature:

B Hole diameter and depth

B Thread size and depth

B Counterbore or countersink size
|

Quantity, especially for hole patterns

Use the Hole/Thread Notes tool to add hole notes and thread information to
holes and threaded features in drawing views.

Autodesk Inventor captures the information used when creating holes and
threaded features on a part. This information accurately generates the hole
or thread notes in drawing views. If you modify a hole or threaded feature,
the hole or thread note is automatically updated.

Hole and thread notes are generated according to the current drafting standard.
Right-click a hole note, and then choose Text from the context menu to change
its format and choice of parameters.

A thread is always considered right hand unless otherwise specified. A left-hand
thread is always labeled LH on a drawing.

Thread Representations

Autodesk Inventor drawings present threads using the simplified method.
Visible external threads display in side views, sections views, and shaded views.

In a drawing view, you can add hole and thread notes to features created using
the hole feature or thread feature tools in parts. In addition, a hole note may
be added to extruded cuts (except midplane extrusions), iFeatures, holes in
patterns, and sheet metal flat patterns.
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In section views, the hole must either be displayed in its face normal position
or seen as a profile.

You can also annotate holes in isometric views.

Working with Title Blocks

Title block information that you typically enter when you complete a drawing
is obtained from the drawing properties. Right-click the drawing name in the
drawing browser and select iProperties. You enter information in the Properties
dialog box, and the values are displayed in the corresponding locations in the
title block.

The Drawing Properties dialog box has six tabs for entering information:
General

Summary

Project

Status

Custom

Save

While some of the title block information is entered when you start the
drawing, approvals and approval dates are not entered until the drawing is
complete.

Other information displayed in the title block is derived from the operating
system, the drawing, and the sheet.

NOTE The date format is set by the system Regional Settings application, located
in the Control Panel folder.

Working with Dimensions and Annotations

In this exercise, you create drawing views, edit a view, and then add dimensions
and annotations to a drawing of a clamp that is used to hold a work piece in
position during machining operations.
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Both model dimensions and drawing dimensions are used to document feature

size.

TRY IT: Add views to a drawing

1

With the project tutorial_files active, open the file dimsannot-5.idw. The
drawing file contains a single sheet with a border and title block.

Click the Base View tool in the panel bar or from the Drawing Views
panel bar. The Drawing View dialog box is displayed.

Click the Browse button, and then double-click views-5.ipt to use it as the

source for the view.

On the Component tab, verify that Front is selected in the View list. Set

the Scale to 1:1.

-

Drawing View

File:

Wiews | Scale Label

Scale 111
jaym

Component | Madel State || Display Options

C:\Program Filesiautodesk! Inventor 20094 Tutorial Files\views-5.ipt

View Identifier | Viswl

Origntation

Front {2}
Current

Top

Battorm

Left

Right

Back.

Iso Top Right
Iso Top Left
Iso Bottom Right
Iso Bottom Left

Projection: @E}

Skyle

[ Ok ] [ Cancel

5 Click the Display Options tab. Make sure that All Model Dimensions is
not selected. Select the Tangent Edges check box.
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Drawing View

Component | Model State | Display Options
Crientation
Al Model Dimensions

o Fronkt (%)
Current
Top
EBottom
Left

Thread Feature Right

Cuk Inhetitance Back

Isa Top Right

[Juser work Features Iso Top Left
Iso Bottam Right
Iso Bottom Left

[ 7angent Edges

Wiew Justification
Centered ™ Projection: @E}
Wiew | Scale Label Style
Scale | 1:1 ™ D Wiew Identifier | Yiewl
et

6 Position the view preview in the lower left corner of the sheet (in Zone
C6). Click the sheet to place the view.

7 Click the Projected View tool in the panel bar or from the Drawing Views
panel bar.

Click the base view and move the cursor vertically to a point above the
base view. Click the sheet in Zone E6 to place the top view.

8 Move the cursor horizontally to the right of the base view. Click the sheet
in Zone C3 to place the right-side view.

9 Move the cursor above the right-side view. Click the sheet in Zone E3 to
place the isometric view.

10 Right-click the sheet, and then select Create.

©

=
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Turn Off Tangent Edge Displays

Turn off the display of tangent edges in the isometric view.

TRY IT: Modify a drawing view

1 Right-click the isometric view, and then select Edit View.

2 In the Drawing View dialog box, click the Options tab, and then clear

the check mark from Tangent Edges. Click OK.

-

Drawing View

Component | Model State | Display Options

Thread Feature

Cuk Inheritance

[]Tangent Edges

Wiew Justification

Centered

View [ Scale Label

Scale | 1:1 [w] 1 View Identifier | View3
e

Crientation

™ & Projection: @E}
Skyle

The following are orthographic and isometric views of the clamp.
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Add Model Dimensions

Next, you add model and drawing dimensions to the views using the Retrieve
Dimensions command. Some model dimensions are removed, while others
are repositioned.

TRY IT: Add model dimensions

1
2

Zoom in on the front view.

Right-click the front view, and then choose Retrieve Dimensions. In the
Retrieve Dimensions dialog box, click the Select Dimensions tool. The
model dimensions that are planar to the view are displayed.

Select each of the dimensions except for the 45.0 horizontal dimension
and the 40.0 horizontal dimension.

NOTE If you prefer, click and then drag a window around the model to select
all of the dimensions in the view. You can then delete the dimensions you
do not need.

Click Apply. Each of the selected dimensions are displayed. The
dimensions that were not selected are hidden.

NOTE If you accidentally selected a dimension, hold down the CTRL key and
reselect it to remove it from the selection set.

Click Cancel to exit dialog box.
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Reposition Model Dimensions

To reposition dimension text, click a dimension text object, and then drag it
into position. The dimension are highlighted when it is a preset distance from
the model.

Radial dimensions can be repositioned by selecting the handle at the end of
the leader.

TRY IT: Reposition radial dimensions

1 Drag the dimensions until they appear as illustrated in the following

figure.

180+ -1

R16.0
|\ 190
-.:._.____Lq '

210 t

] _>\*-._ 1 ]

R15.0 130

2 Pan to display the top view, right-click, and then choose Done.

3 Right-click the top view, and then choose Retrieve Dimensions. In the
Retrieve Dimensions dialog box, click the Select Dimension tool. The
model dimensions that are planar to the view are displayed.
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R2.0
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§

4 Select each of the dimensions except the 13.0 horizontal dimension, and
the R6.0 and R2.0 radial dimensions.

5 Click Apply. Each of the selected dimensions are displayed. The
dimensions that were not selected are hidden. Click Cancel to exit dialog
box.

6 Drag the remaining dimensions until they appear as shown in the
following figure.

| D)a

Add Centerlines and Center Marks

Centerlines and center marks are added to aid in the placement of drawing
dimensions.

TRY IT: Add centerlines and center marks

1 On the Drawing Annotation panel bar, click the Center Mark tool in the
panel bar or from the Drawing Annotation toolbar.

2 Click the outer circle of the boss and the two arcs of the slot.
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Pan to display the front view.

Click the arrow beside Center Mark and then click the Centerline Bisector
tool.

Select the two hidden lines that represent the drilled hole through the
boss.

18.0=
~R16.0

R15.0 . 13.0
The bisecting centerline is added.
Pan to display the right-side view.

Select the two hidden lines that represent the drilled hole through the
boss.

w

|
| S S W U P—

The bisecting centerline is added.

Add Drawing Dimensions

Drawing dimensions are added to complete the documentation of the model.
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TRY IT: Add drawing dimensions

1
2
3

Pan to display the front view.
Click the General Dimension tool on the Drawing Annotation panel bar.

Click the right endpoint of the bottom edge, and then click the right
endpoint of the top of the boss.

Move the cursor to the right and place the 16.0 dimension between the
13.0 and 19.0 vertical dimensions, as shown in the following figure.

r~18.0=
R16.0

¥
i 1

21.0

m»
(=]

R15.0 13.0

Pan to display the top view.

Use the General Dimension tool to add the 13.0, 45.0, and 40.0 horizontal
dimensions as shown in the following figure.

NOTE To align a dimension when dragging it, move the cursor over an
existing dimension and acquire an alignment point. Move the cursor back
to the dimension being placed. The dotted line indicates an alignment
inference. Click to place the dimension.

Use the General Dimension tool to add the R21.0 radial dimension,
right-click, and then choose Done.

Drag the 16.0 dimension to a position that avoids crossing the extension
lines.

—R9.0
T —R21.0 ]
! 15°
| ~
! oA
| X
| @16.0
|
1
13.0—=
40.0 45.0 |
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The drawing dimensions are added.

Format Dimensions

The dimensions can be formatted to add additional information, to adjust
precision, or to add tolerances.

TRY IT: Format dimensions in a drawing

1 Right-click the 15° dimension, and then choose Text.

2 In the Format Text dialog box, enter TYP, and then click OK.
3 Right-click the 16.00 dimension, and then select Text.
4

In the Format Text dialog box at the insertion point, press the space bar,
and then enter BOSS. Press ENTER.

Select the Diameter symbol from the symbol list in the dialog box.
Select Arial from the font drop-down list.

Press the space bar, and then enter 72.0 THRU.

Format Text

Skyle:

EE=

Font

Arial

Type
Component: Source:

wviews-5 w | |Model Parameters

% Stretch
4 [ 100,000
Size
v 3.50 mm

Property

Parameter:

[+ [d1 ¢16.00 mm)

— |Single .v_

vMEEY =

Spacing Walue

Rotation

Precision

Precision

v| & 181

v 21z

B8=8 BOsSS
@ 12 THRU|

Ok ] [ Cancel
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Click OK.

The formatted dimensions are displayed.

l-17.0
~R9.0
{__—Rz210
SN 15°TYP
.t
i 1

~— $16.0 BOSS

@ 12.0 THRU

40.0 45.0

Add Notes and Leader Text

In the following steps, you add a general note and use leader text to document
the round.

TRY IT: Add a note and leader text to a drawing

1 Click the Text tool in the panel bar or from the Drawing Annotation
toolbar.

Click a point below and to the right of the top view.
Enter TOLERANCE FOR, and then press ENTER.
On the next line, enter ALL DIMENSIONS (space).

w©n A W N

Select the tolerance icon from the symbol list. Enter 0.5. Click OK.
Right-click, and then choose Done.

6 Click the Leader Text tool in the panel bar or from the Drawing
Annotation toolbar.

7 Select the bottom arc on the right end to define the leader start point.

8 Click a point below and to the right to define the end of the leader,
right-click, and then select Continue.

9 Enter ROUNDS R2. Click OK.
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~R9.0

15°TYP
~L

1—@16.0 BOSS
\ @ 12.0 THRU

' ROUNDS R2

TOLERANCE FOR
ALL DIMENSIONS £ 0.5

Edit Model Dimensions

If, when you installed Autodesk Inventor, you set the option to allow drawing
dimensions to resize the model, when a model dimension is edited, the part
model is updated along with the drawing views.

TRY IT: Edit a model dimension in a drawing
1 Right-click the 15° dimension, and then choose Edit Model Dimension.

2 In the Edit Dimension dialog box, enter 10-deg for the new dimension,
and then press ENTER.

The model and drawing are updated.

3 Click the 10° dimension, and then drag to position it correctly. Reposition
any other dimensions that were moved.

(= 17.0+
~R9.0
—R21.0 i
/ ___ 10°TYP
/ - 1
T T
—$16.0 BOSS
\ @120 THRU

13.0——= '—ROUNDS R2

TOLERANCE FOR
ALL DIMENSIONS £ 0.5
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Notice how the position of the boss was affected by the change to the
model dimension.

WARNING Modifying a model dimension directly affects your model. Autodesk
Inventor automatically updates the part file with the changes you make.

Complete Title Blocks

The drawing properties are used to complete the title block information.

TRY IT: Complete a title block

1 From the File menu, select iProperties.
The Properties dialog box is displayed.

2 On the Summary tab, in Author, enter your name.

& dims

3 Click the Status tab and select the current date from the Checked Date
list.

4 In Checked By, enter your initials.

5 Click OK.
The title block is updated.

JECT
INVENTOR ‘F—"_!\lN NG Autodcsk_ |nC

t TILE
FIMMERMAN | 061301

Exercise 8-5

A2 7 ¢h.085

scae 191 SHEET 1 oOF 1
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The drawing is complete.
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Save the file.

Printing Drawing Sheets

Autodesk Inventor uses any Microsoft® Windows® configured printer to print
a copy of your design documentation. Most large-format plotters can be
configured as Windows system printers. In the Print Drawing dialog box, you
can control the following:

Printer selection
Print range if you have a multisheet drawing

Scale

Rotate by 90 degrees

|
|
|
B Print all colors in black and white
|
B Remove object line weights

|

Number of copies

From the Print Drawing dialog box, you can display a preview of the plot
based on the selected printer and the current settings.
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If the drawing is too big to print on one sheet, select the Tiling Enabled check
box. This option is only available when the scale is set to Model 1:1.
Registration marks are printed on page corners to allow alignment of printed
pages. Page identifiers contain the drawing and sheet name and a table cell
number to help keep pages in order.

Plotting Multiple Sheets

Use the Multi-Sheet Plot wizard to plot multiple drawing sheets that include
drawings of various sizes. You access the wizard from the Start menu on your
computer task bar. Click Programs » Autodesk » Autodesk Inventor
[version] » Autdesk Multi-Sheet Plot. You can:

Set up the printer to use
Set layout preferences

|
B Specify the project that contains the drawings you want to plot
B Select the drawing files to plot

|

Preview the generated composite (which automatically arranges drawings
for efficient use of paper)

B Plot now, print to a file, or schedule a plot job in the Task Scheduler.

If sheets are larger than the plot area, you can change page size or remove files
from the print list.

Tips for Annotating Drawings

B Use text parameters to display drawing properties and other information
in the title block.

Use the cursor symbols as cues to place and align dimensions.
Drag the dimension text and dimension handles to reposition dimensions.

Edit model dimensions (not drawing dimensions) to update the model.

Include general tables and customized style overrides in the drawing
template so they are available in all drawings based on that template.
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Using Content Center

This chapter provides basic information and concepts about Content Center and Content
Center libraries. For more detailed information, see Help in Autodesk® Inventor™ and
Autodesk® data management server.

About Content Center

Content Center is a tool used for accessing and maintaining the Content Center
library. You use Content Center to:

Find a part in a Content Center library.

Insert a Content Center library part in an assembly.

Edit Content Center library parts placed in assembly.
Customize, add, or remove Content Center library parts.

Publish parts, iParts, or features in the Content Center library.

Content Center can be installed as a part of Autodesk Inventor.

Set and Manage Permissions

Editor and Administrator accounts are required for users who access the Content
Center libraries installed on a central server and must edit the Content Center
libraries or perform administrator tasks. Use Autodesk® Server Console to create
user accounts for anyone requiring these permissions. Communicate user account
information and the Log In procedure to each member in the team.
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Content Center Library

The Autodesk Inventor Content Center library provides Inventor parts
(fasteners, steel shapes, shaft parts) and features to insert in assemblies.

Libraries can be either local, or in a shared environment accessed from a central
server. The Content Center library data are accessed in the Content Center.
See the Help for more information about the library configuration.

The basic component in the Content Center library is a family (part family
or feature family). A family contains related content (members) based on the
same underlying templates. A family is composed of parts with the same shape
but with different sizes. A family member is a part or feature with a specific
size. The family member is the lowest level of the hierarchy.

Families are arranged in categories and subcategories in the Content Center

library. A category is a logical grouping of part types. For example, studs and
hex head bolts are functionally related, and nested under the Bolts category.
A category can contain subcategories and can contain families. A family cannot
be subcategorized.

Two types of parts are included in the Content Center library: standard parts
and custom parts. Standard parts (fasteners, shaft parts) have all part parameters
defined as exact values in the table of parameters. Custom parts (steel shapes,
rivets) have a parameter arbitrarily set in the defined range of values.

Content Center Library Data
The Content Center library contains required data to create part files for
Content Center library parts. The data are:

B Parametric .ipt files which provide the graphics for Content Center library
parts.

B Values of part parameters.

B Descriptions for parts including family properties such as family name,
description, standard, standard organization.

B Preview pictures displayed in the Content Center.

Parametric .ipt files, description texts, and preview pictures are common for
all sizes of one part family. The Content Center library usually contains several
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sets of parameter values for one part family. Every set of parameters defines
one member of the part family.

Working with Content Center

You use the Content Center dialog box to navigate in the Content Center
library hierarchy. You expand categories in the Category Listing panel,
double-click items in the List panel, or use navigation buttons in the toolbar,
such as Back, Forward, and Up one Category Level.

Content Center Environments

There are two distinct environments:

B Consumer environment for locating and placing a library part or feature
into a document.

B Editor environment for editing a Content Center library.

If the Content Center libraries are installed on a remote server, you must be
assigned Editor permissions in Autodesk Server Console to perform any of the
editing tasks. You must also be logged into your Content Center server. If you

work in a single-user environment, you automatically have permissions to
perform editing tasks and you log into the Autodesk server on your local drive.

The Content Center Consumer and Editor environments include methods for
locating the content including:

B Browsing capabilities.

B Advanced and Quick search tools to find parts that correspond to
appropriate parameters.

W Filters for excluding families you do not use.

B Favorites for creating your own personal folder structure with shortcuts to
Members, specific Families or Categories.

B History option to display the last 20 used parts in the Category and Family
pane.
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Consumer Environment

Use the Content Center Consumer environment to use library parts in the
design process. The following commands are available:

Open from Content Opens a family .ipt file.

Center

Place from Content Places a feature or a part into an open assembly file.
Center

Place Feature from  Places a feature into an open part file.

Content Center

Change size Changes the size of a part placed in an assembly.

Replace from Content Replaces an existing part in the assembly with a part
Center from the Content Center library.
TRY IT: Navigate in the Content Center library and place a part

1 To begin, open an assembly file.

2 Click Place from Content Center on the Assembly panel. The Place from
Content Center dialog box is displayed.

3 To select the viewing mode, click the Thumbnails View, List View, or
Detailed View tool button.

NOTE The List View mode is faster, but the Thumbnails View mode is more
descriptive.

4 In the panel on the right, browse in the library until you get to the
appropriate part family:

Double-click a category to display its descendant categories or part
families.

Click Back to return to the previously displayed list.
Click Forward to display the forward list.
Click Up one Category button to get up one level in the category structure.

5 Select the family and click OK.

6 Select the family member to place in the Select or Table View tab of the
Family dialog box.

7 Click OK in the Family dialog box.
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8

Use the typical placement operation to place the part in assembly. Add
constraints as needed to position the part to other geometry.

Editor Environment

Use the Content Center Editor environment to modify library parts by using
one of the following commands:

Create, Delete, and Edit Categories.

Copy a read-only category or family to a read/write library for editing
purposes.

Use the Save Copy As command to create a copy of a family in a read/write
library.

Rename library parts and families.

Edit family properties and family tables and then publish changes to a
read-write library.

TRY IT: Customize libraries

1

Connect to the data server and have editing permissions to edit Content
Center libraries.

You can only modify library data in read/write libraries. If desired, create
a read-write library using Autodesk Server Console.

Click Tools » Content Center Editor. The Content Center Editor dialog
box displays.

To edit a part family that is contained in a read-only library, copy the
family to a read/write enabled library: Right-click the family, select Copy
To, and select a read/write library from the list.

After the family is copied, it can be edited. Edits are saved to the read/write
library.

Right-click the family and select Family Table. The Family Table dialog
box displays.

Edit the family data. Use context or toolbar commands to work with the
data.

Click OK.
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7 On the Content Center Editor dialog box, click Done.

Tips for Using Content Center

B Use Search to find a part in the Content Center library. You can search for
parts with a specified string in the Part Number or Description property,
or you can specify conditions for part family or category parameters.

B Use Content Center Favorites to store frequently used parts or part families.
You can create a folder structure in Favorites and order favorite items as
you need. You can create additional Favorites groups.

B Remove all Content Center libraries you do not use. If you remove libraries
from Content Center configuration, the amount of displayed data reduces
and the performance increases.

Using the Publish Tool

The Publish tool uses a separate dialog box. You use the Publish tool to:

B DPublish parts, iParts, or features.

B Define and map family properties.

B Select the library to publish to.

If you publish a part or iPart in Content Center library, the published part is

saved as a part family to a selected category. Before you publish a part, map
the part parameters to the category parameters.

For more information on publishing to the Content Center library, refer to
the Help in Autodesk Inventor.

NOTE You must have Content Center Editor permissions to publish a part or
feature.
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Managing Administrative Tasks

You add and remove libraries to and from the active Content Center
configuration, using the Configure Content Center Libraries dialog box. The
configuration of Content Center libraries is saved in the active project.

Libraries must be configured on the Autodesk server before you configure
Content Center libraries in the Inventor project. Perform all administrator
tasks using Autodesk Server Console.

Create a new read/write or read-only library.
Detach a library from the server.
Attach or reattach a library.

Delete a library from the computer.

Create user accounts and permission. Set up Editor accounts for users who
edit or publish libraries and access the Content Center libraries from a
central server.
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Autodesk Inventor
Utilities

In this chapter, you learn how to edit a project in Autodesk® Inventor™, resolve missing file
links, search rules for library and non library files, and old versions of files. You learn how to
copy, move, rename and delete data, and change the file structure in a project.

Editing Projects

After you create a project, you can use the Project Editor to change some of its
options, add or delete file locations, or change its name. To edit the active
project or change which project is active, first close all open Autodesk Inventor
files.

In general, avoid creating multiple editable locations. File resolutions problems
greatly increase when you use a complicated file structure.

The active project is marked read-only once you open files. An exception is that
you can add libraries when files are open.
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Projects

Project name
Default
ProjectMame
Studio
samples

+" tutorial_Files

Project location

Ci\My DocumentstinventoriProjectame),

CiAMy Documentsiinventor Studiol

Ci\Program Filest\Autodeski Inventor 2008\Samples),
Ci\Program FilestAutodeski Inventor 20084 Tutorial Files)

@ Project

’3 Type = Single User

Included file =
of® Use Style Library = Read Orly

@

+ @ Folder Dptions
# @3 Options

Location = C:YProgram Files\AutodeskiInventor 20084 Tutorial Files),
[

Mew ” Browse. .. ” Save

I S Y A R B K

Done

Keep in mind:

B To add a single folder to a project path, right-click Libraries or Frequently
Used Subfolders, and then select Add Path. Browse to the individual folder
and add it to the project.

B To add an editable location for each immediate subfolder of a folder,
right-click a search path, and then select Add Paths from Directory. Browse
to the root folder and add it to the project.

B To change the order in which locations are listed, select a location, and
then use the Move Up or Move Down arrow on the right side of the Project

Editor.

W If you delete a path, Autodesk Inventor is unable to find referenced files

from that path.

B To add a Content Center library, click the Configure Content Center
Libraries button on the right side of the Project Editor and use Data
Management Solutions tools. You must be logged in to Data Management.
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TRY IT: Edit a project

1
2

Verity that all Autodesk Inventor files are closed.

Use one of these methods to start editing:
B Click File » Project.

B On the Microsoft® Windows® Start menu, click Programs » Autodesk
Inventor » Tools » Project Editor.

B On the Microsoft Windows Start menu, click Autodesk » Autodesk
Inventor » Tools » Project Editor.

B In Microsoft® Windows® Explorer, right-click an .ipj file, and then
click Edit.

In the Project Editor, double-click a project name in the top pane to make
it the active project. A check mark indicates the active project.

In the lower pane, right-click the type of path to edit, and then select an

option from the menu:

Add path Browse to the folder you want to add. Add a custom
name for the folder, if desired.

Add paths from file Browse to another project file. The paths from the
file are added to the current project file. Use only
to add libraries.

Add paths from di- Browse to any folder on any disk drive where you

rectory have files in its subfolders. A path is automatically
generated for each subfolder. For best results during
file resolution, avoid nesting paths. Use only for li-
braries.

Paste paths Paste a path from the Clipboard into the selected
section of the project. Use only for libraries.

Delete section paths Deletes all of the paths from the selected section of
the project.

If you prefer, select the type of path to edit, and use the Add or Edit
button on the right side of the dialog box.

Right-click other options to make changes. You can, for example, add
frequently used subfolders, rename the project, expand and change folder
options, or change the project owner and release ID.

Click Save, and then click Close.
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NOTE To review definitions of all project options, click the Help button on the
Project Editor dialog box.

Legacy Project Types

In the Project wizard, semi-isolated and shared project types are unavailable
by default. Autodesk® Vault is the recommended solution for managing
multi-user projects. If, however, you have legacy projects and have a
requirement to create and use them, consider the following points:

B Click Tools » Application Options » General table. Select the check
box for Enable creation of legacy project types. The legacy project types
can then be created with the Project wizard.

B Use the Help topics to learn how to set options, set up workspaces and
workgroups. Multi-user projects have additional restrictions and capabilities
from single-user projects.

B Do not use Design Assistant Manager to change files that are checked out
in a semi-isolated or shared project. Always make sure that all files are
checked in to the shared storage location.

Resolving File Links

When one Autodesk Inventor file references another file, the relative path
from the first project location containing the referenced file, the file name
and library name (if it is in a library location) is saved in the referencing file.

Autodesk Inventor uses this information to locate the referenced file the next
time the source file is opened. The first file found that matches validation

conditions and reference information stored in the source document is loaded.
The location must be in a defined project path to be resolved automatically.

NOTE An exception is if no project location is defined, such as when using the
default project or when a source file and its referenced files are both copied outside
a project.

Autodesk Inventor cannot find a file if:

B The file is no longer located in a location defined in the active project.
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B The Using Unique File Names option is No, and the file was renamed,
moved to a different subfolder, or one of the project subfolders was
renamed.

B A library was renamed or its location was removed from the project.

B The file was moved from one library to another or from an editable
location.

B The file was moved from one library subfolder to another.

B The data set was taken off site without the shared libraries. If it is
acceptable, select the Skip All options when the Resolve Link.

B A network location defined by a project becomes unavailable.

When a file cannot be located, the Resolve Link dialog box opens
automatically, showing the location and file name from the last save.

In the Resolve Link dialog box, choose an option:

Browse Browse to a new location for the part, and open it.

Skip Loads the assembly without the missing component
file.

Skip All Loads the assembly without trying to resolve any

missing files.

Cancel Cancels file loading and closes the dialog box.

Sometimes an entire set of files is missing. For example, the library name
changed or a subfolder was moved or renamed. Because many files would be
missing for the same reason, Autodesk Inventor automatically attempts to
find other unresolved files that were originally in the named library or folder
by searching in the new location you specify in the Resolve Link dialog box.

In the same session, if other files in the same project have unresolved references
to the same path, you can select the check box to search for other unresolved
references using the location.

To resolve the file correctly in the future:

B Move the file to a location in the active project. If you move the file to a
subfolder of a location, use the Resolve Link dialog box once to establish
the correct subfolder path to the new location of the file.

B Save the referencing file to save the updated information.
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Search for Library and Non Library Files

Autodesk Inventor searches for referenced files in library locations in the order
listed in the Project Editor and then the workspace.

If a referenced file is contained in multiple project locations, the reference
uses the relative path from the first one found, and stores the path in the
reference. If the project location is a library, the name of the library is also
stored in the reference.

If the referenced file is not found in a project location, the relative path from
the referencing file is used in the reference.

If the referenced file is also not located in the folder or a subfolder of the
referencing file, the absolute path is stored.

A message warns you if the file is not in a location specified in the project.
Confirm its location each time you open the referencing file until you relocate
the file in the project location.

Autodesk Inventor uses a different search procedure for resolving library and
non library references.

Search for Library References

Library references use the following rules:

B A reference to a file in a library location includes the library name in the
reference.

B If a reference includes a library name,Autodesk Inventor searches only in
that library location for the file.

B If the source file is in a library, the referenced file is presumed to be in the
same library unless the reference identifies a different library.

NOTE Avoid using duplicate file names, even for files in different directories. Set
the project option Using Unique File Names to Yes. The Resolve Link dialog box
opens only if the file cannot be located in any project location.

If no library location is defined in the project,Autodesk Inventor searches for
the referenced file relative to the source file.
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Search for Non Library Locations

In non library locations, Autodesk Inventor appends the relative path stored
in the reference to the project location and looks for a file at the resulting full
path. If no file is found, the file name stored in the referenced file is appended
to the project location folder path and Autodesk Inventor looks there.

Use Substitution Rules to Find Missing Files

In the Resolve Link dialog box, you can create a substitution rule to search
for missing files. Click the More button (>>) to see the current substitution
rule or modify it, if necessary, to create a substitution rule:

B Select the check box for Search for other unresolved references using this
location.

B Specify a path location. You can edit the substitution rule, usually by
deleting a tail portion of the path common to both the original and
resolved path.

B Browse to the new library location. You might need to remove both the

source and replacement folder paths.

In the following example, use Microsoft Windows Explorer to rename the
folder from ABC to DEF.

Wiorkgroup = CATEST

CATEST CATEST
\ABC \DEF
AXXX WKXX
4.ipt
Old Structure Mew Structure

When the assembly A.iam is opened, 1.ipt is expected to be in a location
specified in the active project. Because it is in a renamed directory, you browse
to the new directory.

After you browse to 1.ipt, the dialog box shows the following:
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Resolve Link
Locations Look ini I 0z ﬂ = [ s FE-
Vorkspare Danm_assy (D eody.ipt (Ferg_
Libraties D)library [Pbore.ipt Flerg_|
D Content Center Files ) 0ldversions [ battle.ipt (Teap.i
@assyflink.ipt Ij Brace.ipt ﬁlcap,
(D basevsourcs it (P brackst.ipt Dcap,
|E basic_platz.ipt (T erg_sall.ipt Sicap,
'@bodvl.ipt @Brg_}n-'ls.ipt Cep_
P bodyz.ipt [erg_in-Sé.iot [Fehan
] _m_| (] Find ... |
@ File name: 17 int j Dpen I Skip All |
Files of lype:  [Part Files (ipt) = Skip I
r~Unresolved Reference (i.e., nok found in Project)
Filename Subfolder Path: Library:
[1int [ARCyIZZR [rares
File: Conkaining the Referance: Found in Library:
| DA\ Testing)4.iam [hures
¥ Search for other unresolved references using khis location Cancel |
r—Substitution Rule
Leading portion of the Referenced Subfolder Path to replace: Referenced Library
[sBCyrvrizzzy [ rures
Replacement Subfolder Path Replacement Library
| oEFvrYvizzEY I

Using the new subfolder path, select the check box, and edit both paths to
remove the \yyy\zzz tail as shown in the following image to locate all parts.

¥ Search for other unresobeed references using Hhis location

Cancel |

Substitution Rule

Leading portion of the Referenced Subfolder Path to replace: Referenced Library
[mBC [nia

Replacement Subfolder Path Replacsment Library
| DEF |

When you click Open, you indicate that the path is correct. Autodesk Inventor
attempts to find part 2.ipt, and each of the other referenced parts, it
automatically substitutes DEF for the ABC subfolder portion of the relative

path.

If you renamed a library, but kept the file at the same relative path location,
you remove both the leading portion of the referenced subfolder path to
replace and the replacement subfolder path. In this case, the replacement
library contains the new library name. If the original reference was to a library,
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the referenced library box contains its name. You can use these boxes to repair
references to:

A renamed library.
Files moved from one library to another.

Files moved from a library to an editable location.

Files moved from an editable location to a library.

NOTE Search for other unresolved references using this location is automatically
selected. Clear the check box to avoid creating a substitution rule.

Keeping Old File Versions

When you save a file, the previous version is moved to an automatically created
folder called OldVersions.

The previous versions of an Autodesk Inventor file use this naming convention.

<file name>.<version>.<file type>

J O O

Old Wersions AdA,.ipt BEE.ipt

4

(7 aaa.0001.ipt
(7 aaa.0002.ipt
(P ees.0o01.ipt
(T eeB.0002.ipt

Other designers who opened the same file in an Autodesk Inventor work
session continue to use the older version until they refresh the file, or close
and reopen it.

You can always retrieve a previous version of a file. But it is important to note
that while you can retrieve an old version of an assembly file, it may not
include edits to all of its various referenced files. Autodesk Vault can restore
any checked-in version of a referenced file.

To restore an old version, do not move the file from the OldVersions folder
and rename it. Instead, restore the old version with Autodesk Inventor
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TRY IT: Restore an old version of a file
1 Click File » Open.

2 Browse to the file you want to restore from the OldVersions directory. The
Open Version dialog box is displayed.

Open Version E

‘ou have selected an old version (Handle.0031.iam) of the file (C:\Program
Files\AutodeskiInventor 1115a...\Handle iam) to open. If you proceed with
wpening the old version, you will not be allowed to save. You can Restore
the old version to be the current version if no other versions are open and
the current version is not checked out.

1+ Open old version (Save not allowed)
" Restore old version to current version
" Open current version

Cancel |

3 Select one of the options in the Open Version dialog box:
Open old version  Opens the old version of the file. Because the cur-
rent file still exists, you cannot save the opened
version. Use Save Copy As to save a copy.

Restore old version Restores the selected old version as the current
to current version version. The current version is not lost, but it be-
comes a file in the Old Versions folder.

Open current ver- Opens the current version of the file.
sion

4 Click OK.

Every time you save a file, a new globally unique version ID (GUID) is
assigned to the file. Each Autodesk Inventor session remembers the ID
version it is accessing. If you try to reopen the file at the normal location
and the version ID has changed, Autodesk Inventor searches the
OldVersions\ folder and then opens the appropriate version of the file.
The version of the opened file is used from then on to access additional
information.
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NOTE To save memory, Autodesk Inventor loads only the portion of a file
that is needed for an operation. Additional information is loaded as needed.
Therefore, do not delete an Autodesk Inventor file if there is a chance that
someone else is using the file in an active Autodesk Inventor session.

You can set the number of versions to keep when you create or edit a
project.

Each time a file is saved, the previous version is moved to its OldVersions\
folder. When the folder contains the maximum number of versions, and
a newer file is moved into the folder, the oldest version is automatically
purged from the OldVersions\ folder and deleted, if it is not open in an
Autodesk Inventor session.

Moving, Copying, and Archiving Design Files

You can safely copy files to new locations. Do not replace existing files in the
process.

If you use Microsoft Windows Explorer to rename files in a project, you break
references to the files. It can also happen if you move files or folders or rename
folders. When a file is not located, the Resolve Link dialog box automatically
opens. Update the references to the new location.

NOTE Open the files immediately after you move them and resolve the links. You
can avoid forgetting where you moved the files or confusing another user who
tries to open the files without knowing the new location. Do not move files when
anyone has the file open.

To avoid breaking links or losing data:

B [n all cases, close all Autodesk Inventor sessions before you move or copy
files.

B Backup your files. Create a zip file or use Pack and Go to package the entire
data set so you can restore data if necessary.

B Use the Where Used tool in Design Assistant to determine where a file is
used in other designs. For example, drawing D.idw might have an indirect
reference to Pipt (if, for example, it has a dimension or annotation to a
face or edge or P). If you rename P.ipt, use the Where Used tool to locate
S.iam, and then use Where Used again to find D.idw. Using this recursive
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search, you preserve the references, along with annotations and dimensions
in the indirect references.

B Use Design Assistant to move, copy, or rename files and repair the

references from referencing files at the same time.

After you copy or move files, open them in Autodesk Inventor to verify that
all of the links are correct before you give them to a vendor or other designer
to use.

Zip Files

You can use zip files to move data, archive, or copy data sets for vendors.
Avoid using nested folders in your project.

TRY IT: Move or copy Autodesk Inventor data using zip files

1 Copy each project location folder to a zip file, including subfolder paths
and files.

Do the same for the Styles Folder, Template Folder, and Content Center
Files folder. If you share these folders across multiple projects, you may
get files that are not used in your project.

2 Name each zip file with the location name of the project.

3 Include each zip file and the project in another zip file.

NOTE If your project has thread or clearance data, also include the Threads.xls
and Clearance.xls file from the Design Data folder. You may need to restore
the file to retrieve thread data for the project, but be sure to preserve the
original file so other projects that reference the file are not damaged.

4 The recipient unzips each project location folder into a new separate
folder and resets the project so that each location goes to the new
destination folder.

If you prefer, you can use a temporary root folder.
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Temporary Root Folders

You can move data, archive, or copy data sets for vendors. When you have
no nested folders in your project, you can easily archive or give data sets to
vendors.

You can move data, archive, or copy data sets for vendors. When you have
no nested folders in your project, you can easily archive or give data sets to
vendors.

TRY IT: Move or copy data using a temporary root folder
1 Create a top-level (root) folder.

2 Create a subfolder for each project location (with the identical name of
the location named in the project).

3 Copy the contents of each project location to its corresponding subfolder.
If you can easily identify the library files you used, you can copy only
those files.

4 Create a subfolder for each of the folder locations, such as .\Styles,
.\Content Center and .\ Templates, and copy the corresponding folders
from the source project. If you can easily identify the content center files
used by your project, you can copy only those files.

It is a good idea to copy the Threads.xls and Clearance.xls file from the
Design Data folder location to the Styles folder as a precaution.

5 Copy your project file to the new top-level (root) folder.

6 Edit the project copy so that all locations are relative to the top-level
(root) folder. Use the format .\subfolderName\.

7 Zip the contents of the root folder, specifying the Recursive and Preserve
Subfolder Path options.

8 The recipient unzips to an empty folder and the project is ready to use.

To reference your styles folder or merge the Threads.xls and Clearance.xls
files, you may have to reset the Design Data folder location on the File
tab of the Application Options dialog box.

You can use Pack and Go to package an Autodesk Inventor file and all or a
selection of its referenced files under a single folder, even though the files are
stored in multiple network locations. You can also include files that reference
the selected Autodesk Inventor file. When you package a file, the files are
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copied to the specified location without changing the contents of any of the
source files.

All referenced files must be resolvable using the current project (.ipj) file. If
not, it is important to either open the correct .ipj file and make it current
either in Autodesk Inventor or the standalone project editor, or to browse to
it in the Pack and Go dialog box in the Project File field.

Pack and Go

Pack and Go is a tool that packages an Autodesk Inventor file and all of its
referenced files in a single location. All files that reference the selected Autodesk
Inventor file from a selected project or folder can also be included in the
package.

Use Pack and Go to archive a file structure, copy a complete set of files while
retaining links to referenced files, or isolate a group of files for design
experimentation.

TRY IT: Move or copy Autodesk Inventor data using Pack and Go

1 Use Microsoft Windows Explorer or a Design Assistant session started
outside Autodesk Inventor to find the file to package.

2 Select the file, right-click, and then select Pack and Go.

3 On the Pack and Go dialog box, specify the Destination Folder for the
package.

4 Set the path and packaging options.

5 Make sure that the path in the Project File field identifies the appropriate
project file for the selected file. If not, use the Browse button to locate it.

6 Click Search Now to search for referenced files. The total files found and
required disk space are displayed when the search is complete.

7 Click Start to begin packaging the files. As the files are packaged, the
status is shown in the Progress box. A new project file and a log file are
created in the destination folder reflecting the structure chosen in the
packaging options.

The log file is replaced each time you package an Autodesk Inventor file
to the same destination.
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If the Missing File dialog box is displayed, click the Set Project button.
Select the project to use for resolving referenced file locations. Click Open,
and then click Start to begin the search.

You can click Cancel on the Find Missing File dialog box to cancel the
action and display the Pack and Go dialog box without referenced files.

You can use Design Assistant to copy an entire assembly file (.iam), including
the referenced drawing file (.idw). Close all Autodesk Inventor files and use
Windows Explorer to open the Design Assistant.

Design Assistant Manager

Using Design Assistant, the Design Assistant Manager can maintain links
between Autodesk Inventor files. You can change the file relationships four
ways: rename files, revise files, replace files, and create product configurations.

NOTE You cannot manage links for released files and read-only files.

TRY IT: Copy assembly and referenced drawing files using Design Assistant

1

In Windows Explorer, right-click the .iam file (for example, test1.iam),
and then click Design Assistant.

In the left panel, click the Manage button (if it is not already selected).
Highlight the entry for the .iam file (test1.iam) in the upper pane.

Select the Drawing Files check box in the bottom right pane, and then
select Find Files.

A message box is displayed, indicating if files were found. The list of files
found is displayed in the lower part of the right pane.

Right-click in the Action column for the .iam file (test1.iam) in the upper
pane and then click Copy.

Right-click in the Name column for the .iam file (test1.iam) in the upper
pane, and then click Change Name. Enter the new name for the Assembly
(for example, test2.iam). Enter a new path to specify a new location, if
desired.

Repeat steps 5 and 6 for the .idw file. Use the same name you used for
the assembly file, but use an extension of .idw (for example, test2.idw).

On the File menu, click Save to save the settings.
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All changes are saved and new files (test2.iam and test2.idw) are created.

NOTE The newly created (or copied) drawing file (test2.idw) is referenced only to
the newly created (or copied) assembly file (test2.iam). All changes made in the
original assembly file (test1.iam) is reflected only in the copied test2.idw that
references it.

Occasionally, annotations for a referenced file of a subassembly may not be
visible in a drawing view after you use Design Assistant to move or copy. If
so, open the drawing file in Autodesk Inventor and use the Resolve Link dialog
box to restore the annotations.

Move and Copy Files Between Projects

You can temporarily rename the original files or move them out of the project
locations (so they are not found). Then open a top-level assembly or drawing
and use the Resolve Link dialog box to change the references to copies of the
referenced files. After the referencing files are saved, the original files (from
which the copies were made) can be restored and renamed to their original
names.

If you copy files from one project to another, remember:

B [f the file you copy to another project has a library reference, you must
define the same library in the destination project. It can be to the same
UNC location as the original.

B If the file you copy to another project has a non library reference, it resolves
to a file in the editable locations in the destination project. You can copy
the entire contents of a workspace (including subfolders) to another project
workspace. The files resolve to the copies rather than to the source files.

B You can copy an entire reference hierarchy in the same way, but preserve
the original subfolder structure from the project root location for the copied
files.

To copy a workspace folder to another location, follow these guidelines:
B The folders must include the project (.ipj).
B The project must contain only one editable location.

B All library locations must be accessible from the destination location (the
folder where the copies reside).
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You can move or copy the folder containing the project file, browse to and
activate the copied project file in the project editor, and then use the design
files immediately after you copy them.

If one or more of the previous conditions are not met, edit the destination
project (.ipj) to specify the new paths for each of the copied folders.

Consider using Pack and Go when copying an entire project. You can create
a zipped copy on a CD-ROM, for example, and send it to a customer, vendor,
or client. You can include only those library files that are referenced instead
of an entire library, if appropriate. Pack and Go can also create a read-only
library copy so you can continue to change the project data, but the recipient
can use the copy as a library.

Deleting Files

Deleting a file permanently removes it from your system. Because there is no
recovery, follow these guidelines:

B Verify that the file or files you intend to delete are not referenced or open
in Autodesk Inventor. If the file is open when you delete it, additional data
cannot be retrieved from the file and the open file cannot be saved. The
person using the file permanently loses any in-memory edits that were
not saved.

B Back up your data before you delete the file. Copy the file to another
location or create a zip file so that you can recover it if necessary.

B Use The Where Used tool in Design Assistant to find out where the file is
being referenced by other Autodesk Inventor files (including drawings,
parts, assemblies, and presentations).

When you are certain it is safe to delete the file, use Microsoft Windows
Explorer to delete the file.

TRY IT: Delete a file using Windows Explorer
1 In Windows Explorer, browse to the folder where the file is located.
2 Right-click the file name, and then select Delete.

3 Click Yes to confirm deletion.
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The deleted file is temporarily placed in the Recycle bin and can be
restored to its original location if necessary. When you empty your Recycle
bin, the file is permanently lost.

Changing File Structure

Projects often grow over time and the file structure must change to
accommodate the complexity. You can more easily change the file structure
if you plan it before you start the project, laying it out so that the data is
portable.

Using the project option Using Unique File Names = Yes, you can restructure
folders or move data files without breaking references.

NOTE Before you open files after moving them, click Tools » Application Options.
On the Save tab, select the Reference Resolution Changes check box. Open all
files and save them to update the references to the new location.

TRY IT: Use Windows Explorer to restructure files

1 Define the subfolder structure you need before you create or edit any
files. Create the subfolders immediately after creating a project so that
new saved files are located in the correct subfolder.

2 Create subfolders under the project home folder for personal workspace,
such as:

Create a subfolder named Components where you store shared
subcomponents, including assemblies.

Create a subfolder named SubAssemblies and under it, a subfolder for
each main subassembly. Put the assemblies and parts unique to each
in the subfolder.

For custom content library parts such as structural steel shapes, create
a subfolder named for it (for example, Structural Steel) and save the
generated parts in it.

Create folders for drawings and presentations.

Place the top-level (main) assembly or assemblies in the root workspace
folder.
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B If needed, create a subfolder named Tube_Pipe_Content. Create a library
named Tube_Pipe Content. Configure the tube and pipe library to place
standard tube and pipe components in that library.

3 Add the paths to the new subfolders of the project as Frequently Used
Subfolders. They are listed in the Locations box of the file Open dialog
box.

4 For safekeeping, make a copy of all of the data files, before you move
them to a new directory or delete old folders. After they safely move to
a new folder, delete the copy.

TRY IT: Use the Resolve Link dialog box to restructure files
1 Create needed subfolders.
2 Open the referencing files in Autodesk Inventor.

3 In the Resolve Link dialog box, navigate to the new locations to restore
links.

4 Save the referencing file with the new locations.

Within an Autodesk Inventor session, the Resolve Link dialog retains the
information you specify regarding the source and destination folder paths
and library names of files that were moved.

If you open other files with broken references to the same folders/libraries,
Autodesk Inventor remembers the folder/library name and tries that location
before opening the Resolve Link dialog box again. By default, a map is created
with the complete folder path.

If you move a folder that has many subfolders and files, you can edit the fields
in the dialog so that the source and destination paths of the moved folder are
shown. Using a substitution rule, Autodesk Inventor attempts to resolve the
file references without opening the Resolve Link dialog box for each of the
subfolders below it.

About Autodesk Vault

Autodesk Vault is a workgroup data management system integrated with
Autodesk Inventor. It enables fast, accurate sharing of design data across a
project team. The vault is a file management and version control system for
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all engineering and related data, providing design team members with a central
and secure collaborative environment.

Autodesk Vault is the preferred data management system for Autodesk
Inventor. Its capabilities extend beyond the data management scope of projects.

After you install Autodesk Vault, use the Project Wizard to create a vault
project. Specify a personal workspace where you create and edit files. In
addition, you also specify the vault server, its name and the virtual folder
stored on the server. (These values are set using Autodesk Vault.)

For more information about using Autodesk Vault, see Managing Your Data.
The guide is installed in Program Files > Autodesk > Vault 2009 > Help.
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141, 143-145, 157, 160, 162,
166, 175, 178
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color styles, defining 139
constraining 145

creating 157, 160
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grounded 144
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patterns, associative 162

placed 144

promoting 138

replacing 166

visibility, controlling 136
assembly coordinate system 133

Auto Dimension tool 39, 45

Autodesk Mechanical Desktop files,
importing 14

Autodesk Vault 292

Auxiliary View dialog box 228

auxiliary views in drawings 220, 228
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Balloons tool 240

base features 55, 158

base views in drawings 221-222, 232

Baseline Dimension tool 239

bills of material (BOMs) 140
bottom-up assembly design 132
break out views in drawings 220
Broken View dialog box 231
broken views in drawings 220, 231
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Camera View tools 11

Caterpillar annotation tool 241

center marks in drawings 240, 247, 256

centerlines in drawings 240, 256

Chamfer dialog box 76

chamfer features 69, 75

circular patterns 90, 95

coil features 58

Coil tool 63

command aliases 5

Comments feedback link in Help 19

component patterns 162

components, dragging into
assemblies 143

composite iMates 153

Constraint tool 147

constraints 32-34, 36-37, 134, 145, 147-
148, 150-154, 178

angle 150

assemblies 134, 145
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deleting from sketches 36
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insert 152
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motion, adding 152
showing 33, 153
sketch 32-34
tangent 147, 151
tips for creating 37
tips for managing 154
Content Center 265-271
configuration 266, 271
editor 269
library 266
permissions 265
place component 268
publishing 270
using 267
Content Library in Autodesk
Inventor 127
coordinate system 23, 133
assembly 133
sketch 23
Create In-Place Component dialog
box 142
Create Parts List dialog box 242
crop operations in drawings 221

cross sections on models, analyzing 100

curvature comb analysis 100

D

data files for exercises 2, 32

data files, managing with Autodesk
Vault 292

datum target leaders 240

default project 111, 114

degrees of freedom (DOF) 175, 178

design accelerator 185-186, 188, 197,

199, 201
author parts 199
bolted connections 188
component generators 186
file names 201
mechanical calculators 186, 197
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173,177-178, 228-229, 231, 242~
243,277,279, 282, 291
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Broken View 231

Chamfer 76

Create In-Place Component 142

Create Parts List 242

Detail view 229
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Drive Constraint 177

Edit Constraint 148

Edit Dimension 37, 40, 43

Edit Feature 66

Edit Parts List 243

Fillet 79

Holes 70, 72,91

Interference Detected 173

Open File 2

Open New File 2

Open Version 282

Place Constraint 146

Properties 178

Resolve Link 277, 279, 291

Shell 89

Thread Feature 86

diametric dimensions 41
dimensioning sketches 38
dimensions 39, 41, 45, 243-245, 254

255, 259, 261
automatic 39
deleting and adding 45
diametric 41
driven 41
formatting 259
model, in drawings 243-244, 254,

261
modifying 41, 261
repositioning 255
styles in drawings 245



tips for creating 45
types, changing 39
displays, graphics window 139
Document Settings dialog box 3
DOF (degrees of freedom) 175
draft styles, Primary Zebra 100
draft views in drawings 220, 232
draft, analyzing 100
drawing dimensions 244
Drawing Resources folder 210
drawing sheets, printing 263
drawing view types 221
drawings 203-205, 211-212, 214, 216,
220, 222, 232, 234, 236, 243,
249-250, 253, 257, 259-260, 262-
263
borders 212
creating 205
dimensions, creating 243, 257
model dimensions, editing 205
model dimensions, formatting 259
multiview, creating 222
notes and leader text 260
parts lists, creating 243
plotting and printing 263
sheets, adding 211
templates 204
thread representations 249
tips for creating 216
title blocks 214, 250, 262
views, creating 220, 250
views, modifying 232
views, moving 211, 234, 236
views,modifying 253
Drive Constraint dialog box 177
Drive Constraint tool 176
driven dimensions 41
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Edit Constraint dialog box 148

Edit Dimension dialog box 37, 40, 43
Edit Feature dialog box 66

Edit Parts List dialog box 243
editable locations 111

environments 22, 54, 131
assembly 131
part modeling 54
sketch 22

Extrude tool 58
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faces on models, analyzing 100
features 55, 58, 60-64, 66, 69-70, 73,
75,79, 84, 88, 90-91, 105
base 55
chamfer
coil 63
editing 66
extrude 58
fillet 69, 73, 79
hole 69-70, 91
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mirrored 69
pattern 69, 90
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revolve 60
rib and web 64
shell 69, 88
sketched 58
swept 61
thread 69, 84
work 105
file locations
278
Autodesk Mechanical Desktop 125
Content Library 127
editable 111
read-only 111
search order 276, 278
workgroup and workspace 113
file names 129
file storage in projects 113
file structures, changing 290
files 2,112,115, 129, 203, 276, 279,
281-282, 289
deleting in projects 289
drawing 203
naming 129, 281
old versions, keeping  281-282
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old versions, restoring 281
opening in projects 129, 282
proxy 112
referenced locations, finding
resolving links 276, 279
templates 2

285
moving and copying 285
Fillet dialog box 79
fillet features 69, 73, 79
folders in projects 113

Files
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Gaussian curvature analysis
General Dimension tool 239
geometry, sketch 21
graphics window displays,
controlling 139
grid displays, setting 25
Ground Shadow tool 11
grounded components 144
grounded work points 108
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hatch patterns, editing 235
Help system 16-17, 19-20
feedback links 19

skill builder links 20
Hidden Edge tool 11
hole features 69-70, 91

hole notes in drawings 249
hole patterns 92

Hole table tool 240
Hole/Thread Notes tool 240
Holes dialog box 70, 72, 91

IGES files, importing 15

iMates 153

import/export data  14-15
IGES (*.igs, *.ige, *.iges) 15
Mechanical Desktop (*.dwg)

296 | Index

115

14

SAT (*.sat) 15

STEP (*.stp, *.ste, *.step) 15
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iProperties in proxy files 126
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leader text in drawings
Leader Text tool 240
libraries

248, 260

129, 278, 281
Autodesk Mechanical Desktop
parts 125

defining files for 128

file locations, searching 278

iParts 126
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naming

proxy files

specifying

various types
library search paths

iParts 126
loft features 58
Loft tool 62
Look At tool 10
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129, 281
125
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mate constraint 148
middle-out assembly design
mirror features 69

missing files, finding 279
model dimensions in drawings
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motion constraints 152
multi-user Off (single user) mode
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multiview drawings 222
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notes in drawings 248

173

112, 115, 122, 124-126, 128-
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occurrences in patterns, suppressing 94,
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Open File dialog box 2

Open New File dialog box 2

Open Version dialog box 282

Options dialog box 3

options in projects, setting 123

Ordinate Dimension Set tool 239

Ordinate Dimension tool 239

orthographic camera view 11
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Pack and Go function 286
Pan tool 9
parametric dimensions 38
parent/child parts in models 54, 135
part modeling environment 54
part models 2, 7,11, 53-55, 58, 66, 69,
90, 205, 244
creating 2, 54
displaying 11
editing in drawings
modifying 66
parent/child relationships 54
pattern features 90
placed features 69
sketch planes 58
templates, creating for files 2
viewing 7
workflows 55
Parts list tool 240
paths, relative 113
pattern features 69, 90, 92, 94-95, 97,
99, 162-164
along 3D paths 97
circular 95
independent elements 164
occurrences, suppressing 94, 99
rectangular and circular 90
rectangular from holes 92
pattern occurrences, suppressing 94
perspective camera view 11
Place Constraint dialog box 146

205, 244

placed features 69
plotting drawings 263
precise values in sketches 24, 29
printing drawings 263
profiles 21, 41
dimensioning 41
Project Geometry tool 160
project modes, setup 120
project setups 118, 120
recommendations 120
Vault 118
project types 116
projected edges in sketches 24
projected views in drawings 220-221
projects 2,111, 114-116, 118, 120-123,
128-129, 275, 283-285, 288-290
activating 115
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creating with Project Editor 121
default 111
default folder location, setting 120
deleting files 289
editing 275
file structures, changing 290
files, moving and copying 283, 285
files, moving between projects 288
library types 128
moving entire projects 284
naming 121
new for existing design folder 122
opening files 129
options, setting 123
settingup 116
vault mode 118
wizard 121
workspaces and workgroups 121
Properties dialog box 178
proxy files 112, 125
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read-only file locations
rectangular patterns 90
referenced files 113, 115, 278
locations, finding 115, 278
referenced model edges in sketches 24

112, 115
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relative paths 113

Resolve Link dialog box 277, 279, 291
restructure assemblies 137

Retrieve Dimensions tool 241, 254
Revision table tool for annotations 241
revolve features 58

Revolve tool 60

rib and web features 58

Rib tool 64

root folders in projects 113

Rotate tool, 3D 10
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SAT files, importing 15

search order in projects 278

search paths 123-125, 129, 275
Autodesk Mechanical Desktop

parts 125

library 124, 129
projects, setting 275
workspaces 123

section views in drawings

semi-isolated mode 116

settings, application and document 3

Shaded Display tool 11

shared mode 116

sheets, drawing 211

Shell dialog box 89

shell features 69, 88

shortcut keys 5

Show All Constraints 33

Show Constraints tool 32

single user mode 113, 116

sketch coordinate system 23

sketch environment 22

sketch planes 58, 159

sketched features 58

sketches  21-22, 24-26, 28-30, 32, 34,

36, 38, 40-41, 47, 159

completing 26, 29
constraining 32, 34, 41
deleting constraints 36
dimensioning 38, 40
edges, projecting 24, 159
modifying 47

220, 225
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starting 25, 28
tips for creating 30
using drag to resize 30
skill builders 16, 20
slice operations in drawings 221
solid models 53, 56
standard parts 266
STEP files, importing 15
structures, assembly 136
subassemblies 161
substitution rules in projects 279
surface curvature, analyzing 100
sweep features 58
Sweep tool 61
Symbol tool for annotations 241
symbols in drawing annotations 240

T

Tables 240

tangent constraint 151

tangent edge displays in drawings 253

templates for new files 2

templates, drawing 204

Text tool 240

Thread Feature dialog box 86

thread features 69, 84

thread notes in drawings 249

title blocks in drawings 214, 216, 250,
262

top down assembly design 133

tutorial files for exercises 32

tutorial files project 2
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Vault mode in projects
viewing tools 7
views 7, 211, 221-222, 232-234, 236,
250, 253

adding to drawings 250

aligning 234

changing 7

creating 222
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deleting 233
editing 221, 253
modifying 232
moving 211, 236
rotating 236
visibility of assembly components 136
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Wireframe Display tool 11
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adaptive planes 158
axes 106

in assemblies 165
modifying 109
planes 106
points 107
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locations 113
search paths 123
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Zoom tools 8
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